Версия для печати темы (https://pro1c.org.ua/index.php?s=1e390bde262d680f264aaa079506fa01&showtopic=56340)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Программирование в 1С Предприятие 8.3 _ Отправка писем через 1с(ukr.net)

Автор: Pashaboston 14.01.20, 20:02

Конфигурация УТП для Украины версия 1.2.54.1 платформа 8.3.15.1489. Настроил встроиный почтовый клиент проверка через 1с, проверк проходит нормально, отправка писем проходит но письмо до адресата не доходит.
Почта ukr.net, работает через IMAP, настройки на самой почте сделал.Немного переделал стандартній механизм но не получается.

Профиль = Новый ИнтернетПочтовыйПрофиль;
    //Pawa
    Если УчетнаяЗапись.ТипСервера = "POP3" Тогда
        Профиль.АдресСервераPOP3    = УчетнаяЗапись.POP3Сервер;
        Профиль.ПортPOP3            = УчетнаяЗапись.ПортPOP3;
        Профиль.Пользователь        = УчетнаяЗапись.Логин;
        Профиль.Пароль                = УчетнаяЗапись.Пароль;
    Иначе
        Профиль.АдресСервераIMAP    = УчетнаяЗапись.POP3Сервер;
        Профиль.ПользовательIMAP    = УчетнаяЗапись.Логин;
        Профиль.ПарольIMAP            = УчетнаяЗапись.Пароль;
        Профиль.ПортIMAP            = УчетнаяЗапись.ПортPOP3;
    КонецЕсли;

        
    Профиль.АдресСервераSMTP = УчетнаяЗапись.SMTPСервер;
    Если УчетнаяЗапись.ВремяОжиданияСервера > 0 Тогда
        Профиль.ВремяОжидания = УчетнаяЗапись.ВремяОжиданияСервера;
    КонецЕсли;
    Профиль.ПортSMTP         = УчетнаяЗапись.ПортSMTP;
    
    Если УчетнаяЗапись.ТребуетсяSMTPАутентификация Тогда
        Профиль.АутентификацияSMTP = СпособSMTPАутентификации.ПоУмолчанию;
        Профиль.ПарольSMTP         = УчетнаяЗапись.ПарольSMTP;
        Профиль.ПользовательSMTP   = УчетнаяЗапись.ЛогинSMTP;
    Иначе
        Профиль.АутентификацияSMTP = СпособSMTPАутентификации.БезАутентификации;
        Профиль.ПарольSMTP         = "";
        Профиль.ПользовательSMTP   = "";
    КонецЕсли;
    
    Профиль.ИспользоватьSSLSMTP = Истина;
    Профиль.ИспользоватьSSLPOP3 = Истина;
    Профиль.ИспользоватьSSLIMAP = Истина;
    Профиль.POP3ПередSMTP = Ложь;
    

    
    СистемнаяИнформация = Новый СистемнаяИнформация;
    Если СтроковыеФункцииКлиентСервер.СравнитьВерсии(СистемнаяИнформация.ВерсияПриложения, "8.3.1.0") > 0 Тогда
        Профиль.ИспользоватьSSLPOP3 = УчетнаяЗапись.ИспользоватьЗащищенноеСоединениеДляВходящейПочты;
        Профиль.ИспользоватьSSLSMTP = УчетнаяЗапись.ИспользоватьЗащищенноеСоединениеДляИсходящейПочты;
    КонецЕсли;
    
    Возврат Профиль;

и вот здесь
Если УчетнаяЗапись.ТипСервера = "IMAP" Тогда
                    ИнтернетПочта.Подключиться(Профиль,ПротоколИнтернетПочты.IMAP);
                    //ИнтернетПочта.ТекущийПочтовыйЯщик = "Отправленные";
                Иначе
                    ИнтернетПочта.Подключиться(Профиль);
                КонецЕсли;

Ошыбок никаких не выдает, пишет что отправило а на деле письма приходят на ту учетную запись с какой отправлялись(.

Автор: andr_andrey 15.01.20, 6:04

Цитата(Pashaboston @ 14.01.20, 20:02) *
Ошыбок никаких не выдает, пишет что отправило а на деле письма приходят на ту учетную запись с какой отправлялись(.

Адрес получателя случайно не совпадает с адресом отправителя?

Автор: Pashaboston 15.01.20, 9:57

Pashaboston @ Вчера, 20:02 * ,
Получатель на gmail в отладчике видно, а отправитель ukr.net


Отправка так же переделал через IMAP

Если УчетнаяЗапись.ТипСервера = "IMAP" Тогда
    ИнтернетПочта.Послать(ПочтовоеСообщение,,ПротоколИнтернетПочты.IMAP);
Иначе
    ИнтернетПочта.Послать(ПочтовоеСообщение);
КонецЕсли;


Автор: volodya1122 15.01.20, 10:32

Pashaboston @ Сегодня, 9:57 * ,

А почему бы Вам не завести почту оправителя на GMAIL ? и не иметь этих проблем?

Автор: Pashaboston 15.01.20, 10:42

volodya1122 @ Сегодня, 10:32 * ,
Задача у клиента стоит настроить именно на ukr.net.

Пробую через Shtunnel тоже ничего не выходит. Выдает ошибку :
Ошибка при вызове метода контекста (Подключиться): Произошла ошибка при работе с SMTP. Код ошибки: 25 (Отказ в установлении соединения со стороны сервера.)
Вот настройки Shtunnel :
[ukr.net-imap]
client = yes
accept = 127.0.0.1:143
connect = imap.ukr.net:993
verifyChain = yes
CAfile = ca-certs.pem
checkHost = imap.ukr.net
OCSPaia = yes

[ukr.net-smtp]
client = yes
accept = 127.0.0.1:25
connect = smtp.ukr.net:465
verifyChain = yes
CAfile = ca-certs.pem
checkHost = smtp.ukr.net.com
OCSPaia = yes

Автор: sava1 15.01.20, 11:17

а у них не платній вариант СМТП ?

Автор: Vofka 15.01.20, 11:49

Pashaboston, а если отправлять не с ukr.net, то работает как положено?

Автор: Pashaboston 15.01.20, 18:18

Vofka @ Сегодня, 11:49 * ,
C gmail все ок


Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua