Версия для печати темы (https://pro1c.org.ua/index.php?s=f17ba6f8a3d0efafe919d2c2489f5d4b&showtopic=66796)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Конфигурация "1С:Конвертация данных" _ Ошибка при установке обработки загрузки/выгрузки документов в XML

Автор: berjozov 12.11.21, 12:48

Здравствуйте, хочу подключить обработку для загрузки/выгрузки документов в XML для 1С:Підприємство 8.3 (8.3.18.1289) BAS 2.1 (2.1.16.1), при добавлении выдает ошибку "Невозможно подключить дополнительную обработку из файла. Возможно она не подходит для этой версии программы. Техническая информация.Метод объекта не обнаружен (СведенияОВнешнейОбработке)"
Обработки - "Выгрузка загрузка данных XML" (ВыгрузкаЗагрузкаДанныхXML83.epf)" и аналогичные, которые входили в поставку 1С:Предприятие 8 Типовая конфигурация Конвертация данных, редакция 2.1. Также реагирует на обработки универсального обмена данных в XML, утянутые с просторов интернета.
Возможно для данной конфигурации существуют другие обработки или способы выгрузить информацию про авансовые отчеты/определенные хоз.операции и загрузить их потом в базу снова?
Заранее благодарен за ответ

Автор: mvo2008 12.11.21, 13:06

В модулі немає процедур типу: тільки для обробки а не звіту (пошукайте в інеті)

Функция СведенияОВнешнейОбработке() Экспорт

    ИмяОтчета = ЭтотОбъект.Метаданные().Имя;
    Синоним = ЭтотОбъект.Метаданные().Синоним;
    Синоним = ?(ЗначениеЗаполнено(Синоним), Синоним, ИмяОтчета);

    РегистрационныеДанные = Новый Структура;
    РегистрационныеДанные.Вставить("Вид", "ДополнительныйОтчет");
    РегистрационныеДанные.Вставить("Наименование", Синоним);
    РегистрационныеДанные.Вставить("Версия", "2.1");
    РегистрационныеДанные.Вставить("БезопасныйРежим", Истина);
    РегистрационныеДанные.Вставить("Информация", "Отчет " + Синоним);

    ТаблицаКоманд = ПолучитьТаблицуКоманд();

    ДобавитьКоманду(ТаблицаКоманд, Синоним, "СформироватьОтчет", "ОткрытиеФормы", Истина);

    РегистрационныеДанные.Вставить("Команды", ТаблицаКоманд);

    Возврат РегистрационныеДанные;

КонецФункции

Функция ПолучитьТаблицуКоманд()

    Команды = Новый ТаблицаЗначений;
    Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
    Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));

    Возврат Команды;

КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование = "ОткрытиеФормы", ПоказыватьОповещение = Ложь, Модификатор = "ПечатьMXL")

    НоваяКоманда = ТаблицаКоманд.Добавить();
    НоваяКоманда.Представление = Представление;
    НоваяКоманда.Идентификатор = Идентификатор;
    НоваяКоманда.Использование = Использование;
    НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
    НоваяКоманда.Модификатор = Модификатор;

КонецПроцедуры

Автор: Gazulo 12.11.21, 13:52

berjozov @ Сегодня, 13:48 * ,
Открывайте через Файл - Открыть.

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua