Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

85 страниц V   1 2 3 > » 

>  IBAN в 1С:Підприємство
sava1
Отправлено: 11.10.19, 10:00


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2139
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Цитата(temabuh @ 11.10.19, 9:47) *
но если можно конкретнее,


тогда конкретнее про конфигурацию

в УТП
модуль объекта

комментируем все конструкции

Если НЕ ОбщегоНазначения.ТолькоЦифрыВСтроке(СокрЛП(НомерСчета)) Тогда
---------
КонецЕсли;
  Форум: Бухгалтерский учет, налоги, последние изменения... · Просмотр сообщения: #156450 · Ответов: 19 · Просмотров: 2641
 

>  IBAN в 1С:Підприємство
sava1
Отправлено: 11.10.19, 8:38


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2139
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


в модуле справочника , ПередЗаписью
  Форум: Бухгалтерский учет, налоги, последние изменения... · Просмотр сообщения: #156447 · Ответов: 19 · Просмотров: 2641
 

>  Заполнение счетов учета при импорте контрагентов
sava1
Отправлено: 10.10.19, 13:36


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2139
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Цитата(n25 @ 10.10.19, 14:19) *
про групповое заполнение потом


Цитата(sava1 @ 10.10.19, 10:47) *
заполнить счета для группы контрагентов


это как-то сходится ? кроме слова "группа"

для группы контрагентов заполняем счета учета и обеспечиваем, чтобы новые контрагенты создавались в этой группе
  Форум: 1С Управление небольшой фирмой для Украины · Просмотр сообщения: #156407 · Ответов: 5 · Просмотров: 87
 

>  Заполнение счетов учета при импорте контрагентов
sava1
Отправлено: 10.10.19, 9:47


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2139
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


А если заполнить счета для группы контрагентов ?
  Форум: 1С Управление небольшой фирмой для Украины · Просмотр сообщения: #156396 · Ответов: 5 · Просмотров: 87
 

>  Как программно получить цену по договору
sava1
Отправлено: 09.10.19, 13:13


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2139
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


запрос к рег. сведений ЦеныНоменклатуры с отбором по указанной цене и Номенклатуре
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #156352 · Ответов: 11 · Просмотров: 140
 

>  Программное создание кнопки для всех документов в формах объекта
sava1
Отправлено: 08.10.19, 14:39


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2139
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


1. Парамет Пустая или что-то другое. Отладчик есть или скачать ?
2.код в студию

Отказ = Истина не надо - это обычная команда
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #156328 · Ответов: 23 · Просмотров: 483
 

>  Программное создание кнопки для всех документов в формах объекта
sava1
Отправлено: 08.10.19, 14:02


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2139
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Если не надо вопроса про запись - тупо отказ и все.

Выше вариант, когда надо спросить человека - "Объект то новый. может Вы хочите его записать ?"

Если человек жмет на кнопу - он на что-то рассчитывает. Хотябы на обратную связь.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #156326 · Ответов: 23 · Просмотров: 483
 

>  Программное создание кнопки для всех документов в формах объекта
sava1
Отправлено: 08.10.19, 13:27


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2139
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Копипаст из бухии

Кнопки = Новый СписокЗначений;
        Кнопки.Вставить(0, КодВозвратаДиалога.Да, "Провести");
        Кнопки.Вставить(1, КодВозвратаДиалога.Нет, "Отмена");
        ДополнительныеПараметры = Новый Структура;
        ДополнительныеПараметры.Вставить("ПараметрыВыполненияКоманды", ПараметрыВыполненияКоманды);
        ДополнительныеПараметры.Вставить("ПараметрКоманды", ПараметрКоманды);
        
        Оповещение = Новый ОписаниеОповещения("ВопросПередПросмотромСледуетПровестиЗавершение", ЭтотОбъект, ДополнительныеПараметры);
        ПоказатьВопрос(Оповещение, НСтр("ru='Перед просмотром проводок документ следует провести';uk='Перед переглядом проводок документ слід провести'"), Кнопки,, КодВозвратаДиалога.Да);


и собственно обработка ответа

Если Ответ <> КодВозвратаДиалога.Да Тогда
        Возврат;
    КонецЕсли;
    
    ПараметрКоманды = ДополнительныеПараметры.ПараметрКоманды;
    ПараметрыВыполненияКоманды = ДополнительныеПараметры.ПараметрыВыполненияКоманды;
    
    ДокументПроведен = ПровестиДокумент(ПараметрКоманды);
    Если ДокументПроведен Тогда
        ОповеститьОбИзменении(ПараметрКоманды);
        Оповестить("ВыполненаЗаписьДокумента", Новый Структура("ДокументСсылка", ПараметрКоманды));
    Иначе
        Сообщить(НСтр("ru='Не удалось провести документ';uk='Не вдалося провести документ'"), СтатусСообщения.Важное);
        Возврат;
    КонецЕсли;


а дальше Ваши идеи
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #156324 · Ответов: 23 · Просмотров: 483
 

>  Программное создание кнопки для всех документов в формах объекта
sava1
Отправлено: 08.10.19, 12:41


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2139
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Цитата(Gigi @ 08.10.19, 13:35) *
что происходит когда на кнопку «Назначить авто-заполнение» нажимаешь не на форме уже сохраненного объекта, а на форме нового.


а сами как думаете ?
если параметром команды идет ссылка на объект, а ссылка пустая ? по-идее Вы должны разрулить эту ситуевину.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #156322 · Ответов: 23 · Просмотров: 483
 

>  Программное создание кнопки для всех документов в формах объекта
sava1
Отправлено: 08.10.19, 11:58


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2139
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


оффтоп -

Цитата(Gigi @ 08.10.19, 10:48) *
сам в 1С всего два годика.


это типа - знаю, что такое циклы - и для меня достаточно....

по-аналогии - первый раз увидел авто с коробкой-автоматом -- "Как на ней можно ехать - здесь сцепления нет !!!!"
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #156320 · Ответов: 23 · Просмотров: 483
 

>  Программное создание кнопки для всех документов в формах объекта
sava1
Отправлено: 08.10.19, 11:27


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2139
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


чем не нравится Важное ?

Цитата(Gigi @ 08.10.19, 10:48) *
возможно указать только конкретный документ. А указать все документы 1С естественно не позволяет. Это во-первых.


ТипПараметра = составной тип - и ставите "птисы" на чем хочите.

Цитата(Gigi @ 08.10.19, 10:48) *
пределить ссылку на объект, для того что бы вызвать процедуру требующую контекста самой формы?


в модуле команды -

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)

//ПараметрКоманды и есть Ссылка на объект



Цитата(Gigi @ 08.10.19, 10:48) *
вызвать процедуру требующую контекста самой формы


интересно, что Вы в формах храните ?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #156314 · Ответов: 23 · Просмотров: 483
 

>  Программное создание кнопки для всех документов в формах объекта
sava1
Отправлено: 07.10.19, 15:52


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2139
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Цитата(Gigi @ 07.10.19, 16:35) *
Пользователь ее должен нажать в другом одном месте, а нужно что бы он нажимал на самой форме.


Уважаемый, Вы хреново осведомлены об Общих Командах. Возьмите типовую бухию и посмотрите, как показываются проводки документа.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #156285 · Ответов: 23 · Просмотров: 483
 

>  Программное создание кнопки для всех документов в формах объекта
sava1
Отправлено: 07.10.19, 14:28


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2139
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


При добавлении команды формы обработчик (по-моему) тоже должен быть в форме.

ОбщаяКоманда - не подходит ?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #156274 · Ответов: 23 · Просмотров: 483
 

>  Обробка "Обмін з банком" для БУ 2.0
sava1
Отправлено: 05.10.19, 13:22


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2139
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


имя ДБФ файла - по-англицки и не более 8 символов ?
  Форум: Отчеты / Обработки · Просмотр сообщения: #156222 · Ответов: 137 · Просмотров: 20156
 

>  Настройка доступа через RLS!
sava1
Отправлено: 03.10.19, 10:08


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2139
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


у пользователя по другим ролям доступ к кассам закрыт ?

это видели ? тыц

аль это тыц
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #156158 · Ответов: 2 · Просмотров: 121
 

>  Форма выбора. Параметр "Дата между". Реально?
sava1
Отправлено: 24.09.19, 11:23


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2139
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


а вот так ?

&НаКлиенте
Процедура ОткрытьФормуА(Команда)
    
    фиксНастройки = Новый НастройкиКомпоновкиДанных;
    
    эОтбор = фиксНастройки.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    эОтбор.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Дата");
    эОтбор.ВидСравнения = ВидСравненияКомпоновкиДанных.БольшеИлиРавно;
    эОтбор.ПравоеЗначение = Объект.Период.ДатаНачала;
    эОтбор.Использование = Истина;
    
    эОтбор = фиксНастройки.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    эОтбор.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Дата");
    эОтбор.ВидСравнения = ВидСравненияКомпоновкиДанных.МеньшеИлиРавно;
    эОтбор.ПравоеЗначение = Объект.Период.ДатаОкончания;
    эОтбор.Использование = Истина;

    эОтбор.РежимОтображения = РежимОтображенияЭлементаНастройкиКомпоновкиДанных.Недоступный;

    ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("ФиксированныеНастройки", фиксНастройки);

    ОткрытьФорму("Документ.РеализацияТоваровУслуг.Форма.ФормаСписка", ПараметрыФормы, ЭтаФорма);
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155915 · Ответов: 21 · Просмотров: 535
 

>  Форма выбора. Параметр "Дата между". Реально?
sava1
Отправлено: 24.09.19, 10:39


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2139
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


а по-человечески - так

ФормаВыбора = ПолучитьФорму("Справочник.ТестСправочник.Форма.ФормаВыбора"
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155909 · Ответов: 21 · Просмотров: 535
 

>  Форма выбора. Параметр "Дата между". Реально?
sava1
Отправлено: 24.09.19, 10:37


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2139
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


ФормуВыбора на сервере - вернуть на клиент - открыть
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155907 · Ответов: 21 · Просмотров: 535
 

>  Форма выбора. Параметр "Дата между". Реально?
sava1
Отправлено: 24.09.19, 8:45


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2139
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Цитата(Vofka @ 23.09.19, 15:39) *
В управляемых формах тоже можно получить форму, что-то с ней поделать и потом открыть.


Не рекомендуют - тыц

по-правильному - устанавливаем фикс. настройки и открываем форму - 2 параметра (большравно и меньшеравно) - о чем и писАл в #2

кстати - по ПолучитьФорму - тыц
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155904 · Ответов: 21 · Просмотров: 535
 

>  Форма выбора. Параметр "Дата между". Реально?
sava1
Отправлено: 23.09.19, 14:40


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2139
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


вот такая фигня не проходит ? - самому впадло пробовать
Сп = Новый СписокЗначений;
Сп.Добавить(Значение1);
Сп.Добавить(Значение2);

ПараметрыОтбор = Новый Структура("Контрагент", Сп);
ПараметрыОткрытия = Новый Структура("Отбор", ПараметрыОтбор);
ОткрытьФорму("Документ.........Форма.ФормаВыбора", ПараметрыОткрытия, Элемент);
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155876 · Ответов: 21 · Просмотров: 535
 

>  Форма выбора. Параметр "Дата между". Реально?
sava1
Отправлено: 23.09.19, 14:30


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2139
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Цитата(fly @ 23.09.19, 14:56) *
Там уже получать отборы и потом уже открывать непосредственно форму.

Форма.Открыть();


уважаемый, Упр. формы открываются по-другому (тем более с установкой отбора списка)

Цитата(Inkognito @ 23.09.19, 11:16) *
//сюда бы добавить период отбора документа. Например, документы за последние 2 месяца. Сейчас за все годы попадают в список, не годится так.

Цитата(Inkognito @ 23.09.19, 13:59) *
Да, так и есть. Нужно типовыми средствами как-то сделать. Но как период всунуть в "Дату", непонятно.


я в маразме ?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155874 · Ответов: 21 · Просмотров: 535
 

>  Форма выбора. Параметр "Дата между". Реально?
sava1
Отправлено: 23.09.19, 12:29


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2139
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


А два параметра не проходит ? 1- больше А, 2- меньше Б ???
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155868 · Ответов: 21 · Просмотров: 535
 

>  Заміна УТП на кофігурацію із групи BAS
sava1
Отправлено: 20.09.19, 18:16


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2139
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Цитата(fly @ 20.09.19, 17:07) *
потом будет только БАС


Из "Москва слезам не верит" - Не будет ничего - ни кино, ни театра - только одно телевидение.... 12201689.gif
  Форум: 1С Управление Торговым Предприятием 8 · Просмотр сообщения: #155796 · Ответов: 4 · Просмотров: 288
 

>  Настроить вывод в заголовки отчетов время и дата формирования отчета, как было в 1с77
sava1
Отправлено: 17.09.19, 7:30


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2139
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


З.Ы. СКД- параметры- Выражение ТекущаяДата() нормально работает
  Форум: Система компоновки данных · Просмотр сообщения: #155684 · Ответов: 12 · Просмотров: 247
 

>  Как вывести значение булево(да или нет) в колонку Формы списка документа
sava1
Отправлено: 13.09.19, 16:33


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2139
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Цитата(jojojoba2 @ 13.09.19, 17:04) *
ОформлениеСтроки.Ячейки.Флаг = Истина;


стр.Ячейки.Флаг = Истина;

Цитата(jojojoba2 @ 13.09.19, 17:04) *
Запрос.УстановитьПараметр("ЗначениеКритерияОтбора",ЭтаФорма.ЭлементыФормы.Список.ТекущаяСтрока);


Запрос.УстановитьПараметр("ЗначениеКритерияОтбора",масЗаказы);

соответственно выбирать в запросе с условием в (&ЗначениеКритерияОтбора)

а что получите - посмотрите в консоли запросов
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155610 · Ответов: 1 · Просмотров: 201
 

85 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 14.10.19, 23:10
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!