Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



7 страниц V   1 2 3 > » 

>  Условия сохранения определенного документа (1с 7.7.27)
denis84
Отправлено: Вчера, 19:53


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 166
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


andrew76 @ Сегодня, 18:57 * ,
При записи тоже есть такая процедура там и проверьте заполняемость реквизита

призаписи()

И вот тут полезно почитать:
тут
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #168587 · Ответов: 4 · Просмотров: 67
 

>  Условия сохранения определенного документа (1с 7.7.27)
denis84
Отправлено: Вчера, 17:54


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 166
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


andrew76 @ Сегодня, 16:58 * ,
Добрый день! Если "сотрудник" в шапке документа то в модуле документа пишем:

// ===========================
Функция ПроверкаШапки()
    глВсеВыбрано = 1;
    глВыбранЛи(сотрудник,"сотрудник");
    //глВыбранЛи(Цех,"Цех");
    Возврат глВсеВыбрано;
КонецФункции


А если в строке, то так:
// ===========================
Функция ПроверкаСтроки()
    глВсеВыбрано = 1;
    глВыбранЛи(сотрудник,"сотрудник",НомерСтроки);
    Возврат глВсеВыбрано;
КонецФункции


А потом в обработке проведения проверяем:
// ===========================
Процедура ОбработкаПроведения()


Если ПроверкаШапки() = 0 Тогда
    глНеПроводить(Контекст);
    Возврат;
КонецЕсли;


ВыбратьСтроки();
Пока ПолучитьСтроку() = 1 Цикл
    Если ПроверкаСтроки() = 0 Тогда
        глНеПроводить(Контекст);
        Возврат;
    КонецЕсли;
КонецЦикла;
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #168582 · Ответов: 4 · Просмотров: 67
 

>  Программно цена устанавливается, а руками не получается установить
denis84
Отправлено: 18.11.20, 14:08


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 166
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


sinchik @ Сегодня, 13:51 * ,
Добрый день! А доступность у реквизита цена установлена
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168374 · Ответов: 2 · Просмотров: 104
 

>  Как добавить колонку "Коды УКТВЭД" в табличную часть приходной накладной
denis84
Отправлено: 09.11.20, 9:56


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 166
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


fender2121 @ Сегодня, 8:10 * ,
Добрый день! Я Вам писал в личные сообщения еще 07/11
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168059 · Ответов: 4 · Просмотров: 618
 

>  Как можно получить значение реквизита?
denis84
Отправлено: 04.11.20, 16:58


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 166
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Evgeniux @ Сегодня, 16:17 * ,
Цитата
ОбластьКомплектующие.Параметры.Гарантия = Константы.СрокГарантии.Получить();

так Вы вот прописали, откуда получаете гарантию

Напишите сюда условие
Если СборкаПК.ЦельСборки = "некое значение" тогда
ОбластьКомплектующие.Параметры.Гарантия = Константы.СрокГарантии.Получить();
Иначе

конецесли;
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #167940 · Ответов: 7 · Просмотров: 237
 

>  Добавить поле ручного ввода. Бухгалтерский учёт для Украины 7.70.252
denis84
Отправлено: 29.10.20, 9:24


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 166
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


graf.vorontsov @ Сегодня, 8:49 * ,
Для спасибо, есть специальная кнопка.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #167787 · Ответов: 6 · Просмотров: 587
 

>  Добавить поле ручного ввода. Бухгалтерский учёт для Украины 7.70.252
denis84
Отправлено: 29.10.20, 8:20


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 166
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


graf.vorontsov @ Вчера, 23:02 * ,
1.Открываем конфигурацию.
2.Находим наш документ, в его табличной части добавляем реквизит с типом строкам.
3.Открываем форму документу.
4.Меню "вставить" - "реквизиты".
5.Потом в "реквизитах табличной части" находим наш реквизит. Отмечаем его галочкой и жмем "вставить".
6.Сохраняем конфигурацию и проверяем в предприятии.

У меня по такому плану действий - реквизит доступен для редактирования. Вы что его добавили как текст, а не реквизит? Сделайте так, как я Вам написал. Потому, что "текст" добавляется "не доступным" для редактирования.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #167785 · Ответов: 6 · Просмотров: 587
 

>  Добавить поле ручного ввода. Бухгалтерский учёт для Украины 7.70.252
denis84
Отправлено: 28.10.20, 21:31


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 166
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


graf.vorontsov @ Сегодня, 17:39 * ,
Добрый вечер! Добавьте реквизит с типом строка в свой документ, в его табличную часть.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #167759 · Ответов: 6 · Просмотров: 587
 

>  Анализ ОСВ 361, 631, 6412, 661 счетов...
denis84
Отправлено: 21.10.20, 13:45


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 166
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


bookkeeper @ Сегодня, 13:45 * ,
Добрый день
Цитата(bookkeeper @ 21.10.20, 13:45) *
не могу понять что показывают ОСВ 361,631 счетов, так как суммы в оборотах там совсем не сходятся.

Что Вы имеете ввиду 361 счет - это взаиморасчеты с покупателями, а 631 это взаиморасчеты с поставщиками. Как могут сходится обороты?
  Форум: 1С Бухгалтерия 7.7 для Украины · Просмотр сообщения: #167526 · Ответов: 6 · Просмотров: 210
 

>  Ведение нескольких организаций
denis84
Отправлено: 13.10.20, 17:55


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 166
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


megamin @ Сегодня, 18:19 * ,
Добрый день! А приход правильно отражается по организациям?
  Форум: 1С Управление Торговым Предприятием 8 · Просмотр сообщения: #167329 · Ответов: 6 · Просмотров: 241
 

>  1с 8 БП 3.0 ВПФ при отправки на почту получаю ошибку
denis84
Отправлено: 12.10.20, 13:28


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 166
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Тема закрыта. Необходимо было в "Функция ПечатьДокумента(МассивОбъектов, ОбъектыПечати)" добавить строку

УправлениеПечатью.ЗадатьОбластьПечатиДокумента(ТабличныйДокумент, 
                НомерСтрокиНачало, ОбъектыПечати, Шапка.Документ);


После этого стало формировать печатные формы для отправки по электронной почте
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #167276 · Ответов: 1 · Просмотров: 110
 

>  1с 8 БП 3.0 ВПФ при отправки на почту получаю ошибку
denis84
Отправлено: 12.10.20, 10:57


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 166
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Добрый день! Есть внешняя печатная форма для документа "Акт сверки взаиморасчетов". Данная печатная форма формируется без ошибок. После её формирования, я могу отправить на почту контрагенту (из печатной формы).
А вот если находишься в списке документов, то при нажатии отправки на почту - отмечаю 2 формы "акт сверки"(печатная форма в конфигурации) и свою внешнюю, то получаю ошибку "Индекс находится за границами массива". Если отдельно "акт", то отправляется. А если отдельно свою внешнюю, то не происходит ничего. Кто-нибудь сталкивался с таким? Прошу совета

Вот код функции "печать":

Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
    ПараметрыВывода.ДоступнаПечатьПоКомплектно = Истина;
    Для Каждого ЭлементМассива из МассивОбъектов Цикл
        Наименование = ЭтотОбъект.Метаданные().Представление()  +" № " +ЭлементМассива.Номер +" от " + Формат(ЭлементМассива.Дата, "ДЛФ=D") + " " +
                                          ЭлементМассива.Контрагент;
        УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "ВозвратПоАктуСверки",Наименование, ПечатьДокумента(МассивОбъектов,
                                                                                                              ОбъектыПечати));
    КонецЦикла;
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #167275 · Ответов: 1 · Просмотров: 110
 

>  Как создать ссылку на определенную строку ТаблицыЗначений? 1с 7.7 конф 7.7.003
denis84
Отправлено: 22.09.20, 17:28


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 166
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


ZUBR @ Сегодня, 18:12 * ,
Добрый день. ТЗ.ПолучитьСтроку() используется без параметров и показывает( получает) строки ТЗ.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #166659 · Ответов: 6 · Просмотров: 215
 

>  УАТ подорожній лист автобуса незагального користування бланк №6 (спец )
denis84
Отправлено: 01.09.20, 15:10


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 166
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


alexandr_f @ Сегодня, 14:27 * ,
Добрый день! Для какой конфигурации нужен макет?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #166090 · Ответов: 2 · Просмотров: 215
 

>  Нужен совет по документу и данным в нем.
denis84
Отправлено: 25.08.20, 7:08


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 166
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Evgeniux @ 23.08.20, 0:39 * ,
Добрый день! Где заполнять (хранить) данные, все зависит от того, если сборщик будет собирать несколько ПК в день, делать тесты, то лучше в табличную часть документа. Потом запросом из регистра получать данные.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #165883 · Ответов: 1 · Просмотров: 182
 

>  Не установлен приемник xml
denis84
Отправлено: 21.08.20, 15:14


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 166
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


на просторах интернета нашел такое:
Проблема может быть в макете. Ищите в какой области у вас выскакивает эта ошибка, найдите строчку, в которой происходит эта проблема и используйте метод "Очистить -> Все", и заведите содержимое снова.

А другие печатные формы не пробовали в ворд сохранять?
  Форум: Платформа 8 · Просмотр сообщения: #165830 · Ответов: 4 · Просмотров: 290
 

>  Не установлен приемник xml
denis84
Отправлено: 21.08.20, 14:42


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 166
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


jambbadbalance @ Сегодня, 15:15 * ,
Сохраняете стандартно через "файл" - "сохранить как" или программно
  Форум: Платформа 8 · Просмотр сообщения: #165828 · Ответов: 4 · Просмотров: 290
 

>  COMобъекты Запрос и получение значений результата
denis84
Отправлено: 20.08.20, 7:43


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 166
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


DmitryPushkarev @ Сегодня, 8:17 * ,
Добрый день! Я когда импртировал справочник ТМЦ из 1С 7 в 1с 8 по ОЛЕ, то использовал вот такой код:

V77 = Новый COMОбъект("V77.Application");

V77.глрасшифровка = СпрОле.ВидТМЦ;       //получение представления идентификатора Перечисления.ВидыТМЦ
Вид = V77.EvalExpr("Строка(глРасшифровка)");
ЭлементПоиска = Справочники.ВидыНоменклатуры.НайтиПоНаименованию(Вид);
Если ЭлементПоиска.Пустая() Тогда
    ЭлементПоиска = Справочники.ВидыНоменклатуры.СоздатьЭлемент();
    ЭлементПоиска.Наименование = Вид;
    Если Вид = "Услуга" Тогда
        ЭлементПоиска.ТипНоменклатуры = Перечисления.ТипыНоменклатуры.Услуга;
    Иначе
        ЭлементПоиска.ТипНоменклатуры = Перечисления.ТипыНоменклатуры.Товар;
    КонецЕсли;
    ЭлементПоиска.Записать();
Иначе
    Сообщить("Такой вид ТМЦ уже есть!");
КонецЕсли;
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #165789 · Ответов: 4 · Просмотров: 286
 

>  Как использовать один и тот же программный блок с небольшими изменениями несколько раз? 1с 7.7 конф 7.7.00
denis84
Отправлено: 17.08.20, 8:31


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 166
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


ZUBR @ Сегодня, 0:51 * ,
Добрый день! А если при выборке документов - эти все условия вставить, если конечно я правильно Вас понял
Если ((Найти(Расх.Телефон,Телефон_)>0)и(Расх.ПометкаУдаления()=0)) Тогда
ТЗ.НоваяСтрока();
...........................
ИначеЕсли ((Найти(Расх.Имя,Имя_)>0)и(Расх.ПометкаУдаления()=0)) Тогда
ТЗ.НоваяСтрока();
...........................

И так далее.
Или на форме отчета сделать переключатель "почем осуществлять поиск" сделать и все это писать в ТЗ
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #165700 · Ответов: 14 · Просмотров: 800
 

>  Номенклатура и её родители
denis84
Отправлено: 04.08.20, 13:31


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 166
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Bon Jovi @ Сегодня, 13:37 * ,
Вот здесь можно почитать

и здесь

Добавить в условии что - то типа того
                   
                |ГДЕ
                | Номенклатура.Признак = &ТекущийЭлементНоменклатуры";

                  Запрос.УстановитьПараметр("ТекущийЭлементНоменклатуры", Признак);
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #165311 · Ответов: 5 · Просмотров: 377
 

>  Объеденение приходных накаладных
denis84
Отправлено: 28.07.20, 7:20


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 166
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Дмитрий_____ @ Сегодня, 7:17 * ,
Добрый день! Ну теоретически можно объединить, если Вам не важно в какой накладной пришел товар. Введите все товары в одну накладную. Накладные в печатном виде приходят или в электронном тоже есть? Если есть в электронном можно написать загрузку в один документ. Если я конечно Вас правильно понял.
  Форум: Платформа 8 · Просмотр сообщения: #165105 · Ответов: 4 · Просмотров: 304
 

>  Как вытянуть значения измерений из регистра ? (1c 7.7.027)
denis84
Отправлено: 14.07.20, 20:00


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 166
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


andrew76 @ Сегодня, 20:43 * ,
Надо вспоминать))

ОстаткиТоваров.Количество = ОстТоваров.Остаток(Фирма,ТекТов,Склад,"ОстатокТовара");
        
ОстаткиТоваров.Количество = ОстТоваров.СводныйОстаток(Фирма,ТекТов,,"ОстатокТовара");


А вот пример в виде запроса, как получить остатки и обороты товаров по складам

//*******************************************
Процедура Сформировать()
    Запр = СоздатьОбъект("Запрос");
    Таб = СоздатьОбъект("Таблица");
    ПечФорма = "ТаблицаШир_НеБУ";
    Таб.ИсходнаяТаблица(ПечФорма);

    ТекстЗапр = "";
    Заг = "";
    Заг1 = "";
    Заг2 = "";

    ПозицияОтчета = ДатаПо;
        
    ТекстЗапр = "
    |Период с ДатаС по ДатаПо;
    |Фир = Регистр.Остатки.Фирма;
    |Скл = Регистр.Остатки.МестоХранения;
    |ТМЦ = Регистр.Остатки.ТМЦ;";
    |Док = Регистр.Остатки.ТекущийДокумент;
    |Кво = Регистр.Остатки.ОстатокТовара;;
    |Условие (Фир = выбФирма);";
    |Условие (Скл в ВыбСклад);
    |Условие (Скл.Тип = Перечисление.ТипыМестХранения.Склад);
    |Условие (ТМЦ в ВыбТМЦ);
    |Группировка Скл;
    |Группировка ТМЦ упорядочить по ТМЦ.Код без групп;
    |Функция НОКво = НачОст(Кво);
    |Функция КОКво = КонОст(Кво);
    |Функция ПКво = Приход(Кво);
    |Функция РКво = Расход(Кво);";
    Если ВыбТМЦ.РазмерСписка() = 0 Тогда
        Заг1 = Заг1 + "По всім ТМЦ. ";
    Иначе
        Заг1 = Заг1 + "По ТМЦ зі списку: " + ВыбТМЦ.ВСтрокуСРазделителями() + ". ";
    КонецЕсли;
    Если ВыбСклад.Выбран() = 0 Тогда
        Заг2 = Заг2 + "По всім складам.";
    Иначе
        Заг2 = Заг2 + "По складу " + СокрЛП(ВыбСклад.ИсторическоеНаименование.Получить(ДатаПо)) + ".";
    КонецЕсли;

    Если Запр.Выполнить(ТекстЗапр) = 0 Тогда
        Возврат;
    КонецЕсли;

    Таб.ВывестиСекцию("Шапка");
    Пока Запр.Группировка("Скл") = 1 Цикл
        Таб.ВывестиСекцию("Скл");
        текНом = 0;
        Пока Запр.Группировка("ТМЦ") = 1 Цикл
            Если Запр.ТМЦ.Выбран() = 0 Тогда
                Продолжить;
            КонецЕсли;
            Если Запр.ТМЦ.ЭтоГруппа() = 1 Тогда
            Иначе
                текНом = текНом + 1;
                УчЦена = Запр.ТМЦ.УчетнаяЦена.Получить(ДатаПо);
                Таб.ВывестиСекцию("ТМЦ");
            КонецЕсли;
        КонецЦикла;
        
        Если Запр.Скл.ЭтоГруппа() = 0 Тогда
            Таб.ВывестиСекцию("ИтСклад");
            ИтКво = ИтКво + текНом;
            текНом = 0;
        КонецЕсли;
    КонецЦикла;
    Таб.ВывестиСекцию("Итог");
    Таб.Опции(0,0,Таб.ВысотаСекции("Шапка"),0);
    Таб.ТолькоПросмотр(1);    
    Таб.ПараметрыСтраницы(2,95,,3,3,3,3,,,,,);
    Таб.Показать("Оборотка ТМЦ по складам");
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #164738 · Ответов: 5 · Просмотров: 425
 

>  Как вытянуть значения измерений из регистра ? (1c 7.7.027)
denis84
Отправлено: 14.07.20, 19:18


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 166
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


andrew76 @ Сегодня, 18:26 * ,
Если в Вашу процедуру вписывать, то по -моему можно так

Склад = рег.склад;
МОЛ = рег.МОЛ
Таб.ВывестиСекцию("Строка");


склад и мол - это выражения на печатной форме в секции "строка".

Запросом можно, напишу позже. опробуйте этот вариант пока.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #164736 · Ответов: 5 · Просмотров: 425
 

>  Как вытянуть значения измерений из регистра ? (1c 7.7.027)
denis84
Отправлено: 14.07.20, 18:19


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 166
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


andrew76 @ Сегодня, 18:26 * ,
Добрый день! Сформулируйте еще раз! Вы хотите получить данные из регистра? А справочников материалов зачем Вам? Сама задача в чем заключается? Вообще можно запросом к регистру все это получить
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #164734 · Ответов: 5 · Просмотров: 425
 

>  Автоматично зміна схеми реалізації
denis84
Отправлено: 10.07.20, 8:45


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 166
Регистрация: 12.06.09
Из: Украина
Пользователь №: 700


Sirius83 @ Вчера, 16:32 * ,

Добрый день! В новых документах при выборе номенклатуры со счетом учета 26 и с выбранной схемой реализации в УПП (демо) все работает. Как сказал Макс1С, у Вас в регистре значит есть ещё какие-то записи для продукции.

Вот мой регистр сведений счета учета:


Вот документ:


Вот проводки по этой схеме:

  Форум: 1С Управление производственным предприятием 8 · Просмотр сообщения: #164616 · Ответов: 8 · Просмотров: 372
 

7 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 26.11.20, 8:24
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!