Версия для печати темы (https://pro1c.org.ua/index.php?s=d37ab34f62468df5e1df439c51856764&showtopic=57974)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Программирование в 1С Предприятие 8.3 _ Как в СКД при сохранении отчета чтобы имя файла уже было заполненным?

Автор: twilight_dream 26.03.20, 15:29

Платформа: 1С:Предприятие 8.3 (8.3.16.1224)
Конфигурация: любая

САБЖ.


Автор: Aquarrius 26.03.20, 16:31

twilight_dream @ Сегодня, 15:29 * ,

Процедура КоманднаяПанельФормыСохранитьВExcel(Кнопка)

Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Сохранение);
Диалог.ПолноеИмяФайла = ЭтаФорма.Заголовок+".xls"; // имя файла
Диалог.Фильтр = "(*.xls)|*.xls";
Если Диалог.Выбрать() Тогда
ЭлементыФормы.ПолеТабличногоДокумента.Записать(Диалог.ПолноеИмяФайла,ТипФайлаТабличногоДокумента.XLS);
КонецЕсли;

КонецПроцедуры



Скорее всего по аналогии smile.gif

Автор: twilight_dream 26.03.20, 16:42

Да, это хороший вариант. Но надо без отдельных кнопок через меню "Файл - сохранить". Вашу версию оставлю на-последок, если ничего не найду.

Автор: Vofka 27.03.20, 9:22

twilight_dream, для спасибо есть специальная кнопочка.

Автор: Vladal 29.03.20, 17:45

Я сделал так:

&НаКлиенте
Процедура ПечатьСабжа(Команда)
    ТабДок = Новый ТабличныйДокумент();
    ТабДок.Область(1, 1).Текст = "САБЖ";
    ТабДок.Показать("Это заголовок окна", КаталогВременныхФайлов() + "НужноеИмяФайла.mxl");
КонецПроцедуры
По команде меню "Файл - Сохранить как" будет открыт диалог с нужным именем файла.

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua