Версия для печати темы (https://pro1c.org.ua/index.php?s=57f6ffdf2cc454d2d20814a2f904458e&showtopic=66759)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Программирование в 1С Предприятие 8.3 _ Не могу выгрузить текстовый документ в файл на локальном диске

Автор: lina1982 06.10.21, 11:17

Здравствуйте, Конфигурация:
1С:Предприятие 8.3 (8.3.16.1063)
Бухгалтерия предприятия, редакция 3.0 - (1.3.10.150)

При выгрузки текстового документа с сервисной базы выходит сообщение:


Ошибка доступа к файлу: D:\rrr.txt



АдресФайла = Объект.Файл;
    // Текст.Записать("D:\Оптима\гог.txt");
    Текст.Записать(АдресФайла);



Пробовала:
Код
&НаКлиенте
Процедура ФайлНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    Режим                                     = РежимДиалогаВыбораФайла.Сохранение;
    ДиалогОткрытияФайла                     = Новый ДиалогВыбораФайла(Режим);
    //ДиалогОткрытияФайла.Каталог                = АдресФайла;    
    ДиалогОткрытияФайла.ПолноеИмяФайла         = "";
    Фильтр                                     = "Файл(*.txt;*)|*.txt";
    ДиалогОткрытияФайла.Фильтр                 = Фильтр;
    ДиалогОткрытияФайла.МножественныйВыбор     = Ложь;
    ДиалогОткрытияФайла.Заголовок             = "Укажите имя файла txt и выберите папку, в которую необходимо записать этот файл";
    
    ДиалогОткрытияФайла.Показать(Новый ОписаниеОповещения("ПутьКФайлуНачалоВыбораЗавершение", ЭтотОбъект, Новый Структура("ДиалогОткрытияФайла", ДиалогОткрытияФайла)));

КонецПроцедуры

&НаКлиенте
Процедура ПутьКФайлуНачалоВыбораЗавершение(ВыбранныеФайлы, ДополнительныеПараметры) Экспорт
    
    ДиалогОткрытияФайла = ДополнительныеПараметры.ДиалогОткрытияФайла;      
    
    Если (ВыбранныеФайлы <> Неопределено) Тогда
        Объект.Файл = ДиалогОткрытияФайла.ПолноеИмяФайла;
    КонецЕсли;
      
КонецПроцедуры


Не получается

Автор: Vofka 06.10.21, 19:59

lina1982, база клиент серверная и строчка

Текст.Записать(АдресФайла);

выполняется в процедуре с директивой &НаСервере?

Автор: lina1982 07.10.21, 3:23

Vofka @ Вчера, 20:59 * ,
да

Автор: Vofka 07.10.21, 9:14

lina1982, код, который выполняется на сервере, физически выполняется на компьютере, где установлен сервер 1С. В вашем случае скорее всего диск D есть на вашем локальном компьютере, но нету на сервере.

Автор: lina1982 07.10.21, 10:06

Vofka @ Сегодня, 10:14 * ,
это понятно, я не знаю как написать, чтобы документ записывался на локальный компьютер, а не на сервер. Если база локальная, то записывает на диск без проблем.

Автор: Vofka 07.10.21, 11:11

lina1982, делать запись в процедуре НаКлиенте.

Автор: lina1982 07.10.21, 11:26

Vofka @ Сегодня, 11:11 * ,
на клиенте я пробовала, код показала в данной теме, все равно не получается...

Автор: takefive 08.10.21, 10:42

Не пишите в корень диска. Настройте каталогу уровень безопасности и доступа. Учитывая, что Ваши права и права программы различны...

Автор: lina1982 09.10.21, 7:18

takefive @ Вчера, 10:42 * ,
я не знаю как это сделать

Автор: takefive 11.10.21, 17:20

lina1982 @ 09.10.21, 7:18 * ,
В свойствах папки на закладке Безопасность включите группе Пользователи флажки - разрешить...

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua