Версия для печати темы (https://pro1c.org.ua/index.php?s=8187977a44e4e6123413e3fca3f75f14&showtopic=61605)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Управление торговлей для Украины редакция 3 (Управление торговлей для России редакция 11) _ Отключение объединения номенклатурных позиций

Автор: KIODAMAGE 16.09.20, 14:06

Добрый день. В Рознице 2.2 есть возможность в настройках РМК запретить объединение одинаковых номенклатурных позиций в одну строку(когда при добавлении не добавляется новая строка, а только возрастает количество). Подскажите, можно ли это каким-то образом сделать в УТ 3.2.16.3?

Автор: KIODAMAGE 16.09.20, 15:32

Получилось сделать таким образом:

Процедура ПолучитьТаблицуДоступныхДействий(Отбор, АдресаВХранилище, НадписьОбеспечено)
    
    ...
            
            НайденныеСтроки = ТаблицаДоступныхДействий.НайтиСтроки(СтруктураПоиска);
            //Если НайденныеСтроки.Количество()>0 Тогда
            //    НайденныеСтроки[0].Доступно = НайденныеСтроки[0].Доступно + КоличествоОформлено;  - отключил проверку на количество;
            //Иначе
                НоваяСтрока = ТаблицаДоступныхДействий.Добавить();
                ЗаполнитьЗначенияСвойств(НоваяСтрока, ТаблицаДоступныхДействий[ТаблицаДоступныхДействий.Количество()-2]);
                НоваяСтрока.ВариантОбеспечения = СтруктураПоиска.ВариантОбеспечения;
                НоваяСтрока.Доступно = КоличествоОформлено;
            //КонецЕсли;
        КонецЕсли;
        
    ...
    
КонецПроцедуры


В процедуре отключил проверку на количество, при добавлении через подбор товаров работает нормально, но при выборе быстрых товаров по-прежнему объединяет строки.

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua