Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

История благодарностей участнику 1Cv77 ::: Спасибо сказали: 61 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
05.10.19, 22:20 В печатной форме вместо фирмы НеизвестныйОбъект 1с 7.7 конф 7.7.003
ZUBR @ Сегодня, 19:22 * ,
Доброго времени суток.

Реквизит "Фирма" - скорее всего - общий!!! (см. Документы -> Общие реквизиты)

Насчет "Адреса", то, посмотрите, возможно, он - периодический.

Тогда, нужно так:
Адрес.Получить(ДатаДок)

ZUBR,
30.07.19, 20:18 Как сохранить текущее значение переменной в 1С 7.70.003 торговля склад для Украины?
ZUBR @ Сегодня, 18:49 * ,
В принципе : решение - правильное!!!
Хотя, можно, без объявления константы, просто, в процедуре ВводНового() прописать такое:
    НомерЗаказа=0;
    врДок=СоздатьОбъект("Документ.АктПриема");
    врДок.ОбратныйПорядок(1);
    врДок.ВыбратьДокументы(ДатаДок-30,ДатаДок);
    Пока врДок.ПолучитьДокумент()=1 Цикл
                НомерАкта=врДок.НомерЗаказа;
        Прервать;   /// для экономии времени
    КонецЦикла;
    НомерЗаказа+1;



 ! 

Правила: 9
 
ZUBR,
24.07.19, 23:06 Как в документ Расходная накладная внести по умолчанию курс валюты 1с 7.7 конф 7.7.003
ZUBR @ Сегодня, 21:51 * ,

Пробуйте так:

Расх.Курс = Константа.БазоваяВалюта.Курс.Получить(ТекущаяДата());
ZUBR,
29.05.18, 19:36 работа с перечислениями
4andriy @ Сегодня, 17:29 * ,
Вообще-то, нужно так:

Если СокрЛП(Контрагент.ВидТМЦ)="Продукция" Тогда
    Склад="Первый";
ИначеЕсли СокрЛП(Контрагент.ВидТМЦ)="Материал" Тогда
    Склад="Второй";
КонецЕсли;


И, то, при условии: что Контрагент.ВидТМЦ - ЭТО СТРОКА!!!!!

4andriy,
12.07.17, 22:03 загрузка свойств номенклатуры из xls
Korotkiy @ Сегодня, 20:44 * ,
Строки

Запрос = СоздатьОбъект("Запрос"); 
СпрСвойств = СоздатьОбъект("Справочник.ВидыСвойств");        
СпрЗначСвойств = СоздатьОбъект("Справочник.ЗначенияСвойств");
СпрСвойствНом = СоздатьОбъект("Справочник.СвойстваНоменклатуры");


Перенеси ЗА строчку
Процедура  ПоКнопкеЗагрузить() Далее



 ! 

Правила: 9
 
Korotkiy,
15.07.14, 10:08 Заполнение табличной части документа
Ну элементарно:

    Для Сч = НачМесяца(ДатаДок) По КонМесяца(ДатаДок) Цикл
        НоваяСтрока();
        Дата=НачМесяца(ДатаДок)+Сч-1;
    КонецЦикла;


там насчет Сч-1 проверьте


 i 

Выделяем код!
 
Циган,
29.10.12, 18:32 Vofka, с Днем рождения!
Присоединяюсь!!!
Желаю:
Море удачи!
И дачу у моря!
Vofka,
02.08.12, 18:32 ошибка при обновлении 7.7 до 293 релиза
Цитата(Буду_Знать @ 02.08.12, 17:12) *
Приветствую!
Подскажите при обновлении до 293 релиза при входе в базу после проверки легальности помощник обновления и клавиша дальше выдает следующую ошибку

СпрВЗ.Родитель = ТекущийРодитель;
{Обработка.ОбновлениеРелиза.Форма.Модуль(9494)}: Неверное значение!


Моя версия 1С Предприятие 7,7 (7,70,025) конфигурация "Бух. учет" для Украины 7,70,293
windows 7, 32-разрядная

Что это может быть и как его побороть. Предприятие на едином налоге, справочник доходов не обновлялся за ненадобностью.
Помогите исправить ситуацию!

А какой релиз стоял до этого???
MaxMl76,
12.05.12, 21:05 Улыбнуло
Вот шутка с сайта работы

ЗП: телефон скрыт.

Ну ни.... себе зарплата...
семизначная что-ли???

еще на одном сайте:
Читаю:
Программист 1С
Программист 1С 7,7
Программист 1С 7,7 8,х
Оператор станков ЧПУ
Программист 1С 8,2

ДА........
вот сижу и думаю, что я пропустил???

И еще:

Программист 1с: предприятие 8 (встроенный язык) - 30-80 грн.
Программист 1с - 3000-8000 грн.
......
Зарплата: - премии, соц. пакет

т.е. как? Зарплату не платят???

и тут же в другой компании

Программист 1С Харьков 600012000 грн 03.05.12

вот это я понимаю........


И еще прикол из области рекрутинга...
Программист 1С ..... тра ля ля
тра ля ля
сопровождение сайта компании
захожу на сайт - 404

Продолжение...
Отослал резюме, приходить письмо:

Здравствуйте, Сергей.
перезвоните пожалуйста.
С уважением,
Ирина,095.....

//-----
эксклюзивный дистрибьютор известных алкогольных брендов
Програмист 1S

точно с будуна писали....


//--------
Программист 1С - в разделе куплю

//--------
Программист 1С (проект внедрения)
испытанный срок 3 мес.

//--------
Обязанности:
1. Амортизация предприятия

//--------
Занятость: Полный рабочий день(жесткий)
Хоть сразу предупреждают.....

//--------
Опыт работы от 2-х лет с платформой 1С 8.3

я что, что-то пропустил?

//--------
администрирование типовых и нетиповых конфигураций на базе 1С 7.5 / 8.0
объявление мая этого года

//--------
Возраст от 2 до 3

Что они этим хотели сказать???
MaxMl76, yur,
06.05.12, 14:18 Одна база на двух компах
Под семеркой была такая штука как МОД (Модуль Обмена Данными).
Под восьмеркой не скажу.... ((((
MaxMl76,
05.05.12, 20:46 HR-Менеджеры.....
сейчас занимаюсь поиском работы...
на одном из сайтов прочитал (в требованиях к кандидату)
"поддерживает программное обеспечение 1С(8.2)для удовлетворения"

долго думал.....


ДОСЛОВНО из вакансии:
оптный ползователь и програмист 1С 7 и 8 серии

забыли дописать: знание русского - не нужно
MaxMl76,
27.04.12, 22:20 Переход с ПУБ на Бух
Цитата(MATEVI @ 17.02.12, 20:53) *
"Универсал 2.7" Вам в помощь


А где взять эту штуку???
ОЧЕНЬ НУЖНО причем срочно

Заранее СПАСИБО!!!

P.S. Вещь классная я сам, в свое время, ей пользовался!
Особенно помогает если базы - разные!!!
MaxMl76,
27.04.12, 22:01 Переход с ПУБ на Бух
Цитата(MATEVI @ 17.02.12, 20:53) *
"Универсал 2.7" Вам в помощь


А где его взять?????

Ну очень надо причем срочно....

Заранее спасибо
MaxMl76,
30.05.11, 12:01 1С и Клиент-Банк
Всем доброго времени суток!
Подскажите кто сталкивался в ВТБ банком!
Где найти клиент-банк для него?

Заранее спасибо!
MaxMl76,
12.01.11, 11:07 Анекдот
Дневник пингвина

Понедельник.
Сегодня совсем тепло, всего минус десять. Утром на берегу высадились две группы людей. Что-то строят, кажется, зимовки. Те, что победнее одеты, часто вспоминают чью-то маму и стреляют у своих соседей сигареты.

Вторник.
Сегодня в наше стадо приходили гости. Называли себя американцами и угощали нас бананами. Вкусно.

Среда.
Вчера вечером наше стадо посетили русские. Угощали огненной водой и называли нас чукчами. После третьего стакана я упал клювом в сугроб. Утром обнаружил, что мои глаза смотрят в разные стороны. Может быть, бананов переел?

Четверг.
Ходил к русским. Человек в медвежьей шубе показал рукой в сторону американцев и сказал: "Тащи бананы, чукча, тогда налью". Его зовут Костя. Очень душевная личность. На этот раз я спал в сугробе вместе с ним.

Воскресенье.
Американцы дают бананы все неохотнее.

Вторник.
Вчера американцы не дали бананов совсем. Я спер у них какую-то железяку с проводами и притащил Косте. Он сказал, что чукча молодец, и налил мне стакан спирта. Потом пили еще, за удачный бизнес. В сугроб спать не пошли: Костя заснул за столом, а я так и не смог добраться до двери.

Среда.
Сегодня американцы приходили к русским и требовали вернуть антенну. Костя сказал им по-русски: "Банан вам, а не антенну!". Американцы банан не взяли и ушли с пустыми руками. Вечером американцы приходили с обыском в наше стадо. Искали меня, чтобы снять шкуру. Ну, ни фига себе налоги на бизнесменов!..

Четверг.
Ночью, когда все спали, перекатил на зимовье русских все американские бочки с соляркой. У американцев поднялась паника. Здоровый рыжий американец стрелял из ружья и кричал: "Рашен чукча - партизан!". Дурак! Нечего было бананы жалеть!

Пятница.
Американцы сидят без топлива и без рации. Сегодня немного похолодало (минус сорок), и они согласились сесть за стол переговоров. Я теперь живу в комнате Кости. Он говорит, что бизнесмену нужна крыша.

Суббота.
Переговоры идут второй день. Американцы называют меня "русский мафиози". Оказывается, все их бочки с соляркой были помечены. Костя предъявил американцам документы, по которым все их бочки были взяты в качестве трофеев у немцев еще в 1945 году во время прорыва танковой дивизии генерала Мирошниченко к городу Шпандау.

Воскресенье.
Русские продали американцам бочку солярки за десять тысяч долларей и три ящика бананов. Что ни говори, бананы - классный закусон! Воспользовавшись пургой, пошел к американцам и перекатил бочку назад. Зачем - не знаю. Наверно, из принципа.

Понедельник.
Русские вернули американцам бочку за какую-то несчастную тысячу долларей и бутылку вина. Господи, какую же гадость пьют эти американцы!

Среда.
Русские требуют за солярку рубли, а у американцев только доллары. Костя организовал валютную биржу. Курс доллара сразу стал падать. Сегодня за один рубль можно купить 17 657 долларей.

Суббота.
Американцы просят солярку в кредит. Костя обещал подумать, а пока предложил им гуманитарную помощь: один стакан солярки в день. Мне объяснил, что эта гуманная акция поднимет наш престиж. М-да... Мудреная это штука - бизнес.

Воскресенье.
Американские женщины просятся к нам на заработки. Их можно понять: у нас тепло и очень весело. А теперь, кажется, будет еще веселее.

Понедельник.
Костя заявил, что у американцев нет демократии. И он совершенно прав! У американского начальника отвратительнейшая физиономия. Да и вообще он такой жмот: за лишний миллион долларей удавиться готов.

Вторник.
Костя не удосужился объяснить американцам, как строить демократию, и они дерутся уже второй день. А мы смотрим. Интересно! Я сегодня поставил на рыжего триста тысяч долларей, но беднягу в самом начале драки стукнули табуреткой по голове. Рыжий упал носом в сугроб. В дальнейшем строительстве демократии он не участвовал.

Среда.
Да здравствует бизнес! Курс рубля все растет. Мне выделили отдельный кабинет и охрану. Что поделаешь, американцы - довольно дикий народ: бродят возле нашей территории с топорами. Ага, жди, так я и выйду без охраны!

Пятница.
Костя показал мне расписку рыжего. Теперь мой друг владеет фамильным замком Генри Форда и его окрестностями. Сам рыжий возражал против такой приватизации, но его товарищи показали ему табуретку, и рыжий быстро согласился.

Среда.
Зимовка подходит к концу. А жаль! Вполне возможно, что у американцев еще осталась парочка-другая фамильных фирм и банков. Костя уговаривает меня ехать с ним в Россию. Говорит, что именно сейчас его стране нужны такие честные бизнесмены, как я.

Без даты.
Прощай, Антарктида! Говорят, в России много работы. Костя сказал, что рядом с Россией живут не только американцы, но и много разных других народов. Это хорошо. Потому что американцы слишком хорошо меня знают. А с остальными нам только предстоит познакомиться. Ре-е-е-бята-а!.. Я к вам иду!.
Alan68, logist,
11.01.11, 14:28 Новая форма налоговой накладной
Достали меня бухи седня...
вот наваял на скорую руку!

Налоговая накладная 2011

P.S. Читаем текстачь внутри архива!!!
FLancer, IntEres-Centre, metallurg, sobiren,
21.05.10, 8:17 Вопросик
Цитата(Vitalis @ 21.05.10, 0:57) *
Можно ли как-то организовать чтобы в переферийной базе (001) создателе этого элемента Наименование отображалось полностью (А+Б+В+Г), а в переферийной базе (002) отображался как (А+Б)?


Попробуй так:
В форме списка справочника замени колонку наименование на текст где будет обращение в функции.
В самой функции проверяй если код 001 (централькая база) то Возврат (А+Б+В+Г)
Иначе Возврат (А+Б)

P.S. Первое что пришло на ум. Но только код 001 желательно сделать констатой
Vitalis,
26.03.10, 8:26 Нужна помощь с обработкой
Все спасибо, сам допер....
просто с утра (после вчерашнего) голова совсем не работает...

кому интересно:

//*******************************************
Процедура Сформировать()
    Cпр=СоздатьОбъект("Справочник.Счета");
    Спр.ПорядокНаименований();
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()=1 Цикл
        Нкод=Спр.Код;
        Нкод=СтрЗаменить(Нкод,".","");
        Спр.Код=Нкод;
        Спр.Записать();
    КонецЦикла;
КонецПроцедуры
nonsens,
15.09.09, 15:35 Проблемы регламентированная отчетность для конфигурации Fort
Цитата(treefrog @ 15.09.09, 15:08) *
Проблема с отчетом по НДС, созданным в регламентированной отчетности за второй квартал для конфигурации Fort 2000. Отчеты созданные в 1с не читаются в налоговой. Причем этот же отчет нормально читается программой OPz и Zvit. Ошибок при создании не выдает.
Кто может "ткнуть носом", где искать порблему.


Там проблема в самом отчете. Нужно РУКАМИ менять!!!!

Смотри строки:




фтзПоляXML.НоваяСтрока();
фтзПоляXML.ИдентификаторПоля = "C_STI";
фтзПоляXML.ПредставлениеПоля = "Код ДПІ";
ЗначениеПоля = ПолучитьПустоеЗначение(); ЗначениеПоля = Число(2510); // Значение по умолчанию
фтзПоляXML.ПредставлениеЗначенияПоля = СокрЛП(Строка(ЗначениеПоля));
фтзПоляXML.Обязательный = Перечисление.Булево.Да;
СЗ_ПоляXML.ДобавитьЗначение(ЗначениеПоля,фтзПоляXML.ИдентификаторПоля);
Если фтзПоляXML.Обязательный = Перечисление.Булево.Да Тогда
СЗ_ПоляXML.Пометка(СЗ_ПоляXML.РазмерСписка(),1);
КонецЕсли;

фтзПоляXML.НоваяСтрока();
фтзПоляXML.ИдентификаторПоля = "C_REG";
фтзПоляXML.ПредставлениеПоля = "Код регіону";
ЗначениеПоля = ПолучитьПустоеЗначение(); ЗначениеПоля = Число(26); // Значение по умолчанию
фтзПоляXML.ПредставлениеЗначенияПоля = СокрЛП(Строка(ЗначениеПоля));
фтзПоляXML.Обязательный = Перечисление.Булево.Да;
СЗ_ПоляXML.ДобавитьЗначение(ЗначениеПоля,фтзПоляXML.ИдентификаторПоля);
Если фтзПоляXML.Обязательный = Перечисление.Булево.Да Тогда
СЗ_ПоляXML.Пометка(СЗ_ПоляXML.РазмерСписка(),1);
КонецЕсли;

фтзПоляXML.НоваяСтрока();
фтзПоляXML.ИдентификаторПоля = "C_RAJ";
фтзПоляXML.ПредставлениеПоля = "Код району";
ЗначениеПоля = ПолучитьПустоеЗначение(); ЗначениеПоля = Число(54); // Значение по умолчанию
фтзПоляXML.ПредставлениеЗначенияПоля = СокрЛП(Строка(ЗначениеПоля));
фтзПоляXML.Обязательный = Перечисление.Булево.Да;
СЗ_ПоляXML.ДобавитьЗначение(ЗначениеПоля,фтзПоляXML.ИдентификаторПоля);
Если фтзПоляXML.Обязательный = Перечисление.Булево.Да Тогда
СЗ_ПоляXML.Пометка(СЗ_ПоляXML.РазмерСписка(),1);
КонецЕсли;

treefrog,
10.08.09, 12:04 Где хранятся параметры XML?
Цитата(Георгий @ 10.08.09, 12:56) *
Именно в ней - в НДС. Я именно "ручками в самом отчете" и исправляю.
Думал, может есть способ "автомотизировать" этот процесс... sad.gif

фтзПоляXML.НоваяСтрока();
фтзПоляXML.ИдентификаторПоля = "C_STI";
фтзПоляXML.ПредставлениеПоля = "Код ДПІ";
ЗначениеПоля = ПолучитьПустоеЗначение(); ЗначениеПоля = Число(832); // Значение по умолчанию

Ты здесь исправлял???

А насчет автоматизации: Флаг в руки, я уже както пытался это сделать, только каждый раз при выходе новой отчетности опять все менять....

P.S. "ЗначениеПоля = Число(832)" это у меня уже измененные данные - и все ОК работает
Георгий,
18.07.09, 12:39 Обмен документами между контрагентами в 1С
Цитата(gersik @ 18.07.09, 11:29) *
Как можно в 1С 7.7 Бухгалтерия для Украины при большой номенклатуре поставки отослать в электронном виде расходную (для контрагента приходную) накладную, чтобы облегчить работу по оприходованию товаров (материалов) покупателем. Взаимоотношения с покупателем постоянные.

Попродуй через ексель иди дбф!
только тогда нужно ввести какойто общий реквизит (типа артикул) чтоб и у Вас и у Покупателя
он совпадал по каждой позиции.

P.S. а вобще задача очень интересная, но не бесплатная!!!
Если что пиши в личку, я уже ришал подобную задачу, причем конфы у пок. и пост. были разные!
gersik,
12.07.09, 9:04 декларация по прибыли
Цитата(gammalia @ 11.07.09, 18:50) *
очень нужна помощь!
В преддверии квартальных отчетов, столкнулась с проблемой - декларация по прибыли выходит минусовой.
В прошлом квартале была та же ситуация, при анализе обнаружились дубляжи по проводкам - проблема была решена. В этом квартале - дубляжей не обнаружила, но проблема осталась. У меня 1С ПРОФ


Если по бухгалтерскому учету выходит прибыль, а по налоговому убыток,
то попробуй перепровести все проведенные документы за квартал!
gammalia,

RSS Текстовая версия Сейчас: 20.11.19, 21:06
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!