Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> комментарий к номенклатуре из формы списка          
4andriy Подменю пользователя
сообщение 28.11.18, 12:01
Сообщение #1

Завсегдатай
****
Группа: Пользователи
Сообщений: 123
Спасибо сказали: 0 раз
Рейтинг: 0

1С 7.7 7.7.0.027 Предприятие

Хочу открыть справочник номенклатуры, есть колонка "Скидка". Добавил кнопку "Скидка". Нужно не открывая саму позицию нажать на кнопку и что-бы в текущей строке был добавлен нужный текст.

Процедура Кнопка1()
Документ = ТекущийДокумент();
Документ.ТекущаяСтрока("Справочник.Номенклатура.Скидка","Товар со скидкой")
Скидка = ?(СокрЛП(Основание) = "", "Товар со скидкой", Основание);
КонецПроцедуры


mister-x Подменю пользователя
сообщение 28.11.18, 13:07
Сообщение #2

...
Иконка группы
Модератору Про1С (за заслуги в 2011 году)
Группа: Местный
Сообщений: 3477
Из: Тернопіль
Спасибо сказали: 1393 раз
Рейтинг: 0

Це в списку номенлатури хочете таке реалізувати чи в журналі документів?
Щодо коду 48000000.gif де ви такий код в 7.7 бачили?

4andriy Подменю пользователя
сообщение 28.11.18, 14:03
Сообщение #3

Завсегдатай
****
Группа: Пользователи
Сообщений: 123
Спасибо сказали: 0 раз
Рейтинг: 0

mister-x @ Сегодня, 13:07 * ,
в довіднику номенклатури

4andriy @ Сегодня, 13:36 * ,
не відкриваючи сам довідник, щоб міняло тільки ту строку де виділено

mister-x Подменю пользователя
сообщение 28.11.18, 14:38
Сообщение #4

...
Иконка группы
Модератору Про1С (за заслуги в 2011 году)
Группа: Местный
Сообщений: 3477
Из: Тернопіль
Спасибо сказали: 1393 раз
Рейтинг: 0

Що таке Основание в контексті довідника Номенклатури? Для документів є таке поняття, а для довідників у 7.7 немає.

Vofka Подменю пользователя
сообщение 28.11.18, 14:45
Сообщение #5

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13544
Из: Киев
Спасибо сказали: 4213 раз
Рейтинг: 3365.6

Цитата(mister-x @ 28.11.18, 14:38) *
Що таке Основание в контексті довідника Номенклатури?

Какой-то произвольно добавленный реквизит, видимо.

mister-x Подменю пользователя
сообщение 28.11.18, 14:53
Сообщение #6

...
Иконка группы
Модератору Про1С (за заслуги в 2011 году)
Группа: Местный
Сообщений: 3477
Из: Тернопіль
Спасибо сказали: 1393 раз
Рейтинг: 0

Можливо, поки що задача сумбурно описана. Є підозра, що таке потрібно реалізувати у журналі документів, оскільки в документі можна надавати знижки, а довідник загальне поняття. Хіба що це якась самописка. ІМХО
Цитата(4andriy @ 28.11.18, 12:01) *
1С 7.7 7.7.0.027 Предприятие

це версія Платформи, а яка конфігурація, якщо ви вже вказали таку інформацію?

4andriy Подменю пользователя
сообщение 28.11.18, 19:01
Сообщение #7

Завсегдатай
****
Группа: Пользователи
Сообщений: 123
Спасибо сказали: 0 раз
Рейтинг: 0

це 1с 7: Підприємство, змінні довільні

потрібно щоб можна було правити в довіднику, а не в документі
коли я відкриваю конкретну номенклатуру там все працює з даним кодом
Процедура Кнопка1()
Скидка = ?(СокрЛП(Скидка) = "", "Скидка 10%", Скидка);
КонецПроцедуры


але задача винести кнопку в форму списку - там де курсор там і йде зміна

Naghual Подменю пользователя
сообщение 28.11.18, 19:21
Сообщение #8

Завсегдатай
****
Группа: Пользователи
Сообщений: 102
Из: Днепропетровск
Спасибо сказали: 21 раз
Рейтинг: 21

Андрей. Вы бы подучили сам язык сначала.
От вас много нубских вопросов.
Сложно программировать не зная азов языка.


Signature
Я желаю всем Счастья!

4andriy Подменю пользователя
сообщение 28.11.18, 19:25
Сообщение #9

Завсегдатай
****
Группа: Пользователи
Сообщений: 123
Спасибо сказали: 0 раз
Рейтинг: 0

Naghual @ Сегодня, 19:21 * ,
угу, кнопка уже работает

4andriy Подменю пользователя
сообщение 28.11.18, 20:41
Сообщение #10

Завсегдатай
****
Группа: Пользователи
Сообщений: 123
Спасибо сказали: 0 раз
Рейтинг: 0

4andriy @ Сегодня, 19:25 * ,
только как кнопку вывести в форму списка не знаю

mister-x Подменю пользователя
сообщение 28.11.18, 21:31
Сообщение #11

...
Иконка группы
Модератору Про1С (за заслуги в 2011 году)
Группа: Местный
Сообщений: 3477
Из: Тернопіль
Спасибо сказали: 1393 раз
Рейтинг: 0

так як і в форму елемента wink.gif

4andriy Подменю пользователя
сообщение 28.11.18, 21:44
Сообщение #12

Завсегдатай
****
Группа: Пользователи
Сообщений: 123
Спасибо сказали: 0 раз
Рейтинг: 0

mister-x @ Сегодня, 21:31 * ,
в формі елементу все працює)

volodya1122 Подменю пользователя
сообщение 29.11.18, 10:51
Сообщение #13

Оратор
Иконка группы
Группа: Местный
Сообщений: 311
Из: Тернопіль
Спасибо сказали: 117 раз
Рейтинг: 119.4

4andriy @ Вчера, 21:44 * ,
Процедура Кн()
    Если ПустоеЗначение(ТекущийЭлемент())=1 Тогда
        Возврат;
    КонецЕсли;  
    Если ТекущийЭлемент().ЭтоГруппа()=1 Тогда
        Возврат;
    КонецЕсли;    
    Элемент=СоздатьОбъект("Справочник.Контрагенти");
    Элемент.найтиЭлемент(ТекущийЭлемент());
    Элемент.Телефони=СокрЛП(Элемент.Телефони)+" проба";
     Элемент.Записать();
КонецПроцедуры


Сообщение отредактировал volodya1122 - 29.11.18, 10:52

mister-x Подменю пользователя
сообщение 29.11.18, 11:06
Сообщение #14

...
Иконка группы
Модератору Про1С (за заслуги в 2011 году)
Группа: Местный
Сообщений: 3477
Из: Тернопіль
Спасибо сказали: 1393 раз
Рейтинг: 0

4andriy, отут є можливість пізнати чому в одному випадку проацює, а в іншому ні.

Vofka Подменю пользователя
сообщение 29.11.18, 12:11
Сообщение #15

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13544
Из: Киев
Спасибо сказали: 4213 раз
Рейтинг: 3365.6

mister-x, без обид, но отвечайте либо по сути вопроса либо обратите внимание на 16 пункт правил.

Sharzem Подменю пользователя
сообщение 29.11.18, 14:43
Сообщение #16

Оратор
Иконка группы
Группа: Местный
Сообщений: 276
Спасибо сказали: 86 раз
Рейтинг: 85.6

Цитата(4andriy @ 28.11.18, 12:01) *
Хочу открыть справочник номенклатуры, есть колонка "Скидка". Добавил кнопку "Скидка". Нужно не открывая саму позицию нажать на кнопку и что-бы в текущей строке был добавлен нужный текст.


1. Довідники на платформі 7.7. ніколи не мали табличних полів, тому колонка "Скидка" в формі довідника може відображуватися у вигляді Таблиці значень яка в свою чергу може заповнюватися як приклад, з підчинених довіднику довідників.
2. Облік товарів (в плані ціноутворення) на різних платформах обліковується по-різному (FIFO, LIFO, середньому)
3. Зважаючи на п. 2 Ви не можете універсально виконувати ті дії які викладені в Вашій процедурі (то зовсім не туди).
4. Цілком підтримую позицію шановного mister-x і рекомендую Вам замість кнопки в формі списку довідника вивести додатково поле з функцією яка поверне Вам 2 ціни: 1 звичайна, вона в Вас вже є (незрозуміло як вона розраховується і від яких чинників залежить, оскільки дуже мало інформації про те з чим Ви працюєте) та 2 - ціна із знижкою.

Якби я був Вашим роботодавцем я б Вам задав одне питання: накой Вам розмір знижки на формі довідника ?

Будь-ласка, почніть з початку питання, що Вам потрібно зробити в цілому, а не лише кусочок якоїсь незрозумілої нам ідеї. Ваші питання розглядають спеціалісти з багаторічним досвідом і те що Ви намагаєтеся реалізовувати це дрібниці... Головне правильно описати завдання.

volodya1122 @ Сегодня, 10:51 * ,

volodya1122, Ви що просто познущалися ?
А він візьме і вставить Ваш кусок кода...
Добре якщо в довідник "Номенклатура" friends.gif


Signature
То, что для одного человека константа, для другого - переменная. (Алан.Дж.Перлис)

volodya1122 Подменю пользователя
сообщение 29.11.18, 18:06
Сообщение #17

Оратор
Иконка группы
Группа: Местный
Сообщений: 311
Из: Тернопіль
Спасибо сказали: 117 раз
Рейтинг: 119.4

Sharzem @ Сегодня, 14:43 * ,

Ну я бачу автор не повний "0". Бачу в 1С щось розуміє. Думаю вийде проаналізувати мій примітивний код на декілька рядків і виправити так як йому потрібно.
p.s. Одного разу на Іншому форумі реально приходилось одному "програмісту" пояснювати що означає знак запитання перед дужками (а автор бачу вміє ним користуватись, значить розбереться)

Сообщение отредактировал volodya1122 - 29.11.18, 18:07

Спасибо сказали: 4andriy,

mister-x Подменю пользователя
сообщение 03.12.18, 12:40
Сообщение #18

...
Иконка группы
Модератору Про1С (за заслуги в 2011 году)
Группа: Местный
Сообщений: 3477
Из: Тернопіль
Спасибо сказали: 1393 раз
Рейтинг: 0

а хтось взагалі зрозумів до кінця ТЗ?

4andriy Подменю пользователя
сообщение 03.12.18, 21:52
Сообщение #19

Завсегдатай
****
Группа: Пользователи
Сообщений: 123
Спасибо сказали: 0 раз
Рейтинг: 0

mister-x @ Сегодня, 12:40 * ,
вже все працює)

twilight_dream Подменю пользователя
сообщение 13.12.18, 22:42
Сообщение #20

Оратор
*****
Группа: Пользователи
Сообщений: 263
Спасибо сказали: 4 раз
Рейтинг: 4

А в таблице справочника (форма списка) разве нет события списка, в котором имеется такие переменные, как ТекущаяСтрока, ТекущаяКолонка, или это методы таблицы, давно в семерку не заходил. плюс используем функцию "Ввести Значение", в которой выбираем нужный документ, а из него уже берем текст скидки?


Signature

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 06.08.21, 4:29
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!