Версия для печати темы (https://pro1c.org.ua/index.php?s=a4f37464ae4dec8b3d5d7e5c24279ab5&showtopic=67004)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Программирование в 1С Предприятие 8.3 _ Сохранить и восстановить результат отчета

Автор: Bdrh 21.06.22, 13:09

Всем привет.
Есть РС с измерением типа Документ и ресурсом Хранилище значений. В него помещается табличный документ. Можно ли как-то отчетом вытянуть записи из этого РС в таком виде?:
-Документ
---- Табличный документ из хранилища значений
Я сделал отчет, в вычисляемых полях сделал поле, которое через общий модуль получает значение хранилища значения. Но при выводе этого поля в групировку скд просто выводит надпись "Табличный документ". Как бы сделать так, чтобы выводился сам табличный документ?

Автор: sava1 21.06.22, 13:37

дык и сохраняйте таб.док.
Восстановление - вытащили табдок из хранилища, вставили в итоговый Табличный документ

Автор: lolmatrix 21.06.22, 14:58

Цитата(Bdrh @ 21.06.22, 14:09) *
Всем привет.
Есть РС с измерением типа Документ и ресурсом Хранилище значений. В него помещается табличный документ. Можно ли как-то отчетом вытянуть записи из этого РС в таком виде?:
-Документ
---- Табличный документ из хранилища значений
Я сделал отчет, в вычисляемых полях сделал поле, которое через общий модуль получает значение хранилища значения. Но при выводе этого поля в групировку скд просто выводит надпись "Табличный документ". Как бы сделать так, чтобы выводился сам табличный документ?

&НаКлиенте
Процедура ТипВФормеНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    
    ТекущийПараметр = Элементы.Параметры.ТекущиеДанные;
    
    ЗаголовокЭлемента = НСтр("ru = 'Выбрать тип'");
    ВыбранныйЭлемент = СписокТипов.ВыбратьЭлемент(ЗаголовокЭлемента);
    Если ВыбранныйЭлемент <> Неопределено Тогда
        ТекущийТип                     = ВыбранныйЭлемент;
        
        Если ТекущийТип.Значение = "ТаблицаЗначений"
            или ТекущийТип.Значение = "МоментВремени"
            или ТекущийТип.Значение = "Граница" Тогда
        
            ТипСтрока                        = ТипСтрока(ТекущийТип.Значение);
            ТекущийПараметр.Тип             = ТипСтрока;
            ТекущийПараметр.ТипВФорме         = ТекущийТип.Представление;
            ТекущийПараметр.Значение         = "";
            ТекущийПараметр.ЗначениеВФорме     = ТекущийТип.Представление;
        Иначе
            ИнициализацияТипаИЗначенияПараметра(ТекущийПараметр, ТекущийТип);
        КонецЕсли;    
        
        Модифицированность = Истина;
    КонецЕсли;
КонецПроцедуры


я делал так в стандартной консоли запросов


Автор: Bdrh 21.06.22, 16:28

sava1 @ Сегодня, 14:37 * ,
Так вот как его вставить в результат? Можно ли как-то обходить то, что получила СКД циклом, обрабатывать группировки и результат обработки выводить в конечный таблиный документ?
Сейчас выводится так


Автор: sava1 21.06.22, 18:37

можно, но сохранять надо не таю.док. а выборку.
В типовых посмотрите ПриКомпоновке - НачатьВывод (вроде так называется метод), т.е. -
при формировании отчета сохраняете не табдок, а выборку
потом получаете выборки и выводите в Результат методом СКД

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua