Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



107 страниц V   1 2 3 > » 

>  1С 8.3. Не работает карточка счета после того как убрал режим совместимости
Batchir
Отправлено: 17.07.21, 12:17


Живет на форуме
Иконка группы

Группа: Команда
Сообщений: 3509
Регистрация: 03.02.09
Из: Одесса
Пользователь №: 2


Для того чтоб снять режим совместимости (или повысить его) необходимо в конфигурации дописывать/переписывать некоторые конструкции кода. На ИТСе есть спец обработка, которая проверяет конфигурацию на совместимость и показывает все фрагменты.
Я для ERP повышал режим для того чтоб можно было использовать мобильный клиент. Ничего сложного не возникало с повышением.
Ещё следует обратить внимание на то что конфигурация писалась на БСП, которая поддерживает определённый режим совместимости и вполне вероятно что методы которые используются в БСП не поддерживаются отключенным режимом совместимости
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #173868 · Ответов: 7 · Просмотров: 418
 

>  Программно скрыть все панели в веб-клиенте
Batchir
Отправлено: 25.05.21, 15:10


Живет на форуме
Иконка группы

Группа: Команда
Сообщений: 3509
Регистрация: 03.02.09
Из: Одесса
Пользователь №: 2


Так тут же и проблема, что права у пользователя одни и те же.
Используемые клиенты разные

Мне кажется что у ТС стоит задача что-то типа запустить веб клиенты на планшетах, где нужно максимально экономить место на экране - убрать все панели и оставить только рабочую область.

  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #173413 · Ответов: 10 · Просмотров: 241
 

>  Підключення сканера Magellan 8400
Batchir
Отправлено: 25.05.21, 8:07


Живет на форуме
Иконка группы

Группа: Команда
Сообщений: 3509
Регистрация: 03.02.09
Из: Одесса
Пользователь №: 2


allspice @ 20.05.21, 16:30 * , Настраивал, но давненько.
Берем/ качаем инструкцию к настройке сканера.
А тут краткая инструкция, которую когда-то нарыл
Сканированием переводим к заводским настройкам (на случай скинуть всё, если с ним кто-то игрался).
А дальше программируем его под ваши требования.
Основные настройки, которые чаще всего используются в 1С:
Скорость com порта 9600,
Биты данных 8,
Стоп бит 1,
Четность - нет.
  Форум: Работа с торговым оборудованием · Просмотр сообщения: #173409 · Ответов: 4 · Просмотров: 179
 

>  Программно скрыть все панели в веб-клиенте
Batchir
Отправлено: 25.05.21, 7:32


Живет на форуме
Иконка группы

Группа: Команда
Сообщений: 3509
Регистрация: 03.02.09
Из: Одесса
Пользователь №: 2


Стояла задача для мобильного клиента урезать функционал, т.к. на нем не нужны были все эти подсистемы
т.е. В толстом/тонком/веб клиенте должен быть интерфейс тот который настроен ролями, в мобильном клиенте - только определенный состав.
Написал обработку с пользовательским интерфейсом (с доступными командами). При старте мобильного клиента открывал её в режиме блокировки всего интерфейса.
При закрытии обработки вызывал команду завершения работы.
Тем самым убрал возможность лазить где-попало.
Из самой обработки люди уже переходили по нужному функционалу.
Мне кажется это самый простой способ который доступен (в моем случае ещё нужен был кликабельный интерфейс)
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #173408 · Ответов: 10 · Просмотров: 241
 

>  Регламентований звіт "Розрахунок доходів та єдиного внеску фізосіб" для Бухгалтерії 2.1
Batchir
Отправлено: 30.04.21, 11:06


Живет на форуме
Иконка группы

Группа: Команда
Сообщений: 3509
Регистрация: 03.02.09
Из: Одесса
Пользователь №: 2


Alexandr_2017, в правилах пароль
  Форум: Отчеты / Обработки · Просмотр сообщения: #172848 · Ответов: 13 · Просмотров: 935
 

>  Тормоза при открытии списка подчиненных документов
Batchir
Отправлено: 31.03.21, 15:52


Живет на форуме
Иконка группы

Группа: Команда
Сообщений: 3509
Регистрация: 03.02.09
Из: Одесса
Пользователь №: 2


Проверьте, выполняются ли регламентные задания по обслуживанию базы данных.
Может быть такое что устарела статистика и на СУБД строится некорректный план запроса.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #172026 · Ответов: 3 · Просмотров: 235
 

>  Преобразование значения к типу Дата не может быть выполнено
Batchir
Отправлено: 28.09.20, 9:43


Живет на форуме
Иконка группы

Группа: Команда
Сообщений: 3509
Регистрация: 03.02.09
Из: Одесса
Пользователь №: 2


А ДнейБезЗаказа без заказа это случайно не реквизит с типом Дата?
Или может проблема в ДатаПоследнейРеализации = Выборка.Дата;
В результате запроса нет данных поэтому ДатаПоследнейРеализации это не дата, которую пытаетесь привести к началу дня
  Форум: Программирование в 1С Предприятие 8.1 (8.0) · Просмотр сообщения: #166837 · Ответов: 2 · Просмотров: 236
 

>  По поводу нарушения авторских прав
Batchir
Отправлено: 14.08.20, 9:44


Живет на форуме
Иконка группы

Группа: Команда
Сообщений: 3509
Регистрация: 03.02.09
Из: Одесса
Пользователь №: 2


А я не понял, каким образом мы используем их торговую марку?
Где-то в названии форума? в логотипах? в описании ресурса? Где?
Размещение ссылок на сторонний ресурс нынче карается законом?

Они просто понимают что бабло частично мимо них проходит.
Разместили ссылку, кто-то зашел, посмотрел и понял что ему это пригодится, скачал (если есть стартмани) и в личку передал просящему.
Один заплатил за скачивание а другой нет, вот поэтому и бомбит у инфостарта.

Не понимаю как за это можно наказать в условиях того что мы физически для них не доступны.
  Форум: http://pro1c.org.ua/ · Просмотр сообщения: #165636 · Ответов: 23 · Просмотров: 4890
 

>  Особенности сортировки в POSTGRE SQL
Batchir
Отправлено: 03.08.20, 13:29


Живет на форуме
Иконка группы

Группа: Команда
Сообщений: 3509
Регистрация: 03.02.09
Из: Одесса
Пользователь №: 2


У нас нет проблем с сортировками на POSTGRE, админы вроде средствами СУБД с сортировками поигрались и всё.
  Форум: Администрирование и настройка серверов баз данных · Просмотр сообщения: #165279 · Ответов: 4 · Просмотров: 395
 

>  Обработка XML большого объема
Batchir
Отправлено: 03.08.20, 11:14


Живет на форуме
Иконка группы

Группа: Команда
Сообщений: 3509
Регистрация: 03.02.09
Из: Одесса
Пользователь №: 2


Упрощенно код который разбивает файл на куски выглядит так:
                ИмяБезРасширения     = ""; // Чистое имя используется для генерации новых файлов
        ИмяФайла             = ""; // ИмяФайла - закачанный и разархивированный файл XML
        ПутьКНовымФайлам    = ""; // путь куда будут сохраняться новые файлы
        
        Если ЭтоLinuxСервер() ТОгда // отдельная функция которая распознает где крутится сервер 1С
            Слеш = "/";
        Иначе
            Слеш = "\";
        КонецЕсли;
        
        // читаем файл,
        ЧтениеXML = Новый ЧтениеXML;
        ЧтениеXML.ОткрытьФайл(ИмяФайла);
        //Разделяем указанный файл на несколько частей заданного размера, по 100000 записей.
        НомерФайла = 0;
        КоличествоСтрокФайла = 0;
        КоличествоЗаписейДляПрерыванияАлгоритма = 100000;
        
        ЗаписьXML = Неопределено;
        Пока ЧтениеXML.Прочитать() Цикл  //Цикл по структуре
            ИмяЧтения             = ЧтениеXML.Имя;
            ТипУзлаЧтения         = ЧтениеXML.ТипУзла;
            Если ИмяЧтения = "DATA" Тогда
                // этот тег нам не нужен, пропускаем и переходим к записям
                Продолжить;
            КонецЕсли;
            Если ИмяЧтения = "RECORD" И ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
                // увеличиваем счетчик обработанной записи для того что бы как только достигнет нужного числа мы запишем файл и начнем новый
                КоличествоСтрокФайла = КоличествоСтрокФайла + 1;
            КонецЕсли;
            
            // инициируем запись нового файла
            Если КоличествоСтрокФайла = 1 И ЗаписьXML = Неопределено Тогда
                НомерФайла = НомерФайла + 1;
                ЗаписьXML = Новый ЗаписьXML;
                ИмяНовогоФайла = ПутьКНовымФайлам + Слеш + ИмяБезРасширения + "_"+ НомерФайла + ".xml";
                ЗаписьXML.ОткрытьФайл(ИмяНовогоФайла, "UTF-8");
                ЗаписьXML.ЗаписатьОбъявлениеXML(); //
                ЗаписьXML.ЗаписатьНачалоЭлемента("DATA"); // начинаем общий тег для хранения списка записей
            КонецЕсли;
            
            // в упращенном файле используются только начало, конец элемента и текст
            Если ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
                ЗаписьXML.ЗаписатьНачалоЭлемента(ИмяЧтения);
            ИначеЕсли ЧтениеXML.ТипУзла = ТипУзлаXML.КонецЭлемента Тогда
                ЗаписьXML.ЗаписатьКонецЭлемента();
            ИначеЕсли ЧтениеXML.ТипУзла = ТипУзлаXML.Текст Тогда
                ЗаписьXML.ЗаписатьТекст(ЧтениеXML.Значение);
            КонецЕсли;
            
            // определяем что в новом файле уже нужное нам количество записей
            Если КоличествоСтрокФайла = КоличествоЗаписейДляПрерыванияАлгоритма И ЧтениеXML.ТипУзла = ТипУзлаXML.КонецЭлемента И ИмяЧтения = "RECORD" Тогда
                ЗаписьXML.ЗаписатьКонецЭлемента(); // DATA
                ЗаписьXML.Закрыть();
                // обнуляем значения для того чтоб попало в проверку генерации нового файла
                КоличествоСтрокФайла = 0;
                ЗаписьXML = Неопределено;
            КонецЕсли;
        КонецЦикла;
        
        Если ЗаписьXML <> Неопределено Тогда
            // последний файл с вероятностью 99.99% не записан
            ЗаписьXML.ЗаписатьКонецЭлемента(); // DATA
            ЗаписьXML.Закрыть();
            КоличествоСтрокФайла = 0;
            ЗаписьXML = Неопределено;
        КонецЕсли;


Вырезал куски, у меня просто там куча всего ещё написано для отладки и настройки алгоритмов загрузки.
Но для понимания должно хватить)
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #165273 · Ответов: 19 · Просмотров: 887
 

>  Возможно ли задать переменную в вычисляемые поля в схеме СКД
Batchir
Отправлено: 03.08.20, 10:45


Живет на форуме
Иконка группы

Группа: Команда
Сообщений: 3509
Регистрация: 03.02.09
Из: Одесса
Пользователь №: 2


Вы можете в функцию передать все ваши параметры плюс один дополнительный, например:
Функция ВычислитьСумму(Сумма1, Сумма2, Сумма3, Сумма4, МетодСуммирования) Экспорт
    
    Если МетодСуммирования = 1 Тогда
        Результат = Сумма1 + Сумма2;
    ИначеЕсли МетодСуммирования = 2 Тогда
        Результат = Сумма3 + Сумма4;
    ИначеЕсли МетодСуммирования = 3 Тогда
        Результат = Сумма1 + Сумма2 + Сумма3 + Сумма4;
    Иначе
        Результат = 0;
        // ну и т.д. как душе угодно
    КонецЕсли;
    Возврат Результат;

Конецфункции;


Тогда код в выражениях будет почти всегда один и тот же для облегчения написания, а управлять расчетом будет отдельный параметр
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #165272 · Ответов: 4 · Просмотров: 634
 

>  Возможно ли задать переменную в вычисляемые поля в схеме СКД
Batchir
Отправлено: 30.07.20, 14:34


Живет на форуме
Иконка группы

Группа: Команда
Сообщений: 3509
Регистрация: 03.02.09
Из: Одесса
Пользователь №: 2


В схеме компоновки данных есть возможность определения вычисляемого поля. Вычисляемые поля представляют собой дополнительные поля схемы, значения которых будут вычисляться по некоторой формуле. Вычисляемые поля можно создавать для того, чтобы использовать поля из различных наборов данных, выполнять операции над полями наборов данных - объект, и для других целей. В настройках компоновки данных вычисляемое поле будет фигурировать под именем, указанным в пути к данным этого поля. Пользователь сможет работать с вычисляемым полем точно так же, как и с полем набора данных.

Для того чтобы система смогла получить значение вычисляемого поля, необходимо указать выражение вычисляемого поля. Выражение вычисляемого поля описывается на языке выражений компоновки данных. В выражениях вычисляемого поля есть ограничение - в нем нельзя использовать вычисляемые поля. В остальном, ограничений нет - можно использовать все синтаксические конструкции языка выражений, можно использовать поля наборов данных, можно использовать функции общих модулей конфигурации.

Для вычисляемого поля можно определить заголовок, ограничение доступности, выражение представления, выражения упорядочивания, тип значения, доступные значения и оформление также как для полей наборов данных. Кроме того, вычисляемое поле может быть определено как ресурс, для этого необходимо добавить данное поле в список ресурсов и указать выражение, по которому будет вычисляться итог.

Р.S. Информация взята с сайта ИТС.
Как вариант можно написать свою функцию общего модуля и передавать в неё значения в качестве параметров, а она пусть уже считает как Вам хочется.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #165184 · Ответов: 4 · Просмотров: 634
 

>  Обработка XML большого объема
Batchir
Отправлено: 30.07.20, 10:20


Живет на форуме
Иконка группы

Группа: Команда
Сообщений: 3509
Регистрация: 03.02.09
Из: Одесса
Пользователь №: 2


Vond,
Фишка в том что есть огромный файл.
Его нужно читать последовательно, а не целиком.
Алгоритм следующий:
1. Читаешь последовательно строки XML с помощью
ЧтениеXML = Новый ЧтениеXML; 
ЧтениеXML.ОткрытьФайл(ИмяФайла);
ЧтениеXML.Прочитать();
// начинаем читать дальше строки файла
        
Пока ЧтениеXML.Прочитать() Цикл  //Цикл по структуре
// .........
КонецЦикла;

В этом случае оперативная память не загружается и в ней находятся только прочитанные на момент чтения строки.
Минус в том что мы не можем контролировать что загружено из файла что нет и если что-то пойдет не так то нам нужно начинать сначала.
2. Поэтому перед тем как выполнять записи в базу я этот большой XML дробил программно на кучу (по 100000 записей, это на усмотрение)
В результате у меня было N количество небольших файлов ожидающих загрузки данных.
3. После того как новые файлы сформированы запускаем уже разбор этих отдельных файлов.
Читаю каждый файл и гружу по нему данные. Если успешно загрузился, то грохаю его, если прошла какая-то ошибка, то пропускаю (перемещаю в отдельный каталог. что бы потом выяснить на чем прошел затык)
И так выполняется пока все они не будут обработаны.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #165179 · Ответов: 19 · Просмотров: 887
 

>  Обробка "Обмін з банком" для БУ 2.0
Batchir
Отправлено: 23.07.20, 11:47


Живет на форуме
Иконка группы

Группа: Команда
Сообщений: 3509
Регистрация: 03.02.09
Из: Одесса
Пользователь №: 2


9992952, В правилах
  Форум: Отчеты / Обработки · Просмотр сообщения: #164986 · Ответов: 409 · Просмотров: 70372
 

>  Обработка XML большого объема
Batchir
Отправлено: 21.07.20, 14:46


Живет на форуме
Иконка группы

Группа: Команда
Сообщений: 3509
Регистрация: 03.02.09
Из: Одесса
Пользователь №: 2


Пересекался, делал для 8.3.
Основная проблема в том что файлики с https://data.gov.ua/ уж очень большие и нужно время что бы их полностью обработать.
А так писал в служебную базу, а потом через http сервисы обращался к ней за информацией (перенаправлял запросы пактрума на свою базу)
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #164914 · Ответов: 19 · Просмотров: 887
 

>  Отбор документов в журнале
Batchir
Отправлено: 20.07.20, 15:10


Живет на форуме
Иконка группы

Группа: Команда
Сообщений: 3509
Регистрация: 03.02.09
Из: Одесса
Пользователь №: 2


byshchenko, Боюсь что это сделать невозможно 44000000.gif
8 лет прошло с тех пор))) я то и 7.7 не помню как выглядит
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #164889 · Ответов: 39 · Просмотров: 22726
 

>  Почему не сходится управленческий баланс?
Batchir
Отправлено: 15.07.20, 10:42


Живет на форуме
Иконка группы

Группа: Команда
Сообщений: 3509
Регистрация: 03.02.09
Из: Одесса
Пользователь №: 2


Обработка для российских конфигураций. Лучше задавать вопросы по ней автору непосредственно на инфостарте. Опыта нет с этой обработкой.
Из описания я понял что вроде как должна работать. С одним НО: без разработчика не обойтись - он должен настроить статьи и алгоритмы получения данных по статьям.
Обработка всего-лишь инструмент, основным источником получения данных являются запросы, которые пишутся под каждую статью.
Когда-то давно для УПП я делал нечто подобное что описано в обработке.
Определялся список статей расходов и доходов и описывались источники получения данных для этих статей (правда у меня могли обходиться без программиста, нужен был просто продвинутый пользователь 1С)

А управленческий баланс дело очень интимное. У каждой организации он считается по разному и почему он не сходится - нужно разбираться непосредственно в базе.

  Форум: Управление торговлей для Украины редакция 3 (Уп... · Просмотр сообщения: #164768 · Ответов: 1 · Просмотров: 455
 

>  Ошибка с WinHttp.WinHttpRequest
Batchir
Отправлено: 06.07.20, 9:59


Живет на форуме
Иконка группы

Группа: Команда
Сообщений: 3509
Регистрация: 03.02.09
Из: Одесса
Пользователь №: 2


Цитата(dobrotank @ 03.07.20, 17:32) *
Так он уже на сервере, а не на клиенте.

Ну мне ж откуда это знать. Я делаю вывод только из прочитанного.
Если физическая среда одна и та же и регламентным заданием отрабатывает, то на сервере (в теории) оно должно работать.
Если у вас не отрабатывает и Вы такую же ошибку получаете при использовании файловой базы то я и предположил что в вашем случае по какой-то причине выполняется на клиенте, а не на сервере.
К сожалению сказать так это или нет я без физического просмотра проблемы не могу, только догадки)
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #164492 · Ответов: 7 · Просмотров: 1012
 

>  Ошибка с WinHttp.WinHttpRequest
Batchir
Отправлено: 03.07.20, 15:46


Живет на форуме
Иконка группы

Группа: Команда
Сообщений: 3509
Регистрация: 03.02.09
Из: Одесса
Пользователь №: 2


А что значит "другая" база?
Обе базы клиент серверные и находятся на одном сервере? или где-то у кого-то в какой-то среде работает, а перенесенный код не работает на другом сервере?

Нужно понимать что использование WinHttp.WinHttpRequest это не штатный функционал и зависит от настройки среды где выполняется, может администратор сети сделал какие-то настройки и блокирует все непонятные исходящие веб запросы с клиентов.
Почему не используются штатные механизмы отправки GET/POST запросов? (я понимаю что бывают ситуации что по другому никак, но всё же)

Файловая база - считайте всё выполняется на клиенте, и проблемы скорее все именно в клиентской среде.

Как исправить? Выполнение кода перенести на сервер и проверить будет ли работать или нет, но если отрабатывает фоновым заданием то скорее всего должно.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #164446 · Ответов: 7 · Просмотров: 1012
 

>  Ошибка с WinHttp.WinHttpRequest
Batchir
Отправлено: 03.07.20, 9:21


Живет на форуме
Иконка группы

Группа: Команда
Сообщений: 3509
Регистрация: 03.02.09
Из: Одесса
Пользователь №: 2


Первое что приходит на ум это либо ошибка в указании адреса http/https.
Второе что проблема в клиент серверном варианте.
Клиент не понимает что от него хотят и валится с ошибкой, в то время как сервер понимает и отрабатывает.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #164437 · Ответов: 7 · Просмотров: 1012
 

>  Пактум контрагент
Batchir
Отправлено: 19.05.20, 15:27


Живет на форуме
Иконка группы

Группа: Команда
Сообщений: 3509
Регистрация: 03.02.09
Из: Одесса
Пользователь №: 2


alex-rc @ 13.05.20, 15:43 * ,
Самому написать. Все данные есть в открытых источниках на официальных сайтах, например, тут https://data.gov.ua/dataset/1c7f3815-3259-4...f1-64dca07ddc10
  Форум: Прочее 1С 8 · Просмотр сообщения: #163133 · Ответов: 7 · Просмотров: 590
 

>  Замер продуктивности. Почему так?
Batchir
Отправлено: 12.05.20, 11:40


Живет на форуме
Иконка группы

Группа: Команда
Сообщений: 3509
Регистрация: 03.02.09
Из: Одесса
Пользователь №: 2


1. Обращаясь через точку к реквизиту, мы обращаемся в БД за всей таблицей с данными, а нам нужны конкретные. В Вашем случае с диска в память тянутся все реквизиты из таблицы в которой хранятся реквизиты шапки и если там пару реквизитов, то может быстро отработать, а если документ сложный, то вот весь он и помещается в память, а потом Вам возвращается только одно значение. Дальнейшее обращение к этому же реквизиту возвращает уже значение, которое находится в оперативной памяти, поэтому отрабатывает быстро.
2. Обращение через точку это запрос. В описанной процедуре это запрос в цикле, а при скролинге списка имеем постоянный запрос в цикле, что конечно отражается на быстродействии работы с формой

По правильному необходимо заполнить ИтогВес в данных и выводить в списке уже стандартно.
Если же нет возможности хранить (а такое вполне бывает) ,то я б использовал следующую схему:

// 1. подготавливаем таблицы для оформления строк
тз = Новый ТаблицаЗначений;
тз.Колонки.Добавить("Ссылка");
тз.Колонки.Добавить("СтрокаОформления");
тз.Индексы.Добавить("Ссылка");
спДокументов = Новый СписокЗначений;

Для каждого СтрокаОформления Из ОформленияСтрок Цикл
    ДокументСсылка = СтрокаОформления.ДанныеСтроки.Ссылка;
    Если спДокументов.НайтиПоЗначению(ДокументСсылка) = Неопределено;
        спДокументов.Добавить(ДокументСсылка);
    КонецЕсли;
    // запоминаем строку оформления, которая соответствует ссылке
    СтрокаТЗ = тз.Добавить();
    СтрокаТЗ.Ссылка = ДокументСсылка;
    СтрокаТЗ.СтрокаОформления = СтрокаОформления;
КонецЦикла;

// 2. одним запросом получаем необходимые данные по всем "видимым" ссылкам
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
|    МойДокумент.Ссылка,
|    МойДокумент.Ссылка.ИтогВес КАК ВесПоШапке,
|    СУММА(МойДокумент.Вес) КАК ВесПоСтрокам
|ИЗ
|    Документ.МойДокумент.Товары КАК МойДокумент
|ГДЕ
|    МойДокумент.Ссылка В(&спДокументов)
|
|СГРУППИРОВАТЬ ПО
|    МойДокумент.Ссылка,
|    МойДокумент.Ссылка.ИтогВес";
Запрос.УстановитьПараметр("спДокументов", спДокументов);

РезультатЗапроса = Запрос.Выполнить();

// 3. Обходим запрос, находим строку оформления по ссылке и делаем в ней то что нужно
Если Не РезультатЗапроса.Пустой() Тогда
    Выборка = РезультатЗапроса.Выбрать();
    Пока Выборка.Следующий() Цикл
        
        ПараметрыОтбора = Новый Структура;
        ПараметрыОтбора.Вставить("Ссылка", Выборка.Ссылка);
        НайденныеСтроки = тз.НайтиСтроки(ПараметрыОтбора);
        Для каждого НайденнаяСтрока Из НайденныеСтроки Цикл
            СтрокаОформления = НайденнаяСтрока.СтрокаОформления;
            Если Выборка.ВесПоШапке > 0 Тогда
                ВесИтого = Выборка.ВесПоШапке;
            Иначе
                ВесИтого = Выборка.ВесПоСтрокам;
            КонецЕсли;
            Строкаоформления.Ячейки.Вес.Значение = ВесИтого;
        КонецЦикла;
    КонецЦикла;
КонецЕсли;


Описал для веса, в том же запросе получаем и другую информацию.

В итоге имеем один запрос вместо кучи (это условно конечно, т.к. всё таки он будет выполняться при любом скролинге списка) и этот запрос вытягивает только интересующие нас данные, а не все подряд
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #162923 · Ответов: 4 · Просмотров: 350
 

> Опрос: 1С Вакансии: хочется узнать ваше мнение
Batchir
Отправлено: 28.11.19, 15:58


Живет на форуме
Иконка группы

Группа: Команда
Сообщений: 3509
Регистрация: 03.02.09
Из: Одесса
Пользователь №: 2


По тексту ничем. Но если тема получит развитие то хотелось что бы это было учтено))
По факту просто что было видно кто предлагает себя на постоянную работу, кто удаленную, кто временную почасовую, кто (как я) на проектную работу.
Что б была возможность поставить стикер "ксерокса нет" poster_nospam.gif , т.е. типа интересует только такая работа, другую не предлагать.
  Форум: http://pro1c.org.ua/ · Просмотр сообщения: #158054 · Ответов: 27 · Просмотров: 1862
 

> Опрос: 1С Вакансии: хочется узнать ваше мнение
Batchir
Отправлено: 28.11.19, 11:35


Живет на форуме
Иконка группы

Группа: Команда
Сообщений: 3509
Регистрация: 03.02.09
Из: Одесса
Пользователь №: 2


А меня не интересует вакансия на постоянное место. Меня устраивает то где я работаю, но почему бы не предложить себя вместе с командой на проект?
т.е. напишу, например, ищу работу на проект, есть команда программистов и аналитиков. Опыт такой-то. Реализованные проекты такие-то. Кому-то это понадобится.
Сразу скажу - таким образом ко мне два проекта пришли, только через ЛС. Непосредственно работодатель, а не агенство, вышло на меня и работаем.
В этом случае почему бы не продать себя именно таким образом, если спрос есть и я собственно соответствую этому спросу?
  Форум: http://pro1c.org.ua/ · Просмотр сообщения: #158049 · Ответов: 27 · Просмотров: 1862
 

>  Системная функция "ТипЗнч()" - не вопрос, а просто мнение
Batchir
Отправлено: 21.11.19, 14:23


Живет на форуме
Иконка группы

Группа: Команда
Сообщений: 3509
Регистрация: 03.02.09
Из: Одесса
Пользователь №: 2


Gigi, Земля плоская и стоит на трех китах
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #157801 · Ответов: 74 · Просмотров: 5657
 

107 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 31.07.21, 6:39
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!