Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



3 страниц V   1 2 3 >

>  Как включить видимость колонки в табличной части программно
lolmatrix
Отправлено: 23.02.20, 17:44


Говорящий
***

Группа: Пользователи
Сообщений: 54
Регистрация: 19.06.18
Пользователь №: 61101


Здравствуйте, подскажите пожалуйста. как включить видимость колонки табличной части программно,на управляемой форме. как к ней обратиться, видимость отключена в расширении, например:
Элементы.Товары.Колонка("Цена").Видимость = Истина

1с 8.3.16.1030
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #160697 · Ответов: 2 · Просмотров: 674
 

>  как получить значение поля из выгруженной таблицы запроса из ComОбъекта
lolmatrix
Отправлено: 15.01.20, 13:28


Говорящий
***

Группа: Пользователи
Сообщений: 54
Регистрация: 19.06.18
Пользователь №: 61101


Petre @ Вчера, 13:44 * ,
данные одинаковые, те что не сходятся поправят руками
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #159360 · Ответов: 6 · Просмотров: 461
 

>  как получить значение поля из выгруженной таблицы запроса из ComОбъекта
lolmatrix
Отправлено: 14.01.20, 11:55


Говорящий
***

Группа: Пользователи
Сообщений: 54
Регистрация: 19.06.18
Пользователь №: 61101


Petre @ Вчера, 18:11 * ,
одинаковые конфигурации
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #159314 · Ответов: 6 · Просмотров: 461
 

>  как получить значение поля из выгруженной таблицы запроса из ComОбъекта
lolmatrix
Отправлено: 13.01.20, 15:46


Говорящий
***

Группа: Пользователи
Сообщений: 54
Регистрация: 19.06.18
Пользователь №: 61101


Petre @ Сегодня, 16:25 * ,
я выбирал в запросе коды, а теперь их надо в базе из которой подключаюсь заполнить в справочнике
ссыл= Справочники.Должности.ссылка.ПолучитьОбъект();
ссыл.Код = Тз.ОКПДТР;
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #159286 · Ответов: 6 · Просмотров: 461
 

>  как получить значение поля из выгруженной таблицы запроса из ComОбъекта
lolmatrix
Отправлено: 13.01.20, 15:21


Говорящий
***

Группа: Пользователи
Сообщений: 54
Регистрация: 19.06.18
Пользователь №: 61101


Здравствуйте, уважаемые форумчане, подскажите пожалуйста продолжающему обучение новичку, как получить значение поля из выгруженной таблицы запроса из ComОбъекта есть таблица ТЗ полученная методом выгрузить из ComОбъекта хочу из не взять значение из поля, Наименование по индексу не предусмотрено как я понял, а как, подскажите пожалуйста вот такой код, заранее благодарен
    // Подключение к файловой базе
Соединение = Новый COMОбъект("V83.COMConnector");
ПараметрыДоступа = "File=""C:\Базы\222"";Usr=""Администратор"";Pwd=""123"";";
Попытка
    База = Соединение.Connect(ПараметрыДоступа);
Исключение
    Сообщить("Проблемы при подключении: " + ОписаниеОшибки());
    //Возврат;
КонецПопытки;
Запрос = База.NewObject("Запрос");
Запрос.Текст =
    "ВЫБРАТЬ
    |    Должности.Наименование КАК Наименование,
    |    Должности.ОКПДТРКатегория КАК ОКПДТРКатегория,
    |    Должности.ОКПДТРКод КАК ОКПДТРКод
    |ИЗ
    |    Справочник.Должности КАК Должности";
запр = Запрос.Выполнить();
запр.Выбрать();
Тз = запр.Выгрузить();
ТЗ.Свойство

Для Индекс = 0  по ТЗ.ВГраница() Цикл

НужныйОбъект =   Справочники.Должности.НайтиПоНаименованию(Тз[Индекс].Наименование).Ссылка.ПолучитьОбъект();
НужныйОбъект.ОКПДТРКод = Тз[Индекс].ОКПДТРКод;
Сообщить(НужныйОбъект.Наименование+НужныйОбъект.ОКПДТРКод);
НужныйОбъект.ОКПДТРКатегория = Тз[Индекс].ОКПДТРКатегория;
НужныйОбъект.Записать();
КонецЦикла;


lolmatrix @ Сегодня, 15:55 * ,
Спасибо, элемент, нашел сам, циклом для каждого, теперь не знаю как обратиться к справочнику той базы из которой подключаюсь, точнее получить из справочника ссылку, делаю всё внешней обработкой
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #159283 · Ответов: 6 · Просмотров: 461
 

>  Как скопировать данные из одного реквизита справочника в другой
lolmatrix
Отправлено: 28.12.19, 11:12


Говорящий
***

Группа: Пользователи
Сообщений: 54
Регистрация: 19.06.18
Пользователь №: 61101


fly @ Вчера, 18:36 * ,
часть полей теперь имеет тип null, как программно изменить тип на строковой
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #158959 · Ответов: 14 · Просмотров: 795
 

>  Как скопировать данные из одного реквизита справочника в другой
lolmatrix
Отправлено: 27.12.19, 10:50


Говорящий
***

Группа: Пользователи
Сообщений: 54
Регистрация: 19.06.18
Пользователь №: 61101


В результате этого запроса много пустых строк, как их убрать, пожалуйста подскажите
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #158933 · Ответов: 14 · Просмотров: 795
 

>  Как скопировать данные из одного реквизита справочника в другой
lolmatrix
Отправлено: 27.12.19, 6:55


Говорящий
***

Группа: Пользователи
Сообщений: 54
Регистрация: 19.06.18
Пользователь №: 61101


fly @ Вчера, 15:51 * ,
подскажите, пожалуйста, чем он подходит и подробней про этот инструмент я в нем не совсем разобрался, в чем его преимущество

Anderson @ Вчера, 17:33 * ,
Спасибо огромное за советы сделал так:
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    Должности.Ссылка КАК Долж,
        |    ЕСТЬNULL(Должности.Наименование, 0) КАК Наименование,
        |    ЕСТЬNULL(ОКПДТР.КОДОКПДТР, 0) КАК КОДОКПДТР,
        |    ЕСТЬNULL(ОКПДТР.Категория, 0) КАК Категория
        |ИЗ
        |    Справочник.ОКПДТР КАК ОКПДТР
        |        ЛЕВОЕ СОЕДИНЕНИЕ Справочник.Должности КАК Должности
        |        ПО (Должности.Наименование = ОКПДТР.Наименование)
        |ГДЕ
        |    Должности.ВведенаВШтатноеРасписание = ИСТИНА";
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
    Если не ВыборкаДетальныеЗаписи.Долж=Неопределено и не ТипЗнч(ВыборкаДетальныеЗаписи.Долж)=Тип("Null") тогда
        Об =ВыборкаДетальныеЗаписи.Долж;
    Нужныйэлемент= Об.ПолучитьОбъект();
        Сообщить("Получил:"+Нужныйэлемент);
  
        
        Нужныйэлемент.ОКПДТРКод = ВыборкаДетальныеЗаписи.КОДОКПДТР;
         Нужныйэлемент.ОКПДТРКатегория = ВыборкаДетальныеЗаписи.Категория;
          Нужныйэлемент.Записать();
          Сообщить("Записал:"+Нужныйэлемент);
    КонецЕсли;
      
    КонецЦикла;


lolmatrix @ Сегодня, 7:40 * ,
Теперь встал вопрос как вывести в таблицу те должности соответствие которым не найдены во втором справочнике
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #158926 · Ответов: 14 · Просмотров: 795
 

>  Как скопировать данные из одного реквизита справочника в другой
lolmatrix
Отправлено: 26.12.19, 13:50


Говорящий
***

Группа: Пользователи
Сообщений: 54
Регистрация: 19.06.18
Пользователь №: 61101


sava1 @ Сегодня, 14:38 * ,
Спасибо, а как если не расширением, временно
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #158905 · Ответов: 14 · Просмотров: 795
 

>  Как скопировать данные из одного реквизита справочника в другой
lolmatrix
Отправлено: 26.12.19, 13:20


Говорящий
***

Группа: Пользователи
Сообщений: 54
Регистрация: 19.06.18
Пользователь №: 61101


sava1 @ Сегодня, 13:36 * ,
почему, нужно один раз коды перенести и все, я ж писал только начинаю,

sava1,
поясните , пожалуйста, что не так в моем коде
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #158903 · Ответов: 14 · Просмотров: 795
 

>  Как скопировать данные из одного реквизита справочника в другой
lolmatrix
Отправлено: 26.12.19, 12:20


Говорящий
***

Группа: Пользователи
Сообщений: 54
Регистрация: 19.06.18
Пользователь №: 61101


lolmatrix @ Сегодня, 12:13 * ,
сделал так:
    выборка =Справочники.Должности.Выбрать();
    Пока выборка.Следующий() Цикл
    ЗаполняемыйОбъект =выборка.ПолучитьОбъект();        
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    ОКПДТР.Наименование КАК Наименование,
        |    ОКПДТР.КОДОКПДТР КАК КОДОКПДТР
        |ИЗ
        |    Справочник.ОКПДТР КАК ОКПДТР
        |ГДЕ
        |    ОКПДТР.Наименование = &Наименование";
    
    Запрос.УстановитьПараметр("Наименование", выборка.Наименование);
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
     ЗаполняемыйОбъект.ОКПДТРКод = ВыборкаДетальныеЗаписи.КОДОКПДТР;
     ЗаполняемыйОбъект.Записать();
     Сообщить("Заполнен:"+" "+ЗаполняемыйОбъект.Ссылка+"Код:"+ВыборкаДетальныеЗаписи.КОДОКПДТР);
    КонецЦикла;
КонецЦикла;

Но встает вопрос как добавить в запросе условие где если не найден, тосообщить не найден
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #158900 · Ответов: 14 · Просмотров: 795
 

>  Как скопировать данные из одного реквизита справочника в другой
lolmatrix
Отправлено: 26.12.19, 11:13


Говорящий
***

Группа: Пользователи
Сообщений: 54
Регистрация: 19.06.18
Пользователь №: 61101


Здравствуйте уважаемые программисты, подскажите пожалуйста начинающему специалисту, как скоприрорвать данные из одного реквизита справочника в другой есть два о справочника Должности и ДолжностиСКодами, в обоих есть наименование должности а код заполнен только во втором. как скопировать этот самый код из Должности в ДолжностиСКодами, заранее благодарен(в типовой конфигурации) хочу расширением сделать
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #158897 · Ответов: 14 · Просмотров: 795
 

>  метод ВыгрузитьКолонку не досупен
lolmatrix
Отправлено: 10.12.19, 6:43


Говорящий
***

Группа: Пользователи
Сообщений: 54
Регистрация: 19.06.18
Пользователь №: 61101


TipsyKID @ Вчера, 20:41 * ,
Спасибо, так я тоже пробовал метод выгрузить не доступен
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #158345 · Ответов: 17 · Просмотров: 1264
 

>  метод ВыгрузитьКолонку не досупен
lolmatrix
Отправлено: 09.12.19, 14:12


Говорящий
***

Группа: Пользователи
Сообщений: 54
Регистрация: 19.06.18
Пользователь №: 61101


sava1 @ Сегодня, 15:01 * ,
спасибо, Всем за ответы, если можно напишите пожалуйста с пример выгрузить из ДанныеФормыКоллекция
решил так
&НаКлиенте
Процедура ПриОткрытии(Отказ)
        ТипыЦен = Объект.ТипыЦен;
Для каждого Элемент из ТипыЦен Цикл
    
    СписокТиповЦен.Добавить(Элемент.Типцен);
    КонецЦикла;

КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #158322 · Ответов: 17 · Просмотров: 1264
 

>  метод ВыгрузитьКолонку не досупен
lolmatrix
Отправлено: 09.12.19, 13:35


Говорящий
***

Группа: Пользователи
Сообщений: 54
Регистрация: 19.06.18
Пользователь №: 61101


sava1 @ Сегодня, 14:33 * ,
можно конечно и обойти, спасибо, попробую обойти, но есть же метод выгрузить, хочу понят как ? примера в Синтаксис помощнике нет
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #158320 · Ответов: 17 · Просмотров: 1264
 

>  метод ВыгрузитьКолонку не досупен
lolmatrix
Отправлено: 09.12.19, 13:30


Говорящий
***

Группа: Пользователи
Сообщений: 54
Регистрация: 19.06.18
Пользователь №: 61101


написано в справке, что доступность на Сервере
ДанныеФормыКоллекция.Выгрузить (FormDataCollection.Unload)
Доступность:
Сервер, мобильное приложение(сервер).

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    
    ТипыЦен = Объект.ТипыЦен;
    СписокТиповЦен.ЗагрузитьЗначения(ТипыЦен.ВыгрузитьКолонку("ТипЦен"));
КонецПроцедуры


Так тоже не работает
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #158318 · Ответов: 17 · Просмотров: 1264
 

>  метод ВыгрузитьКолонку не досупен
lolmatrix
Отправлено: 09.12.19, 12:05


Говорящий
***

Группа: Пользователи
Сообщений: 54
Регистрация: 19.06.18
Пользователь №: 61101


Макс1С @ Сегодня, 12:14 * ,
спасибо, теперь ошибка такая
ВремТабл = ДанныеФормыВЗначение(ТипыЦен,Тип("ТаблицаЗначений"));
по причине:
Недопустимое значение параметра (параметр номер '1'), скажите ,
а есть у ДанныеФормыКоллекция метод выгрузить, как его правильно написать, пробовал по разному тоже пишет нет метода им же тоже можно колонку выгузить?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #158311 · Ответов: 17 · Просмотров: 1264
 

>  метод ВыгрузитьКолонку не досупен
lolmatrix
Отправлено: 09.12.19, 10:25


Говорящий
***

Группа: Пользователи
Сообщений: 54
Регистрация: 19.06.18
Пользователь №: 61101


sava1 @ Сегодня, 11:11 * ,
пробовал та же ошибка
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #158307 · Ответов: 17 · Просмотров: 1264
 

>  метод ВыгрузитьКолонку не досупен
lolmatrix
Отправлено: 09.12.19, 9:55


Говорящий
***

Группа: Пользователи
Сообщений: 54
Регистрация: 19.06.18
Пользователь №: 61101


Здравствуйте,уважаемые Форумчане, подскажите пожалуйста, почему не доступен метод ВыгрузитьКолонку в ДанныеФормыКоллекция, что-то не так пишу? Заранее благодарен за ответы, пишу собственную конфигурацию 1с 8.3
 
&НаСервере
Функция ПолучаемКолонку(ТипыЦен)
Колонка = ТипыЦен.ВыгрузитьКолонку("ТипЦен");//ДанныеформыКоллекция
Возврат Колонка;    
КонецФункции
&НаКлиенте
Процедура ПриОткрытии(Отказ)
    
    ТипыЦен = Объект.ТипыЦен;
Колонка =  ПолучаемКолонку(ТипыЦен);

    СписокТиповЦен.ЗагрузитьЗначения(Колонка);
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #158305 · Ответов: 17 · Просмотров: 1264
 

>  Откуда берется должность на форме справочника сотрудники
lolmatrix
Отправлено: 11.09.19, 13:14


Говорящий
***

Группа: Пользователи
Сообщений: 54
Регистрация: 19.06.18
Пользователь №: 61101


fly @ Сегодня, 13:59 * ,
fly @ Сегодня, 13:59 * ,
fly @ Сегодня, 13:59 * ,
в общих модулях искал модуль с названием ПроцедурыУправленияПерсоналом не нашел, а как в отладчике событие отследить
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155518 · Ответов: 8 · Просмотров: 649
 

>  Откуда берется должность на форме справочника сотрудники
lolmatrix
Отправлено: 11.09.19, 10:34


Говорящий
***

Группа: Пользователи
Сообщений: 54
Регистрация: 19.06.18
Пользователь №: 61101


fly @ Вчера, 15:52 * ,
не нашел ни модулей таких ни процедуры, ни регистра сведений, вопрос остается
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155514 · Ответов: 8 · Просмотров: 649
 

>  Откуда берется должность на форме справочника сотрудники
lolmatrix
Отправлено: 10.09.19, 14:48


Говорящий
***

Группа: Пользователи
Сообщений: 54
Регистрация: 19.06.18
Пользователь №: 61101


fly @ Сегодня, 15:25 * ,
Из штатного расписания выборку в каком месте искать, в каком модуле
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155479 · Ответов: 8 · Просмотров: 649
 

>  Откуда берется должность на форме справочника сотрудники
lolmatrix
Отправлено: 10.09.19, 14:22


Говорящий
***

Группа: Пользователи
Сообщений: 54
Регистрация: 19.06.18
Пользователь №: 61101


cgfcbfly @ Сегодня, 15:02 * ,
спасибо, но именно подробностей и хочется
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155474 · Ответов: 8 · Просмотров: 649
 

>  Откуда берется должность на форме справочника сотрудники
lolmatrix
Отправлено: 10.09.19, 12:57


Говорящий
***

Группа: Пользователи
Сообщений: 54
Регистрация: 19.06.18
Пользователь №: 61101


Здравствуйте, пытаюсь разобраться в ЗУп 3.1, подскажите , пожалуйста в справочнике сотрудники есть параметризуемая команда ДолжностьПоШтатномуРасписанию, но из какого места попадает туда эта команда и соответственно какой код исполняет команда,
никак не найду, подскажите пожалуйста уважаемы специалисты
как найти код этой команды или место откуда же попадает
она на форму и подскажите пожалуйста откуда вообще попадает должность на форму справочника сотрудники ,
заранее благодарен всем за ответы


  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155469 · Ответов: 8 · Просмотров: 649
 

>  как работать с адресами в БСП
lolmatrix
Отправлено: 06.09.19, 8:00


Говорящий
***

Группа: Пользователи
Сообщений: 54
Регистрация: 19.06.18
Пользователь №: 61101


забыл сказать БСП 3.0 на видео 2.4, так не работает
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155384 · Ответов: 4 · Просмотров: 533
 

3 страниц V   1 2 3 >

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 20.10.20, 8:22
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!