Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )




>  Не могу выгрузить текстовый документ в файл на локальном диске
lina1982
Отправлено: 09.10.21, 7:18


Общительный
**

Группа: Пользователи
Сообщений: 14
Регистрация: 13.08.18
Пользователь №: 61864


takefive @ Вчера, 10:42 * ,
я не знаю как это сделать
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #174420 · Ответов: 9 · Просмотров: 497
 

>  Не могу выгрузить текстовый документ в файл на локальном диске
lina1982
Отправлено: 07.10.21, 11:26


Общительный
**

Группа: Пользователи
Сообщений: 14
Регистрация: 13.08.18
Пользователь №: 61864


Vofka @ Сегодня, 11:11 * ,
на клиенте я пробовала, код показала в данной теме, все равно не получается...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #174402 · Ответов: 9 · Просмотров: 497
 

>  Не могу выгрузить текстовый документ в файл на локальном диске
lina1982
Отправлено: 07.10.21, 10:06


Общительный
**

Группа: Пользователи
Сообщений: 14
Регистрация: 13.08.18
Пользователь №: 61864


Vofka @ Сегодня, 10:14 * ,
это понятно, я не знаю как написать, чтобы документ записывался на локальный компьютер, а не на сервер. Если база локальная, то записывает на диск без проблем.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #174395 · Ответов: 9 · Просмотров: 497
 

>  Не могу выгрузить текстовый документ в файл на локальном диске
lina1982
Отправлено: 07.10.21, 3:23


Общительный
**

Группа: Пользователи
Сообщений: 14
Регистрация: 13.08.18
Пользователь №: 61864


Vofka @ Вчера, 20:59 * ,
да
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #174387 · Ответов: 9 · Просмотров: 497
 

>  Не попадают данные с запроса в текстовые документ
lina1982
Отправлено: 06.10.21, 16:02


Общительный
**

Группа: Пользователи
Сообщений: 14
Регистрация: 13.08.18
Пользователь №: 61864


denis84 @ 04.10.21, 8:20 * ,
Спасибо большое за помощь!
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #174385 · Ответов: 4 · Просмотров: 371
 

>  Не могу выгрузить текстовый документ в файл на локальном диске
lina1982
Отправлено: 06.10.21, 11:17


Общительный
**

Группа: Пользователи
Сообщений: 14
Регистрация: 13.08.18
Пользователь №: 61864


Здравствуйте, Конфигурация:
1С:Предприятие 8.3 (8.3.16.1063)
Бухгалтерия предприятия, редакция 3.0 - (1.3.10.150)

При выгрузки текстового документа с сервисной базы выходит сообщение:


Ошибка доступа к файлу: D:\rrr.txt



АдресФайла = Объект.Файл;
    // Текст.Записать("D:\Оптима\гог.txt");
    Текст.Записать(АдресФайла);



Пробовала:
Код
&НаКлиенте
Процедура ФайлНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    Режим                                     = РежимДиалогаВыбораФайла.Сохранение;
    ДиалогОткрытияФайла                     = Новый ДиалогВыбораФайла(Режим);
    //ДиалогОткрытияФайла.Каталог                = АдресФайла;    
    ДиалогОткрытияФайла.ПолноеИмяФайла         = "";
    Фильтр                                     = "Файл(*.txt;*)|*.txt";
    ДиалогОткрытияФайла.Фильтр                 = Фильтр;
    ДиалогОткрытияФайла.МножественныйВыбор     = Ложь;
    ДиалогОткрытияФайла.Заголовок             = "Укажите имя файла txt и выберите папку, в которую необходимо записать этот файл";
    
    ДиалогОткрытияФайла.Показать(Новый ОписаниеОповещения("ПутьКФайлуНачалоВыбораЗавершение", ЭтотОбъект, Новый Структура("ДиалогОткрытияФайла", ДиалогОткрытияФайла)));

КонецПроцедуры

&НаКлиенте
Процедура ПутьКФайлуНачалоВыбораЗавершение(ВыбранныеФайлы, ДополнительныеПараметры) Экспорт
    
    ДиалогОткрытияФайла = ДополнительныеПараметры.ДиалогОткрытияФайла;      
    
    Если (ВыбранныеФайлы <> Неопределено) Тогда
        Объект.Файл = ДиалогОткрытияФайла.ПолноеИмяФайла;
    КонецЕсли;
      
КонецПроцедуры


Не получается
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #174382 · Ответов: 9 · Просмотров: 497
 

>  Не попадают данные с запроса в текстовые документ
lina1982
Отправлено: 06.10.21, 11:03


Общительный
**

Группа: Пользователи
Сообщений: 14
Регистрация: 13.08.18
Пользователь №: 61864


Vofka @ 04.10.21, 8:30 * ,
Благодарю! У меня все получилось!
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #174381 · Ответов: 4 · Просмотров: 371
 

>  Не попадают данные с запроса в текстовые документ
lina1982
Отправлено: 03.10.21, 5:36


Общительный
**

Группа: Пользователи
Сообщений: 14
Регистрация: 13.08.18
Пользователь №: 61864


Здравствуйте, Кнфигурация:
1С:Предприятие 8.3 (8.3.16.1063)
Бухгалтерия предприятия, редакция 3.0 - (1.3.10.150)

&НаСервере
Процедура ВыгрузитьНаСервере()
    
    
    Текст = Новый ТекстовыйДокумент;
    
    СтрокаТекст = "1CClientBankExchange";
    Текст.ДобавитьСтроку(СтрокаТекст);
    СтрокаТекст = "ВерсияФормата = 1.01";
    Текст.ДобавитьСтроку(СтрокаТекст);
    СтрокаТекст = "Кодировка = Windows";
    Текст.ДобавитьСтроку(СтрокаТекст);

            
        Запрос = Новый Запрос;
        
        
        Запрос.Текст =
        "ВЫБРАТЬ
        |    ПлатежноеПоручениеИсходящее.Ссылка,
        |    ПлатежноеПоручениеИсходящее.БанковскийСчет,
        |    ПлатежноеПоручениеИсходящее.Контрагент,
        |    ПлатежноеПоручениеИсходящее.БанковскийСчетПолучателя,
        |    ПлатежноеПоручениеИсходящее.СуммаДокумента
        |ИЗ
        |    Документ.ПлатежноеПоручениеИсходящее КАК ПлатежноеПоручениеИсходящее
        |ГДЕ
        |    ПлатежноеПоручениеИсходящее.Ссылка = &Ссылка";
                
        Запрос.УстановитьПараметр("Ссылка",  Ссылка);


        РезультатЗапроса = Запрос.Выполнить();
    
    ТЗ = РезультатЗапроса.Выбрать();
    Стр = ТЗ.БанковскийСчет;
    Текст.ДобавитьСтроку(Стр);
    Стр = ТЗ.Контрагент;
    Текст.ДобавитьСтроку(Стр);
    Стр =  ТЗ.БанковскийСчетПолучателя;
   Текст.ДобавитьСтроку(Стр);

    
        
        
    //КонецЦикла;
    АдресФайла = Объект.Файл;
    // Текст.Записать("D:\30_03_2021\гог.txt");
    Текст.Записать(АдресФайла);
    
    
    
    
    
КонецПроцедуры



&НаКлиенте
Процедура Выгрузить(Команда)
    ВыгрузитьНаСервере();
КонецПроцедуры



До запроса информацию выгружает, а сам запрос не видит... и ругается на:
Запрос.УстановитьПараметр("Ссылка",  Ссылка);


Не могу понять как из запроса записать данные в текстовый документ.
Помогите, пожалуйтста!
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #174333 · Ответов: 4 · Просмотров: 371
 

>  Обработка - Декомпилятор объектов
lina1982
Отправлено: 25.06.21, 8:58


Общительный
**

Группа: Пользователи
Сообщений: 14
Регистрация: 13.08.18
Пользователь №: 61864


У меня нет получается
  Форум: Отчеты / Обработки · Просмотр сообщения: #173760 · Ответов: 15 · Просмотров: 9430
 

>  Обработка - Декомпилятор объектов
lina1982
Отправлено: 21.06.21, 10:45


Общительный
**

Группа: Пользователи
Сообщений: 14
Регистрация: 13.08.18
Пользователь №: 61864


При открытии:

Не удалось загрузить внешнюю компоненту V8cf (не хватает прав)

1С:Предприятие 8.3 (8.3.16.1063)

Конфигурация: Бухгалтерия для Кыргызстана, редакция 1.7, разработка для Кыргызстана: (1.7.22.1)
  Форум: Отчеты / Обработки · Просмотр сообщения: #173719 · Ответов: 15 · Просмотров: 9430
 

>  Корректировка движений регистров без перепроведения документов (с возможностью выгрузки в документ "Корректировка записей регистров")
lina1982
Отправлено: 26.04.21, 8:31


Общительный
**

Группа: Пользователи
Сообщений: 14
Регистрация: 13.08.18
Пользователь №: 61864


1С:Предприятие 8.3 (8.3.16.1063)
Зарплата и кадры (1.0.0.1)
Выходит сообщение : поле объекта недоступно для записи...
  Форум: Отчеты / Обработки · Просмотр сообщения: #172762 · Ответов: 6 · Просмотров: 8591
 

>  Запись не верна! Значение поля "Пользователь" не может быть пустым!: НастройкиПользователей
lina1982
Отправлено: 02.12.20, 10:36


Общительный
**

Группа: Пользователи
Сообщений: 14
Регистрация: 13.08.18
Пользователь №: 61864


denis84 @ Сегодня, 9:33 * ,
Благодарю Вас, все получилось!
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168759 · Ответов: 3 · Просмотров: 999
 

>  Запись не верна! Значение поля "Пользователь" не может быть пустым!: НастройкиПользователей
lina1982
Отправлено: 02.12.20, 9:22


Общительный
**

Группа: Пользователи
Сообщений: 14
Регистрация: 13.08.18
Пользователь №: 61864


Здравствуйте, 1С:Предприятие 8.3 (8.3.16.1063), Бухгалтерия , редакция 1.7, разработка 2007-2018 (1.7.22.1), обычное приложение.

Выходит ошибка: {ОбщийМодуль.Пользователи.Модуль(210)}: Ошибка при вызове метода контекста (Записать)
Набор.Записать();
по причине:
Запись не верна! Значение поля "Пользователь" не может быть пустым!: НастройкиПользователей: , Текущая страница Панели функций (Регистр сведений: Настройки пользователей).

При переходе указывает на процедуру. Где искать, непонятно.

Процедура УстановитьЗначениеПоУмолчанию(Пользователь, Настройка, Значение) Экспорт

    СсылкаНастройки = ПланыВидовХарактеристик.НастройкиПользователей[Настройка];
    Набор = РегистрыСведений.НастройкиПользователей.СоздатьНаборЗаписей();
    Набор.Отбор.Пользователь.Установить(Пользователь);
    Набор.Отбор.Настройка.Установить(СсылкаНастройки);
    Запись = Набор.Добавить();
    Запись.Пользователь = Пользователь;
    Запись.Настройка = СсылкаНастройки;
    Запись.Значение = Значение;
    Набор.Записать();

КонецПроцедуры // ПолучитьЗначениеПоУмолч
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168757 · Ответов: 3 · Просмотров: 999
 

>  Переход на средневзвешенную цену в середине года
lina1982
Отправлено: 11.08.20, 12:22


Общительный
**

Группа: Пользователи
Сообщений: 14
Регистрация: 13.08.18
Пользователь №: 61864


Здравствуйте, помогите, пожалуйста, кто сталкивался с переходом на средневзвешенную цену в середине года, какие проводки должны быть? Конфигурация самописная, версия платформы 17.70.027.
  Форум: Остальные конфигурации 1С 7.7 · Просмотр сообщения: #165505 · Ответов: 1 · Просмотров: 446
 


Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 06.12.21, 7:38
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!