Версия для печати темы (https://pro1c.org.ua/index.php?s=b453958bcb57e31de711b8f99a0b5c2c&showtopic=55038)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Корзина _ ПОМОГИТЕ

Автор: Danaza 05.11.19, 23:05

Помогите, пожалуйста.
Я не профи.
Есть раздел где появляется таблица, в ней период чисел от и до на выбор и кнопка сформировать цены за этот период. А мне нужно сделать так, чтоб, если период касается сегодняшнего числа - появлялось окно в стиле "Вы уверенны?" и если вдруг да, то продолжались действия. 1Cv7

Автор: andrew76 06.11.19, 2:49

Danaza @ Сегодня, 2:05 * ,

Синтаксис:
Вопрос(<Текст_вопроса>,<Режим>,<Таймаут>)
Назначение:
Вывести окно вопроса и получить ответ.
Возвращает ответную реакцию в виде числа или строки, в соответствии с заданием параметра <Режим>:
-1 или 'Таймаут' ('Timeout'), если закончилось время ожидания ответа;
1 или 'ОК' ('ОК'), если если нажата кнопка OK;
2 или 'Отмена' ('Cancel'), если нажата кнопка Отмена;
3 или 'Стоп' ('Abort'), если нажата кнопка Стоп;
4 или 'Повтор' ('Retry'), если нажата кнопка Повтор;
5 или 'Пропустить' ('Ignore'), если нажата кнопка Пропустить;
6 или 'Да' ('Yes'), если нажата кнопка Да;
7 или 'Нет' ('No'), если нажата кнопка Нет.
Параметры:
<Текст_вопроса> - cтрока текста вопроса;
<Режим> - определяет набор кнопок диалога в виде числа или строки (в скобках английское написание):
0 или 'ОК' ('ОК') - кнопка OK;
1 или 'ОК+Отмена' ('OK+Cancel') - кнопки OK и Отмена;
2 или 'Стоп+Повтор+Пропустить' ('Abort+Retry+Ignore') - кнопки Стоп, Повтор, Пропустить;
3 или 'Да+Нет+Отмена' ('Yes+No+Cancel') - кнопки Да, Нет, Отмена;
4 или 'Да+Нет' ('Yes+No') - кнопки Да, Нет;
5 или 'Повтор+Отмена' ('Retry+Cancel') - кнопки Повтор, Отмена;
(любое другое значение или отсутствие параметра равносильно 0);
<Таймаут> - число секунд времени ожидания ответа (если опущен или 0, то без ограничения).
Подробнее см. в документации, глава 'Системные процедуры и функции'



Если Вопрос("Вы уверены ?","Да+Нет")="Да"  Тогда
       //нужные действия
      Иначе
         Возврат;
КонецЕсли;

Автор: Макс1С 07.11.19, 11:55

andrew76 @ Вчера, 2:49 * ,
Телепат, прочитав 1е сообщение, не сразу понял в чём проблема 12201689.gif
Да и заголовок темы - огонь ))))

Автор: andrew76 07.11.19, 12:16

Макс1С @ Сегодня, 14:55 * ,

Та якiй там телепат ? Я кстати на вопрос не ответил толком.

Если КакаятоПеременная=ТекущаяДата() Тогда
       Если Вопрос("Вы уверены ?","Да+Нет")="Да"  Тогда
              //нужные действия
       Иначе
             Возврат;
       КонецЕсли;
КонецЕсли;

Автор: Vofka 09.11.19, 23:39

Тема едет в корзину.


 ! 

https://pro1c.org.ua/index.php?act=announce&id=2: 3, 4, 7
 

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua