Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )




>  Выделение в форме строк цветом
odzolalvl
Отправлено: 09.10.20, 12:24


Молчаливый
*

Группа: Пользователи
Сообщений: 9
Регистрация: 27.08.20
Пользователь №: 70318


sava1 @ Сегодня, 13:19 * ,
Огромное спасибо.
И вопрос почему 1 способ не работает,я же так понимаю я передаю занчение реквизита тут("")
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #167215 · Ответов: 10 · Просмотров: 195
 

>  Выделение в форме строк цветом
odzolalvl
Отправлено: 09.10.20, 12:18


Молчаливый
*

Группа: Пользователи
Сообщений: 9
Регистрация: 27.08.20
Пользователь №: 70318


sava1 @ Сегодня, 13:16 * ,
"Управление торговлей для Украины", редакция 2.3.


 ! 

Правила: 8
 
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #167213 · Ответов: 10 · Просмотров: 195
 

>  Выделение в форме строк цветом
odzolalvl
Отправлено: 09.10.20, 12:12


Молчаливый
*

Группа: Пользователи
Сообщений: 9
Регистрация: 27.08.20
Пользователь №: 70318


sava1 @ Сегодня, 12:50 * ,
Если ЗначениеЗаполнено(ДанныеСтроки.Номенклатура) Тогда
        ЦенГруп = Справочники.Номенклатура.ЦеноваяГруппа("Скидки");
        Если ДанныеСтроки.Номенклатура.ЦеноваяГруппа = ЦенГруп Тогда
        ОформлениеСтроки.Ячейки.Номенклатура.ЦветФона = Новый Цвет(217, 234, 211);
        КонецЕсли;
    КонецЕсли;

Ошибка
{Документ.ЗаказПокупателя.Форма.ФормаДокумента.Форма(2101)}: Метод объекта не обнаружен (ЦеноваяГруппа)
        ЦенГруп = Справочники.Номенклатура.ЦеноваяГруппа("Скидки");

можете объяснить в чем проблема
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #167210 · Ответов: 10 · Просмотров: 195
 

>  Выделение в форме строк цветом
odzolalvl
Отправлено: 09.10.20, 11:37


Молчаливый
*

Группа: Пользователи
Сообщений: 9
Регистрация: 27.08.20
Пользователь №: 70318


sava1 @ Сегодня, 12:27 * ,
Я так понимаю ДанныеСтроки - то что там прописано
у меня есть форма в которой два столбика номер и номенклатура
мне надо что если у номенклатуры реквизит НоменклатурнаяГруппа имет значение НоменклатурнаяГруппа1
тогда в моей табличке ,где номер и номенклатура, закрасило номенклатуру,если не имеет ничего или другой тогда ничего не окрашивало
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #167208 · Ответов: 10 · Просмотров: 195
 

>  Выделение в форме строк цветом
odzolalvl
Отправлено: 09.10.20, 11:10


Молчаливый
*

Группа: Пользователи
Сообщений: 9
Регистрация: 27.08.20
Пользователь №: 70318


Добрый день. подскажите.
Процедура ТоварыПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    
    Если ЗначениеЗаполнено(ДанныеСтроки.Номенклатура) Тогда
        ОформлениеСтроки.Ячейки.Номенклатура.ЦветФона = Новый Цвет(217, 234, 211);
    КонецЕсли;
КонецПроцедуры

У номенклатуры есть свои реквизиты, мне надо что-то вроде

Если Номенклатура.Реквизит ("лалала") Тогда
ОформлениеСтроки.Ячейки.Номенклатура.ЦветФона = Новый Цвет(1, 1, 1);

вопрос как правильно обратиться к реквизиту номенклатуры в текущей строке
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #167205 · Ответов: 10 · Просмотров: 195
 

>  Преобразование значения к типу Дата не может быть выполнено
odzolalvl
Отправлено: 28.09.20, 10:17


Молчаливый
*

Группа: Пользователи
Сообщений: 9
Регистрация: 27.08.20
Пользователь №: 70318


Batchir @ Сегодня, 10:43 * ,
Проверил - нет,
сейчас проверю условием если получаю пустую строку

Спасибо, разобрался ,совет помог. Проблем была я так понял в том ,что у некоторых клиентов ,новых, не было реализации из за чего так ругалось.
  Форум: Программирование в 1С Предприятие 8.1 (8.0) · Просмотр сообщения: #166838 · Ответов: 2 · Просмотров: 174
 

>  Преобразование значения к типу Дата не может быть выполнено
odzolalvl
Отправлено: 28.09.20, 9:38


Молчаливый
*

Группа: Пользователи
Сообщений: 9
Регистрация: 27.08.20
Пользователь №: 70318


Помогите разобраться из за чего такое бывает.

Ошибка
Преобразование значения к типу Дата не может быть выполнено
    ДнейБезЗаказа =ДнейБезЗаказа + ((НачалоДня(ТекущаяДата)-НачалоДня(ДатаПоследнейРеализации))/ 60 / 60 / 24);


Мой код
Функция  ВычДнейБезЗаказа(Клиент)
ТекущаяДата = ТекущаяДата();
Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ ПЕРВЫЕ 1
                   |    РеализацияТоваровУслуг.Дата КАК Дата
                   |ИЗ
                   |    Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
                   |ГДЕ
                   |    РеализацияТоваровУслуг.Контрагент = &Клиент
                   |    И РеализацияТоваровУслуг.Проведен
                   |
                   |УПОРЯДОЧИТЬ ПО
                   |    Дата УБЫВ";
    
    Запрос.УстановитьПараметр("Клиент",Клиент);    
    Выборка = Запрос.Выполнить().Выбрать();
    Выборка.Следующий();
    ДатаПоследнейРеализации = Выборка.Дата;
    ДнейБезЗаказа = 0; // Добавил ,так как думал так тип число смогу передать
    ДнейБезЗаказа =ДнейБезЗаказа + ((НачалоДня(ТекущаяДата)-НачалоДня(ДатаПоследнейРеализации))/ 60 / 60 / 24);
    Возврат ДнейБезЗаказа;

КонецФункции

Но когда через отладчик смотрю, и нажимаю (шагнуть в) то все считает нормально.

Подскажите почему так происходит
  Форум: Программирование в 1С Предприятие 8.1 (8.0) · Просмотр сообщения: #166836 · Ответов: 2 · Просмотров: 174
 

>  Создание обработки для замены данных разных справочников
odzolalvl
Отправлено: 27.08.20, 12:45


Молчаливый
*

Группа: Пользователи
Сообщений: 9
Регистрация: 27.08.20
Пользователь №: 70318


mut @ Сегодня, 12:16 * ,
Спасибо. А что посоветуете прочитать из методиче ,книжек для освоения 1С.
Так как вот столкнулся по работе что не хватает функционала,надо для удобства доделать, как понимаете отдать на сторону,чтобы доработали никто не спонсирует.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #165958 · Ответов: 2 · Просмотров: 224
 

>  Создание обработки для замены данных разных справочников
odzolalvl
Отправлено: 27.08.20, 9:47


Молчаливый
*

Группа: Пользователи
Сообщений: 9
Регистрация: 27.08.20
Пользователь №: 70318


Доброе утро.
Подскажите пожалуйста,как правильно сделать или где можно почитать(желательно с примерами) такую обработку.И правильно ли я понимаю задачу.
Для начала объясню,что надо.

Есть Справочник Направления , в нем есть Табличная Часть Города.
Сделано для того,чтобы можно было сориентироваться по каким городам будет ехать машина с данным направлением.
Так же есть 7 реквизитов с типом булево. Пн Вт Ср ЧТ Пят Суб Вс . Для возможности проставить галочками, в какие дни данное направление будет ехать.
Есть Справочник ТорговаяТочка ,в нем так же 7 реквизитов с типом булево. Пн Вт ... (для того чтобы было видно в какой день недели туда доставка). и реквизит Город. Город указывает ,где находится Торговая Точка. и 7реквизитов направление напротив каждого дня недели(для того чтобы видеть в какой день недели к ним приезжает машина и в каком нашем направлении)(данные берутся из справочника направления)

Вопрос/и суть задачи.
Когда создаю направление,или редактирую старое направление в справочнике Направления.
Нужно добавить кнопку,при нажатии на которую, запускалась следующая обработка.
Получить Название текущего направления (которое создаем,редактируем),получить заполненые реквизиты ПН-Вс.
И подставить (Пн-Вс и Направление) всем в Справочник Торговые Точки, у которых значение город совпадает с занченем из списка Города.

То есть если есть Направление (Киев-Одесса) и там в ТЧ указны Винница,Харьков...
То чтобы в справочнике Торговая Точка (Всем торговым точкам ,где их Город указан как Виннца и Харьков) у них перезаписало (если заполнено),или заполнило если пусто реквизиты.
Пн-Вс и направления.


До этого создавал справочники нужные реквизиты в них и указывал что откуда брать, также создавал отчеты СКД .
Но тут уже другой уровент.
Я вроде понимаю что и как должно делаться,но как это записать в коде не знаю.

Для себя вижу примерно так.
Создать обработку в которой
ПриНажатии
Получаю текущий СправочникНапраление.Ссылка
Далее по идее получаю все что там заполнено,затем надо
Получить Справочник Торговая точка ссылка , где
Справочник торговая точка . Город = Выбор ТЧСправчоникНаправление.Города
Заменить(Перезаписать)
СравочникТорговаяТочка.ДоставкаПН = СправочникНаправление.ДоставкаПН
....
до Вс
Если СправочникНаправление.ДоставкаПН = Истина Тогда
СравочникТорговаяТочка.НаправлениеПН = СправочникНапраление.Ссылка
Если СправочникНаправление.ДоставкаВТ = Истина
Тогда
СравочникТорговаяТочка.НаправлениеВТ= СправочникНапраление.Ссылка

и так до вс
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #165952 · Ответов: 2 · Просмотров: 224
 


Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 22.01.21, 9:06
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!