Версия для печати темы (https://pro1c.org.ua/index.php?s=d2a707bc19a12962e199ffc669da5545&showtopic=52926)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Программирование в 1С Предприятие 8.3 _ Общая форма не раскрывается во весь экран

Автор: Constantus 09.07.19, 10:46

Приветствую, Форумчане!
1с.8.3.13, БСП, самопис, УФ

Прямого отношения к программированию не имеет, приношу извинения, но более правильной ветки не нашел

Ранее на 8.3.6 работали и перешли на 8.3.12

В документе Заказ на панели навигации есть ссылка на "Присоединенные файлы" . Это общая форма, где отображаются графические файлы к этому документу.

После перехода на 8.3.12 эта общая форма не раскрывается по вертикали и горизонтали на весь экран.

Где хранятся эти настройки, чтобы при активации раскрывалась эта форма во весь экран? Уже всё, где нашел поставил расширять по вертикали и горизонтели, но как стоит скромно с полосами прокрутки, так и стоит

Подскажите...

_________________________________________________________________

Такая же ерунда и с другим документом, точнее с выводом формы списка по команде:

Код

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    ПараметрыФормы = Новый Структура("Отбор", Новый Структура("Заказ", ПараметрКоманды));
    ОткрытьФорму("Документ.Ретушь.ФормаСписка", ПараметрыФормы, ПараметрыВыполненияКоманды.Источник, ПараметрыВыполненияКоманды.Уникальность, ПараметрыВыполненияКоманды.Окно, ПараметрыВыполненияКоманды.НавигационнаяСсылка);
КонецПроцедуры


Документ.Ретушь.ФормаСписка тоже не раскрывается во весь экран, а скромно выходит маленькой с полосами прокруток

//------------------------------------------------

Если вызывать эти документы через правую клавишу в отдельном окне, то форма раскрывается по полной программе

Автор: Constantus 09.07.19, 15:12

_______________________________

Обратил внимание, что при переходе на новую платформу многие формы как-то странно отображаться стали, т.е. где-то поля съехали, нокоторые табличные части скрылись...

Такое ощущение, что типа не хватает разрешения монитора, хотя мониторы у пользователей остались прежними...

Как платформа регулирует процесс размещения элементов на форме? Может есть где-то настройка разрешения экрана для форм 1с? Или что-то в этом роде?

Автор: Constantus 11.07.19, 12:30

Мне тут шыпнули, что это из-за того, что начиная с 8.3.7 1с изменил политику рисования форм, понадобвлял всяко разно...
А можно как-то одним движением руки сбросить настройки настройки от 8.3.6, чтобы они перерисовались заново? Или легче заново создать форму?

У меня и в других формах стали проявляться косяки прорисовки

Автор: python 15.07.19, 14:06

Constantus @ 11.07.19, 13:30 * ,
Сбросить настройки на стандартные можно, но не сильно это помогает.

&НаСервере
Процедура СброситьРазмерыИПоложениеОкна()
    
    КлючОбъекта        = "РегистрСведений.Отправления.Форма.ФормаЗаписи/Такси/НастройкиОкна";
    ИмяПользователя = ПользователиИнформационнойБазы.ТекущийПользователь().Имя;
    
    ХранилищеСистемныхНастроек.Удалить(КлючОбъекта, "", ИмяПользователя);
    КлючСохраненияПоложенияОкна = Строка(Новый УникальныйИдентификатор);
    
КонецПроцедуры    // СброситьРазмерыИПоложениеОкна

Автор: Constantus 25.07.19, 8:14

Обратил внимание на следующее.

У меня открытие формы стоит в разделе навигации. Если на ссылку нажать правую кнопку, то выходит "Открыть в новом окне". При нажатии открытия в новом окне - открывается всё нормально... во весь экран

Открытие идет по общей команде:

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    
    ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("ВладелецФайла",  ПараметрКоманды);
    //34246 -->
    //ПараметрыФормы.Вставить("ТолькоПросмотр", ПараметрыВыполненияКоманды.Источник.ТолькоПросмотр);
    ПараметрыФормы.Вставить("ТолькоПросмотр", Ложь);
    //34246 <--
    
    ОткрытьФорму("ОбщаяФорма.ПрисоединенныеФайлы2",
                 ПараметрыФормы,
                 ПараметрыВыполненияКоманды.Источник,
                 ПараметрыВыполненияКоманды.Уникальность,
                 ПараметрыВыполненияКоманды.Окно);
    
КонецПроцедуры


Как мне тогда открыть эту форму в новом окне по полному аналогу контекстного меню открытия этой формы в отдельном окне?


Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua