Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



История благодарностей участнику sava1 ::: Спасибо сказали: 603 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
25.05.20, 10:15 Задваивание строк в результирующих данных запроса
Сначала выбрать данные из рег.Партии, свернуть, а в основном запросе присоединять не рег., а полученную таблицу
bizisoft,
24.04.20, 15:02 Управляемая форма. Ввод на основании
я вооще-то про Структуру подчиненности.

а для ввода на основании добавляйте свою команду - автоматом не прокатит
vbi,
01.04.20, 15:49 Як налаштувати друк розрахункової відомості по зарплаті в 1С:Підприємство 8.3 (8.3.10.2252)
кнопочка ПредварительныйПросмотр (с лупой) потом Параметры страницы - Ландшафт
fg_taisiya,
05.03.20, 13:01 Прайс-лист с картинками
Цитата(DianaZ @ 05.03.20, 12:46) *
Обработка запаролена sad.gif

КругОм ВРАГИ...
ravkat_29,
26.02.20, 10:51 Создание элементов справочника через СОМ соединение
Цитата(bizisoft @ 26.02.20, 10:41) *
пропишу свою функцию (например которая ищет Товар по двум параметрам Артикул и Производитель и возвращает результат), и запущу ее через СОМ соединение, в каком контексте она отработает


в контексте подключенной базы и вернет СОМ-объект, поэтому в таких случаях возвращает примитивные типы
bizisoft,
27.01.20, 19:11 Шаблоны ценников и этикеток
обработки - печать ценников
SergeyB,
16.01.20, 11:58 ПолеВвода СписокЗначения
Цитата(bizisoft @ 16.01.20, 8:19) *
Есть иерархический справочник номенклатура, пользователь в ПолеВвода выбирает группу (или несколько групп) номенклатуры, но как узнать, что подгружать в этот список, т.к. заведомо неизвестно пожелания пользователя в выборе.
Может ему нужно сделать отбор из номенклатуры по одной группе, а может и по двум или по пяти группам.


ИСПОЛЬЗУЙТЕ Построитель или СКД - выведите отбор на форму - пусть выбирает что хочет
bizisoft,
28.12.19, 11:51 Как скопировать данные из одного реквизита справочника в другой
IsNULL(ИмяПоля,"") как Поле
lolmatrix,
26.12.19, 13:59 Как скопировать данные из одного реквизита справочника в другой
внешней обработкой
lolmatrix,
26.12.19, 13:38 Как скопировать данные из одного реквизита справочника в другой
не надо - это про Расширение.

по коду -
запрос - выборка из справочникаБезКодов+левое соединение справочника с кодами
прошли по выборке - получили объект - записали.
lolmatrix,
18.12.19, 11:29 Подружить Бухгалтерию с Фискальным регистратором
по-моему АртСофт - гугль в помощь
Володька,
09.12.19, 13:33 метод ВыгрузитьКолонку не досупен
а просто обойти и заполнить список ?
lolmatrix,
26.11.19, 14:10 ПКС-ИсходящиеДанные - ПКО-ВходящиеДанные, не передаются данные
Цитата(edmah @ 26.11.19, 13:34) *
ЕдиницаХраненияОстатков
- это элемент справочника Единицы измерений, а не Номенклатура.
Вы хотите при выгрузке номенклатуры передать элемент справочника ЕИ. Откуда приемник может об этом знать ? В таких случаях используйте ВыгрузитьПоПравилу
edmah,
26.11.19, 11:43 ПКС-ИсходящиеДанные - ПКО-ВходящиеДанные, не передаются данные
Цитата(edmah @ 26.11.19, 11:28) *
В смысле создает таблицу значений с нужными полями и выгружаем по правилу?


любую коллекцию (структура,выборка и т.д) , вызываем выгрузить по правилу.

но -
для Вашего случая проще на стороне приемника просто добавить Базовую ЕИ в справочник с Владельцем - Объект.

ПослеЗагрузки - ищем по коду классификатора и владельцу (Объект) единицу измерения и добавляе в справочник , если не нашли.
edmah,
20.11.19, 12:15 Как сделать так что бы при создании на основании переносились данные табличной части?
прописать заполнение.
darrr,
15.11.19, 17:00 Підкажіть будь-ласка у мене 1с 1.2 Базова для України ,можна якось зняти конфігурацію з підтримки?
лицензия скорее всего действительна только для базовой.
надо будет на другом компе (не сетевом) установить платформу, крякнуть, поменять конфигурацию, потом вернуть базу на место.
платформу желательно до 10й.
почту дайте.
zoltan,
15.11.19, 10:28 При обмене из объекта-источника передать два реквизита в один реквизит объекта-приемника
в ПКС докуменЗаказ

Цитата(sava1 @ 15.11.19, 10:24) *
Это в обработчике "Перед выгрузкой"?


Да. иначе отказаться негде
info230a02,
15.11.19, 10:15 Підкажіть будь-ласка у мене 1с 1.2 Базова для України ,можна якось зняти конфігурацію з підтримки?
Цитата(zoltan @ 15.11.19, 10:08) *
У мене базова і конфігурація не знімається


Может, с этого надо было начать ?
варианты
1. покупаете ключ проф - и снимаете.
2. патчите платформу (унипатч) - и снимаете....
zoltan,
15.11.19, 10:05 Підкажіть будь-ласка у мене 1с 1.2 Базова для України ,можна якось зняти конфігурацію з підтримки?
В ПКО документа ПКС ДокЗаказ

Если ЗначениеЗаполнено(Источник.ДокОснование) Тогда Отказ=Истина; КонецЕсли


это для приоритета ДокОснование
если приоритет докЗаказ - тогда наоборот

Цитата(zoltan @ 15.11.19, 9:52) *
зняти конфігурацію з підтримки


в конфигураторе Конфигурация-Поддержка --- снимаете. Какого там эмулятора надо ?
info230a02,
07.11.19, 15:14 Код Банку "0" в счете на оплату покупателю
в константах есть даты перехода. после перехода код будет 0 - кажись так писали.
yoj,
07.11.19, 9:51 На сервере не работает ADODB.Connection
запускать регл. задание под пользователем с соответствующими правами.- по умолчанию пользователь - 1СЮзер (попробуйте добавить его в группу Повер Юзерс)
vbi,
25.10.19, 16:18 Где описывается код "меню действия", вывести список (обычный клиент)
Цитата(george_smith @ 25.10.19, 16:07) *
Выборка = РЗ.Выбрать(); Пока Выборка.Следующий() Цикл Для Каждого Эл Из Соо Цикл Если Выборка.НоменклатураРегистраШтрихКод = Эл.Ключ Тогда Эл.Значение = Выборка.Штрихкод; КонецЕсли; КонецЦикла; КонецЦикла;


здеся не так.

Выборка делается по оформлению

Для каждого ос из ОформленияСтроки Цикл


для рз надо добавить индекс - иначе будет тормозиииить....

потом ищем для конкретного значения из ос значение штрихкода в Выборке.

если нашли -
ос.Ячейки.Штрихкод.Текст (или значение) = найденнаяСтрокаВыборки.Штрихкод



ну и конецЦикла
george_smith,
08.10.19, 14:02 Программное создание кнопки для всех документов в формах объекта
Если не надо вопроса про запись - тупо отказ и все.

Выше вариант, когда надо спросить человека - "Объект то новый. может Вы хочите его записать ?"

Если человек жмет на кнопу - он на что-то рассчитывает. Хотябы на обратную связь.
Gigi,
08.10.19, 13:27 Программное создание кнопки для всех документов в формах объекта
Копипаст из бухии

Кнопки = Новый СписокЗначений;
        Кнопки.Вставить(0, КодВозвратаДиалога.Да, "Провести");
        Кнопки.Вставить(1, КодВозвратаДиалога.Нет, "Отмена");
        ДополнительныеПараметры = Новый Структура;
        ДополнительныеПараметры.Вставить("ПараметрыВыполненияКоманды", ПараметрыВыполненияКоманды);
        ДополнительныеПараметры.Вставить("ПараметрКоманды", ПараметрКоманды);
        
        Оповещение = Новый ОписаниеОповещения("ВопросПередПросмотромСледуетПровестиЗавершение", ЭтотОбъект, ДополнительныеПараметры);
        ПоказатьВопрос(Оповещение, НСтр("ru='Перед просмотром проводок документ следует провести';uk='Перед переглядом проводок документ слід провести'"), Кнопки,, КодВозвратаДиалога.Да);


и собственно обработка ответа

Если Ответ <> КодВозвратаДиалога.Да Тогда
        Возврат;
    КонецЕсли;
    
    ПараметрКоманды = ДополнительныеПараметры.ПараметрКоманды;
    ПараметрыВыполненияКоманды = ДополнительныеПараметры.ПараметрыВыполненияКоманды;
    
    ДокументПроведен = ПровестиДокумент(ПараметрКоманды);
    Если ДокументПроведен Тогда
        ОповеститьОбИзменении(ПараметрКоманды);
        Оповестить("ВыполненаЗаписьДокумента", Новый Структура("ДокументСсылка", ПараметрКоманды));
    Иначе
        Сообщить(НСтр("ru='Не удалось провести документ';uk='Не вдалося провести документ'"), СтатусСообщения.Важное);
        Возврат;
    КонецЕсли;


а дальше Ваши идеи
Gigi,
08.10.19, 12:41 Программное создание кнопки для всех документов в формах объекта
Цитата(Gigi @ 08.10.19, 13:35) *
что происходит когда на кнопку «Назначить авто-заполнение» нажимаешь не на форме уже сохраненного объекта, а на форме нового.


а сами как думаете ?
если параметром команды идет ссылка на объект, а ссылка пустая ? по-идее Вы должны разрулить эту ситуевину.
Gigi,

19 страниц V  < 1 2 3 4 5 > » 
RSS Текстовая версия Сейчас: 18.06.21, 19:24
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!