Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4, свеженьких 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



2 страниц V   1 2 >

>  Импорт данных с TXT файла в 1С с множественными разделителями
takefive
Отправлено: 05.03.20, 13:44


Говорящий
***

Группа: Пользователи
Сообщений: 50
Регистрация: 16.12.11
Из: Днепропетровск
Пользователь №: 13264


кусочек кода из подобной обработки...

Функция НайтиПозициюРазделителя(СтрокаТекста)
    Позиция = Найти(СтрокаТекста,":");
    Если Позиция = 0 Тогда
        Позиция = Найти(СтрокаТекста,". .");
    КонецЕсли;
    Возврат Позиция;
КонецФункции

Функция УбратьЛишниеСимволы(Значение)//для цифр
    Пока Найти("-0123456789",Лев(Значение,1)) = 0 Цикл
        Значение = Сред(Значение, 2);
    КонецЦикла;
    Возврат Значение;
КонецФункции

Процедура Сформировать()
    ТекстФайла = ПолучитьТекстФайла();
    НомерБлока = 0;
    Для НомерСтроки=1 По ТекстФайла.КоличествоСтрок() Цикл
        СтрокаТекста = ТекстФайла.ПолучитьСтроку(НомерСтроки);
        Если ПустаяСтрока(СтрокаТекста) = 1 Тогда
            Продолжить;
        КонецЕсли;
        Если Лев(СтрокаТекста, 8 ) = "Контракт" Тогда
            НомерБлока = НомерБлока + 1;
            Сообщить("Блок: " + НомерБлока);
        КонецЕсли;
        Позиция = НайтиПозициюРазделителя(СтрокаТекста);
        Ключ = Лев(СтрокаТекста, Позиция - 1);
        Значение = УбратьЛишниеСимволы(Сред(СтрокаТекста, Позиция + 1));
        Сообщить("Ключ: " + Ключ + ", Значение: "+ Значение);
    КонецЦикла;
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #161050 · Ответов: 8 · Просмотров: 522
 

>  Как открыть форму элемента справочника Контрагенты из формы расходной накладной в 1С 7.70.003 торговля склад для Украины?
takefive
Отправлено: 04.02.20, 11:04


Говорящий
***

Группа: Пользователи
Сообщений: 50
Регистрация: 16.12.11
Из: Днепропетровск
Пользователь №: 13264


Позиционироваться также лучше по ссылке
Если Спр.НайтиЭлемент(Контрагент) = 1 Тогда

т.с. больше шансов... smile.gif
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #160022 · Ответов: 13 · Просмотров: 1680
 

>  Непонятный глюк с Авто.выбор в Расходной Накладной в 1С 7.70.003 торговля склад для Украины?
takefive
Отправлено: 30.01.20, 18:56


Говорящий
***

Группа: Пользователи
Сообщений: 50
Регистрация: 16.12.11
Из: Днепропетровск
Пользователь №: 13264


Автовыбор срабатывает для пустых незаполненных элементов формы при активации. т.е. для полей необязательных для заполнения лучше флаг снять. Кроме того у формы есть порядок обхода. Если при открытии формы курсор на таком элементе - сработает автовыбор... Обойти проблему можно флажком Пропускать при вводе.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #159897 · Ответов: 9 · Просмотров: 1133
 

>  Как открыть форму элемента справочника Контрагенты из формы расходной накладной в 1С 7.70.003 торговля склад для Украины?
takefive
Отправлено: 28.01.20, 10:45


Говорящий
***

Группа: Пользователи
Сообщений: 50
Регистрация: 16.12.11
Из: Днепропетровск
Пользователь №: 13264


Зачем вообще поиск, когде есть ссылка?
ОткрытьФорму(Контрагент)
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #159809 · Ответов: 13 · Просмотров: 1680
 

>  В запросе задать тип значения вручную
takefive
Отправлено: 06.11.19, 9:30


Говорящий
***

Группа: Пользователи
Сообщений: 50
Регистрация: 16.12.11
Из: Днепропетровск
Пользователь №: 13264


ТЗН=Тип(Справочники.Номенклатура.ПустаяСсылка())
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #157258 · Ответов: 6 · Просмотров: 1608
 

>  В запросе задать тип значения вручную
takefive
Отправлено: 05.11.19, 17:53


Говорящий
***

Группа: Пользователи
Сообщений: 50
Регистрация: 16.12.11
Из: Днепропетровск
Пользователь №: 13264


ГДЕ ТоварыВКладовойОстатки.Номенклатура ССЫЛКА Справочник.Номенклатура
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #157232 · Ответов: 6 · Просмотров: 1608
 

>  Как в выборке результата запроса сравнить значение(ВалютаДокумента)
takefive
Отправлено: 28.10.19, 19:00


Говорящий
***

Группа: Пользователи
Сообщений: 50
Регистрация: 16.12.11
Из: Днепропетровск
Пользователь №: 13264


jojojoba2 @ Сегодня, 17:56 * ,
Если Выборка.ВалютаДокумента.Код = КодДоллара Тогда
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #156976 · Ответов: 9 · Просмотров: 664
 

>  Как в документе создать кнопку, доступную только админу? в 1С 7.70.003 торговля склад для Украины?
takefive
Отправлено: 23.10.19, 13:04


Говорящий
***

Группа: Пользователи
Сообщений: 50
Регистрация: 16.12.11
Из: Днепропетровск
Пользователь №: 13264


ZUBR @ Сегодня, 13:36 * ,
Если (НазваниеНабораПрав() = "Администратор")

  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156809 · Ответов: 6 · Просмотров: 692
 

>  Запись без (пере)проведения
takefive
Отправлено: 14.08.19, 10:59


Говорящий
***

Группа: Пользователи
Сообщений: 50
Регистрация: 16.12.11
Из: Днепропетровск
Пользователь №: 13264


ОбменДанными это свойство для типа "ДокументОбъект". ДокументОбъект можно получить методом формы РеквизитФормыВЗначение. Ну и, если изменили, вернуть обратно на форму не помешает...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #154700 · Ответов: 8 · Просмотров: 1269
 

>  Запись без (пере)проведения
takefive
Отправлено: 14.08.19, 8:46


Говорящий
***

Группа: Пользователи
Сообщений: 50
Регистрация: 16.12.11
Из: Днепропетровск
Пользователь №: 13264


Объект.ОбменДанными.Загрузка = Истина;
Объект.Записать();
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #154696 · Ответов: 8 · Просмотров: 1269
 

>  Запрос по ОЛЕ не читает значение "булево"
takefive
Отправлено: 22.07.19, 11:04


Говорящий
***

Группа: Пользователи
Сообщений: 50
Регистрация: 16.12.11
Из: Днепропетровск
Пользователь №: 13264


а без параметра?
И НЕ Склад.НеПоказыватьВБухгалтерии

  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #154011 · Ответов: 10 · Просмотров: 755
 

>  Печатная форма. Порядок строк.
takefive
Отправлено: 19.07.19, 8:57


Говорящий
***

Группа: Пользователи
Сообщений: 50
Регистрация: 16.12.11
Из: Днепропетровск
Пользователь №: 13264


1cProger @ Вчера, 14:31 * ,
2 цикла?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #153950 · Ответов: 6 · Просмотров: 728
 

>  Ссылка на Документ основание
takefive
Отправлено: 26.06.19, 16:44


Говорящий
***

Группа: Пользователи
Сообщений: 50
Регистрация: 16.12.11
Из: Днепропетровск
Пользователь №: 13264


jojojoba2 @ Сегодня, 16:00 * ,
нужно делать отбор в секции ГДЕ
Процедура СкопироватьТовары(ЗаказПокупателя)
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    Товары.Номенклатура,
        |    Товары.ЕдиницаИзмерения,
        |    Товары.Коэффициент,
        |    Товары.Цена,
        |    Товары.ПроцентСкидкиНаценки,
        |    Товары.Сумма,
        |    Товары.Количество
        |ИЗ
        |    Документ.ЗаказПокупателя.Товары КАК Товары
        |ГДЕ
        |    Товары.Ссылка = &Ссылка";
    Запрос.УстановитьПараметр("Ссылка", ЗаказПокупателя);
    РезультатЗапроса = Запрос.Выполнить();
    Выборка = РезультатЗапроса.Выбрать();
    Пока Выборка.Следующий() Цикл
        НоваяСтрока = Товары.Добавить();
        ЗаполнитьЗначенияСвойств(НоваяСтрока, Выборка);
    КонецЦикла;
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #153376 · Ответов: 4 · Просмотров: 969
 

>  Вывод данных в 2 таблицу, что выбрали в первой
takefive
Отправлено: 24.06.19, 10:17


Говорящий
***

Группа: Пользователи
Сообщений: 50
Регистрация: 16.12.11
Из: Днепропетровск
Пользователь №: 13264


Lolita @ 22.06.19, 8:42 * ,
примерно так...
&НаКлиенте
Процедура ПеремещениеСтроки(ВыбраннаяСтрока, ТаблицаИсточник, ТаблицаПриемник)
    СтрокаПриемник = ТаблицаПриемник.Добавить();
    СтрокаИсточник = ТаблицаИсточник.НайтиПоИдентификатору(ВыбраннаяСтрока);
    ЗаполнитьЗначенияСвойств(СтрокаПриемник, СтрокаИсточник);
    ТаблицаИсточник.Удалить(СтрокаИсточник);
КонецПроцедуры

&НаКлиенте
Процедура тз1Выбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
    ПеремещениеСтроки(ВыбраннаяСтрока,тз1,тз2);
КонецПроцедуры

&НаКлиенте
Процедура тз2Выбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
    ПеремещениеСтроки(ВыбраннаяСтрока,тз2,тз1);
КонецПроцедуры
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #153320 · Ответов: 3 · Просмотров: 643
 

>  как удалить все записи регистра
takefive
Отправлено: 19.06.19, 9:14


Говорящий
***

Группа: Пользователи
Сообщений: 50
Регистрация: 16.12.11
Из: Днепропетровск
Пользователь №: 13264


lolmatrix @ Вчера, 15:06 * ,
КорректировкаРегистров = Документы.КорректировкаРегистров.СоздатьДокумент();
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #153197 · Ответов: 8 · Просмотров: 680
 

>  Открыть все табличные части (с закладками) в отдельной форме с возможностью редактирования
takefive
Отправлено: 22.02.19, 13:22


Говорящий
***

Группа: Пользователи
Сообщений: 50
Регистрация: 16.12.11
Из: Днепропетровск
Пользователь №: 13264


модуль формы на клиенте. Это же события. Конфигуратор сам все создает. Если будете копировать - помните о привязке к событиям
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #150084 · Ответов: 6 · Просмотров: 663
 

>  Открыть все табличные части (с закладками) в отдельной форме с возможностью редактирования
takefive
Отправлено: 21.02.19, 17:31


Говорящий
***

Группа: Пользователи
Сообщений: 50
Регистрация: 16.12.11
Из: Днепропетровск
Пользователь №: 13264


Constantus @ Сегодня, 16:30 * ,

Процедура ПриОткрытии(Отказ)
    КопироватьДанныеФормы(ЭтаФорма.ВладелецФормы.Объект,ЭтаФорма.Объект);
КонецПроцедуры


Процедура ПриЗакрытии(ЗавершениеРаботы)
    КопироватьДанныеФормы(ЭтаФорма.Объект, ЭтаФорма.ВладелецФормы.Объект);
КонецПроцедуры


Процедура ПередЗакрытием(Отказ, ЗавершениеРаботы, ТекстПредупреждения, СтандартнаяОбработка)
    ЭтаФорма.Модифицированность = Ложь;//чтобы не было вопросов...
КонецПроцедуры


владельца не забыть передать...

Процедура ОткрытьДубльФорму(Команда)
    ОткрытьФорму("имя формы",,ЭтаФорма);
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #150060 · Ответов: 6 · Просмотров: 663
 

>  Помогите Найти Разность ДАТ!
takefive
Отправлено: 31.01.19, 13:54


Говорящий
***

Группа: Пользователи
Сообщений: 50
Регистрация: 16.12.11
Из: Днепропетровск
Пользователь №: 13264


Кирилл659 @ Вчера, 21:17 * ,
если тип реквизитов дата:
Объект.Реквизит3 = Дата(1,1,1) + (Объект.Реквизит2 - Объект.Реквизит1);


Кирилл659 @ Вчера, 21:17 * ,
строкой:
    Строки = СтрЗаменить(Формат(Объект.Реквизит3, "ДФ=ЧЧ:мм:сс"),":",Символы.ПС);
    ВремяСтрокой = "Время строкой:"
        + " " + СтрПолучитьСтроку(Строки,1) + " час. "
        + " " + СтрПолучитьСтроку(Строки,2) + " мин. "
        + " " + СтрПолучитьСтроку(Строки,3) + " сек.";
    Сообщить(ВремяСтрокой);
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #149417 · Ответов: 2 · Просмотров: 754
 

>  На какую конфигурацию платформы 1С 8.3 можно перейти с Комплексной 1С 7.7 (с конвертацией всех данных)?
takefive
Отправлено: 27.12.18, 9:50


Говорящий
***

Группа: Пользователи
Сообщений: 50
Регистрация: 16.12.11
Из: Днепропетровск
Пользователь №: 13264


В каталоге шаблонов смотрели? Часто в поставке есть правила...
  Форум: 1С Комплексный учет 7.7 для Украины · Просмотр сообщения: #148448 · Ответов: 6 · Просмотров: 1043
 

>  выгрузка в УПП через Конвертацию "Проведение документа: Платежное поручение исходящее Не совпадают сумма документа и ее расшифровка"
takefive
Отправлено: 25.12.18, 15:06


Говорящий
***

Группа: Пользователи
Сообщений: 50
Регистрация: 16.12.11
Из: Днепропетровск
Пользователь №: 13264


там же, после загрузки:
Объект.СуммаДокумента = Объект.РасшифровкаПлатежа.Итог(<Колонка>)
  Форум: Конфигурация "1С:Конвертация данных" · Просмотр сообщения: #148377 · Ответов: 15 · Просмотров: 1791
 

>  Обработка 1С 8.3 & CABiNET
takefive
Отправлено: 12.12.18, 11:24


Говорящий
***

Группа: Пользователи
Сообщений: 50
Регистрация: 16.12.11
Из: Днепропетровск
Пользователь №: 13264


конвертер - обработка, которая по данным банка создаст файл в нужном формате...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #148022 · Ответов: 15 · Просмотров: 3267
 

>  Как вытянуть в печ. таблицу несколько списков значений, с разным количеством значений
takefive
Отправлено: 12.10.18, 14:59


Говорящий
***

Группа: Пользователи
Сообщений: 50
Регистрация: 16.12.11
Из: Днепропетровск
Пользователь №: 13264


складываете все что будете выводить в коллекцию включая шапки данные подвалы и т.п.. Делите размерность коллекции на количество колонок и получаете количество строк и одинаковые по высоте колонки. И выводите получая данные колонок из коллекции.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #146249 · Ответов: 9 · Просмотров: 823
 

>  Как вытянуть в печ. таблицу несколько списков значений, с разным количеством значений
takefive
Отправлено: 12.10.18, 9:06


Говорящий
***

Группа: Пользователи
Сообщений: 50
Регистрация: 16.12.11
Из: Днепропетровск
Пользователь №: 13264


2 цикла: по спискам и вложенный по элементам списка. Вместо секций можно использовать адрес ячейки
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #146236 · Ответов: 9 · Просмотров: 823
 

>  Отловить процедуру при закрытии подиченной формы
takefive
Отправлено: 10.08.18, 15:01


Говорящий
***

Группа: Пользователи
Сообщений: 50
Регистрация: 16.12.11
Из: Днепропетровск
Пользователь №: 13264


dsfdsfsdf @ Сегодня, 15:14 * ,
Вам нужно:
1 передать в форму выбора владельца формы
2 у владельца формы создать событие Обработка выбора где и ловить выбор

еще возможно надо установить в Истина форме выбора: Форма выбора и Закрывать при выборе
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #144287 · Ответов: 11 · Просмотров: 3153
 

>  Отловить процедуру при закрытии подиченной формы
takefive
Отправлено: 10.08.18, 11:06


Говорящий
***

Группа: Пользователи
Сообщений: 50
Регистрация: 16.12.11
Из: Днепропетровск
Пользователь №: 13264


dsfdsfsdf @ Сегодня, 11:45 * ,
ЗначениеВыбора = ФормаВыбора.ОткрытьМодально();
ЗначениеВыбора - это значение из формы выбора
в форме выбора пишете
ЭтоФорма.Закрыть(ЗначениеКотороеНужноВернуть)
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #144270 · Ответов: 11 · Просмотров: 3153
 

2 страниц V   1 2 >

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 26.11.20, 20:03
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!