Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 1, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



6 страниц V   1 2 3 > » 

>  Злетіли привязки керованих форм!
zay
Отправлено: 12.07.22, 18:31


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 127
Регистрация: 02.04.12
Из: Киев
Пользователь №: 16639


Про керовані форми не знаю, на звичайних виникає у випадках коли користувач працює по RDP з дому і з офісу. У моніторів різна розподільна здатність. Допомогло зміна налаштувань на вкладці "Екран" RDP
Також є користувачі у яких використовується окремий стиль (збільшений шрифт у полях форми). У них злітає прив'язка окремих панелей. Налаштування точок прив'язки стоїть правильно, допомагає таке:
  1. Щось змінити з проблемною панеллю, наприклад колір. Оновити базу
  2. Поставити назад те що було. Оновити базу
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #175984 · Ответов: 7 · Просмотров: 601
 

>  Обычные формы, язык внешней обработки
zay
Отправлено: 12.07.22, 18:12


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 127
Регистрация: 02.04.12
Из: Киев
Пользователь №: 16639


MK-61 @ 08.07.22, 14:50 * ,
  1. Нет
  2. И да и нет

Насколько я понял вы хотите сделать все просто, одной строкой. Как сделать одной строкой не знаю, можно написать процедуру. Обходим в цикле все элементы формы и в зависимости от типа элемента меняем заголовок
Как-то так:
Для каждого ЭлементФормы из ЭтаФорма.ЭлементыФормы Цикл

    ТипЭлемента = ТипЗнч(ЭлементФормы);

    Если (ТипЭлемента=Тип("Надпись") ИЛИ ТипЭлемента=Тип("Кнопка")) Тогда
        
        ЭлементФормы.Заголовок = НСтр("ru='"+ЭлементФормы.Заголовок+"';uk='"+ЭлементФормы.Заголовок+"'");
        
    ИначеЕсли (ТипЭлемента=Тип("КоманднаяПанель")) Тогда
    
        КоллекцияКнопокКоманднойПанели = ЭлементФормы.Кнопки;
        
        Для каждого Кнопка из КоллекцияКнопокКоманднойПанели Цикл
            
            Если Кнопка.ТипКнопки = ТипКнопкиКоманднойПанели.Действие Тогда
            
                Кнопка.Заголовок = НСтр("ru='"+Кнопка.Заголовок+"';uk='"+Кнопка.Заголовок+"'");
                
            ИначеЕсли Кнопка.ТипКнопки = ТипКнопкиКоманднойПанели.Подменю Тогда
                
                Для каждого КнопкаПоменю из Кнопка.Кнопки Цикл
                    
                    Если КнопкаПоменю.ТипКнопки = ТипКнопкиКоманднойПанели.Действие Тогда
                    
                        КнопкаПоменю.Заголовок = НСтр("ru='"+КнопкаПоменю.Заголовок+"';uk='"+КнопкаПоменю.Заголовок+"'");
                        
                    КонецЕсли;
                    
                КонецЦикла;
                
            КонецЕсли;
            
        КонецЦикла;
        
    КонецЕсли;
    
КонецЦикла;
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #175983 · Ответов: 2 · Просмотров: 526
 

>  О3 з 0 залишковою вартістю
zay
Отправлено: 25.06.22, 11:40


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 127
Регистрация: 02.04.12
Из: Киев
Пользователь №: 16639


Xmdrug @ Вчера, 8:22 * ,
Якщо це потрібно один раз і не треба робити новий звіт з відповідним фільтром, то я би зробив так:
  1. Сформувати звіт по ОС в 1С
  2. Вивантажити результат звіту в Ексель
  3. Відкрити звіт в Ексель і накласти фільтр на колонку "залишкова вартість"
  Форум: 1С Управление Торговым Предприятием 8 · Просмотр сообщения: #175896 · Ответов: 1 · Просмотров: 458
 

>  Архивація обєктів 1С
zay
Отправлено: 08.06.22, 15:15


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 127
Регистрация: 02.04.12
Из: Киев
Пользователь №: 16639


Цитата(Diana1c @ 08.06.22, 13:44) *
Якщо обрубати по даті то можливі втрати рідковикористовуваних обєктів

У "Конвертації даних" можна створити декілька наборів правил. Наприклад для об'єктів які використовуються часто, для об'єктів які використовуються з середньою частотою і для для об'єктів які використовуються рідко. І вивантажувати кожну групу окремо на різні дати

При цьому створюється проблема переноса залишків. Залишки ми можемо переносити тільки на найбільшу дату. А об'єкти, що йдуть до цієї дати, переносити без рухів. І добавляти у модуль документа заглушку, яка блокує рухи документа до певної дати. Щоб користувачі випадково не перепровели старий документ
Але те що ви пропонуєте, також зіткнеться із цією проблемою
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #175783 · Ответов: 21 · Просмотров: 1911
 

>  как опредилить уровень группы
zay
Отправлено: 08.06.22, 11:57


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 127
Регистрация: 02.04.12
Из: Киев
Пользователь №: 16639


Как и sava1 я тоже не уверен что понял вопрос

Если у вас какие-то группы выполняют определенную функцию (по ним устанавливаются лимиты остатков), а другие группы не выполняют эту функцию, то мне кажется логично добавить реквизит Булево для группы. И дальше смотрим, если этот признак установлен - то именно эти группы нам и нужны. То что такой признак не был добавлен - породило бардак с группами и вы сейчас по сути боретесь с последствиями

Реализация как найти все группы нижнего уровня
Функция ПолучитьВсеГруппыНижнегоУровня()
    
    Результат = новый Массив;
    
    Запрос = новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    Номенклатура.Ссылка
        |ИЗ
        |    Справочник.Номенклатура КАК Номенклатура
        |ГДЕ
        |    Номенклатура.ЭтоГруппа = ИСТИНА";
    
    Выборка = Запрос.Выполнить().Выбрать();
    
    Пока Выборка.Следующий() Цикл
        
        Если ЭтоГруппаНижнегоУровня(Выборка.Ссылка) Тогда
            
            Результат.Добавить(Выборка.Ссылка);
            
        КонецЕсли;
        
    КонецЦикла;
    
    Возврат Результат;
    
КонецФункции

Функция ЭтоГруппаНижнегоУровня(Группа)
    
    Запрос = новый Запрос;
    
    Запрос.УстановитьПараметр("Группа", Группа);
    
    Запрос.Текст =
        "ВЫБРАТЬ
        |    КОЛИЧЕСТВО(РАЗЛИЧНЫЕ Номенклатура.Ссылка) КАК КоличествоГрупп
        |ИЗ
        |    Справочник.Номенклатура КАК Номенклатура
        |ГДЕ
        |    Номенклатура.ЭтоГруппа = ИСТИНА
        |    И Номенклатура.Ссылка В ИЕРАРХИИ(&Группа)";
    
    Выборка = Запрос.Выполнить().Выбрать();
    
    Если Выборка.Следующий() Тогда
        
        Возврат (Выборка.КоличествоГрупп = 1);
            
    КонецЕсли;
    
    Возврат Ложь;
    
КонецФункции

  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #175777 · Ответов: 20 · Просмотров: 1181
 

>  Архивація обєктів 1С
zay
Отправлено: 08.06.22, 11:02


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 127
Регистрация: 02.04.12
Из: Киев
Пользователь №: 16639


Доброго дня
Ось дуже класна стаття про міф о пришвидшенні роботи 1С за допомогою видалення частини даних
Раніше я підозрював що "обрєзка" бази - це маячня. Коли мені трапилася ця стаття, остаточно переконався в цьому
Давайте забудем о свертке БД? Файловые группы и секции таблиц SQL, сжатие таблиц SQL

По моєму досвіду пришвидшенню роботи 1С:
  1. Самий поширений випадок - оптимізації потребує конкретний об'єкт. Запит чи фрагмент програмного коду
  2. Якщо "тормозить" просто все, дивимось монітором ресурсів в чому проблема, який ресурс (процесор, пам'ять, диск чи мережа) зайнятий близько до 100%. В моєму досвіді найпоширеніше це була мережа


Якщо ж ви все ж таки прийняли рішення архівувати базу, то зробити це можна так:
  1. Створюємо нову базу с такою самою конфігурацією
  2. Використовуємо "Конвертації даних". Налаштовуємо правила перенесення об'єктів
  3. За допомогою "Конвертації даних" переносимо в нову базу документи та регістри відомостей після обраної дати (наприклад 01.01.2022)
  4. При перенесені за допомогою конвертації будуть також перенесені елементи довідників, які використовуються у документах та регістрах відомостей що переносятся
  5. "Старі" елементи довідників (включно із "старими" користувачами) перенесені не будуть

Так ми отримаємо дві бази. Одну архівну і одну "нову" в якій продовжуємо працювати
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #175776 · Ответов: 21 · Просмотров: 1911
 

>  формирование универсальный отчет / построитель отчетов в фоновом задании на сервере
zay
Отправлено: 23.09.21, 10:53


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 127
Регистрация: 02.04.12
Из: Киев
Пользователь №: 16639


Я это решал так: формирую отчеты в режиме клиента
По расписанию (планировщик заданий Windows) запуск 1С с определенным параметром, например /C"CreateReport"
В модуле обычного приложения ПриНачалеРаботыСистемы() вставляем обработчик ПараметрЗапуска. Если в параметрах есть CreateReport, формируем и отправляем отчет
При формировании отчета доступны функции клиента
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #174258 · Ответов: 3 · Просмотров: 926
 

>  Збереження реалізації в ексель
zay
Отправлено: 23.08.21, 18:33


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 127
Регистрация: 02.04.12
Из: Киев
Пользователь №: 16639


Встановити у програмному коді властивість табличного документа АвтоМасштаб
ТабДокумент.АвтоМасштаб = Истина;


Мені здається що це не завжди спрацьовує. В такому випадку при першому друці необхідно зайти в пункт меню "Файл" - "Параметри сторінки" і вручну поставити ознаку "За шириною сторінки"

І ще як варіант можна поставити властивість табличного документа МасштабПечати менше 100
  Форум: 1С Управление Торговым Предприятием 8 · Просмотр сообщения: #174089 · Ответов: 5 · Просмотров: 814
 

>  Видимость реквизитов на обычной форме с компактным размещением
zay
Отправлено: 16.08.21, 11:21


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 127
Регистрация: 02.04.12
Из: Киев
Пользователь №: 16639


Цитата
В зависимости от условий количество выводимых на экран реквизитов меняется

Т.е. у вас для справочника существует несколько вариантов заполнения. Для каждого варианта предусмотрен свой набор реквизитов. Правильно?

Можно добавить панель, на панель несколько страниц, отображение закладок = "Отсутствует". Каждая страница соответствует определенному варианту заполнения элемента справочника. На каждую станицу поместить те реквизиты, которые соответствуют данному варианту заполнения. При выборе варианта делать активной нужную страницу
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #174056 · Ответов: 5 · Просмотров: 1038
 

>  Выгрузка информационной базы
zay
Отправлено: 21.04.21, 7:47


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 127
Регистрация: 02.04.12
Из: Киев
Пользователь №: 16639


Поставьте в начале скрипта
rem -- Убивам процесс 1С если он такой есть
taskkill /f /im 1cv8c.exe
taskkill /f /im 1cv8.exe

Скрипт должен запускаться под пользователем с правами администратора
  Форум: Администрирование и настройка 1С · Просмотр сообщения: #172607 · Ответов: 7 · Просмотров: 1016
 

>  ЗУП, релиз 2_1_60_1, расчет средней зп по годовой премии
zay
Отправлено: 01.03.21, 12:01


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 127
Регистрация: 02.04.12
Из: Киев
Пользователь №: 16639


onsamuy @ 25.02.21, 16:14 * ,
Сделать самому

У меня в нескольких организациях есть "Премия по результатам работы за прошлый месяц". У нее базовый период - предыдущий месяц. Делать надо было срочно, надо было рассчитывать отпуска за декабрь, а когда то обновление будет - непонятно
+ пришлось сделать обработку. Во всех базах расчетчики зп с этой премией работали неправильно, базовый период проставлялся = периоду регистрации. Обработкой исправлял базовый период в регистре
И кстати после обновления 2_1_59_1 расчет среднего продолжал считаться неправильно. Точнее как: если премию платили только 1 раз, тогда расчет был верный; если каждый месяц - неверный
  Форум: 1С Зарплата и Управление Персоналом 8 · Просмотр сообщения: #171155 · Ответов: 1 · Просмотров: 797
 

>  Как програмно перепровести Реализацию в бух. учёте
zay
Отправлено: 18.01.21, 9:52


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 127
Регистрация: 02.04.12
Из: Киев
Пользователь №: 16639


Обработка для заполнения табличных частей документов
С ее помощью можно дозаполнить все необходимые реквизиты табличных частяй
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #169881 · Ответов: 16 · Просмотров: 1736
 

>  Универсальные подбор и обработка объектов (управляемое и обычное приложение)
zay
Отправлено: 17.01.21, 19:09


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 127
Регистрация: 02.04.12
Из: Киев
Пользователь №: 16639


Не помню откуда у меня эта обработка. Автор доработал типовую "Универсальный подбор и обработка объектов"
Добавлены возможности:
1. Работа в управляемом приложении
2. Отбор по значениям из табличных частей. В том числе отбор по агрегированным значениям (количество строк, СУММА(поле), КОЛИЧЕСТВО(поле) и т.п.)
3. Обработчики табличных частей в "Установка реквизитов" (замена по выбранному значению, добавление строк, удаление по выбранному значению)

Мной доработан обработчик табличных частей "Удаление по выбранному значению" в режиме обычного приложения. В авторской обработке происходил вылет с ошибкой
  Форум: Отчеты / Обработки · Просмотр сообщения: #169857 · Ответов: 3 · Просмотров: 2139
 

>  Как програмно перепровести Реализацию в бух. учёте
zay
Отправлено: 17.01.21, 12:44


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 127
Регистрация: 02.04.12
Из: Киев
Пользователь №: 16639


Цитата(Yevhenii_S @ 14.01.21, 13:45) *
и при проведении получаю ошибку:
Проведение документа "Реализация товаров и услуг НО000000004 от 27.06.2011 12:00:00"

Тот способ, как вы собираетесь перевести упр.базу на упр.+бух., мог бы сработать, если бы вам надо было это сделать за пол года. Но не за 9 лет. (Или у вас очень мало документов). Я исхожу из того, что у вас велся бух. учет по этой базе (например на 7-ке). И вы перепроводите документы по бух.учету и ожидаете что результат сойдется с той другой бух.базой. Если это так, то есть 2 варианта:
1. Вы каким-то образом перепроведете документы по бух.учету. Бухгалтер проверит результат. Взаиморасчеты с контрагентами, НДС - ничего не сходится. Отменяем проведение по бух.учету. Бухгалтер садится и вносит остатки
2. Бухгалтер садится и вносит остатки

Я в похожих ситуациях пытаюсь убедить на вариант 2
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #169854 · Ответов: 16 · Просмотров: 1736
 

>  Отбор в колонке ТЧ. 8.3
zay
Отправлено: 18.08.20, 20:01


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 127
Регистрация: 02.04.12
Из: Киев
Пользователь №: 16639


feelgood @ Сегодня, 16:49 * ,
Я бы добавил в ТЧ невидимую колонку "Скрывать". При заполнении строки ТЧ значение "Скрывать" получал бы из функции
Для каждого Запись из ТЧ Цикл
    Запись.Скрывать = ПолучитьСкрывать(Запись);
КонецЦикла

Функция ПолучитьСкрывать(Параметры)

    Если Параметры.КолЧисло < -0.1
        ИЛИ Параметры.КолЧисло > 0.1 Тогда
        
        Возврат ложь;
        
    КонецЕсли;
    
    Возврат истина;

КонецФункции

И дальше отбор строк делать на основании значения "Скрывать"
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #165737 · Ответов: 2 · Просмотров: 626
 

>  Руководство разработчика для MEDOC
zay
Отправлено: 29.07.20, 11:32


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 127
Регистрация: 02.04.12
Из: Киев
Пользователь №: 16639


Делаю задачу. В рамках задачи надо было получить некоторые данные из НН из базы Медок. Клиент не покупал модуль интеграции, поэтому пришлось разобраться как получать данные из Медка прямыми запросами. Хочу поделиться

Для отладки SQL запросов к базе Firebird использовал программу "SQL Manager for InterBase/Firebird". Входит в пакет "SQL Management Studio for InterBase/Firebird", использование 30 дней бесплатно

Запрос, которым можно получить список таблиц базы и их объем
SELECT I.rdb$relation_name RELATION,
  cast(1/I.RDB$STATISTICS as integer) RECORD_COUNT
  FROM RDB$INDICES I
  JOIN RDB$RELATION_CONSTRAINTS C
  ON (C.RDB$INDEX_NAME = I.RDB$INDEX_NAME)
  AND (C.RDB$CONSTRAINT_TYPE = 'PRIMARY KEY')
  AND (I.RDB$STATISTICS > cast(0 as double precision))

Запрос взят отсюда Полезные запросы к системным таблицам Firebird и InterBase
Эту информацию можно использовать для поиска нужного справочника

С документами все проще. В Медке при открытии документа он открывается на отдельной странице. Заголовок страницы - это часть имени таблицы БД



Документ в Медок состоит минимум из двух таблиц. Имя таблицы с реквизитами документа заканчивается на _MAIN, имя таблицы с табличной частью заканчивается на _TAB1, _TAB2 и т.д. Связь между этими таблицами по полю CARDCODE
Пример запроса для получения данных из НН
select
  MAIN.*
, T.*
from FJ1201002_MAIN AS MAIN
INNER JOIN FJ1201002_TAB1 AS T
      ON T.CARDCODE = MAIN.CARDCODE


Расшифровку имен полей для НН нашел здесь: Опис структури файлів у форматі DBFдля імпорту у ПК M.E.Doc
  Форум: Тематическое общение · Просмотр сообщения: #165152 · Ответов: 15 · Просмотров: 9202
 

>  Проблема после переустановки системы
zay
Отправлено: 30.06.19, 20:32


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 127
Регистрация: 02.04.12
Из: Киев
Пользователь №: 16639


Talkman @ Сегодня, 20:44 * ,
Цитата(Talkman @ 30.06.19, 20:44) *
Какое приблизительное время выполнения процедуры

Думаю не больше пол часа - час

Вот тут у человека возникла похожая проблема. Скопирую ответ оттуда:
Цитата
Краткое резюме сути вопроса:
1) Период хранения 5 дней.
2) Регистр Покупатели не закрывался по измерению СтавкаНП (стандартная ошибка) + был "Основной покупатель" по которому в регистр шел только приход.
3) Регистры КнигаПокупок и КнигаПродаж не закрывались (регламентные документы не формировались).

Ход устранения:
1) При помощи 1С++ очищено значение измерения СтавкаНП в таблице движений регистра Покупатели
2) Удалены движения по регистрам КнигаПокупок, КнигаПродаж
3) Удалены движения из регистра Покупатели только по договорам Основного покупателя.
4) Добавлен признак в справочник Договоры "Не вести взаиморасчеты".
5) Изменены процедуры ГМ для отключения движений по регистрам КнигаПокупок, КнигаПродаж. Изменены процедуры движения долгов.
6) Обработкой с использованием 1С++ ТА двинута назад, вперед.
7) Обновлена статистика занимаемого места и произведено переиндексирование базы.
8) Результат сдан вопрошающему.

  Форум: Администрирование и настройка 1С · Просмотр сообщения: #153449 · Ответов: 6 · Просмотров: 1657
 

>  Проблема после переустановки системы
zay
Отправлено: 30.06.19, 18:45


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 127
Регистрация: 02.04.12
Из: Киев
Пользователь №: 16639


Виснет под пользователем с полными правами? Я бы для начала попробовал отключить RLS

Еще можно попробовать в sql server management studio выполнить
EXEC sp_updatestats;

Сбор статистики ms sql server
  Форум: Администрирование и настройка 1С · Просмотр сообщения: #153447 · Ответов: 6 · Просмотров: 1657
 

>  Управление торговым предприятием для Украины 8.2 Доступно для бухгалтера
zay
Отправлено: 13.05.19, 16:19


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 127
Регистрация: 02.04.12
Из: Киев
Пользователь №: 16639



Теперь эта книга здесь
  Форум: Литература, ссылки на полезные ресурсы · Просмотр сообщения: #152160 · Ответов: 8 · Просмотров: 5652
 

>  Подводные камни при объеденение 5 баз Бухгалтерія в 1
zay
Отправлено: 20.01.19, 10:04


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 127
Регистрация: 02.04.12
Из: Киев
Пользователь №: 16639


Цитата(kvital @ 19.01.19, 22:28) *
Базы 5 организаций объеденены

Цитата(kvital @ 19.01.19, 22:28) *
от меня требуется почистить дубли

Насколько я понял, внутри одной базы уже ведется учет по нескольким организациям. И ничего объединять не надо.
В таком случае с планом счетов делать ничего не надо, он един для всех.
С договорами делать ничего не надо, они ведутся в разрезе организаций.

С чем есть проблема - это номенклатура. Если по характеру деятельности организации могут использовать одну и ту же номенклатуры.
Вы можете
1. инициировать создание регламента ведения справочника номенклатуры, чтобы в будущем избежать создание дублей
2. сделать обработку для поиска и замены дублей номенклатуры (или переделать типовую с диска ИТС)
3. инициировать назначение ответственного за ведение справочника номенклатуры и дать ему обработку из п.2

если п.1 не выполнен, "чистка" номенклатуры от дублей не имеет смыла. Скоро там опять опять будут дубли

Также надо проверить на дубли такие справочники как "Статьи затрат", "Статьи движения денежных средств". Если там есть дубли, инициировать чтобы финансовый отдел разработал правила ведения этих справочников.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #149129 · Ответов: 5 · Просмотров: 818
 

>  Конфигурация с "Акцизним податком на пальне"
zay
Отправлено: 18.01.19, 17:47


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 127
Регистрация: 02.04.12
Из: Киев
Пользователь №: 16639


Добрый день.
Ищу конфигурацию в которой реализован "Облік акцизного податку на пальне".
На платформе 7.7, на базе какой конфигурации это реализовано - не принципиально.
Если есть такое, то в предложении напишите пожалуйста краткое описание в чем именно заключается доработка.
  Форум: Прочее 1С 7.7 · Просмотр сообщения: #149101 · Ответов: 0 · Просмотров: 835
 

>  Восстановление файловой базы после вируса PETYA
zay
Отправлено: 04.07.17, 16:05


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 127
Регистрация: 02.04.12
Из: Киев
Пользователь №: 16639


Lackynastya @ Сегодня, 15:56 * ,
Написал в личном сообщении
  Форум: Платформа 7.7 · Просмотр сообщения: #129121 · Ответов: 12 · Просмотров: 4460
 

>  Восстановление файловой базы после вируса PETYA
zay
Отправлено: 04.07.17, 8:51


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 127
Регистрация: 02.04.12
Из: Киев
Пользователь №: 16639


Цитата(nik389 @ 03.07.17, 19:30) *
Делайте бекапы - они спасают

Все бэкапы что были в ZIP или RAR - зашифрованы. Те бэкапы что не были запакованы, с теми все нормально.

Цитата(awp @ 03.07.17, 19:54) *
перешли в облако - "крутое на ХайперВи" - 5 день еб**ся

Аналогично. Сисадмины смогли вытащить базы с рэйда, но не могут вытащить из облака.
  Форум: Платформа 7.7 · Просмотр сообщения: #129062 · Ответов: 12 · Просмотров: 4460
 

>  Восстановление файловой базы после вируса PETYA
zay
Отправлено: 03.07.17, 17:40


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 127
Регистрация: 02.04.12
Из: Киев
Пользователь №: 16639


Добрый день.
Нашел решение как восстановить зашифрованную базу 1С 7.7 после вируса
Возможно эта информация кому-то пригодится

Для восстановления нужен поврежденный архив базы (сохранение 1С) и сама поврежденная база
Вирус повреждает архив в его начале. В начале архива находится MD-файл. Делаем тестирование/исправление архива. WinRAR восстанавливает его без первого файла.
К восстановленым файлам копируем MD-файл из самой поврежденной базы. Там он не поврежден.
Архивируем файлы в ZIP и получается восстановленный бэкап. Полученый бэкап загружаем в конфигураторе 1С в новую базу.
  Форум: Платформа 7.7 · Просмотр сообщения: #129009 · Ответов: 12 · Просмотров: 4460
 

>  Требуется программист 1С 8.3, УТП, Киев
zay
Отправлено: 15.12.14, 11:01


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 127
Регистрация: 02.04.12
Из: Киев
Пользователь №: 16639


Требуется программист 1С 8, Киев.

Зарплата: 16 000.

Работодатель:
Энерджи сервис
Направление деятельности: строительство и ремонт электрораспределительных сетей.
Адрес: Киев, ул. Суворова, 4/6

Необходимые навыки:
Опыт работы с 1С 8 от 3-х лет.
Умение общаться с людьми
Знание конфигурации УТП
Наличие сертификатов 1С необязательно
Уверенное знание предметной области бухгалтерского учета
Знание производственного учета на уровне УТП
Желательно знание зарплаты
Написание сложных SQL запросов
Настройка ограничений прав доступа на уровне записи (RLS)

Необходимые качества:
Системность при разработке и написании программного кода
Умение выстраивать работу с пользователями (быть немного бюрократом)

Профессиональные обязанности:
Поддержка нескольких баз в конфигурации УТП, обычное приложение
Разработка отчетов
Небольшие доработки документов
Количество пользователей: 17 бухгалтерия, около 40 прочие

Условия работы:
Работа в офисе
Рабочий день с 9:00 по 18:00, обед 1 час
Количество коллег программистов - 1
Командировок нет.

Условия собеседования:
Предоставьте пожалуйста примеры ваших разработок. Желательно документы. С кратким пояснением для чего служат эти документы/обработки/отчеты. Возможно какие-то красивые решения, которые вы использовали.
После этого два собеседования: с программистом, с начальником ИТ

Контактные данные для связи:
Резюме высылайте пожалуйста на: d.zaytsev@esfmc.com
Для доп. вопросов по вакансии тел.: 095 271 38 66
  Форум: Архив · Просмотр сообщения: #94325 · Ответов: 0 · Просмотров: 2411
 

6 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 07.10.22, 14:55
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!