Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )




>  Сформировать ЗаказПоставщику из Табличной Части
DmitriiKr
Отправлено: 16.11.20, 13:15


Молчаливый
*

Группа: Пользователи
Сообщений: 4
Регистрация: 16.11.20
Пользователь №: 71030


ТаблЗнач = ЭтотОбъект.ТЧ.Выгрузить();
    
    ТаблЗначСв = ТаблЗнач.Скопировать();
    ТаблЗначСв.Свернуть("Поставщик","");
    Для Каждого СтрСв Из ТаблЗначСв Цикл
        СтруктураПоиска = Новый Структура();
        СтруктураПоиска.Вставить("Поставщик",СтрСв.Поставщик);
        НайденныеСтроки  = ТаблЗнач.НайтиСтроки(СтруктураПоиска);
        Если НайденныеСтроки.Количество() > 0 Тогда  // создаем новый документ
            ДокументЗаказПоставщику = Документы.ЗаказПоставщику.СоздатьДокумент();
            ДокументЗаказПоставщику.Дата = ТекущаяДата();
            ДокументЗаказПоставщику.Контрагент = СтрСв.Поставщик;
            ДокументЗаказПоставщику.Склад = Склад;
            
            Для Каждого СтрНайденыш Из НайденныеСтроки Цикл
                
                НоваяСтрокаТЧДокумента = ДокументЗаказПоставщику.Товары.Добавить();
                НоваяСтрокаТЧДокумента.Номенклатура = СтрНайденыш.Номенклатура;
                НоваяСтрокаТЧДокумента.Количество = СтрНайденыш.КупитьНужно;
                НоваяСтрокаТЧДокумента.Сумма = СтрНайденыш.ЦенаЗакупки;
                
                ДокументЗаказПоставщику.Записать();
                
                ДокументЗаказПоставщику.Записать(РежимЗаписиДокумента.ОтменаПроведения);
                
                Сообщить("Создан документ: заказ поставщику " + СтрНайденыш.Номенклатура.Поставщик + " на товар " + СтрНайденыш.Номенклатура + " в количестве " + СтрНайденыш.КупитьНужно + " шт.");
                
                Элементы.СозданиеЗаказаПотавщику.Доступность = Ложь;
                
            конецЦикла;
        КонецЕсли;
    КонецЦикла;



Вот так вот получилось.



Спасибо всем
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168308 · Ответов: 6 · Просмотров: 190
 

>  Сформировать ЗаказПоставщику из Табличной Части
DmitriiKr
Отправлено: 16.11.20, 11:38


Молчаливый
*

Группа: Пользователи
Сообщений: 4
Регистрация: 16.11.20
Пользователь №: 71030


Я вот не понимаю, за чем так реагировать...

Я понимаю что вопрос может и простой, но для новичка он может быть и не простым.
Натолкнуть и какой нибудь пример написать на мой взгляд это было бы правильно.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168300 · Ответов: 6 · Просмотров: 190
 

>  Сформировать ЗаказПоставщику из Табличной Части
DmitriiKr
Отправлено: 16.11.20, 11:19


Молчаливый
*

Группа: Пользователи
Сообщений: 4
Регистрация: 16.11.20
Пользователь №: 71030


А можно пример кода.

Я пробовал метод свернуть, не получилось. сварачивается только колонка поставщик, а все остальные колонки пустые
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168298 · Ответов: 6 · Просмотров: 190
 

>  Сформировать ЗаказПоставщику из Табличной Части
DmitriiKr
Отправлено: 16.11.20, 11:00


Молчаливый
*

Группа: Пользователи
Сообщений: 4
Регистрация: 16.11.20
Пользователь №: 71030


Доброго времени суток.

Для каждого СтрТЧ Из ТЧ Цикл
        
        ДокументЗаказПоставщику = Документы.ЗаказПоставщику.СоздатьДокумент();
        
        ДокументЗаказПоставщику.Дата = ТекущаяДата();
        ДокументЗаказПоставщику.Контрагент = СтрТЧ.Номенклатура.Поставщик;
        ДокументЗаказПоставщику.Склад = Склад;
        
        НоваяСтрокаТЧДокумента = ДокументЗаказПоставщику.Товары.Добавить();
        НоваяСтрокаТЧДокумента.Номенклатура = СтрТЧ.Номенклатура;
        НоваяСтрокаТЧДокумента.Количество = СтрТЧ.КупитьНужно;
        НоваяСтрокаТЧДокумента.Сумма = СтрТЧ.ЦенаЗакупки;
        
        ДокументЗаказПоставщику.Записать();
        
        ДокументЗаказПоставщику.Записать(РежимЗаписиДокумента.ОтменаПроведения);
        
        Сообщить("Создан документ: заказ поставщику " + СтрТЧ.Номенклатура.Поставщик + " на товар " + СтрТЧ.Номенклатура + " в количестве " + СтрТЧ.КупитьНужно + " шт.");
        
        Элементы.СозданиеЗаказаПотавщику.Доступность = Ложь;
        
        
    КонецЦикла;



Этот код просто берет значения которые указаны в ТЧ на форме (в обработке), данные на форме получаются из документа:ЗаказПокупателя за определенный период.



Так вот застрял на том: В Табличной части есть несколько номенклатурой с одним и темже поставщиком.
Как сделать так чтобы заказПоставщику формировался по дному поставщику с несколькими номенклатурами.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168294 · Ответов: 6 · Просмотров: 190
 


Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 27.01.21, 14:55
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!