Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



3 страниц V   1 2 3 >

>  Передача реквизитов между формами
Prospero
Отправлено: 01.04.20, 21:29


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 25.09.12
Из: Киев
Пользователь №: 20729


Цитата(4andriy @ 01.04.20, 11:50) *
через форма.параметр нет

Ну, наверное потому, что
форма.параметр
в явном виде существует в принимающей форме,
которую пользуют через ОткрытьФорму (ОткрытьФормуМодально или ОткрытьПодбор)...
Вы ж явным образом пытались ему значение присвоить до этого счастливого момента.
Хотя по факту это всего лишь контекст, передающийся в открываемую форму.
Думаю, если бы Вы открывали Ваш ТТН через ОткрытьФорму и передавали бы туда Контрагента,
в форме ТТН ПриОткрытии у Вас бы все присваивалось, т.к. на момент открытия Параметр уже существовал бы с конкретным
значением (переданным ранее), а не с Неопределенным.
Ну и наверное, как вариант, в уже вызванной (открытой) форме Вы можете присваивать ему что-то и возвращать в вызывающую форму...
Наверное, как-то так... upset.gif
Может, гуру что подскажут еще, поправят.., конечно, если хотите до конца разобраться в этом вопросе... upset.gif
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #161842 · Ответов: 8 · Просмотров: 342
 

>  Передача реквизитов между формами
Prospero
Отправлено: 31.03.20, 21:24


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 25.09.12
Из: Киев
Пользователь №: 20729


4andriy, Можно подробнее, что Вы хотите сделать?
Форма 1 - это Форма списка справочника Контрагенты?
Вы становитесь на один из элементов....
Хотите его запомнить.
Жмакаете кнопочку открытия документа (Форма 3?) из нее
И при открытии хотите туда передать Контрагента?
Не могу придумать, куда журнал документов тут пристроить (Форма 2)
Поправьте пж.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #161807 · Ответов: 8 · Просмотров: 342
 

>  Как создать документ из справочника контрагентов?
Prospero
Отправлено: 26.03.20, 21:57


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 25.09.12
Из: Киев
Пользователь №: 20729


Sharzem, отчего ж он пустым то будет?
Нет, если создать и потом сразу записать, то будет, согласен smile.gif
Но ТС не указал какой конкретно ему нужно создать документ, а значит, неизвестны конкретные
реквизиты, которые ему нужно заполнять.
Как я понял, ему из справочника Контрагенты нужно создать док с уже заполненными реквизитами данного контрагента?
Так в чем сложность после создания документа программно заполнить реквизиты нужные?
Строки "//....." в моем примере и подразумевают часть кода, заполняющего документ данными из справочника...
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #161683 · Ответов: 9 · Просмотров: 484
 

>  Как создать документ из справочника контрагентов?
Prospero
Отправлено: 25.03.20, 22:30


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 25.09.12
Из: Киев
Пользователь №: 20729


4andriy @ Сегодня, 17:24 * ,
А что мешает из модуля справочника создать документ программно? По кнопочке
Документ = СоздатьОбъект("Документ.Ваш_документ");
//...
//...
//...
Документ.Записать();
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #161639 · Ответов: 9 · Просмотров: 484
 

>  Открыть форму документа из модуля команды
Prospero
Отправлено: 04.03.20, 22:21


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 25.09.12
Из: Киев
Пользователь №: 20729


Constantus,
а РежимОткрытияОкна в ОткрытьФорму не поможет? upset.gif
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #161016 · Ответов: 2 · Просмотров: 238
 

>  Чем можно открыть *.als файл?
Prospero
Отправлено: 07.01.20, 23:03


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 25.09.12
Из: Киев
Пользователь №: 20729


А в папку BIN закинуть и потом открыть через Синтакс-помощник?
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #159089 · Ответов: 7 · Просмотров: 469
 

>  Ограничение видимости в в форме списка справочника по реквизиту
Prospero
Отправлено: 23.09.19, 17:28


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 25.09.12
Из: Киев
Пользователь №: 20729


l2d808 @ Сегодня, 15:53 * ,
Вам нужен отбор при открытии?
Гляньте, может, поможет
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155883 · Ответов: 5 · Просмотров: 545
 

>  Не коректре виведення інформацї в команді
Prospero
Отправлено: 22.09.19, 14:21


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 25.09.12
Из: Киев
Пользователь №: 20729


Цитата(awp @ 21.09.19, 22:23) *
Формат, вроде не сработает.

Да должен вроде...
Сообщить(Прав((сокрЛП("0000"+Формат(кодНовий,"ЧГ=0"))),4)+" - "+кодНовий+"   кількість-"+стрДлина(Прав((сокрЛП("0000"+кодНовий)),4)));

0998 - 998   кількість-4
0999 - 999   кількість-4
1000 - 1 000   кількість-4
1001 - 1 001   кількість-4

Не знаю, так ТС-у нужно или нет
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155835 · Ответов: 7 · Просмотров: 384
 

>  Не коректре виведення інформацї в команді
Prospero
Отправлено: 21.09.19, 20:46


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 25.09.12
Из: Киев
Пользователь №: 20729


l2d808 @ Сегодня, 16:15 * ,

Роздільник розрядів числа - це не зовсім пробіл - це нерозривний пробіл з кодом 160, якщо хочете його прибирати через стрЗаменить - використовуйте другим параметром або Символ(160) або Символы.НПП, або ж застосовуйте попереднє форматування числа за допомогою приклада від AWP
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155816 · Ответов: 7 · Просмотров: 384
 

>  Загрузка адресов контрагента в 8.3 2.0
Prospero
Отправлено: 28.07.19, 7:36


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 25.09.12
Из: Киев
Пользователь №: 20729


kdv2000 @ Вчера, 19:38 * ,
Подозреваю, что обработкой...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #154180 · Ответов: 5 · Просмотров: 400
 

>  Редактирование yml/xml
Prospero
Отправлено: 27.07.19, 7:28


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 25.09.12
Из: Киев
Пользователь №: 20729


Gariks @ Сегодня, 7:14 * ,
Думаю, как минимум глянуть на пример структуры форматов для начала...
YML
XML
По второму информации даже не вагон, а целый состав, наверное, ну и тележка в придачу, как же без нее smile.gif
Первый - это частный случай второго, заточенный под товарные площадки.
Скинули бы файлик, интересно глянуть smile.gif
  Форум: Тематическое общение · Просмотр сообщения: #154160 · Ответов: 1 · Просмотров: 332
 

>  Как создать таблицу значений. Пример. 1с 7.7 конф 7.7.003
Prospero
Отправлено: 12.07.19, 22:11


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 25.09.12
Из: Киев
Пользователь №: 20729


Vofka @ Вчера, 8:01 * ,
Кнопочка есть для Спасибо, а для Большого Спасибо надо бы Большую кнопку 12201689.gif

  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #153757 · Ответов: 9 · Просмотров: 1059
 

>  На панели инструментов нет кнопки документы.
Prospero
Отправлено: 11.07.19, 22:02


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 25.09.12
Из: Киев
Пользователь №: 20729


Ветров @ Сегодня, 14:03 * ,
Вам как пользователю?
Попробуйте правый ТЫЦ мышкой на панели (под меню) - Панели инструментов - Модификация
Выберите категорию и перетяните нужную кнопку на панель

Хотите больше?
Конфигурация - Интерфейсы (внизу вкладка) - на нужном правый ТЫЦ мышкой - Редактировать панели инструментов (или кнопка на панели)
Список панелей, состав панелей, пиктограммки - все что душа пожелает...
Окно Состав - добавить (кнопка, мышка) - выбирайте объект из имеющихся (список), команду, ну и всякое такое (параметры, хоткей, вид)

Попробуйте...

Ну а причина....
Могли просто не добавить в интерфейс...

Разумеется, подразумевается, что у Вас есть соответствующие права, как пользователя системы smile.gif
  Форум: Платформа 7.7 · Просмотр сообщения: #153720 · Ответов: 1 · Просмотров: 479
 

>  Очистка не выбранных строк в таблице
Prospero
Отправлено: 27.06.19, 20:40


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 25.09.12
Из: Киев
Пользователь №: 20729


Цитата(Vladal @ 26.06.19, 16:00) *
На скорую руку:
    УдаляемыеСтроки = ТаблицаЗначений.НайтиСтроки(Новый Структура("ОД", Истина));
    Для каждого УдаляемаяСтрока Из УдаляемыеСтроки Цикл
        ТаблицаЗначений.Удалить(УдаляемаяСтрока);
    КонецЦикла;


Доброго времени суток.
Мне кажется, или код удалит строки, где стоит "птичка"?
ТС вроде их оставить хотел...
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #153409 · Ответов: 3 · Просмотров: 485
 

>  Загрузка курсов валют НБУ для 1с 7.7
Prospero
Отправлено: 14.05.19, 22:40


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 25.09.12
Из: Киев
Пользователь №: 20729


Доброго времени суток.
Небольшой оффтоп по теме (да простит меня Админ):
ИМХО, дело в скрипте, который добавляет
style="display: none;"

к строкам. Причем у меня первая строка не меняется при переходе на новую страницу...
Наверное, фишка автора скрипта smile.gif
Тем не менее, вся страница загружается при выполнении обработки, а не первый месяц.
Acid, если бы Вы добавили при парсинге куска кода таблицы что-то типа
elems = Стрзаменить(elems,"<TR STYLE=""DISPLAY: NONE"">",НачСтроки);

потомки были бы Вам благодарны.
Если же Вам некогда, с Вашего позволения на досуге покопаюсь smile.gif
  Форум: Отчеты / Обработки · Просмотр сообщения: #152196 · Ответов: 7 · Просмотров: 1076
 

>  Пучить полный адрес файла внешней обработки при ее открытии
Prospero
Отправлено: 17.04.19, 21:07


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 25.09.12
Из: Киев
Пользователь №: 20729


Цитата(Gigi @ 17.04.19, 12:38) *
А мне нужно просто при открытии объекта перехватить адрес файла обработки... Вывел кнопку "Ок" из стандартных команд ... и при открытии нажал.

Может я чего-то не понимаю ... upset.gif
Простите, а что мешает использовать событие в модуле формы "ПриОткрытии" Вашей обработки ?
Вам же привели пример выше (Bernet)

Цитата(Gigi @ 17.04.19, 12:38) *
А если это свойство применимо только в модуле объекта то там у В.О. только одно событие.. "ОбработкаПроверкиЗаполнения"

Так добавьте свою функцию туда...
Модуль объекта Вашей внешней обработки:
#Если Сервер Или ТолстыйКлиентОбычноеПриложение Тогда

Функция ПолучитьИмяФайлаВнешнейОбработки() Экспорт
    Попытка
        Возврат ЭтотОбъект.ИспользуемоеИмяФайла;
    Исключение
        Возврат "";
    КонецПопытки;
КонецФункции
#КонецЕсли


Модуль формы Вашей внешней обработки:
&НаСервере 
Функция (ПолучитьНаСервере()
    Возврат РеквизитФормыВЗначение("Объект").ПолучитьИмяФайлаВнешнейОбработки();
КонецФункции


&НаКлиенте
Процедура ПриОткрытии(Отказ)
    Сообщить(ПолучитьНаСервере());
КонецПроцедуры

  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #151611 · Ответов: 9 · Просмотров: 1235
 

>  Неверно применяется коэфициент повышения оклада?
Prospero
Отправлено: 13.02.19, 19:51


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 25.09.12
Из: Киев
Пользователь №: 20729


Цитата(eact @ 13.02.19, 16:38) *
и как он рассчитан???

Наверное коэф. 1.05 умножился на коэф. 1.1
  Форум: 1С Зарплата и Управление Персоналом 8 · Просмотр сообщения: #149787 · Ответов: 9 · Просмотров: 975
 

>  Реквизит документа с выпадающим списком возможных значений
Prospero
Отправлено: 16.01.19, 23:51


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 25.09.12
Из: Киев
Пользователь №: 20729


leonid_gun @ Сегодня, 23:42 * ,
Просто в меню высвечивается текстовое представление (2 параметр, а если он не указан, то равен значению (1 параметр))
У Вас в представлении запятые, а в значении точки. поэтому на картинке запятая в списке, а в поле точка
Удачи.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #149035 · Ответов: 19 · Просмотров: 1047
 

>  Не заполняется табличная часть через функцию заполнить по заказу покупателя
Prospero
Отправлено: 16.01.19, 23:28


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 25.09.12
Из: Киев
Пользователь №: 20729


N-1 @ Сегодня, 21:57 *
Как на авке - это почухать smile.gif
А потерто, так может текст удален smile.gif
  Форум: Управление торговлей для Украины редакция 2 (Уп... · Просмотр сообщения: #149033 · Ответов: 4 · Просмотров: 536
 

>  исправление ошибок в конфигурации 1С 7.7
Prospero
Отправлено: 16.01.19, 23:25


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 25.09.12
Из: Киев
Пользователь №: 20729


4andriy @ 13.01.19, 23:32 * ,
Смотреть надо....
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #149032 · Ответов: 5 · Просмотров: 1017
 

>  Реквизит документа с выпадающим списком возможных значений
Prospero
Отправлено: 16.01.19, 23:12


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 25.09.12
Из: Киев
Пользователь №: 20729


leonid_gun @ Сегодня, 22:56 * ,
Ваш код

(просто точность 5 ))
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #149031 · Ответов: 19 · Просмотров: 1047
 

>  Реквизит документа с выпадающим списком возможных значений
Prospero
Отправлено: 16.01.19, 22:55


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 25.09.12
Из: Киев
Пользователь №: 20729


leonid_gun @ Сегодня, 22:43 * ,
странно, создал реквизит, кинул на форму, и целые и дробные
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #149029 · Ответов: 19 · Просмотров: 1047
 

>  Реквизит документа с выпадающим списком возможных значений
Prospero
Отправлено: 16.01.19, 22:39


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 25.09.12
Из: Киев
Пользователь №: 20729


leonid_gun @ Сегодня, 22:36 * ,
Точность какая у реквизита типа Число?
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #149027 · Ответов: 19 · Просмотров: 1047
 

>  Реквизит документа с выпадающим списком возможных значений
Prospero
Отправлено: 16.01.19, 9:32


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 25.09.12
Из: Киев
Пользователь №: 20729


Если так, то попробуйте поменять
на
Процедура ПриНачалеВыбораЗначения(Рекв,ФлагСтандОбр)     
    ФлагСтандОбр=0;

Калькулятор не будет появляться, только нечисловые значения будут в 0;

Тут же выше awp выложил по этой функции описание...
Синтакс-Помощник Вам в помощь
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #148998 · Ответов: 19 · Просмотров: 1047
 

>  Реквизит документа с выпадающим списком возможных значений
Prospero
Отправлено: 16.01.19, 2:40


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 25.09.12
Из: Киев
Пользователь №: 20729


leonid_gun,
Вы "от руки" вводите или выбираете из списка?
На скорую руку, извините, если что:
// (с) awp :)
Функция ТипДокИзм()  
    Перем Зн;
    СпЗн = СоздатьОбъект("СписокЗначений");
    СпЗн.ДобавитьЗначение("прозора");
    СпЗн.ДобавитьЗначение("непрозора");
    СпЗн.ДобавитьЗначение(0);
    СпЗн.ДобавитьЗначение(2);
    СпЗн.ДобавитьЗначение(1.1);
    СпЗн.ДобавитьЗначение(2.5);    
    Рез = СпЗн.ВыбратьЗначение(Зн,,,,1);    
    Если Рез = 1 Тогда
        Возврат Зн;
    КонецЕсли;
КонецФункции  


Процедура ПриНачалеВыбораЗначения()    
    Сообщить("Перед появлением меню");     
    Зн = ТипДокИзм();
    Сообщить("Зн="+Зн);
    Сообщить("Меняем Зн на Зн+Зн");
    Если ТипЗначенияСтр(Зн)="Число" Тогда
        Зн = Число(Зн);
    КонецЕсли;
    Зн = Зн+Зн;
    Сообщить("А теперь Зн="+Зн);    
    ТипДок = Зн;
КонецПроцедуры


2 параметр убрал, лень выписывать его ))
Получайте значение и делайте с ним что хотите...

Извиняюсь,вот чуть подправленный...
Изменения:
Процедура ПриНачалеВыбораЗначения()

на
Процедура ПриНачалеВыбораЗначения(Рекв)


ТипДок = Зн;

на
УстановитьАтрибут(Рекв,Зн)


Должно для каждого реквизита выбирать свое значение.
Рекв - Идентификатор Вашего реквизита, таким образом можно на все поля навесить
обработку и каждому присвоить разные значения из списка.

Тыц.тыц.тыц...
Недопонял вначале smile.gif
У Вас жменька разнотиповых
реквизитов, и для них Вы хотите
эту менюшку прикрутить?

  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #148994 · Ответов: 19 · Просмотров: 1047
 

3 страниц V   1 2 3 >

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 06.06.20, 17:19
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!