Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



История благодарностей участнику alex1c ::: Спасибо сказали: 37 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
11.08.21, 20:34 запрос всего справочника
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса =
    "//{{ЗАПРОС(Сформировать)
    |ТекущийЭлемент = Справочник.Сотрудники.ТекущийЭлемент;
    |Группировка ТекущийЭлемент упорядочить по ТекущийЭлемент.Наименование;
    |"//}}ЗАПРОС
;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;

Так надо.
4andriy,
18.10.19, 17:20 Почему программно не заполняется поле с типом Справочник.Сотрудники 1с 7.7 конф 7.7.003
ZUBR @ Сегодня, 18:11 * ,

    Спр = СоздатьОбъект("Справочник.Сотрудники");
    Если Спр.НайтиПоНаименованию(СокрЛП(ПолноеИмяПользователя())) = 1 Тогда
        Инженер = Спр.ТекущийЭлемент();
    КонецЕсли;


как-то так...
ZUBR,
19.08.19, 13:38 Запрос АПИ к Новой почте
Bernet @ Сегодня, 14:18 * ,
Спасибо, все взлетело!!!!! icon_beer17.gif

ЗапросHTTP.УстановитьТелоИзСтроки(ЗапросСтрока, "UTF-8", ИспользованиеByteOrderMark.НеИспользовать);


Вот в этом месте трабл был.
Всем спасибо, сколько страниц перешарил - вы не представляете...
andr_andrey,
08.05.19, 16:36 Воссоздать настройку конвертации по правилам обмена
Пробуйте, получится. Создаете настройку, в ней есть "Загрузить правила", ну и т. д.
vbi,
20.03.19, 9:26 Не відкривається Оборотно сальдова по рахунку
Sirius83 @ Вчера, 16:54 * ,
Зберігаєте звіт як зовнішній, рядок в якому помилка, вставляєте в Попытка ... Исключение. Звіт відкриється, далі думаю проблем не буде.
Sirius83,
05.11.14, 17:12 Начисление ЗП в управленческом учете
Проверьте на закладка "Начисления" и "Взносы ФОТ" есть закладка "проводки" там что-то есть?
Irma_lc,
24.02.14, 15:32 ОСВ по счету, отображение дат
Я делал так:
    Если ТипЗначения(Ит.Субконто(НомСубк)) = 12 Тогда
        ПечПредставлениеСубконто = ДокументВОтчете(Ит.Субконто(НомСубк),  1, 1);
    Иначе
        ПечПредставлениеСубконто = Ит.ПредставлениеСубконто(НомСубк);
    КонецЕсли;

функцию ДокументВОтчете() - опишите там что нужно, ну и ПечПредставлениеСубконто в макет воткнуть.
ZhenyaYa,
10.01.13, 17:36 Налаштування налогів!
А еще пропишите организацию по умолчанию в настройках пользователя и увидите эффект.
Юля,
14.12.12, 9:22 Заполнение расходной накладной
Стандарно - нет, а вот сделать обработку которая заполнит остатки в документ - не проблема.
eugene6691,
23.07.12, 16:34 Управленка в комплексной 7.7. а бухгалтерия в 8.2 Реально
У меня уже год так работает. Через конвертацию написал правила и раз в месяц переношу данные всех устраивает.
Есть только один ньюанс, надо постоянно что-то доделывать так-как идет обновление 8-ки ну т.д.
andreykyiv@bigmir.net,
02.04.12, 14:59 Как убрать автоматически заполняемый "0" в печатной форме налоговой накладной
Обновите до последнего релиза, должно помочь.

 i 

правила п.13
Суть вот в чем - НЕ НАДО ИСПОЛЬЗОВАТЬ НЕ НУЖНОЕ ЦИТИРОВАНИЕ ИЛИ ЦИТИРОВАНИЕ СВОИХ СООБЩЕНИЙ!!!

 
simamura,
12.03.12, 9:35 Схема выгрузки податковой декларации
Цитата(mavrik @ 12.03.12, 9:12) *
ПОДАТКОВА ДЕКЛАРАЦІЯ З ПОДАТКУ НА ПРИБУТОК ПІДПРИЄМСТВА (наказ ДПАУ від 28.09.2011 р. №1213 із змінами внесеними наказом Мінфіну від 21.12.2011 р. № 1684) зі звітності за І квартал 2012 р. Нужна сама схема и описание полей выгрузки додаток ОК,в програму бест звит. Зарание спасибо.


Поищите здесь
Alex729, mavrik,
25.11.11, 8:28 Обработка ожидания в своей обработке
Цитата(Vofka @ 24.11.11, 22:05) *
В клюхах обработку ожидания можно только в глобальном модуле вызывать и использовать процедуру глобального модуля? Короче, как правильно реальзовать то, что мне надо? smile.gif

В глоб. модуле в обработке ожидания открываете вашу обработку, в процедуре при открытии прписываете выполнение ВызываемаяПроцедура() и получаете что надо. Все просто.
Vofka,
28.10.11, 12:29 Выборка в запросе
Цитата(kalyamov @ 28.10.11, 13:18) *
Они много чего говорят, не обязательно их слушать. А случай действительно тот. Если это ПУБ, то там и движения по регистрам должны быть.


Целиком согласен.
wmatik,
28.10.11, 12:04 Выборка в запросе
Вообще-то, когда я проходил атестацию по 1С, то экзаменатор, сказал: "Никогда не делать отчеты по документам, только по движениям которые делает документ." Это как-раз тот случай.
wmatik,
26.10.11, 17:38 ФормированиеПроводокЗарплата
Там ошибка в модуле, кажись в процедуре ПроводкуВДБФ() разработчики еще в 40 релизе когда исправляли, накосячили...
AlexOvch,
21.10.11, 15:32 1С Как лучше всего хранить доработки?
Лично я где в конфе что-то меняю, оставляю свой комментарий, при обновлении делаю копию в ней запускаю глоб. поиск своего комментария, и мне вываливаются все ссылки что я и где делал. При объединении анализирую что лучьше заместить объект и в него вставить изменения (копированием) из копии или не изменять и добавить новые изменения вручную опять же из копии. Лучьшего не придумал, вот так...
svinuk,
05.09.11, 19:39 Улыбнуло
Рекомендую взглянуть, что-то очень родное... http://video.i.ua/user/429833/5751/22962/
Alan68, Ardi, MATEVI, oleynik,
26.07.11, 13:22 Загрузка данныз из 77 в 82
Рекомендую взять типовые, и переделать под свою конфу. Я так делал, правда времени потратил пока разобрался, кучу. Зато сейчас нет проблем с переброской данных.
akella,
23.07.11, 13:49 Амортизация основных средств (начисление износа)
У вас наверное комплексная, а в ней не определен параметр ДатаНачНУ. Ошибка...
Ну а если вы не хотите всем объектам ставить дату ввода 01.04.11, тогда ставьте срок использования, с даты ввода, а не с 1.04...
kostyabuh1971,
23.07.11, 11:49 Амортизация основных средств (начисление износа)
В принципе правильно, но не слишком рационально...
Я пошел другим путем, взял остаточную стоимость отнял "ЛиквидационнаяСтоимость" и разделил на оставшееся количество месяцев (СрокИспользования - к-во месяцев за которые начислялся износ). Если кого-то затронуло...
//СуммаИзноса = Макс(Окр((ПервСтоимость - ЛиквидационнаяСтоимость)/Элемент.СрокИспользования,2),0);
// Начало(
// определим к-во мес. за которые начислялся износ
ДатаВвода = Элемент.ДатаВвода;
ДатаВвода = ?(ДатаЧисло(ДатаВвода)=1, ДатаВвода, КонМесяца(ДатаВвода)+1);
Годы = ДатаГод(ДатаДок)-ДатаГод(ДатаВвода);
Если Годы < 0 Тогда
    Годы = Годы + 100;
КонецЕсли;
РазницаМес = ДатаМесяц(ДатаДок) - ДатаМесяц(ДатаВвода) + Годы*12;
Если ДатаЧисло(ДатаДок) < ДатаЧисло(ДатаВвода) Тогда
    РазницаМес = РазницаМес-1;
КонецЕсли;
СуммаИзноса = Макс(Окр((ОстСтоимость - ЛиквидационнаяСтоимость)/(Элемент.СрокИспользования-РазницаМес),2),0);
// окончание)

единственное что подправил дату ввода на 1.04.11.
Andrij-ko,
25.05.11, 13:07 релиз 286 1с Бух., не формируются отчеты
Язык русский ставите в винде, а в конфигураторе текущая системная установка(самое нижнее).
f12,
15.02.11, 18:31 Отчет в пенсионный фонд (ЕСВ)
Открываете в Бесте Отчет ЕСВ, а там есть импорт из ДБФ
f12,
12.01.11, 16:33 Новая форма налоговой накладной
Друзья есть проблема в Налоговой накладной.
Если в документе есть скидка, то она не учитывается....
Или может не должна? (во всяком случае в 7.7).
Wolf2004,
14.12.10, 19:47 БанковскаяВыписка дайте совет
Насколько я понял это комплексная конфа, а в ней у документов есть общие реквизиты: ТипУчета и ФинУчет.
ПроверьТЕ что у ВАС в них стоит и будет ВАМ счастье...
denismi,

2 страниц V   1 2 >
RSS Текстовая версия Сейчас: 20.09.21, 23:06
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!