Версия для печати темы (https://pro1c.org.ua/index.php?s=23db85ba48d55181ebc3b199170546c2&showtopic=64615)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ 1С Управление Торговым Предприятием 8 _ Расчетные листки организаций

Автор: Xmdrug 11.02.21, 9:26

Конфигурация 1С:Підприємство 8.3 (8.3.9.2309), Управление торговым предприятием для Украины", редакция 1.2. (1.2.41.1)
Стандартный отчёт "Расчетные листки организаций". Нужно сделать, чтобы один расчетный листок выводился на один лист. (Отчет формируется со всеми сотрудниками организации, нужно каждого на отдельный лист). Помогите.

Автор: DartRomanius 11.02.21, 9:50

Xmdrug @ Сегодня, 10:26 * ,

Это редактировать вывод отчета надо,

В конфигураторе:

Отчет - РасчетныеЛисткиОрганизаций - Модуль объекта - Процедура СформироватьОтчет

После строки

ВременныйТабличныйДокумент.Вывести(ОбластьПодвал);
, добавить строку
ДокументРезультат.ВывестиГоризонтальныйРазделительСтраниц();

Автор: Xmdrug 11.02.21, 10:02

DartRomanius @ Сегодня, 10:50 * ,

// Формирует отчет в табличный документ
//
// Параметры:
//  Результат         - табличный документ куда будет сформирован отчет
//  ДанныеРасшифровки - данные расшифровки отчета схемы компоновки данных
//  ВыводВФормуОтчета - признак вывода отчета в форму  
//
Функция СформироватьОтчет(Результат = Неопределено, ДанныеРасшифровки = Неопределено, ВыводВФормуОтчета = Истина) Экспорт
    
    Возврат ТиповыеОтчеты.СформироватьТиповойОтчет(ЭтотОбъект, Результат, ДанныеРасшифровки, ВыводВФормуОтчета);
    
    
    
КонецФункции //СформироватьОтчет()


Не нашол такого

Автор: DartRomanius 11.02.21, 10:22

Xmdrug @ Сегодня, 11:02 * ,

Видимо в более поздних версиях изменили вывод отчета, скинте мне цф-файл, у меня самая ранняя 1,2,44,2

Автор: Xmdrug 11.02.21, 10:34

////////////////////////////////////////////////////////////////////////////////
// ПЕРЕМЕННЫЕ МОДУЛЯ

Перем СохраненнаяНастройка Экспорт;
Перем Расшифровки          Экспорт;

#Если Клиент ИЛИ ВнешнееСоединение Тогда
    
////////////////////////////////////////////////////////////////////////////////
// ПРОЦЕДУРЫ И ФУНКЦИИ ОБЩЕГО НАЗНАЧЕНИЯ

// Формирует отчет в табличный документ
//
// Параметры:
//  Результат         - табличный документ куда будет сформирован отчет
//  ДанныеРасшифровки - данные расшифровки отчета схемы компоновки данных
//  ВыводВФормуОтчета - признак вывода отчета в форму  
//
Функция СформироватьОтчет(Результат = Неопределено, ДанныеРасшифровки = Неопределено, ВыводВФормуОтчета = Истина) Экспорт
    
    Возврат ТиповыеОтчеты.СформироватьТиповойОтчет(ЭтотОбъект, Результат, ДанныеРасшифровки, ВыводВФормуОтчета);
    
КонецФункции //СформироватьОтчет()
    
// В процедуре можно доработать компоновщик перед выводом в отчет
//
// Параметры:
//  Нет.
//
Процедура ДоработатьКомпоновщикПередВыводом() Экспорт
    
    
КонецПроцедуры //ДоработатьКомпоновщикПередВыводом()

#КонецЕсли

#Если Клиент Тогда

// Настройка отчета
//
// Параметры:
//  Отбор                              - отбор компоновки данных
//  КомпоновщикНастроекОсновногоОтчета - компоновщик настроек
//
Процедура Настроить(Отбор, КомпоновщикНастроекОсновногоОтчета = Неопределено) Экспорт
    
    ТиповыеОтчеты.НастроитьТиповойОтчет(ЭтотОбъект, Отбор, КомпоновщикНастроекОсновногоОтчета);
    
КонецПроцедуры //Настроить()

// Сохраняет настройки отчета
//
// Параметры:
//  Нет.
//
Процедура СохранитьНастройку() Экспорт
    
    СтруктураНастроек = ТиповыеОтчеты.ПолучитьСтруктуруПараметровТиповогоОтчета(ЭтотОбъект);
    СохранениеНастроек.СохранитьНастройкуОбъекта(СохраненнаяНастройка, СтруктураНастроек);
    
КонецПроцедуры //СохранитьНастройку()

// Заполняет параметры отчета по элементу справочника из переменной "СохраненнаяНастройка".
//
// Параметры:
//  Нет.
//
Процедура ПрименитьНастройку() Экспорт
    
    Если СохраненнаяНастройка.Пустая() Тогда
        Возврат;
    КонецЕсли;
    
    СтруктураПараметров = СохраненнаяНастройка.ХранилищеНастроек.Получить();
    ТиповыеОтчеты.ПрименитьСтруктуруПараметровОтчета(ЭтотОбъект, СтруктураПараметров);
    
КонецПроцедуры //ПрименитьНастройку()

// Инициализация отчета
//
// Параметры:
//  Нет.
//              
Процедура ИнициализацияОтчета() Экспорт
    
    ТиповыеОтчеты.ИнициализацияТиповогоОтчета(ЭтотОбъект);
    
КонецПроцедуры //ИнициализацияОтчета()

Расшифровки = Новый СписокЗначений;

НастройкаПериода = Новый НастройкаПериода;

#КонецЕсли



Вот весь модуль данного отчета

Автор: DartRomanius 11.02.21, 10:42

Xmdrug @ Сегодня, 11:34 * ,

Так, отчет на СКД?

Автор: Xmdrug 11.02.21, 10:51

DartRomanius @ Сегодня, 11:42 * ,
Возможно, я полный ноль пока в этом

Автор: DartRomanius 11.02.21, 11:38

Xmdrug @ Сегодня, 11:51 * ,

Нет, скачал 1,2,41,1
Там так, как я и говорил (писал) выше.

Вы уверены что у вас УТП для Украины 1,2,41,1?

Автор: Xmdrug 11.02.21, 11:39

"Управление торговым предприятием для Украины", редакция 1.2. (1.2.41.1) (http://1c.ua/v8/RegionalSolutions_UA_UTP.php)
Copyright © Molenari OU, 2017-2019. All rights reserved

Автор: 29a 11.02.21, 11:48

DartRomanius @ Сегодня, 10:42 * ,
Обычный отчет, так и есть, нужно добавить ДокументРезультат.ВывестиГоризонтальныйРазделительСтраниц();

З.Ы.
пользуйтесь...
https://pro1c.org.ua/redirect.php?https://fex.net/ru/s/zrpc2pn


 ! 

https://pro1c.org.ua/index.php?act=announce&id=2: 1
 

Автор: DartRomanius 11.02.21, 11:56

Xmdrug @ Сегодня, 12:39 * ,
Ответ ниже(выше?) - ссылка, это вам! ))

29a @ Сегодня, 12:48 * ,

Сообщение № 5????

Автор: Xmdrug 11.02.21, 13:19

Цитата(29a @ 11.02.21, 12:48) *
DartRomanius @ Сегодня, 10:42 ,
Обычный отчет, так и есть, нужно добавить ДокументРезультат.ВывестиГоризонтальныйРазделительСтраниц();

Куда добавить??? Сорри за тупость

Автор: DartRomanius 11.02.21, 13:29

Xmdrug @ Сегодня, 14:19 * ,

Файл - Открыть

Автор: Xmdrug 11.02.21, 13:35

DartRomanius @ Сегодня, 14:29 * ,
Что мне надо скопировать из отправленого модуля в мой??? Он все рабочий, просто надо добавить, чтоб каждого на отдельный лист

Автор: DartRomanius 11.02.21, 13:47

Xmdrug @ Сегодня, 14:35 * ,

А судя по всему заменить отчет, лучше все-таки скиньте cf-файл
Конфигуратор - Конфигурация - Сохранить конфигурацию в файлы

Автор: Xmdrug 11.02.21, 15:37

Цитата(DartRomanius @ 11.02.21, 14:47) *
все-таки скиньте cf-файл

Неразрешили скинуть

Автор: DartRomanius 11.02.21, 16:14

Xmdrug @ Сегодня, 16:37 * ,

Мне не нужен файл с данными(DT), а только файл конфигурации(CF).

Автор: Xmdrug 11.02.21, 16:18

по другому никак? модуль я же скинул

Автор: DartRomanius 11.02.21, 16:28

Xmdrug @ Сегодня, 17:18 * ,
Модуль вообще непонятно как взялся, там такого не должно быть

Автор: 29a 11.02.21, 16:36

Xmdrug @ Сегодня, 16:18 * ,
можно просто, зайти в конфигуратор, найти отчет, вызвать контекстное меню, выбрать "Заменить на внешнюю обработку, отчет...", выбрать исправленный отчет.


Цитата(Xmdrug @ 11.02.21, 15:37) *
Неразрешили скинуть

ИМХО, что тогда заморачиваться?... Пусть ищут программиста, который придет и сделает все бесплатно на месте. )))

Автор: Xmdrug 11.02.21, 17:32

Заменил. Не формируется. Идет выполнение долго и ничего?

Автор: 29a 11.02.21, 21:51

Xmdrug @ Сегодня, 17:32 * ,
через меню - файл - открыть, работает?
Если да, то что то сделал не так...

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua