Версия для печати темы (https://pro1c.org.ua/index.php?s=2960a27824d93053cc923b3cac2018b5&showtopic=64637)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Программирование в 1С Предприятие 7.7 _ Стыковка Бухгалтерия для украины7.70.292 7.70.027 и Медок(неизвестная ошибка)

Автор: redking 12.02.21, 13:01

Здравствуйте, Знатоки.Просьба помочь разобраться с "неизвестной ошибкой".Дорабатывается старая стыковка Бухгалтерия для украины(7.70.292) и Медок.Экспорт документа "оказание услуг".В Медке создан новый шаблон "АктАренд"
в 1с его открыли: Doc = pd.OpenOrCreateDocument(orgId, "АктАренд,,, ДокИД, 0)
в шаблоне есть динам. табл "TAB1" и в ней есть поля "TAB1_A41" и "TAB1_NAMENOMENK", - строка
Заполняем табл.часть "TAB1"

    rsMain = Doc.DataSets("TAB1"); 
    
    Если rsMain.Fields.Count() > 0 Тогда
        rsMain.Clear();
    КонецЕсли;
    
    КоличествоСтрок = спДанные.Получить("КоличествоСтрок");
    Для ном = 1 По КоличествоСтрок Цикл
        ТекСтрока = "R" + Прав("000" + ном,4);
        //rsMain.Append();
        //rsMain.Edit();

        
        rsMain.Fields.Item("TAB1_A").Value = Ном;
        rsMain.Fields.Item("TAB1_A6").Value = спДанные.Получить(ТекСтрока + "СуммаБезНДС");
        rsMain.Fields.Item("TAB1_A3").Value = 3;
        rsMain.Fields.Item("TAB1_NAMENOMENK").Value = СокрЛП(спДанные.Получить(ТекСтрока + "ТоварНаименование"));//Здесь выдает "неизвестная ошибка"
    
        rsMain.Fields.Item("TAB1_A41").Value ="111111111";//Здесь выдает "неизвестная ошибка"
        rsMain.Post();
        Если ном <> КоличествоСтрок Тогда
            rsMain.Append();
        КонецЕсли;
    КонецЦикла;




Автор: assist2erp 13.02.21, 9:50

redking @ Вчера, 14:01 * ,

перем1 = rsMain.FldVal("TAB1_NAMENOMENK");

Проверить чему равна перем1 перед присвоением?

вызывайте rsMain.Edit() перед изменением строки таблицы

Автор: redking 15.02.21, 12:11

assist2erp @ 13.02.21, 9:50 * ,
rsMain.FldVal("TAB1_NAMENOMENK") =
переменная пустая

redking @ Сегодня, 12:09 * ,
rsMain.FldVal("TAB1_A41") =
переменная тоже пустая

Автор: redking 15.02.21, 21:34

redking @ Сегодня, 12:11 * ,
пересоздал шаблон.Начало работать... Причины неясны- это плохо, но работает - это хорошо

Автор: redking 18.02.21, 13:07

redking @ 15.02.21, 21:34 * ,
Выяснил в чем проблема была - может кому-то поможет
При наличии уже загруженного ранее в медок документа , новая загрузка его-же(документа) после изменения шаблона не видит новых полей!

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua