Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



История благодарностей участнику igmig65 ::: Спасибо сказали: 160 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
07.10.19, 12:51 Обробка "Обмін з банком" для БУ 2.0
Макс1С @ Сегодня, 9:42 * ,
А как туда попасть...Отладчик не входит вообще в ОбмінЗБанком_ОбробкаФормату_DBF.epf, а текст ошибки в ОбмінЗБанком 3.8.epf не нашел, там вообще модуль не читаемый...
И странно, что не так с ОбмінЗБанком_ОбробкаФормату_DBF.epf, ведь он мне кажется просто переделан из ОбмінЗБанком_ОбробкаФормату_Шаблон 4.1.epf, а если выбираю формат этот файл, этой ошибки нет, там тхт файл он читает, судя по коду, хоть и дбф выбираю...и выдает что проверьте дату, счет...тоесть отладчик в модуль этого файла шаблона заходит, а в тот нет...
alexpalecha,
03.08.19, 18:10 Как сохранить текущее значение переменной в 1С 7.70.003 торговля склад для Украины?
" Я хочу, чтобы этот номер увеличивался с каждым новым документом на единицу"
.....
я ориентировался на ту задачу которая была озвучена сразу...
ZUBR,
27.07.19, 20:36 Как в определенную ячейку существующего многострочного документа внести программно данные из другого документа? 1с 7.7 конф 7.7.003
Не нужен документ База. Это как сказано выше - фактически отчет.
Вам нужно: алгоритм - документ заказ, на его основании Расходная. Формируется отчет по введенным документам. Из отчета можно открывать и редактировать документы, и обновлять отчет. Можно сделать обработку с таблицей на форме для работы с ней. А делать для этого документ мягко говоря - неправильно...
ZUBR,
29.07.18, 21:53 Как получить количество из проводок через Бухг. итоги ?
Да, забыл....тип суммы не 3 а 4 -колличество
Цитата
ВыполнитьЗапрос
Выборка итогов в различных разрезах.
Синтаксис:
ВыполнитьЗапрос(<НачалоПериода>, <КонецПериода>, <ФильтрПоСчетам>,
<ФильтрПоКоррСчет>, <Валюта>, <ТипИтогов>, <Периодичность>, <ТипСуммы>)
Англоязычный синоним:
DoQuery
Параметры:
.............................
<ТипСуммы>
Необязательный параметр. Число или строка — тип рассчитываемых итогов. Может принимать следующие значения (в скобках указаны строко­вые синонимы):
1 («С», «S») рассчитывать суммы;
2 («В», «С») рассчитывать валютные суммы;
4 («К», «А») рассчитывать количество.
Если требуется одновременно рассчитывать раз­ные суммы, значение параметра получается путем сложения допустимых значений, например: 5 (1+4) — рассчитывать суммы и количество. При указании параметра строкой в ней указываются все символы, которые обозначают типы сумм, которые нужно рассчитывать. По умолчанию рассчитываются все типы сумм.

Попробуйте убрать этот параметр, предполагаю стоит аглицкая К, или поставить 4
Тип итогов можно убрать тоже, оставьте только первые 3 параметра, даты и счет
KriAn,
29.07.18, 7:27 Как получить количество из проводок через Бухг. итоги ?
Предполагаю, с таким сталкивался, но такое может произойти с 1 документом, со всеми вряд ли: Дата настроена показывать год 2 знаками, сделайте 4 знака для года, и проверьте даты удокументов, у меня было 3018 год
Или отследите даты у документов в отладчике...ДатаГод
и даты в отчете ВыбНачПериода, ВыбКонПериода
Иначе не знаю что сказать еще, нужно смотреть мд файл, может чтото накурочено ручками, но незнаю что и предположить...
KriAn,
29.07.18, 0:31 Как получить количество из проводок через Бухг. итоги ?
Судя по скринам проводки формирует, значит и должно выбирать остатки/движения по счетам из бух.итогов. Тип суммы - 3 - кол-во..
скорей всего бух.итоги не рассчитаны, если конфигурация самопальная и не все настроено корректно.
Вот код из стандартной бухгалтерии из процедуры ПриНачалеРаботыСистемы(), с его помощью контролируется данная ситуация...
    Если РабочаяДата() > КонецРассчитанногоПериодаБИ() Тогда
        глКомментарий("На текущую дату бухгалтерские итоги не рассчитаны! "+
                       "Это может привести к некоректной работе системы."+РазделительСтрок+
                       "Установите расчет бухгалтерских итогов в "+
                       """Операции - Управление бухгалтерскими итогами"".",1,,"!!");
    КонецЕсли;
KriAn,
26.07.18, 22:43 Феноменальний клієнт
У меня был главбух, который просто вымогал, чтобы я в 7 открыл доступ на редактирование операции у документов....
спасибо шефу, всегда вникал в проблему...
XBrut,
26.07.18, 22:37 Как сделать отбор в отчете?
+Вместо условия когда во всех функциях, просто добавить это условие, а в функциях убрать
bezzil,
18.07.17, 18:27 Отчет ЕСВ для ЗиК 77 с выгрузкой в дбф
В архиве 2 файла, собственно сам отчет + прайс для отчетов, чтобы этот отчет появился как новый, не заменяя старый в списке регл.отчетов. в самой базе ЗиК
Нужно распаковать архив в папку с регл.отчетами, типа ExtForms\Rp17q1.grp, что в каталоге базы.
Vofka,
15.04.17, 20:13 Загрузка кодов УКТВЭД
Обработка грузит коды УКТВЭД из файла HBUKTNZE.DBF - выгрузка из Медок. больше 14 тыс.строк.
Сразу скажу, грузит коды и наименования, то-есть делалась для справочника УКТВЭД (до 324 релиза), там в дбф нет услуг по моему.
Но думаю многим пригодится, но пользуйтесь на свой страх и риск. Грузит без проблем, но только все. отбора нет.
Кому нужно думаю легко подправить.
В архиве обработка и дбф файл

[attachment=1052:zagruzka_yktzed.zip]
ajnbyfAJNBYF, fastiv, StIvZ, Vfif2411, Vofka,
01.04.17, 10:19 Объединение двух таблиц значений
Так получится точно, но может это не оптимально:
Перебираете таблицу 1, при получении каждой строки тб1 перебираете тб2, и если (пар1тб1 = пар1тб2) И (пар2тб1 = пар2тб2) суммируете значения.
Это так, по быстрому, что в голову сразу пришло, но 100% можно оптимизировать, нужно подумать.
leo10k10,
29.11.16, 16:27 Функция счетчик не срабатывает в первом коде
Да у вас в 1 запросе группировки 2, и счетчик покажет ко-во входов во 2 группировку, когда будете на 1 группировке, то-есть при получении итогов по 1 группировке получите счетчик - итог входов во 2, на этом уровне. По-моему так.
Цитата
Посчитать количество Контрагентов которые приобрели данную категорию товара.

А зачем тогда контрагента получаете ч-з документы. а не регистр, та строка что закомментирована-разкоментируйте, а следующую закомментируйте, вот тут вы получите итоги по контрагенту, но, тогда попадут все документы, участвующие в движениях, если нужно, то добавьте условие по виду документа.
inna.innainna84,
30.08.16, 19:17 Ошибка при расчете ЕСВ
вообще признак основного он периодический, возможно на дату док-та они не основные. Иначе, только нужно проверять ч-з отладчик, почему им не добавляет базу до мин.зп
marmidon,
14.05.16, 8:02 Загрузчик внешних компонент, vkloader
Нужно сказать, столкнулся совсем недавно:
компонента конфликтует с BARCODE.OCX, 1ска вылетает, причину не нашел, когда именно вылетает тоже закономерности не заметил..
Vofka,
29.08.15, 12:21 Не проводиться приходная накладная
Цитата
1С Предприятие Торговля +Склад 1С7v7 7.70.025

Это релиз платформы 1с, а релиз конфигурации какой?
Хотя, как сказано выше, конф-ция не типовая, поэтому не важно какой релиз, нужен код проведения для анализа, или отслеживайте в отладчике, сообщение, которое выводится, не дает информации об ошибке..
Чик,
28.08.15, 11:24 Передать параметр из формы
Цитата
Склад = Конт.Склад;//если в обработке есть реквизит склад

тяжело его кинуть в форму обработки? если да, то нужно передавать контекст документа из документа в обработку, и его же потом из обработки передавать в справочник.
в документе:
Процедура ПриНачалеВыбораЗначения(Рекв,Флаг)
    Флаг=0;
    Если Рекв = "ТМЦ" Тогда
            ОткрытьПодбор("Справочник.ТМЦ",,Контекст,0,ТМЦ);
    Иначе
        Флаг=1;
    КонецЕсли;
КонецПроцедуры

В справочнике:
Процедура ПриОткрытии()
    Конт =  Форма.Параметр;
    склад=конт.склад;
КонецПроцедуры

и зачем обработка?
Если же она нужна? мало ли, то:
В док-те:
Процедура ПриНачалеВыбораЗначения(Рекв,Флаг)
    Флаг=0;
    Если Рекв = "ТМЦ" Тогда
            ОткрытьФормуМодально("Обработка.ПодборТМЦДляДокумента", Контекст);
    Иначе
        Флаг=1;
    КонецЕсли;
КонецПроцедуры

в обработке:
Процедура ПриНачалеВыбораЗначения(Рекв,Флаг)
    Флаг=0;
    Если Рекв = "ТМЦ" Тогда
            Конт =  Форма.Параметр;
            ТМЦ = Конт.ТМЦ;
            ОткрытьПодбор("Справочник.ТМЦ","Для подбора",Конт,0,ТМЦ);
    Иначе
            Флаг=1;
    КонецЕсли;
КонецПроцедуры

и в справочнике:
Процедура ПриОткрытии()
    Конт =  Форма.Параметр;
    склад=конт.склад;
КонецПроцедуры



Да и вообще в Тисе все это реализовано просто через кнопку Подбор, там склад передается сразу в справочник ТМЦ, и он (реквизит Склад) уже при открытии заполнен....в форме"ДляПодбора", и в этой форме реализован вывод остатка в самой форме.
Поэтому можно в этой форме брать ТМЦ из контекста док-та, чтобы на нем и спозиционироваться.
dobruan,
28.08.15, 3:59 Передать параметр из формы
Во первых: зачем передавать в параметр список значений, если передаете контекст документа, все реквизиты доступны ч-з контекст.
Тем более ТМЦ, нужно получать в цикле. Достаточно в док-те:
ОткрытьФормуМодально("Обработка.ПодборТМЦДляДокумента", Контекст)

в обработке:
Процедура ПриОткрытии() 
    Конт =  Форма.Параметр;
    Если (ТипЗначенияСтр(Конт) = "ГрупповойКонтекст") Тогда
           Склад = Конт.Склад;

    Иначе
        Сообщить("Обробка підбору ТМЦ викликається тільки з документів!", "!");
        СтатусВозврата(0);
    КонецЕсли;
    ТМЦ.ВыборГруппы(0);
КонецПроцедуры

+
Процедура ПриНачалеВыбораЗначения(Рекв,Флаг)
    Флаг=0;
    Если Рекв = "ТМЦ" Тогда
            ОткрытьПодбор("Справочник.ТМЦ",,Контекст,0,ТМЦ);//если в обработке есть реквизит склад
    Иначе
        Флаг=1;
    КонецЕсли;
КонецПроцедуры

Тут можно и просто ОткрытьФорму("Справочник.ТМЦ", Контекст)
Тогда в справочнике в
ПриОткрытии()
       Конт =  Форма.Параметр;
       Склад = Конт.Склад;//если в обработке есть реквизит склад

Если же в обработке в ПриНачалеВыбораЗначения(Рекв,Флаг)
       Конт =  Форма.Параметр; 
       ОткрытьФорму("Справочник.ТМЦ", Конт);

здесь в Справочник.ТМЦ передается уже контекст документа
У вас же в обработке справочник открывается просто кнопкой и никакие параметры не передаются....
dobruan,
27.08.15, 18:29 Передать параметр из формы
Сначала передавайте контекст в обработку, потом этот же контекст документа передавайте в форму справочника.
Склад = Форма.Параметр.Склад, если реквизит в документе - Склад.
dobruan,
27.08.15, 17:22 Передать параметр из формы
Если ТиС, то кнопка подбор, там все реализовано, склад берется из контекста документа, который передается как параметр.
Если нет, то передавайте в обработку контекст документа, соответственно Склад = Конт.Склад;
dobruan,
25.08.15, 12:39 Таблица заказов (корзина) в 1с
Цитата
В итоге получается в созданном документе (табличная часть например) - из 20 товаров, 2 могут не прийти( или прийти частично)
При оприходовании товара в документе надо 18 отметить как такие что "Доставлены/приобретены", а 2 оставить в "повторно заказать" (либо "Дозаказать" если пришли частично)
Получается как бы проводится не весь документа а только некоторые товары. а в случае отсутствия товара в принципе (снят с производства) документ не будет проведен вообще.


Делаете помимо поля кол-во(заказано) поле Факт(поставлено). Можно доработать стандартный счет, и доработать ввод на основании, чтоб формировался док по недопоставленным товарам
Sede,
24.08.15, 20:18 Bmp_1c.ocx + BullZip PDF Printer
Тему можно закрыть. Задачу решил так, как изначально не хотелось. Текст пришлось вставлять в объект надпись, и манипулировать с надписью и печатью(картинка) - На задний/передний план. Конечно геморойно менять в подвале текст в ячейках на надписи, но это оказался пока единственный вариант, который рабочий. БитМап не использовал. Если для кого пригодится использовал:
1. Для прозрачности все решил средствами 1с - надписи, картинки и На задний/передний план.
2. Для сохранения в пдф - Bullzip PDF Printer.
3. Для отправки почты CDO.
Vofka,
28.07.15, 20:46 Характеристика товаров справочника ТМЦ
Это все реализовано в ТиСе, используются справочники: Категории, КатегорииТоваров ,КатегорииКонтрагентов.
Посмотрите как там реализовано.
На вашем примере: в спр. категории в Папке Категории товаров, создаете нужные папки: Виды телефлнов, виды карт ит.д. Соответственно заполняете эти папки нужными характеристиками. Ну и в подчиненный товарам Категории товаров добавляете для товаров соответствующие категории.
Возможно нужно будет чтото доработать, например при выводе характеристик показывать родителя..
Sede,
26.05.15, 16:19 Не проводятся документы по зарплате
Цитата(MrVit @ 26.05.15, 16:28) *
тут ище такое, эта же база продолжают дальше считать и аванс за май проходит нормально, тоесть документ провелся, как невчем не было, с новым работником

я вообще первый раз такое вижу - документ "выплата/возврат", в стандартных такого нет, это раз, во вторых при выплате нет проводок по счетам, где есть аналитика по видам деятельности, это начисляем зарплату с затратных счетов, где субконто вид деятельности, а тут....
возможно даже мд файл не поможет, нужно будет на самой базе, на конкретном документе, что непроводится отслеживать все в отладчике. Поэтому гадать дальше думаю нет смысла. У вас в конкретной ситуации не проводится документ, скорей всего изза того что, вместо кода справочника получаете пустое значение, именно в определенной ситуации...
В стол заказов..еще раз..
MrVit,
26.05.15, 14:40 Не проводятся документы по зарплате
Цитата(MrVit @ 26.05.15, 14:25) *
И что такое МД файл чет не понятно ничего

Это файл структуры конфигурации - 1cv7.md.
Но еще раз повторюсь, обращайтесь в стол заказов, нужен анализ, там вместо кода получается пустое значение.
MrVit,
26.05.15, 10:19 Не проводятся документы по зарплате
У вас скорей всего конфигурация дорабатывалась, нужен мд файл для анализа, обратитесь в стол заказов.
MrVit,

5 страниц V   1 2 3 > » 
RSS Текстовая версия Сейчас: 02.06.20, 19:04
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!