Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



История благодарностей участнику Макс1С ::: Спасибо сказали: 53 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
10.07.20, 14:05 Регистратор MG N707TS
Віталій 1975 @ Сегодня, 13:15 * ,
Что-то пишет программа установки?

Такую модель подключал через переходник com-usb, установил драйвер переходника - появился порт в диспетчере, установил OLE драйвер от АртСофт платный, проблем не возникло.
Віталій 1975,
08.07.20, 16:26 Отрицательные остатки ОСВ
Татьяна92 @ Сегодня, 12:31 * ,
С первого взгляда можно предположить, что проблемы и с разрешением отрицательных остатков(1), и с вводом задним числом(2). Увидеть причину можно в карточке счета, в осв по счету со всей аналитикой всё равно не увидим сути, имхо.
1) То что заметил TohaMonster: большая начальная цена - допустим на начало было 10 литров на сумму 1000 грн, списали 20 литров: остаток по количеству -10, а сумма 0, в минус не уходит если нет остатков. Потом оприходовали 20 литров на 2000, остатки: 10 литров на сумму 2000
2) на остатках 2 партии, ранняя 10л по 30 грн/л, поздняя - 10л по 25 грн/л (при условии FIFO). Списали сегодня 10 литров (по 30), потом списали вчерашним числом еще 10 л. В итоге на вчера остатки на первой партии еще были и они тоже списались по 30 - получили "-" в сумме по остатку.

Проблема в том, что обе беды лечатся последовательным проведением и выравниванием дат и времени цепочек приход-перемещение-списание, как и описал Тоха. Но вы пишите, что не помогло, что очень странно.
Если групповое не помогает, попробуйте в карточке счета найти проблемный документ и перепровести вручную.

Как вариант, очень редкий случай когда слетели регистры - сделать Тестирование и исправление с пересчетом итогов

пс. Вот еще подумал: Если проводили отдельно списания, отдельно перемещения - могли остаться такие глюки, важно провести все документы по порядку за один проход (универсальными или другими внешними обработками)
Татьяна92,
21.02.20, 10:24 Универсальная свертка базы данных
llen61 @ Вчера, 16:32 * ,
Китайская мудрость: если долго смотреть на Правила форума , можно узнать пароль
llen61, Vofka,
22.01.20, 14:33 В Закрытии месяца не корректируется себестоимость реализации!
MasiaVK @ 17.01.20, 11:58 * ,
Меняйте счёт на 26, такова особенность (баг или фича, хз) 1С бухгалтерии, в списке счетов подлежащими корректировке не указан 27. В базовой редакции нет возможности исправить в коде без нарушения лицензионного соглашения
MasiaVK,
20.01.20, 14:36 Не заполняется колонка динамического списка
Tailor_Made @ 17.01.20, 19:38 * ,
Надо править общие модули
Для товаров:
ПодборТоваровКлиентСервер.СтруктураСтрокиНоменклатуры()
ПодборТоваровКлиентСервер.ПараметрыТовара(Номенклатура = Неопределено)
Для их характеристик:
ПодборТоваровКлиентСервер.СтруктураСтрокиХарактеристик()

Добавленные элементы структуры нужно добавить в запросы в:
ПодборТоваровСервер.ШаблонТекстаЗапросаСпискаНоменклатурыПоПараметрамСоглашенияСПокупателем()
ПодборТоваровСервер.ПараметрыШаблонаТекстаЗапроса()
ПодборТоваровСервер.ПодстрокаЗаменыПараметраШаблонаТекстаЗапроса()

На форме обработки подбора элементы формы можно добавить программно по наименованиям из СтруктураСтрокиНоменклатуры или СтруктураСтрокиХарактеристик

ПС. Пример из БАС ЕРП, для УТ по идее также должно быть
python,
20.01.20, 9:26 ОС - операции введенные вручную. Как исправить ?
WillyM @ 15.01.20, 13:57 * ,
"Это" было введено ручными операциями, без аналитики и т.д. Перезакрытие месяца не повлияет на состояние ввода в эксплуатацию.
ОС , после приобретения номенклатуры на 1521 счёт, необходимо вводить в эксплуатацию документом "Ввод в эксплуатацию ОС".
Правильнее было бы всё таки оформить такие документы, после чего перепровести закрытие месяца для расчета затрат на амортизацию
WillyM,
07.01.20, 23:12 Какую 1с вибрать
Dll @ Сегодня, 0:19 * ,
из 1Сных: 1С8 УТ, 1С8 УНФ. Не 1Сные - гугл по запросу, например "система для учета товаров", выдает сразу много вариантов относительно простых программ. Выбор сильно зависит от количества людей, которые будут работать и задач, которые требуется решить с её помощью.
Dll,
17.12.19, 16:45 Поиск номенклатуры в заказах поставщику
n25 @ Сегодня, 14:41 * ,
Справа, в настройках, в разделе Фильтры можно добавить фильтр по номенклатуре.
fly,
17.12.19, 16:42 Поле "Скидка" при выводе на печать "Счета на оплату"
Limonka11 @ Сегодня, 14:26 * ,
Это не обновление, по крайней мере не последнее.
В настройках пользователя снимите флаг "При изменении суммы пересчитывать скидку, а не цену"
Limonka11,
13.12.19, 16:27 Составной ключ в справочнике
Цитата(bizisoft @ 13.12.19, 16:22) *
на что кроме дублирование строк в ТЧ частях, влияет данный парамметр

Похоже, что отключает проверку дублей любых колонок во всех документах
bizisoft,
13.12.19, 10:02 Военный сбор при начислении зарплаты 1С 8.3 УТП
Цитата(andreydv87 @ 26.03.19, 11:56) *
нет платежки по ВС (642)

С очень большой долей вероятности этот ответ поможет и вам
FLancer,
11.12.19, 9:32 метод ВыгрузитьКолонку не досупен
fly @ Вчера, 13:05 * ,
Коллега, вы немного напутали, метод Выгрузить() для ДанныеФормыКоллекция недоступен на клиенте.
lolmatrix @ Вчера, 6:43 * ,
Если у вас табличная часть, в вашей серверной процедуре пишите:
Колонка = Объект.ТипыЦен.ВыгрузитьКолонку("ТипЦен")

Если "Типы цен" - просто реквизит формы:
ВремТабл = ДанныеФормыВЗначение(ТипыЦен,Тип("ТаблицаЗначений"));
Колонка = ВремТабл.ВыгрузитьКолонку("ТипЦен")

ИЛИ:
ВремТабл = ТипыЦен.Выгрузить(,"ТипЦен"); //можно как со вторым параметром  так и без него, возвращаемый результат - ТЗ
Колонка = ВремТабл.ВыгрузитьКолонку("ТипЦен")
fly,
09.12.19, 11:14 метод ВыгрузитьКолонку не досупен
lolmatrix @ Сегодня, 10:25 * ,
ВыгрузитьКолонку применяется к табличной части или к таблице значений, для ДанныеФормыКоллекция такого метода действительно нет.
Вам пригодится ДанныеФормыВЗначение()
Например так:
ВремТабл = ДанныеФормыВЗначение(ТипыЦен,Тип("ТаблицаЗначений"));
Колонка = ВремТабл.ВыгрузитьКолонку("ТипЦен")

В этом примере "ТипыЦен" - реквизит формы с типом ТЗ
lolmatrix,
06.12.19, 11:14 Работа с QR Code при помощи типовой КомпонентаПечатиQRКода
av.mironov@mail.ru @ Сегодня, 10:00 * ,
Пароль выдается только прочитавшим правила
Vladal,
05.12.19, 13:02 Составной ключ в справочнике
bizisoft @ Сегодня, 12:39 * ,
Как вариант добавьте реквизит в номенклатуру, например "Номер артикула", а в стандартное поле артикул записывайте программно <Номенклатура.НомерАртикула>+<Производитель.Код> при изменении этих полей на форме.
Таким образом вы получите поле с нужной вам уникальностью в стандартном реквизите и не нужно будет переписывать во всех местах поиск и т.п. При необходимости можно добавить ещё какой-то разрез без сильных доработок
И еще можно будет раскоментить уникальность артикула )
bizisoft,
05.12.19, 12:06 Возможна ли перепродажа 1С
awp @ Сегодня, 11:51 * ,
На то они и франчи, чтобы была единая целевая политика по всей стране. Условия ценообразования, как и санкции за нарушения, определены договорными отношениями, при чем ограничение касается только минимальной цены, в большую сторону - хоть за 1 миллион продавать можно. Есть диллерские договора, в которых нет ограничений по минимальной цене, но сильно ограничен ассортимент и уменьшена маржа. Когда-то Комфи или Розетка продавали базовые бухгалтерии дешевле рекомендованых цен
awp,
04.12.19, 15:42 Составной ключ в справочнике
bizisoft @ Сегодня, 14:46 * ,
в целях оптимизации можете оставить только второй запрос-проверку, он будет покрывать и первый случай. единственное - я бы изменил условие на ссылку вместо кода
|    И Номенклатура.Ссылка <> &Ссылка";

        Запрос.УстановитьПараметр("Артикул", ТекАртикул);
        Запрос.УстановитьПараметр("Производитель", ТекПроизводитель);
        Запрос.УстановитьПараметр("Ссылка", Ссылка);


По ограничению в ТЧ: точно не помню, но в АА есть и ТЧ Товары и ТЧ Наборы, судя по комментарию в стандартном коде - это проверка для ТЧ Наборы, нужно поискать в другом мместе
bizisoft,
03.12.19, 17:03 Составной ключ в справочнике
Подумайте над тем, чтобы просто отключить уникальность по артикулу. Вдруг будет ситуация когда у одного производителя будут абсолютно разные запчасти без артикулов - ключ Производитель+Артикул также окажется неуникальным
bizisoft,
03.12.19, 16:54 УТ3 3.1.5.1 Требуется отчет о суммах задолженности по периодам
andreykyiv@bigmir.net @ Сегодня, 12:10 * ,
Надо доделывать отчет. Можно например взять данные из регистра "Расчеты с клиентами", оплаты фиксируются частями по срокам указанным в соглашении. В стандартных отчетах эти данные попадают в платежный календарь и оценивается факт просрочки платежа в отчете Задолженность клиентов.
Пример из ЕРП, в УТ 3.1 должно быть аналогично
andreykyiv@bigmir.net,
20.11.19, 22:44 Как создать новый элемент справочника из документа? 1с 7.7 конф 7.7.003
ZUBR @ Сегодня, 21:58 * ,
Нужно заполнить реквизит "Родитель" у создаваемого элемента справочника. Реквизит с типом Контрагент, т.е. например так:

Родитель = СоздатьОбъект("Справочник.Контрагенты");
    Родитель.НайтиПоНаименованию("Покупатели");
    // если не найдена группа, создадим
Если Родитель.Выбран() = 0 Тогда
    Родитель.НоваяГруппа();
    Родитель.Наименование = "Покупатели";
    Родитель.ПолнНаименование = "Покупатели";
    Родитель.Записать();
    КонецЕсли;
    
Контр.Родитель = Родитель.ТекущийЭлемент();
ZUBR,
20.11.19, 16:58 Системная функция "ТипЗнч()" - не вопрос, а просто мнение
Цитата(Gigi @ 20.11.19, 9:43) *
Я специально изложил подробно и понятно что бы было ясно что нужно было

Ничего подобного. В одном посте я нашел упоминание задачи, всё остальное - вода.
Цитата(Gigi @ 20.11.19, 9:43) *
проблемами я столкнулся для решения поставленной задачи

не интересно сколько проблем. Большинство, если не все, от незнания или нежелания изучить правильные подходы для решения задач. Озвученная задача достаточно тривиальна для того, чтобы изобретать велосипеды.
Искренне понимаю, что трудно признать свой много-дневный/месячный труд не идеальным из-за неверного подхода в самом начале, но ничего страшного, на ошибках учатся.
Цитата(Gigi @ 20.11.19, 9:43) *
Так вот системная функция: "ТИПЗНЧ()"

не знаю чем вас зацепила эта функция... О том что может любая функция и для чего она предназначена описано в документации к каждой системе, не только к 1С.
Вы расчесываетесь вилкой? На хлеб намазываете зубную пасту? к слову о том что инструмент не важен... вы пытаетесь сработавший в одном случае инструмент применить в других, неподходящих, целях. Открыв пивную бутылку ложкой, пытаетесь открыть ложкой окно или глаза спящему человеку.
Цитата(Gigi @ 20.11.19, 9:43) *
Вопрос: Как с помощью функции ТипЗнч() узнать то что слева от точки.

Как с помощью самоката уехать на луну?
Как зубочисткой убить кита?
Как с помощью линейки и циркуля построить квадратуру круга?

Внимание, правильный вопрос: "Как узнать то что слева от точки?"
Ответ в моём предыдущем посте, в самом начале листинга, вместе с примером решения задачи, которую вы озвучили.

Цитата(Gigi @ 20.11.19, 9:43) *
И это первый раунд.

Никаких раундов. Это была последняя бесплатная консультация
demon14,
19.11.19, 14:33 Системная функция "ТипЗнч()" - не вопрос, а просто мнение
Не удержался чтобы не ответить. Насколько я понимаю суть задачи описана так:
Цитата(Gigi @ 15.11.19, 10:11) *
Потом нажимает на кнопку «Назначить реквизиты авто-заполнения» и появляется форма списка всех реквизитов конкретного справочника или документа с галочками. После чего в форме списка отмечает реквизиты для авто-заполнения, при создании нового объекта и нажимает на Ок. И тут, после чего идет запись в табличную часть справочника, на пример с именем: «AutoFill». Где по каждой строке сохраняются имена реквизитов под те значения, которые значились в самой открытой пользователем форме объекта

Т.е. дать пользователю возможность заполнить 1 раз значения по умолчанию, сохранить их и в дальнейшем подставлять в документ.

На реализацию в самописной базе чернового варианта я потратил чуть больше времени (засёк - 32 минуты) чем в 4й раз перечитывая эту ветку и несоизмеримо меньше, пытаясь понять что курит ТС.
&НаСервере
Процедура НужныйОбъектПриИзмененииНаСервере()
    // НужныйОбъект - ссылка, даже пустая элемента справончика или документа
    // ТаблицаЗначенийРеквизитов - ТЗ на форме
    // в которой пользователь будет заполнять всё, что хочет
    Мет = НужныйОбъект.Метаданные();
    Если  Метаданные.Документы.Содержит(Мет)  Тогда
        ВидОбъекта = "Документ";
    ИначеЕсли Метаданные.Справочники.Содержит(Мет) Тогда
        ВидОбъекта = "Справочник";
    Иначе
        Возврат;
    КонецЕсли;
    
    ТипОбъекта = Мет.Имя;
    
    Для Каждого Рекв Из Мет.Реквизиты Цикл        
        НовСтр = ТаблицаЗначенийРеквизитов.Добавить();
        // для идентификации какой объект заполнять,
        // хотя здесь тоже можно 1 реквизитом обойтись
        НовСтр.ВидОбъекта = ВидОбъекта;
        НовСтр.ТипОбъекта = ТипОбъекта;    
        
        НовСтр.ИмяРквизита = Рекв.Имя;
        // для составого типа будет массив, непринипиально
        НовСтр.ТипДанных = Рекв.Тип;
    КонецЦикла;
КонецПроцедуры

&НаКлиенте
Процедура НужныйОбъектПриИзменении(Элемент)
    НужныйОбъектПриИзмененииНаСервере();
КонецПроцедуры

&НаКлиенте
Процедура ТаблицаЗначенийРеквизитовПриАктивизацииЯчейки(Элемент)    
    Если Элемент.ТекущийЭлемент.Имя = "ТаблицаЗначенийРеквизитовЗначениеРеквизита" Тогда
        ТекущиеДанные = Элементы.ТаблицаЗначенийРеквизитов.ТекущиеДанные;

        Если ЗначениеЗаполнено(ТекущиеДанные.ТипДанных) Тогда
            // кроме этого места, когда пользователь выбирает данные, тип больше нигде не нужен
            Элемент.ТекущийЭлемент.ОграничениеТипа = ТекущиеДанные.ТипДанных;
        КонецЕсли;
    КонецЕсли;    
КонецПроцедуры

&НаСервере
Процедура СохранитьШаблонНаСервере()
    Набор = РегистрыСведений.ДанныеАвтозаполнений.СоздатьНаборЗаписей();
    Набор.Отбор.ВидОбъекта.Установить(ВидОбъекта);
    Набор.Отбор.ТипОбъекта.Установить(ТипОбъекта);
    
    Набор.Прочитать();
    Набор.Очистить();
    
    // заполненную значениями таблицу можно сохранить в регистр сведений или куда угодно !!!БЕЗ ТИПОВ!!!
    // при заполнении нового элемента значениями по-умолчанию мне всё равно какой там тип.    
    Для Каждого Стр Из ТаблицаЗначенийРеквизитов Цикл
        Если ЗначениеЗаполнено(Стр.ЗначениеРеквизита) Тогда
            НоваяЗапись = Набор.Добавить();
            ЗаполнитьЗначенияСвойств(НоваяЗапись,Стр);
        КонецЕсли;
    КонецЦикла;
    
    Набор.Записать();
КонецПроцедуры

&НаКлиенте
Процедура СохранитьШаблон(Команда)
    СохранитьШаблонНаСервере();
КонецПроцедуры




так что счёт 0-22(половина постов этой темы) не в вашу пользу
Моё мненеие: вам очень сильно нужно учить матчасть и потренироваться строить структуру ваших решений до начала программирования с более опытными коллегами. Ну и кончено не выливать кучу рассуждений на форумах, вместо того чтобы озвучить внятно задачу и попросить помощи.
Отдельные посты я бы вообще потер, чтобы, не дай бог, не попались кому-то начинающему на глаза, который всерьёз воспримет все ваши АКСИОМЫ.
demon14, Gigi, Vofka,
18.11.19, 11:46 Как упорядочить строки по номеру 1С 7.70.003 торговля склад для Украины?
ZUBR @ Сегодня, 11:40 * ,


Сортировать(<?>,);
Синтаксис:
Сортировать(<Колонки>,<ДокумПоДате>)
Назначение:
Сортировать таблицу значений по колонкам.
Параметры:
<Колонки> - строковое выражение, которое определяет колонки, порядок и направление сортировки. Формат передаваемой строки - это разделенные запятыми номера или идентификаторы колонок со знаком направления сортировки ( ''+'' - сортировать по возрастанию; ''- '' - сортировать по убыванию; ''*'' - сортировать по внутреннему значению). Знак направления сортировки можно указывать до или после обозначения колонки через пробел или без пробела. По умолчанию направление сортировки принимается по возрастанию.
<ДокумПоДате> - необязательный параметр. Имеет смысл только в том случае, если значениями таблицы значений являются документы. В этом случае можно задавать сортировку документов по их хронологии. Число: 1 - сортировка по хронологии документов; 0 - нет. Значение по умолчанию - 0.


например:

МояТабл.Сортировать("ИмяКолонки1,ИмяКолонки2");
ZUBR,
18.11.19, 11:32 Не закрывается 91 счет при закрытии месяца
fokses @ 15.11.19, 17:28 * ,
Если в закрытии "Дт 91 - Кт 207 15.00 грн (корректировка стоимости списания)" - это корректировка Требования накладной.
Такое случается когда в отчете производства за смену одна и та же номенклатура в материалах и в продукции - так делать нельзя, выпускаемая продукция должна отличаться.
fokses,
15.11.19, 18:13 Экономическое обоснование внедрения изменений в бизнес процесс и систему
Fasharama @ Сегодня, 12:06 * ,

5) Начать нужно с целей, скорее всего цели автоматизации частично пересекутся с целями реструктуризации в целом. Т.е. "что нужно в итоге?"
7) Потом хорошо бы описать процессы как новые так и те, которые останутся(вдруг найдем новую систему которая хорошо решает и старые и новые задачи), таким образом получим ответ на вопрос "как будем достигать целей?"
3) Если есть какая-то учетная система пока можно самостоятельно оценить как новые процессы и документы ложатся без правок системы, насколько сложно/долго будет вести новые функции на бумаге/екселе/в уме. То чего нет в текущей системе и будет начальным заданием на автоматизацию, а потенциальная разница в скорости/надежности работы, рисках потерь данных и т.д. будет экономическим обоснованием таких изменений. Я бы рассматривал такие затраты как часть затрат всей реструктуризации, но это по решению того кто платит деньги, могут посчитать что при цели реструктуризации "увеличить продажи в 2 раза" текущий состав менеджеров справиться с блокнотами и ручками в текущем составе
2,1) На начальном этапе кроме затрат на обследование заложить не получится, без опыта внедрения таких или похожих изменений. Если внедрением планирует заниматься внутренняя ИТ служба, тогда это их задача - по предварительным задачам оценить время и ресурсы которые они потратят на доработки и сформировать бюджет в суммовом выражении (условно их зарплата * на количество месяцев внедрения). Если своей службы нет, искать фирмы/аутсорсов которые могут провести обследование (за деньги, поскольку может занять от часов до месяцев).
4) соответственно эту информацию может дать тот кто будет исполнителем или менеджером этого проекта.
6) если речь про лог изменений учетной системы, имхо должны делать аналитики ИТ службы(при наличии) или стороннего исполнителя в виде технического описания по завершении этапов проекта

как-то так..

А в общем без предварительного обследования практически нет шансов "угадать" бюджет. У товарища была задача : внедрить БАС ЕРП в торговой компании. После обследования двумя франчами озвучили бюджеты расходящиеся в 3-4 раза, причем меньшая цифра 7значная, большая - 8значная
Fasharama,

2 страниц V   1 2 >
RSS Текстовая версия Сейчас: 24.10.20, 19:27
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!