Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )




>  вывести текущего сотрудника и должность на макет в отчете
kukulkan
Отправлено: 26.11.20, 13:06


Молчаливый
*

Группа: Пользователи
Сообщений: 9
Регистрация: 21.11.20
Пользователь №: 71084


Yevhenii_S @ Сегодня, 11:47 * ,
Спасибо!
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168617 · Ответов: 6 · Просмотров: 256
 

>  вывести текущего сотрудника и должность на макет в отчете
kukulkan
Отправлено: 25.11.20, 18:50


Молчаливый
*

Группа: Пользователи
Сообщений: 9
Регистрация: 21.11.20
Пользователь №: 71084


Vofka @ Сегодня, 19:46 * ,
да sad.gif
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168585 · Ответов: 6 · Просмотров: 256
 

>  вывести текущего сотрудника и должность на макет в отчете
kukulkan
Отправлено: 25.11.20, 18:29


Молчаливый
*

Группа: Пользователи
Сообщений: 9
Регистрация: 21.11.20
Пользователь №: 71084


мне кажется я перемудрила так что решила все показать. а так не выводит текущего пользователя

Процедура ПриВыводеПодвала(ПараметрыОтчета, Результат) Экспорт
    
    Если НЕ ПараметрыОтчета.ВыводитьПодписи Тогда
        Возврат;
    КонецЕсли;
    
    Макет = ПолучитьМакет("МакетПодвала");
    ОбластьИнтервал = Макет.ПолучитьОбласть("ПодписиИнтервал");
    ОбластьРуководители = Макет.ПолучитьОбласть("ПодписиРуководители");
    ОбластьМОЛ = Макет.ПолучитьОбласть("ПодписиМОЛ");
    
    Результат.Вывести(ОбластьИнтервал);
    
    Если ПараметрыОтчета.ВыводитьПодписиРуководителей Тогда
        
        Если ПараметрыОтчета.СписокСтруктурныхЕдиниц.Количество() > 0 Тогда
            ИскомаяОрганизация = ПараметрыОтчета.СписокСтруктурныхЕдиниц[0].Значение;
        Иначе
            ИскомаяОрганизация = Справочники.Организации.ПустаяСсылка();
        КонецЕсли;
        
        Если НЕ ЗначениеЗаполнено(ИскомаяОрганизация) Тогда
            ИскомаяОрганизация = ПользователиБКВызовСервераПовтИсп.ПолучитьЗначениеПоУмолчанию(Пользователи.ТекущийПользователь(),"ОсновнаяОрганизация");
            
        КонецЕсли;
        
        Если ЗначениеЗаполнено(ИскомаяОрганизация) Тогда
            ОтветЛица = ОбщегоНазначенияБКВызовСервера.ОтветственныеЛицаОрганизаций(ИскомаяОрганизация, КонецДня(ПараметрыОтчета.КонецПериода));
            Если НЕ ЗначениеЗаполнено(ОтветЛица.РуководительДолжность) Тогда
                ОтветЛица.РуководительДолжность     = НСтр("ru = 'Руководитель'");
            КонецЕсли;
            Если НЕ ЗначениеЗаполнено(ОтветЛица.ГлавныйБухгалтерДолжность) Тогда
                ОтветЛица.ГлавныйБухгалтерДолжность = НСтр("ru = 'Главный бухгалтер'");
            КонецЕсли;
            
            
            ОбластьРуководители.Параметры.Заполнить(ОтветЛица);
        Иначе
            ОтветЛица = Новый Структура("РуководительДолжность, ГлавныйБухгалтерДолжность",
                                         НСтр("ru = 'Руководитель'"), НСтр("ru = 'Главный бухгалтер'"));
        КонецЕсли;
        ОбластьРуководители.Параметры.Заполнить(ОтветЛица);
        
        Результат.Вывести(ОбластьРуководители);
        
    КонецЕсли;
    
    // попытаемся определить ответственного по складу, если отбор установлен
    ОтборПоСкладу = Неопределено;
    ИскомыйСклад  = Неопределено;
    Для Каждого ЭлементОтбора Из ПараметрыОтчета.НастройкиКомпоновкиДанных.Отбор.Элементы Цикл
        Если ТипЗнч(ЭлементОтбора) = Тип("ЭлементОтбораКомпоновкиДанных") И ВРег(ЭлементОтбора.ЛевоеЗначение) = "СКЛАД" Тогда
            ОтборПоСкладу = ЭлементОтбора;
            Прервать;
        КонецЕсли;
    КонецЦикла;
    
    Если ОтборПоСкладу <> Неопределено И ОтборПоСкладу.Использование Тогда
        
        Склады = ОтборПоСкладу.ПравоеЗначение;
        
        // в отборе может присутствовать список складов
        Если ТипЗнч(Склады) = Тип("СписокЗначений") Тогда
            Если Склады.Количество() > 0 Тогда
                ИскомыйСклад = Склады[0].Значение;
            КонецЕсли;
        ИначеЕсли ТипЗнч(Склады) = Тип("СправочникСсылка.Склады") Тогда
            ИскомыйСклад = Склады;
        КонецЕсли;
    КонецЕсли;
    
    // если ничего не нашли, то берем из настроек пользователя
    Если Не ЗначениеЗаполнено(ИскомыйСклад) Тогда
        ИскомыйСклад = ПользователиБКВызовСервераПовтИсп.ПолучитьЗначениеПоУмолчанию(Пользователи.ТекущийПользователь(), "ОсновнойСклад");                    
    КонецЕсли;
                          
    ОтветЛицо = ПрочитатьОтветственноеЛицо(ИскомыйСклад);
    Если Не ОтветЛицо = Неопределено Тогда
        ОбластьМОЛ.Параметры.ОтветственноеЛицо = ОбщегоНазначенияБК.ФамилияИнициалыФизЛица(ОтветЛицо);
    КонецЕсли;
    ПодписиМол = Макет.ПолучитьОбласть("ПодписиМол");
    ПодписиМОЛ.Параметры.ТекущийПользователь =
    //Пользователи.ТекущийПользователь();
    ПользователиИнформационнойбазы.ТекущийПользователь();
    Результат.Вывести(ОбластьМОЛ);
        
    
    
КонецПроцедуры
  Функция ПолучитьТекущегоПользователя () Экспорт
    п = ПользователиИнформационнойБазы.ТекущийПользователь();
    польз =  Справочники.Пользователи.НайтиПоНаименованию(п.Имя);
    Если польз = Справочники.Пользователи.ПустаяСсылка() Тогда
        Возврат -1;
    Иначе
        Возврат Справочники.Пользователи.НайтиПоНаименованию(п.Имя);
    КонецЕсли;
КонецФункции



 ! 

Правила: 9
 
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168583 · Ответов: 6 · Просмотров: 256
 

>  вывести текущего сотрудника и должность на макет в отчете
kukulkan
Отправлено: 25.11.20, 16:35


Молчаливый
*

Группа: Пользователи
Сообщений: 9
Регистрация: 21.11.20
Пользователь №: 71084


Привет! (
Подскажите, как написать процедуру, чтобы вывести на макет в отчете текущего сотрудника и его должность?
Спасибо! 32542460.gif
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168577 · Ответов: 6 · Просмотров: 256
 

>  Как сделать отдельный интерфейс для каждого пользователя
kukulkan
Отправлено: 23.11.20, 14:52


Молчаливый
*

Группа: Пользователи
Сообщений: 9
Регистрация: 21.11.20
Пользователь №: 71084


Vofka @ Сегодня, 14:48 * ,
В 8,3 управляемое, спасибо!
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168516 · Ответов: 3 · Просмотров: 156
 

>  Как сделать отдельный интерфейс для каждого пользователя
kukulkan
Отправлено: 23.11.20, 14:46


Молчаливый
*

Группа: Пользователи
Сообщений: 9
Регистрация: 21.11.20
Пользователь №: 71084


Привет! Как сделать, чтобы для пользователя1 при открытии программы отображался только раздел "Банк и касса", для пользователя2 отображался только раздел "Склад", а для пользователя3 отображались все разделы? Спасибо!
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168513 · Ответов: 3 · Просмотров: 156
 

>  1С поле объекта не обнаружено
kukulkan
Отправлено: 21.11.20, 15:47


Молчаливый
*

Группа: Пользователи
Сообщений: 9
Регистрация: 21.11.20
Пользователь №: 71084


sava1 @ Сегодня, 13:44 * ,
из-за того. что у меня нет этого поля, он не дает мне сформировать отчет. и я не могу изменить макет =/
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168481 · Ответов: 4 · Просмотров: 180
 

>  1С поле объекта не обнаружено
kukulkan
Отправлено: 21.11.20, 12:31


Молчаливый
*

Группа: Пользователи
Сообщений: 9
Регистрация: 21.11.20
Пользователь №: 71084


sava1 @ Сегодня, 13:23 * ,
а можно как-то копировать старый макет в новый?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168479 · Ответов: 4 · Просмотров: 180
 

>  1С поле объекта не обнаружено
kukulkan
Отправлено: 21.11.20, 12:20


Молчаливый
*

Группа: Пользователи
Сообщений: 9
Регистрация: 21.11.20
Пользователь №: 71084


помогите понять, что делать. стандартные проверки совершила. очистить кэш, проверить настройки и тд

1С:Предприятие 8.3 (8.3.16.1148)

Поле объекта не обнаружено (ПредставлениеМОЛОтправителя)
{Документ.ПеремещениеМедикаментов.МодульМенеджера(891)}: ОбластьМакетаПодписи.Параметры.ПредставлениеМОЛОтправителя = ОбщегоНазначенияБК.ФамилияИнициалыФизЛица(ВыборкаПоДокументам.МОЛОтправителя);
{Документ.ПеремещениеМедикаментов.МодульМенеджера(577)}: НСтр("ru = 'Накладная на перемещение медикаментов'"),
{ОбщийМодуль.УправлениеПечатью.Модуль(2007)}: МенеджерПечати.Печать(ОбъектыСоответствующиеПечатнойФорме, ПараметрыПечати, ВременнаяКоллекцияДляОднойПечатнойФормы,
{ОбщаяФорма.ПечатьДокументов.Форма(499)}: ПечатныеФормы = УправлениеПечатью.СформироватьПечатныеФормы(Параметры.ИмяМенеджераПечати, ИменаМакетов,
{ОбщаяФорма.ПечатьДокументов.Форма(43)}: КоллекцияПечатныхФорм = СформироватьПечатныеФормы(Параметры.ИменаМакетов, Отказ);
{ОбщийМодуль.УправлениеПечатьюКлиент.Модуль(34)}: ОткрытьФорму("ОбщаяФорма.ПечатьДокументов", ПараметрыОткрытия, ВладелецФормы, Строка(Новый УникальныйИдентификатор));
{ОбщийМодуль.УправлениеПечатьюБККлиент.Модуль(69)}: УправлениеПечатьюКлиент.ВыполнитьКомандуПечати(ОписаниеКоманды.МенеджерПечати, ОписаниеКоманды.Идентификатор, ОписаниеКоманды.ОбъектыПечати,
{(1)}:УправлениеПечатьюБККлиент.ВыполнитьКомандуПечати(ОписаниеКоманды)
{ОбщийМодуль.УправлениеПечатьюСлужебныйКлиент.Модуль(113)}: Результат = Вычислить(Обработчик);
{ОбщийМодуль.УправлениеПечатьюСлужебныйКлиент.Модуль(26)}: ВыполнитьПодключаемуюКомандуПечатиЗавершение(Истина, ПараметрыВыполнения);
{ОбщийМодуль.ПодключаемыеКомандыКлиент.Модуль(190)}: ВыполнитьОбработкуОповещения(Обработчик, ПараметрКоманды);
{ОбщийМодуль.ПодключаемыеКомандыКлиент.Модуль(34)}: ПродолжитьВыполнениеКоманды(Контекст);
{Документ.ПеремещениеМедикаментов.Форма.ФормаСписка.Форма(56)}: ПодключаемыеКомандыКлиент.НачатьВыполнениеКоманды(ЭтотОбъект, Команда, Элементы.Список);

я понимаю.что проблема в том,что в макете нет МОЛотправителя, но в макете он есть. в старом релизе все работает. а вот в новом при регистрации внешнего отчета выдает ошибку. спасибо за любую помощь!
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168477 · Ответов: 4 · Просмотров: 180
 


Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 21.01.21, 12:48
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!