Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



2 страниц V   1 2 >

>  Картинка ОсновноеИзображение при выборе меняет допкартинку
MOTOPARTNER
Отправлено: 30.10.20, 1:18


Общительный
**

Группа: Пользователи
Сообщений: 37
Регистрация: 28.03.16
Из: Харьков
Пользователь №: 49188


Vofka @ Вчера, 13:34 * ,
Процедура ИзображениеДопНажатие(Элемент)

    Если Не РаботаСДиалогами.ЗаписатьНовыйОбъектВФорме(ЭтаФорма) Тогда
        Возврат;
    КонецЕсли;

    РаботаСФайлами.ОткрытьФормуИзображения2(ЭтаФорма, ИзображениеДоп, Ссылка);    
    
КонецПроцедуры

  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #167809 · Ответов: 6 · Просмотров: 280
 

>  Картинка ОсновноеИзображение при выборе меняет допкартинку
MOTOPARTNER
Отправлено: 29.10.20, 11:35


Общительный
**

Группа: Пользователи
Сообщений: 37
Регистрация: 28.03.16
Из: Харьков
Пользователь №: 49188


Vofka @ Сегодня, 12:03 * ,
Это я понимаю вот как правильно написать не могу понять
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #167789 · Ответов: 6 · Просмотров: 280
 

>  Картинка ОсновноеИзображение при выборе меняет допкартинку
MOTOPARTNER
Отправлено: 28.10.20, 17:40


Общительный
**

Группа: Пользователи
Сообщений: 37
Регистрация: 28.03.16
Из: Харьков
Пользователь №: 49188


Как правильно написать что бы выбранный файл сохранялся только в определенную доп картинку ?
Этот код добавляет сразу во все доп картинки.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #167758 · Ответов: 6 · Просмотров: 280
 

>  Картинка ОсновноеИзображение при выборе меняет допкартинку
MOTOPARTNER
Отправлено: 28.10.20, 12:15


Общительный
**

Группа: Пользователи
Сообщений: 37
Регистрация: 28.03.16
Из: Харьков
Пользователь №: 49188


1С 8.3 Управление торговлей для Украины 2.3

Создал еще 3 картинки в номенклатуре как ИзображениеДоп.
Все работает но когда нажимаешь на любую картинку что-бы добавить оно эту картинку ставит во все 3 картинке я так понял проблема в коде
когда выбираю значение оно ставит во все доп фото как сделать что нужно сделать с кодом что бы на определённую картинку допустим ИзображениеДоп2 ставилась картинка только в эту картинку а остальные не трогало не меняло.

я так понимаю для каждой доп картинке нужно ЗначениеВыбора , ЗначениеВыбора2, ЗначениеВыбора3. или как по другому это реализовать

Если ТипЗнч(ЗначениеВыбора) = Тип("СправочникСсылка.ТипыЦенНоменклатуры") Тогда 
  мТипЦенДляПечати = ЗначениеВыбора;
ИначеЕсли ТипЗнч(ЗначениеВыбора) = Тип("СправочникСсылка.ХранилищеДополнительнойИнформации") Тогда
  Если ОсновноеИзображение <> ЗначениеВыбора Тогда
   ОсновноеИзображение = ЗначениеВыбора;
  КонецЕсли;
  Если ИзображениеДоп <> ЗначениеВыбора Тогда
   ИзображениеДоп = ЗначениеВыбора;
  КонецЕсли;
  Если ИзображениеДоп2 <> ЗначениеВыбора Тогда
   ИзображениеДоп2 = ЗначениеВыбора;
  КонецЕсли;
  Если ИзображениеДоп3 <> ЗначениеВыбора Тогда
   ИзображениеДоп3 = ЗначениеВыбора;
  КонецЕсли;




Заранее спасибо за помощь!
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #167751 · Ответов: 6 · Просмотров: 280
 

>  Выполнить процедуру формы документа со своей обработки. Как?
MOTOPARTNER
Отправлено: 23.10.20, 16:09


Общительный
**

Группа: Пользователи
Сообщений: 37
Регистрация: 28.03.16
Из: Харьков
Пользователь №: 49188


Цитата(Vofka @ 13.10.11, 15:13) *
Форма = Ссылка.ПолучитьФорму("ФормаДокумента");
Форма.Открыть();
Форма.МояЛюбимаяПроцедурочка() // в форме должна быть объявлена как экспортная
Форма.Закрыть();


Спасибо работает но в сам документ при выборе не вставляется информация она остается в той обработке(((
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #167616 · Ответов: 8 · Просмотров: 32371
 

>  Регистры сведений Ошибка Поле объекта не обнаружено
MOTOPARTNER
Отправлено: 22.10.20, 16:51


Общительный
**

Группа: Пользователи
Сообщений: 37
Регистрация: 28.03.16
Из: Харьков
Пользователь №: 49188


pablo @ Сегодня, 14:12 * ,
Я так понимаю что должна быть процедура прописана ? так как поля есть везде и в регистре и в самой обработке.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #167574 · Ответов: 5 · Просмотров: 418
 

>  Регистры сведений Ошибка Поле объекта не обнаружено
MOTOPARTNER
Отправлено: 22.10.20, 11:57


Общительный
**

Группа: Пользователи
Сообщений: 37
Регистрация: 28.03.16
Из: Харьков
Пользователь №: 49188


pablo @ Сегодня, 9:42 * ,
Это обработка Раб. место. и там есть посылки посылка это регистр свед. так вот при открытии поля не получается открыть и поменять
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #167567 · Ответов: 5 · Просмотров: 418
 

>  Регистры сведений Ошибка Поле объекта не обнаружено
MOTOPARTNER
Отправлено: 22.10.20, 0:03


Общительный
**

Группа: Пользователи
Сообщений: 37
Регистрация: 28.03.16
Из: Харьков
Пользователь №: 49188


1С Предприятие 8.3 УТ для Украины 2.3

При нажатии на поле к примеру ТТН я хочу добавить ТТН но мне пишет ошибку а должно появится окно что бы я мог поменять ТТН и все данные сохранились с новым ТТН


{Обработка.РМ.Форма.ФормаРМ.Форма(2435)}: Поле объекта не обнаружено (Посылка)
    ДанныеПосылки = РегистрыСведений.WMS_Посылки.ПолучитьДанныеПоПосылке(ВыбраннаяСтрока.Посылка);



Вот код в конфигурации что не так?

Процедура РегистрПосылокВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;
    
    ДанныеПосылки = РегистрыСведений.WMS_Посылки.ПолучитьДанныеПоПосылке(ВыбраннаяСтрока.Посылка);
    
    Если Колонка.Имя = "Мест" Тогда
        Мест = ДанныеПосылки.Мест;
        Если не ВвестиЗначение(Мест,"Корректировка мест") Тогда
            Возврат;
        Иначе
            РегистрыСведений.WMS_Посылки.ОбновитьХарактеристикиПосылки(ВыбраннаяСтрока.Посылка,Мест);
        КонецЕсли;
    ИначеЕсли Колонка.Имя = "Вес" Тогда
        Вес = ДанныеПосылки.Вес;
        Если не ВвестиЗначение(Вес,"Корректировка веса") Тогда
            Возврат;
        Иначе
            РегистрыСведений.WMS_Посылки.ОбновитьХарактеристикиПосылки(ВыбраннаяСтрока.Посылка,,Вес);
        КонецЕсли;
    ИначеЕсли Колонка.Имя = "СпособДоставки" и (РольДоступна("ПолныеПрава") или РольДоступна("NEW_Старший_Бухгалтер")) Тогда
        ФормаВыбора = Справочники.WMS_СпособДоставкиОплатыКонтрагента.ПолучитьФормуВыбора();
        Если ТипЗнч(ВыбраннаяСтрока.Посылка) = Тип ("ДокументСсылка.РеализацияТоваровУслуг") Тогда
            ФормаВыбора.Отбор.Владелец.Значение = ВыбраннаяСтрока.Посылка.Контрагент;
            ФормаВыбора.Отбор.Владелец.Использование = Истина;
        Иначе
            ФормаВыбора.Отбор.АдресОтправителя.Значение = ВыбраннаяСтрока.Посылка.ДокументПередачи.СкладОтправитель;
            ФормаВыбора.Отбор.АдресОтправителя.Использование = Истина;
            
            ФормаВыбора.Отбор.АдресПолучателя.Значение = ВыбраннаяСтрока.Посылка.ДокументПередачи.СкладПолучатель;
            ФормаВыбора.Отбор.АдресПолучателя.Использование = Истина;
        КонецЕсли;
            
        ФормаВыбора.Заголовок = "Корректировка способа доставки";
        НовыйСпособДоставкиКонтрагента = ФормаВыбора.ОткрытьМодально();
        Если Не ЗначениеЗаполнено(НовыйСпособДоставкиКонтрагента) Тогда
            Возврат;
        КонецЕсли;
        РегистрыСведений.WMS_Посылки.ОбновитьХарактеристикиПосылки(ВыбраннаяСтрока.Посылка,,,НовыйСпособДоставкиКонтрагента);
        Сообщить("ВАЖНО: Свяжитесь со складом и уведомите чтобы переклеили стикеры!", СтатусСообщения.Важное);
    ИначеЕсли Колонка.Имя = "МестоХранения" Тогда
        ФормаМеста = Справочники.МестаХранения.ПолучитьФорму("ФормаВводаМестаХранения");
        Результат = ФормаМеста.ОткрытьМодально();
        Если Результат <> Неопределено Тогда
            НовоеМестоХранения = Справочники.МестаХранения.НайтиПоНаименованию(ФормаМеста.МестоХранения,Истина,,ццц);
            ФормаМеста = "";
            Если НовоеМестоХранения = Справочники.МестаХранения.ПустаяСсылка() Тогда
                Предупреждение ("Выбранное место хранения еще не созданно!");
                Возврат;
            Иначе
                РегистрыСведений.WMS_Посылки.ОбновитьХарактеристикиПосылки(ВыбраннаяСтрока.Посылка,,,,НовоеМестоХранения);
            КонецЕсли;
        КонецЕсли;    
    ИначеЕсли Колонка.Имя = "ТТН" Тогда
        ТТН = ДанныеПосылки.ТТН;
        Если не ВвестиЗначение(ТТН,"Корректировка ТТН") Тогда
            Возврат;
        Иначе
            РегистрыСведений.WMS_Посылки.ОбновитьХарактеристикиПосылки(ВыбраннаяСтрока.Посылка,,,,,ТТН);
        КонецЕсли;
    ИначеЕсли Колонка.Имя = "ЗаметкаДляСкладов" Тогда
        ЗаметкаДляСкладов = ДанныеПосылки.ЗаметкаДляСкладов;
        Если не ВвестиЗначение(ЗаметкаДляСкладов,"Заметка для складов") Тогда
            Возврат;
        Иначе
            РегистрыСведений.WMS_Посылки.ОбновитьХарактеристикиПосылки(ВыбраннаяСтрока.Посылка,,,,,,,,,,,ЗаметкаДляСкладов);
        КонецЕсли;
    ИначеЕсли Колонка.Имя = "Локация" Тогда    
        ФормаВыбораСклада = Справочники.Склады.ПолучитьФормуВыбора();
        ВыбранныйСклад = ФормаВыбораСклада.ОткрытьМодально();
        Если ВыбранныйСклад = НЕОПРЕДЕЛЕНО Тогда
            Возврат;
        КонецЕсли;
        ФормаВыбораСклада = "";
        РегистрыСведений.WMS_Посылки.ОбновитьХарактеристикиПосылки(ВыбраннаяСтрока.Посылка,,,,,,,,ВыбранныйСклад,,,);
    Иначе
        Возврат;
    КонецЕсли;
    
    КоманднаяПанельРегистрПосылокОбновить();
     РегистрПосылок.Обновить();
    
    ЭлементыФормы.РегистрПосылок.ТекущаяСтрока = ВыбраннаяСтрока;
    
КонецПроцедуры
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #167554 · Ответов: 5 · Просмотров: 418
 

>  отправка СМС в VIBER с 1С
MOTOPARTNER
Отправлено: 20.10.20, 18:18


Общительный
**

Группа: Пользователи
Сообщений: 37
Регистрация: 28.03.16
Из: Харьков
Пользователь №: 49188


Ошибся viber://chat?number=380630000000 вот так)))


message: qwer - не работает (((
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #167495 · Ответов: 7 · Просмотров: 868
 

>  отправка СМС в VIBER с 1С
MOTOPARTNER
Отправлено: 20.10.20, 16:51


Общительный
**

Группа: Пользователи
Сообщений: 37
Регистрация: 28.03.16
Из: Харьков
Пользователь №: 49188


Vofka @ Сегодня, 17:39 * ,
Я так сделал и когда нажимаю на кнопку то открывается чат с этим номером если он есть в вайбере. У меня работает !
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #167494 · Ответов: 7 · Просмотров: 868
 

>  отправка СМС в VIBER с 1С
MOTOPARTNER
Отправлено: 20.10.20, 14:00


Общительный
**

Группа: Пользователи
Сообщений: 37
Регистрация: 28.03.16
Из: Харьков
Пользователь №: 49188


Добрый день!
1С Предприятие 8.3 УТ для Украины 2.3

Такой вопрос есть кнопка в документе заказа покупателя

ЗапуститьПриложение("C:\Program files\viber.exe tel: 80630000000");


При нажатии открывается приложение вайбер с контактом. но как мне еще при открытии добавить текс произвольный что бы переносился в вайбер ?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #167491 · Ответов: 7 · Просмотров: 868
 

>  Не выгружает несколько картинок номенклатуры
MOTOPARTNER
Отправлено: 15.10.20, 16:06


Общительный
**

Группа: Пользователи
Сообщений: 37
Регистрация: 28.03.16
Из: Харьков
Пользователь №: 49188


Добрый день!
Не выгружает несколько картинок номенклатуры на сайт "управление торговлей для украины 2.3" пробовал другую конфигурацию "управление торговлей для украины 3.1" тут все работает выгружает все картинки которые загружены в карточку товара.
Где нужно редактировать что бы вы выгружало несколько картинок?
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #167384 · Ответов: 0 · Просмотров: 133
 

>  Допоможіть вибрати конфігурацію для інтернет-магазину+сервісного центру.
MOTOPARTNER
Отправлено: 14.10.20, 8:45


Общительный
**

Группа: Пользователи
Сообщений: 37
Регистрация: 28.03.16
Из: Харьков
Пользователь №: 49188


slavikdr @ 12.10.20, 20:46 * ,
Управление торговлей, редакция 2.3 - Это лучший вариант!

1) Обработка есть на сайте НовойПочты уже готовая работает.
2) Импорт прайса - тут уже скорей всего лучше написать под себя обработку. но в Управление торговлей есть стандартная обработка можно доработать под себя.
3) синхронізація з пром.юа - Тоже скачайТЕ обработку готовую на проме..
4) С розеткой не подскажу. возможно они тоже обработку дают.


 ! 

Правила: 1
 
  Форум: Помогите подобрать конфигурацию · Просмотр сообщения: #167343 · Ответов: 2 · Просмотров: 279
 

>  Получить данные с обработке в поле документа
MOTOPARTNER
Отправлено: 13.10.20, 12:33


Общительный
**

Группа: Пользователи
Сообщений: 37
Регистрация: 28.03.16
Из: Харьков
Пользователь №: 49188


Не получится так сделать?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #167315 · Ответов: 5 · Просмотров: 223
 

>  Получить данные с обработке в поле документа
MOTOPARTNER
Отправлено: 12.10.20, 18:26


Общительный
**

Группа: Пользователи
Сообщений: 37
Регистрация: 28.03.16
Из: Харьков
Пользователь №: 49188


alex1c @ Сегодня, 18:06 * ,
Да в документе нажимаю на поле выбрать и хочу получить данные обработке такого же поля если нажимаю
в документ выбрать город то хочу получить с обработке данные поля город
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #167283 · Ответов: 5 · Просмотров: 223
 

>  Получить данные с обработке в поле документа
MOTOPARTNER
Отправлено: 12.10.20, 15:02


Общительный
**

Группа: Пользователи
Сообщений: 37
Регистрация: 28.03.16
Из: Харьков
Пользователь №: 49188


Добрый день!
Есть такой вопрос, возможно ли так реализовать?

Есть обработка НоваяПочта там есть 2 поля город и отделение
Есть документ заказ покупателя,
я добавил там тоже 2 поля город и отделение, теперь у меня вопрос как в документе заказ покупателя при выборе в поле город получить данные поля город с обработки!
УТ для Украины 2.3
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #167278 · Ответов: 5 · Просмотров: 223
 

>  Обработка Проведения не переносятся товары!
MOTOPARTNER
Отправлено: 07.10.20, 11:54


Общительный
**

Группа: Пользователи
Сообщений: 37
Регистрация: 28.03.16
Из: Харьков
Пользователь №: 49188


sava1 @ Сегодня, 12:35 * ,
сделал как написано результата нет

sava1 @ Сегодня, 12:38 * ,
всем большое спасибо работает проблема была в другом еще один документ создавало и код был написан перед этим и до создания счета не доходило. еще раз спасибо
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #167144 · Ответов: 12 · Просмотров: 439
 

>  Обработка Проведения не переносятся товары!
MOTOPARTNER
Отправлено: 07.10.20, 11:19


Общительный
**

Группа: Пользователи
Сообщений: 37
Регистрация: 28.03.16
Из: Харьков
Пользователь №: 49188


sava1 @ Сегодня, 11:54 * ,
Есть

sava1 @ Сегодня, 11:54 * ,
СмотриТЕ
Если так то документ создается
    докСчет = Документы.СчетНаОплатуПокупателю.СоздатьДокумент();
    докСчет.Дата                        = ТекущаяДата();
    докСчет.Контрагент                    = Ссылка.Контрагент;
    докСчет.ДоговорКонтрагента            = Ссылка.ДоговорКонтрагента;
    докСчет.КратностьВзаиморасчетов        = Ссылка.КратностьВзаиморасчетов;
    докСчет.Организация                    = Ссылка.Организация;
    докСчет.ВалютаДокумента                = Ссылка.ВалютаДокумента;
    докСчет.СтруктурнаяЕдиница          = Ссылка.Сделка.СтруктурнаяЕдиница;
    докСчет.Реализация                    = Ссылка;
    докСчет.ЗаказПокупателя                = Ссылка.Сделка;
    докСчет.Склад                        = Ссылка.Склад;

    докСчет.Записать(РежимЗаписиДокумента.Запись);


Как только добавляю перенос товаров, все провожу док реализации проводится нет ошибок но и счет не создает

    докСчет = Документы.СчетНаОплатуПокупателю.СоздатьДокумент();
    докСчет.Дата                        = ТекущаяДата();
    докСчет.Контрагент                    = Ссылка.Контрагент;
    докСчет.ДоговорКонтрагента            = Ссылка.ДоговорКонтрагента;
    докСчет.КратностьВзаиморасчетов        = Ссылка.КратностьВзаиморасчетов;
    докСчет.Организация                    = Ссылка.Организация;
    докСчет.ВалютаДокумента                = Ссылка.ВалютаДокумента;
    докСчет.СтруктурнаяЕдиница          = Ссылка.Сделка.СтруктурнаяЕдиница;
    докСчет.Реализация                    = Ссылка;
    докСчет.ЗаказПокупателя                = Ссылка.Сделка;
    докСчет.Склад                        = Ссылка.Склад;
    
    Для Каждого ТекСтрокаТовары Из Товары Цикл
            НоваяСтрока = докСчет.Товары.Добавить();
            НоваяСтрока.ЕдиницаИзмерения             = ТекСтрокаТовары.ЕдиницаИзмерения;
            НоваяСтрока.Количество                     = ТекСтрокаТовары.Количество;
            НоваяСтрока.Номенклатура                 = ТекСтрокаТовары.Номенклатура;
            НоваяСтрока.Цена                        = ТекСтрокаТовары.Цена;
            НоваяСтрока.Сумма                        = ТекСтрокаТовары.Сумма;
            НоваяСтрока.ХарактеристикаНоменклатуры  = ТекСтрокаТовары.ХарактеристикаНоменклатуры;
            НоваяСтрока.Коэффициент                 = ТекСтрокаТовары.Коэффициент;
    КонецЦикла;
    
    
    докСчет.Записать(РежимЗаписиДокумента.Запись);


Что-то с товаром не так... и странно что нет ошибок.


 ! 

Правила: 1
 
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #167138 · Ответов: 12 · Просмотров: 439
 

>  Обработка Проведения не переносятся товары!
MOTOPARTNER
Отправлено: 07.10.20, 10:22


Общительный
**

Группа: Пользователи
Сообщений: 37
Регистрация: 28.03.16
Из: Харьков
Пользователь №: 49188


Vofka @ Сегодня, 10:46 * ,
не сообщает ((( странно...

sava1 @ Сегодня, 10:53 * ,
Тоже не создает(((
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #167131 · Ответов: 12 · Просмотров: 439
 

>  Обработка Проведения не переносятся товары!
MOTOPARTNER
Отправлено: 07.10.20, 9:45


Общительный
**

Группа: Пользователи
Сообщений: 37
Регистрация: 28.03.16
Из: Харьков
Пользователь №: 49188


Alegzander @ Сегодня, 10:39 * ,
нет ошибок тупо провожу документ реализация и все но док счет не создается



sava1 @ Сегодня, 10:38 * ,
УТ для укр. 2.3
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #167127 · Ответов: 12 · Просмотров: 439
 

>  Обработка Проведения не переносятся товары!
MOTOPARTNER
Отправлено: 07.10.20, 9:18


Общительный
**

Группа: Пользователи
Сообщений: 37
Регистрация: 28.03.16
Из: Харьков
Пользователь №: 49188


Alegzander @ Сегодня, 8:11 * ,
Спасибо попробую

Alegzander @ Сегодня, 8:11 * ,
Вообще теперь не создается документ((((
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #167123 · Ответов: 12 · Просмотров: 439
 

>  Обработка Проведения не переносятся товары!
MOTOPARTNER
Отправлено: 06.10.20, 23:55


Общительный
**

Группа: Пользователи
Сообщений: 37
Регистрация: 28.03.16
Из: Харьков
Пользователь №: 49188


Доброй ночи! Хочу при проведения документа реализация хочу создать автоматом документ счет на оплату, но как только нажимаю ОК в документе реализация 1С зависает
проблема начинается после

Для Каждого ТекСтрокаТовары Из Товары Цикл

если убрать перенос товаров то все нормально в документ счет все переносится, а вот как переносятся товары 1С зависает что не так?

    докСчет = Документы.СчетНаОплатуПокупателю.СоздатьДокумент();
    докСчет.Дата                        = ТекущаяДата();
    докСчет.Контрагент                    = Ссылка.Контрагент;
    докСчет.ДоговорКонтрагента            = Ссылка.ДоговорКонтрагента;
    докСчет.КратностьВзаиморасчетов        = Ссылка.КратностьВзаиморасчетов;
    докСчет.Организация                    = Ссылка.Организация;
    докСчет.ВалютаДокумента                = Ссылка.ВалютаДокумента;
    докСчет.СтруктурнаяЕдиница          = Ссылка.Сделка.СтруктурнаяЕдиница;
    докСчет.Реализация                    = Ссылка;
    докСчет.ЗаказПокупателя                = Ссылка.Сделка;
    докСчет.Склад                        = Ссылка.Склад;
    
    Для Каждого ТекСтрокаТовары Из Товары Цикл
            НоваяСтрока = Товары.Добавить();
            НоваяСтрока.ЕдиницаИзмерения             = ТекСтрокаТовары.ЕдиницаИзмерения;
            НоваяСтрока.Количество                     = ТекСтрокаТовары.Количество;
            НоваяСтрока.Номенклатура                 = ТекСтрокаТовары.Номенклатура;
            НоваяСтрока.Цена                        = ТекСтрокаТовары.Цена;
            НоваяСтрока.Сумма                        = ТекСтрокаТовары.Сумма;
            НоваяСтрока.ХарактеристикаНоменклатуры  = ТекСтрокаТовары.ХарактеристикаНоменклатуры;
            НоваяСтрока.Коэффициент                 = ТекСтрокаТовары.Коэффициент;
    КонецЦикла;
    
    
    докСчет.Записать(РежимЗаписиДокумента.Запись);
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #167119 · Ответов: 12 · Просмотров: 439
 

>  Как добавить телефон контрагента в поле ввода в заказ покупателя
MOTOPARTNER
Отправлено: 06.10.20, 20:26


Общительный
**

Группа: Пользователи
Сообщений: 37
Регистрация: 28.03.16
Из: Харьков
Пользователь №: 49188


nik389 @ 04.10.20, 15:21 * ,
С этим я разобрался спасибо! тему можно закрывать.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #167097 · Ответов: 4 · Просмотров: 802
 

>  Как добавить телефон контрагента в поле ввода в заказ покупателя
MOTOPARTNER
Отправлено: 04.10.20, 14:15


Общительный
**

Группа: Пользователи
Сообщений: 37
Регистрация: 28.03.16
Из: Харьков
Пользователь №: 49188


nik389 @ Сегодня, 15:05 * ,
В этом и проблема что с запросами я не знаю как работать(((
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #167003 · Ответов: 4 · Просмотров: 802
 

>  Как добавить телефон контрагента в поле ввода в заказ покупателя
MOTOPARTNER
Отправлено: 04.10.20, 2:26


Общительный
**

Группа: Пользователи
Сообщений: 37
Регистрация: 28.03.16
Из: Харьков
Пользователь №: 49188


Доброй ночи! У меня к Вам такой вопрос, Как получить телефон контрагента в поле ввода в заказ покупателя
что бы при выборе Контрагента автоматом подставлялся телефон основной.



 ! 

Правила: 5
 
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #167001 · Ответов: 4 · Просмотров: 802
 

2 страниц V   1 2 >

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 31.07.21, 10:16
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!