Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

История благодарностей участнику sava1 ::: Спасибо сказали: 508 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
08.10.19, 14:02 Программное создание кнопки для всех документов в формах объекта
Если не надо вопроса про запись - тупо отказ и все.

Выше вариант, когда надо спросить человека - "Объект то новый. может Вы хочите его записать ?"

Если человек жмет на кнопу - он на что-то рассчитывает. Хотябы на обратную связь.
Gigi,
08.10.19, 13:27 Программное создание кнопки для всех документов в формах объекта
Копипаст из бухии

Кнопки = Новый СписокЗначений;
        Кнопки.Вставить(0, КодВозвратаДиалога.Да, "Провести");
        Кнопки.Вставить(1, КодВозвратаДиалога.Нет, "Отмена");
        ДополнительныеПараметры = Новый Структура;
        ДополнительныеПараметры.Вставить("ПараметрыВыполненияКоманды", ПараметрыВыполненияКоманды);
        ДополнительныеПараметры.Вставить("ПараметрКоманды", ПараметрКоманды);
        
        Оповещение = Новый ОписаниеОповещения("ВопросПередПросмотромСледуетПровестиЗавершение", ЭтотОбъект, ДополнительныеПараметры);
        ПоказатьВопрос(Оповещение, НСтр("ru='Перед просмотром проводок документ следует провести';uk='Перед переглядом проводок документ слід провести'"), Кнопки,, КодВозвратаДиалога.Да);


и собственно обработка ответа

Если Ответ <> КодВозвратаДиалога.Да Тогда
        Возврат;
    КонецЕсли;
    
    ПараметрКоманды = ДополнительныеПараметры.ПараметрКоманды;
    ПараметрыВыполненияКоманды = ДополнительныеПараметры.ПараметрыВыполненияКоманды;
    
    ДокументПроведен = ПровестиДокумент(ПараметрКоманды);
    Если ДокументПроведен Тогда
        ОповеститьОбИзменении(ПараметрКоманды);
        Оповестить("ВыполненаЗаписьДокумента", Новый Структура("ДокументСсылка", ПараметрКоманды));
    Иначе
        Сообщить(НСтр("ru='Не удалось провести документ';uk='Не вдалося провести документ'"), СтатусСообщения.Важное);
        Возврат;
    КонецЕсли;


а дальше Ваши идеи
Gigi,
08.10.19, 12:41 Программное создание кнопки для всех документов в формах объекта
Цитата(Gigi @ 08.10.19, 13:35) *
что происходит когда на кнопку «Назначить авто-заполнение» нажимаешь не на форме уже сохраненного объекта, а на форме нового.


а сами как думаете ?
если параметром команды идет ссылка на объект, а ссылка пустая ? по-идее Вы должны разрулить эту ситуевину.
Gigi,
08.10.19, 11:58 Программное создание кнопки для всех документов в формах объекта
оффтоп -

Цитата(Gigi @ 08.10.19, 10:48) *
сам в 1С всего два годика.


это типа - знаю, что такое циклы - и для меня достаточно....

по-аналогии - первый раз увидел авто с коробкой-автоматом -- "Как на ней можно ехать - здесь сцепления нет !!!!"
Gigi,
08.10.19, 11:27 Программное создание кнопки для всех документов в формах объекта
чем не нравится Важное ?

Цитата(Gigi @ 08.10.19, 10:48) *
возможно указать только конкретный документ. А указать все документы 1С естественно не позволяет. Это во-первых.


ТипПараметра = составной тип - и ставите "птисы" на чем хочите.

Цитата(Gigi @ 08.10.19, 10:48) *
пределить ссылку на объект, для того что бы вызвать процедуру требующую контекста самой формы?


в модуле команды -

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)

//ПараметрКоманды и есть Ссылка на объект



Цитата(Gigi @ 08.10.19, 10:48) *
вызвать процедуру требующую контекста самой формы


интересно, что Вы в формах храните ?
Gigi,
07.10.19, 15:52 Программное создание кнопки для всех документов в формах объекта
Цитата(Gigi @ 07.10.19, 16:35) *
Пользователь ее должен нажать в другом одном месте, а нужно что бы он нажимал на самой форме.


Уважаемый, Вы хреново осведомлены об Общих Командах. Возьмите типовую бухию и посмотрите, как показываются проводки документа.
Gigi,
03.10.19, 10:08 Настройка доступа через RLS!
у пользователя по другим ролям доступ к кассам закрыт ?

это видели ? тыц

аль это тыц
Pashaboston,
24.09.19, 11:23 Форма выбора. Параметр "Дата между". Реально?
а вот так ?

&НаКлиенте
Процедура ОткрытьФормуА(Команда)
    
    фиксНастройки = Новый НастройкиКомпоновкиДанных;
    
    эОтбор = фиксНастройки.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    эОтбор.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Дата");
    эОтбор.ВидСравнения = ВидСравненияКомпоновкиДанных.БольшеИлиРавно;
    эОтбор.ПравоеЗначение = Объект.Период.ДатаНачала;
    эОтбор.Использование = Истина;
    
    эОтбор = фиксНастройки.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    эОтбор.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Дата");
    эОтбор.ВидСравнения = ВидСравненияКомпоновкиДанных.МеньшеИлиРавно;
    эОтбор.ПравоеЗначение = Объект.Период.ДатаОкончания;
    эОтбор.Использование = Истина;

    эОтбор.РежимОтображения = РежимОтображенияЭлементаНастройкиКомпоновкиДанных.Недоступный;

    ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("ФиксированныеНастройки", фиксНастройки);

    ОткрытьФорму("Документ.РеализацияТоваровУслуг.Форма.ФормаСписка", ПараметрыФормы, ЭтаФорма);
КонецПроцедуры
fly, Inkognito,
24.09.19, 10:39 Форма выбора. Параметр "Дата между". Реально?
а по-человечески - так

ФормаВыбора = ПолучитьФорму("Справочник.ТестСправочник.Форма.ФормаВыбора"
fly,
24.09.19, 10:37 Форма выбора. Параметр "Дата между". Реально?
ФормуВыбора на сервере - вернуть на клиент - открыть
fly,
13.09.19, 7:22 Настроить вывод в заголовки отчетов время и дата формирования отчета, как было в 1с77
ПриКомпоновке

Компоновщик.....Параметры.Установить()

варианты
тыц
andreykyiv@bigmir.net,
03.09.19, 10:19 Улыбнуло
Google запретила популярные приложения для Android

сцылко

Потрясла фраза
Поскольку наркотические препараты становятся все более востребованными среди владельцев смартфонов на базе Android, компания Google приняла решение о том, что такие нужно запретить.
nmf,
30.08.19, 14:35 отображение файла формата BOL на сервере и локальной машине по разному
в блокноте поменяйте (вроде Курьер) - запомнится.
awp,
30.08.19, 13:58 отображение файла формата BOL на сервере и локальной машине по разному
Цитата(awp @ 30.08.19, 14:22) *
о есть ttf файл шрифта используемый системой по умолчанию различается?


в одном месте моноширинный, в другом - нет
awp,
29.08.19, 13:27 Заповнення в УТП регламентної 1ДФ в розрізі місцезнаходження працівників
вряд-ли. Я дописывал отбор по группам
sasha007,
29.08.19, 9:34 Заповнення в УТП регламентної 1ДФ в розрізі місцезнаходження працівників
возьмите в спр Сотрудники Группы по нахождению и заполняйте с отбором по группам
sasha007,
19.08.19, 13:36 Проблема отображения записей в справочнике через RLS (1c 8.2.19.106)
для Вашего случая лучше
- создать роль с запретом
- при открытии анализировать доступность роли и соответственно устанавливать доступность/видимость реквизита

и не трогатьРЛС
andrew76,
19.08.19, 13:22 Запрос АПИ к Новой почте
тогда надо с НП связываться. Если DAta = invalid - может опять что-то поменяли
alex1c,
28.07.19, 12:01 Организация справочника ВУЗОВ,СУЗов (1с 8.2)
Не старыеНазвания, а просто названия (в т.ч. и текущее)

все остальное - да.
andrew76,
28.07.19, 11:40 Организация справочника ВУЗОВ,СУЗов (1с 8.2)
andrew76 @ Сегодня, 12:26 * ,
да
andrew76,
28.07.19, 10:53 Организация справочника ВУЗОВ,СУЗов (1с 8.2)
к спр.ВУЗы прицепить подчиненный справочник НаименованияВуза и реквизит соответственно будет тип(НаименованияВуза)
andrew76,
28.07.19, 7:18 БСО=>УСО
наверно, надо снять поиск по УИДу, оставить только поля поиска (код)
igmig65,
27.07.19, 19:15 Организация справочника ВУЗОВ,СУЗов (1с 8.2)
регистрСведений с полями ВУЗ (Ссылка), Наименование
и искать по регистру.
в спр.Вузы добавить тч с типом регистрСведенийСписок и редактировать в формк справочника (типа как штрихкоды в стандартных конфах)
andrew76,
16.07.19, 12:17 Язык интерфейса
Вот теперь заживем !!!!!
nmf,
16.07.19, 10:01 Дождаться закрытия формы и выполнить код в документе открытия этой формы
При закрытии 2й формы Оповестить()
в 1й обработать оповещение.
Constantus,

16 страниц V   1 2 3 > » 
RSS Текстовая версия Сейчас: 14.10.19, 11:03
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!