Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



3 страниц V   1 2 3 >

>  как ПрочитатьJSON(Чтение) массив объектов (выборку запроса)
svetas_l
Отправлено: 20.09.20, 8:12


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 23.12.18
Пользователь №: 63555


mut @ 18.09.20, 17:52 * ,
файл существует
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #166594 · Ответов: 10 · Просмотров: 231
 

>  как ПрочитатьJSON(Чтение) массив объектов (выборку запроса)
svetas_l
Отправлено: 18.09.20, 14:09


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 23.12.18
Пользователь №: 63555


убрала установить строку - пишет недопустимое состояние потока
      
    Чтение         =    Новый ЧтениеJSON;
    Чтение.ОткрытьФайл(Этаформа.ПутьЧтения+".json");

  //  Чтение.УстановитьСтроку("{}");
    Джисон = ПрочитатьJSON(Чтение);
    
    Чтение.Закрыть();


в отладчике
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #166552 · Ответов: 10 · Просмотров: 231
 

>  как ПрочитатьJSON(Чтение) массив объектов (выборку запроса)
svetas_l
Отправлено: 18.09.20, 9:25


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 23.12.18
Пользователь №: 63555


у вас тоже идёт
 ЧтениеJSON = Новый ЧтениеJSON;
    ЧтениеJSON.УстановитьСтроку(Ответ.ПолучитьТелоКакСтроку());
    Данные = ПрочитатьJSON(ЧтениеJSON, Ложь);


только уже с сайтом
мне бы сначала понять что не так и даёт ошибку в 3 строчках ,
а затем уже буду разбираться с сайтом.
В любом случае спасибо .

  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #166543 · Ответов: 10 · Просмотров: 231
 

>  как ПрочитатьJSON(Чтение) массив объектов (выборку запроса)
svetas_l
Отправлено: 18.09.20, 8:36


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 23.12.18
Пользователь №: 63555


добрый день!
такой код выдаёт ошибку "по причине:
Недопустимое состояние потока записи JSON"

  
    Чтение         =    Новый ЧтениеJSON;
    Чтение.ОткрытьФайл(Этаформа.ПутьЧтения+".json");
    Чтение.УстановитьСтроку("{}");
    Джисон = ПрочитатьJSON(Чтение);
    Чтение.Закрыть();

в чем ошибка?
файл
[
{
"Ссылка": "ТОВ \"ДИРЕКТОРІЯ ЗАТИШКУ\"",
"Код": "000000006",
"Наименование": "ТОВ \"ДИРЕКТОРІЯ ЗАТИШКУ\"",
"Префикс": "ДЗ",
"ИНН": "",
"НомерСвидетельства": "",
"КодПоЕДРПОУ": "40769228",
"ФизическоеЛицо": "",
"НаименованиеПолное": "ТОВАРИСТВО З ОБМЕЖЕНОЮ ВІДПОВІДАЛЬНІСТЮ \"ДИРЕКТОРІЯ ЗАТИШКУ\"",
"СвидетельствоСерияНомер": "",
"СвидетельствоДатаВыдачи": "01.01.0001 0:00:00",
"БанковскийСчетПоУмолчанию": "UA653287040000026009054334936 ТОВ \"ДИРЕКТОРІЯ ЗАТИШКУ\"",
"ЮрФизЛицо": "Юр. лицо",
"ТекущийРуководитель": "БЕЗРАДНА СВІТЛАНА ВІКТОРІВНА",
"ТекущаяДолжностьРуководителя": "Директор",
"ТекущийГлавныйБухгалтер": "",
"ТекущийКассир": "",
"ТекущийПаспортист": "",
"ТипОрганизации": "ТОВ",
"УчетнаяЗаписьЭлектроннойПочты": "",
"НазваниеДляСвернутыхУслуг": "",
"ИнформацияПредупреждениеНовойКвитанции": ""
},
{
"Ссылка": "ОК \" ЖБК Морський 1\"",
"Код": "000000001",
"Наименование": "ОК \" ЖБК Морський 1\"",
"Префикс": "МК",
"ИНН": "",
"НомерСвидетельства": "",
"КодПоЕДРПОУ": "39789906",
"ФизическоеЛицо": "",
"НаименованиеПолное": "   Обслуговуючий  Кооператив   \" ЖБК Морський 1\"",
"СвидетельствоСерияНомер": "",
"СвидетельствоДатаВыдачи": "01.01.0001 0:00:00",
"БанковскийСчетПоУмолчанию": "UA583281680000000026003180694",
"ЮрФизЛицо": "Юр. лицо",
"ТекущийРуководитель": "Хапонен Валерий Сергеевич",
"ТекущаяДолжностьРуководителя": "",
"ТекущийГлавныйБухгалтер": "",
"ТекущийКассир": "",
"ТекущийПаспортист": "",
"ТипОрганизации": "Кооператив",
"УчетнаяЗаписьЭлектроннойПочты": "Морской",
"НазваниеДляСвернутыхУслуг": "",
"ИнформацияПредупреждениеНовойКвитанции": ""
},


запись делаю
  ЗаписатьJSON(ЗаписьJSON, Массив_записи);

где Массив_записи
Запрос = Новый Запрос;
    Запрос.Текст =
                "ВЫБРАТЬ *
                 |ИЗ
                | Справочник.Организации КАК Организации
                |";
          Выборка = Запрос.Выполнить().Выбрать();
         Массив_записи =Новый массив;
                                  
     Пока Выборка.Следующий() Цикл

        ОписаниеОбъекта = Новый Структура("Ссылка, Код, Наименование, Префикс,ИНН,НомерСвидетельства,КодПоЕДРПОУ,
ФизическоеЛицо,НаименованиеПолное,СвидетельствоСерияНомер,СвидетельствоДатаВыдачи,
БанковскийСчетПоУмолчанию,ЮрФизЛицо,ТекущийРуководитель,ТекущаяДолжностьРуководителя,
ТекущийГлавныйБухгалтер,ТекущийКассир,ТекущийПаспортист,ТипОрганизации,
УчетнаяЗаписьЭлектроннойПочты,НазваниеДляСвернутыхУслуг,ИнформацияПредупреждениеНовойКвитанции");
        ОписаниеОбъекта.Ссылка = Строка(Выборка.Ссылка);
        ОписаниеОбъекта.Код=Строка(Выборка.Код);
        ОписаниеОбъекта.Наименование=Строка(Выборка.Наименование);
        ОписаниеОбъекта.Префикс=Строка(Выборка.Префикс);
        ОписаниеОбъекта.ИНН=Строка(Выборка.ИНН);
        ОписаниеОбъекта.НомерСвидетельства=Строка(Выборка.НомерСвидетельства);
        ОписаниеОбъекта.КодПоЕДРПОУ=Строка(Выборка.КодПоЕДРПОУ);
        ОписаниеОбъекта.ФизическоеЛицо=Строка(Выборка.ФизическоеЛицо);
        ОписаниеОбъекта.НаименованиеПолное=Строка(Выборка.НаименованиеПолное);
        ОписаниеОбъекта.СвидетельствоСерияНомер=Строка(Выборка.СвидетельствоСерияНомер);
        ОписаниеОбъекта.СвидетельствоДатаВыдачи=Строка(Выборка.СвидетельствоДатаВыдачи);
        ОписаниеОбъекта.БанковскийСчетПоУмолчанию=Строка(Выборка.БанковскийСчетПоУмолчанию);
        ОписаниеОбъекта.ЮрФизЛицо=Строка(Выборка.ЮрФизЛицо);
        ОписаниеОбъекта.ТекущийРуководитель=Строка(Выборка.ТекущийРуководитель);
        ОписаниеОбъекта.ТекущаяДолжностьРуководителя=Строка(Выборка.ТекущаяДолжностьРуководителя);
        ОписаниеОбъекта.ТекущийГлавныйБухгалтер=Строка(Выборка.ТекущийГлавныйБухгалтер);
        ОписаниеОбъекта.ТекущийКассир=Строка(Выборка.ТекущийКассир);
        ОписаниеОбъекта.ТекущийПаспортист=Строка(Выборка.ТекущийПаспортист);
        ОписаниеОбъекта.ТипОрганизации=Строка(Выборка.ТипОрганизации);
        ОписаниеОбъекта.УчетнаяЗаписьЭлектроннойПочты=Строка(Выборка.УчетнаяЗаписьЭлектроннойПочты);
        ОписаниеОбъекта.НазваниеДляСвернутыхУслуг=Строка(Выборка.НазваниеДляСвернутыхУслуг);
        ОписаниеОбъекта.ИнформацияПредупреждениеНовойКвитанции=Строка(Выборка.ИнформацияПредупреждениеНовойКвитанции);
        Массив_записи.Добавить(ОписаниеОбъекта);
      
  КонецЦикла;
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #166540 · Ответов: 10 · Просмотров: 231
 

>  Запись элементов справочника без СериализаторXDTO в формат json под старую платформу 8.3.12
svetas_l
Отправлено: 18.09.20, 7:58


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 23.12.18
Пользователь №: 63555


kihor, спасибо
        ЗаписьJSON.ОткрытьФайл(Этаформа.ПутьЗаписи+имя_файла+".json");       // , , , ПараметрыJSON                        
    //ЗаписьJSON.УстановитьСтроку();  
        ЗаписатьJSON(ЗаписьJSON, Массив_записи);            
    ЗаписьJSON.Закрыть();

спасибо, без строки "УстановитьСтроку(); " вроде работает, а как прочитать этим способом строку, когда массив объектов?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #166539 · Ответов: 3 · Просмотров: 108
 

>  Запись элементов справочника без СериализаторXDTO в формат json под старую платформу 8.3.12
svetas_l
Отправлено: 17.09.20, 16:25


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 23.12.18
Пользователь №: 63555


есть код работает
но нужно его переделать под старую платформу 8.3.12 т.е. без "СериализаторXDTO."
помогите пожалуйста

Код
&НаСервере
Процедура Команда1НаСервере()
    Запрос = Новый Запрос;
    Запрос.Текст =
                "ВЫБРАТЬ *
                 |ИЗ
                | Справочник.Организации КАК Организации
                |";
          Выборка = Запрос.Выполнить().Выбрать();
         Массив_записи =Новый массив;
                                  
     Пока Выборка.Следующий() Цикл

        ОписаниеОбъекта = Новый Структура("Ссылка, Код, Наименование, Префикс,ИНН,НомерСвидетельства,КодПоЕДРПОУ,ФизическоеЛицо,НаименованиеПолное,СвидетельствоСерияНомер,СвидетельствоДатаВыдачи,БанковскийСчетПоУмолчанию,ЮрФизЛицо,ТекущийРуководитель,ТекущаяДолжностьРук
оводителя,ТекущийГлавныйБухгалтер,ТекущийКассир,ТекущийПаспортист,ТипОрганизации,УчетнаяЗаписьЭлектроннойПочты,НазваниеДляСвернутыхУслуг,ИнформацияПредупреждениеНовойКвитанции");
        ОписаниеОбъекта.Ссылка = Строка(Выборка.Ссылка);
        ОписаниеОбъекта.Код=Строка(Выборка.Код);
        ОписаниеОбъекта.Наименование=Строка(Выборка.Наименование);
        ОписаниеОбъекта.Префикс=Строка(Выборка.Префикс);
        ОписаниеОбъекта.ИНН=Строка(Выборка.ИНН);
        ОписаниеОбъекта.НомерСвидетельства=Строка(Выборка.НомерСвидетельства);
        ОписаниеОбъекта.КодПоЕДРПОУ=Строка(Выборка.КодПоЕДРПОУ);
        ОписаниеОбъекта.ФизическоеЛицо=Строка(Выборка.ФизическоеЛицо);
        ОписаниеОбъекта.НаименованиеПолное=Строка(Выборка.НаименованиеПолное);
        ОписаниеОбъекта.СвидетельствоСерияНомер=Строка(Выборка.СвидетельствоСерияНомер);
        ОписаниеОбъекта.СвидетельствоДатаВыдачи=Строка(Выборка.СвидетельствоДатаВыдачи);
        ОписаниеОбъекта.БанковскийСчетПоУмолчанию=Строка(Выборка.БанковскийСчетПоУмолчанию);
        ОписаниеОбъекта.ЮрФизЛицо=Строка(Выборка.ЮрФизЛицо);
        ОписаниеОбъекта.ТекущийРуководитель=Строка(Выборка.ТекущийРуководитель);
        ОписаниеОбъекта.ТекущаяДолжностьРуководителя=Строка(Выборка.ТекущаяДолжностьРуководителя);
        ОписаниеОбъекта.ТекущийГлавныйБухгалтер=Строка(Выборка.ТекущийГлавныйБухгалтер);
        ОписаниеОбъекта.ТекущийКассир=Строка(Выборка.ТекущийКассир);
        ОписаниеОбъекта.ТекущийПаспортист=Строка(Выборка.ТекущийПаспортист);
        ОписаниеОбъекта.ТипОрганизации=Строка(Выборка.ТипОрганизации);
        ОписаниеОбъекта.УчетнаяЗаписьЭлектроннойПочты=Строка(Выборка.УчетнаяЗаписьЭлектроннойПочты);
        ОписаниеОбъекта.НазваниеДляСвернутыхУслуг=Строка(Выборка.НазваниеДляСвернутыхУслуг);
        ОписаниеОбъекта.ИнформацияПредупреждениеНовойКвитанции=Строка(Выборка.ИнформацияПредупреждениеНовойКвитанции);
        Массив_записи.Добавить(ОписаниеОбъекта);
      
  КонецЦикла;
         Запись_в_JSON(Массив_записи,"test");
  КонецПроцедуры
  
процедура  Запись_в_JSON(Массив_записи,имя_файла)
      ЗаписьJSON= Новый ЗаписьJSON;
     ЗаписьJSON.ПроверятьСтруктуру = Истина;
     НастройкиСериализации = Новый НастройкиСериализацииJSON;
     ПараметрыJSON = Новый ПараметрыЗаписиJSON(ПереносСтрокJSON.Авто, " ", Истина);
     НастройкиСериализации.ВариантЗаписиДаты = ВариантЗаписиДатыJSON.УниверсальнаяДата;
     НастройкиСериализации.СериализовыватьМассивыКакОбъекты = Истина;    
     ЗаписьJSON.ОткрытьФайл(Этаформа.ПутьЗаписи+имя_файла+".json");       // , , , ПараметрыJSON                        
     ЗаписьJSON.ЗаписатьНачалоОбъекта();
     ЗаписьJSON.ЗаписатьИмяСвойства("Массив_записи");
      СериализаторXDTO.ЗаписатьJSON(ЗаписьJSON,Массив_записи,НазначениеТипаXML.Явное);     //НастройкиСериализации
     ЗаписьJSON.ЗаписатьКонецОбъекта();
     ЗаписьJSON.Закрыть();

   КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #166514 · Ответов: 3 · Просмотров: 108
 

>  Запись элементов справочника через СериализаторXDTO в формат json
svetas_l
Отправлено: 17.09.20, 10:55


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 23.12.18
Пользователь №: 63555


спасибо всем нашла ошибку
&НаСервере
Процедура Команда1НаСервере()
    Запрос = Новый Запрос;
    Запрос.Текст =
                "ВЫБРАТЬ *
                 |ИЗ
                | Справочник.Организации КАК Организации
                |";
          Выборка = Запрос.Выполнить().Выбрать();
         Массив_записи =Новый массив;
                                  
     Пока Выборка.Следующий() Цикл

        ОписаниеОбъекта = Новый Структура("Ссылка, Код, Наименование, Префикс,ИНН,НомерСвидетельства,КодПоЕДРПОУ,ФизическоеЛицо,НаименованиеПолное,СвидетельствоСерияНомер,СвидетельствоДатаВыдачи,БанковскийСчетПоУмолчанию,ЮрФизЛицо,ТекущийРуководитель,ТекущаяДолжностьРук
оводителя,ТекущийГлавныйБухгалтер,ТекущийКассир,ТекущийПаспортист,ТипОрганизации,УчетнаяЗаписьЭлектроннойПочты,НазваниеДляСвернутыхУслуг,ИнформацияПредупреждениеНовойКвитанции");
        ОписаниеОбъекта.Ссылка = Строка(Выборка.Ссылка);
        ОписаниеОбъекта.Код=Строка(Выборка.Код);
        ОписаниеОбъекта.Наименование=Строка(Выборка.Наименование);
        ОписаниеОбъекта.Префикс=Строка(Выборка.Префикс);
        ОписаниеОбъекта.ИНН=Строка(Выборка.ИНН);
        ОписаниеОбъекта.НомерСвидетельства=Строка(Выборка.НомерСвидетельства);
        ОписаниеОбъекта.КодПоЕДРПОУ=Строка(Выборка.КодПоЕДРПОУ);
        ОписаниеОбъекта.ФизическоеЛицо=Строка(Выборка.ФизическоеЛицо);
        ОписаниеОбъекта.НаименованиеПолное=Строка(Выборка.НаименованиеПолное);
        ОписаниеОбъекта.СвидетельствоСерияНомер=Строка(Выборка.СвидетельствоСерияНомер);
        ОписаниеОбъекта.СвидетельствоДатаВыдачи=Строка(Выборка.СвидетельствоДатаВыдачи);
        ОписаниеОбъекта.БанковскийСчетПоУмолчанию=Строка(Выборка.БанковскийСчетПоУмолчанию);
        ОписаниеОбъекта.ЮрФизЛицо=Строка(Выборка.ЮрФизЛицо);
        ОписаниеОбъекта.ТекущийРуководитель=Строка(Выборка.ТекущийРуководитель);
        ОписаниеОбъекта.ТекущаяДолжностьРуководителя=Строка(Выборка.ТекущаяДолжностьРуководителя);
        ОписаниеОбъекта.ТекущийГлавныйБухгалтер=Строка(Выборка.ТекущийГлавныйБухгалтер);
        ОписаниеОбъекта.ТекущийКассир=Строка(Выборка.ТекущийКассир);
        ОписаниеОбъекта.ТекущийПаспортист=Строка(Выборка.ТекущийПаспортист);
        ОписаниеОбъекта.ТипОрганизации=Строка(Выборка.ТипОрганизации);
        ОписаниеОбъекта.УчетнаяЗаписьЭлектроннойПочты=Строка(Выборка.УчетнаяЗаписьЭлектроннойПочты);
        ОписаниеОбъекта.НазваниеДляСвернутыхУслуг=Строка(Выборка.НазваниеДляСвернутыхУслуг);
        ОписаниеОбъекта.ИнформацияПредупреждениеНовойКвитанции=Строка(Выборка.ИнформацияПредупреждениеНовойКвитанции);
        Массив_записи.Добавить(ОписаниеОбъекта);
      
  КонецЦикла;
         Запись_в_JSON(Массив_записи,"test");
  КонецПроцедуры
  
процедура  Запись_в_JSON(Массив_записи,имя_файла)
     ЗаписьJSON= Новый ЗаписьJSON;
     ЗаписьJSON.ПроверятьСтруктуру = Истина;
     НастройкиСериализации = Новый НастройкиСериализацииJSON;
     ПараметрыJSON = Новый ПараметрыЗаписиJSON(ПереносСтрокJSON.Авто, " ", Истина);
     НастройкиСериализации.ВариантЗаписиДаты = ВариантЗаписиДатыJSON.УниверсальнаяДата;
     НастройкиСериализации.СериализовыватьМассивыКакОбъекты = Истина;    
     ЗаписьJSON.ОткрытьФайл(Этаформа.ПутьЗаписи+имя_файла+".json");       // , , , ПараметрыJSON                        
     ЗаписьJSON.ЗаписатьНачалоОбъекта();
     ЗаписьJSON.ЗаписатьИмяСвойства("Массив_записи");
     СериализаторXDTO.ЗаписатьJSON(ЗаписьJSON,Массив_записи,НазначениеТипаXML.Явное);     //НастройкиСериализации
     ЗаписьJSON.ЗаписатьКонецОбъекта();
     ЗаписьJSON.Закрыть();

   КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #166510 · Ответов: 2 · Просмотров: 152
 

>  чтение массива объектов используя СериализаторXDTO.ПрочитатьJSON
svetas_l
Отправлено: 17.09.20, 10:53


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 23.12.18
Пользователь №: 63555


добрый день!
нужно корректно прочитать файл
Цитата
{
"Массив_записи": {
"#type": "jv8:Array",
"#value": [
{
"#type": "jv8:Structure",
"#value": [
{
"name": {
"#type": "jxs:string",
"#value": "Ссылка"
},
"Value": {
"#type": "jxs:string",
"#value": "ТОВ \"ДИРЕКТОРІЯ ЗАТИШКУ\""
}
},
{
"name": {
"#type": "jxs:string",
"#value": "Код"
},
"Value": {
"#type": "jxs:string",
"#value": "000000006"
}
},
{
"name": {
"#type": "jxs:string",
"#value": "Наименование"
},
"Value": {
"#type": "jxs:string",
"#value": "ТОВ \"ДИРЕКТОРІЯ ЗАТИШКУ\""
}
},
{
"name": {
"#type": "jxs:string",
"#value": "Префикс"
},
"Value": {
"#type": "jxs:string",
"#value": "ДЗ"
}
},
{
"name": {
"#type": "jxs:string",
"#value": "ИНН"

который записывается кодом:
      ЗаписьJSON= Новый ЗаписьJSON;
     ЗаписьJSON.ПроверятьСтруктуру = Истина;
     НастройкиСериализации = Новый НастройкиСериализацииJSON;
     ПараметрыJSON = Новый ПараметрыЗаписиJSON(ПереносСтрокJSON.Авто, " ", Истина);
     НастройкиСериализации.ВариантЗаписиДаты = ВариантЗаписиДатыJSON.УниверсальнаяДата;
   // НастройкиСериализации.ФорматСериализацииДат = ФорматДатыJSON.ISO;
     НастройкиСериализации.СериализовыватьМассивыКакОбъекты = Истина;    
     ЗаписьJSON.ОткрытьФайл(Этаформа.ПутьЗаписи+имя_файла+".json");       // , , , ПараметрыJSON                        
     ЗаписьJSON.ЗаписатьНачалоОбъекта();
     // ЗаписьJSON.ЗаписатьИмяСвойства("ДатаФормирования");
     //ЗаписьJSON.ЗаписатьЗначение(ЗаписатьДатуJSON(ТекущаяДата(), ФорматДатыJSON.ISO, ВариантЗаписиДатыJSON.УниверсальнаяДата));
     ЗаписьJSON.ЗаписатьИмяСвойства("Массив_записи");
                 
     СериализаторXDTO.ЗаписатьJSON(ЗаписьJSON,Массив_записи,НазначениеТипаXML.Явное);     //НастройкиСериализации
     ЗаписьJSON.ЗаписатьКонецОбъекта();
     ЗаписьJSON.Закрыть();


нужно корректно прочитать массив элементов справочника или выборки запроса из элементов справочника

код
           Массив_записи =Новый массив;
  
      Чтение = Новый ЧтениеJSON;
          Чтение.ОткрытьФайл(Этаформа.ПутьЧтения+".json");
    
      Массив_записи= СериализаторXDTO.ПрочитатьJSON(Чтение, Тип("СправочникОбъект.Организации"));
                
      Чтение.Закрыть();


выдаёт ошибку параметров
- как правильно прочитать
Массив_записи= СериализаторXDTO.ПрочитатьJSON(Чтение, Тип("СправочникОбъект.Организации"))
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #166509 · Ответов: 0 · Просмотров: 130
 

>  Запись элементов справочника через СериализаторXDTO в формат json
svetas_l
Отправлено: 16.09.20, 12:00


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 23.12.18
Пользователь №: 63555


Добрый день!
помогите найти ошибку ругается несоответствие типов параметр 3 в строке
" СериализаторXDTO.ЗаписатьJSON(ЗаписьJSON,Массив_записи,НастройкиСериализации); "


Код
    Запрос = Новый Запрос;
    Запрос.Текст =
                "ВЫБРАТЬ *
                 |ИЗ
                | Справочник.Организации КАК Организации
                |";
           
    ЗаписьJSON= Новый ЗаписьJSON;
    ЗаписьJSON.ПроверятьСтруктуру = Истина;
    НастройкиСериализации = Новый НастройкиСериализацииJSON;
    ПараметрыJSON = Новый ПараметрыЗаписиJSON(ПереносСтрокJSON.Авто, " ", Истина);
    НастройкиСериализации.ВариантЗаписиДаты = ВариантЗаписиДатыJSON.УниверсальнаяДата;
    // НастройкиСериализации.ФорматСериализацииДат = ФорматДатыJSON.ISO;
    НастройкиСериализации.СериализовыватьМассивыКакОбъекты = Истина;    

    Выборка = Запрос.Выполнить().Выбрать();
    ЗаписьJSON.ОткрытьФайл("E:\Odecom\test.json, , , ПараметрыJSON");                                
    ЗаписьJSON.ЗаписатьНачалоОбъекта();
    
    // ЗаписьJSON.ЗаписатьИмяСвойства("ДатаФормирования");
    //ЗаписьJSON.ЗаписатьЗначение(ЗаписатьДатуJSON(ТекущаяДата(), ФорматДатыJSON.ISO, ВариантЗаписиДатыJSON.УниверсальнаяДата));
    
    ЗаписьJSON.ЗаписатьИмяСвойства("Массив_записи");
    Массив_записи =Новый массив;
                                  
    Пока Выборка.Следующий() Цикл
        
        
        ОписаниеОбъекта = Новый Структура("Ссылка, Код, Наименование, Префикс,ИНН,НомерСвидетельства,КодПоЕДРПОУ,ФизическоеЛицо,НаименованиеПолное,СвидетельствоСерияНомер,СвидетельствоДатаВыдачи,БанковскийСчетПоУмолчанию,ЮрФизЛицо,ТекущийРуководитель,ТекущаяДолжностьРук
оводителя,ТекущийГлавныйБухгалтер,ТекущийКассир,ТекущийПаспортист,ТипОрганизации,УчетнаяЗаписьЭлектроннойПочты,НазваниеДляСвернутыхУслуг,ИнформацияПредупреждениеНовойКвитанции");
        ОписаниеОбъекта.Ссылка = Строка(Выборка.Ссылка);
        ОписаниеОбъекта.Код=Строка(Выборка.Код);
        ОписаниеОбъекта.Наименование=Строка(Выборка.Наименование);
        ОписаниеОбъекта.Префикс=Строка(Выборка.Префикс);
        ОписаниеОбъекта.ИНН=Строка(Выборка.ИНН);
        ОписаниеОбъекта.НомерСвидетельства=Строка(Выборка.НомерСвидетельства);
        ОписаниеОбъекта.КодПоЕДРПОУ=Строка(Выборка.КодПоЕДРПОУ);
        ОписаниеОбъекта.ФизическоеЛицо=Строка(Выборка.ФизическоеЛицо);
        ОписаниеОбъекта.НаименованиеПолное=Строка(Выборка.НаименованиеПолное);
        ОписаниеОбъекта.СвидетельствоСерияНомер=Строка(Выборка.СвидетельствоСерияНомер);
        ОписаниеОбъекта.СвидетельствоДатаВыдачи=Строка(Выборка.СвидетельствоДатаВыдачи);
        ОписаниеОбъекта.БанковскийСчетПоУмолчанию=Строка(Выборка.БанковскийСчетПоУмолчанию);
        ОписаниеОбъекта.ЮрФизЛицо=Строка(Выборка.ЮрФизЛицо);
        ОписаниеОбъекта.ТекущийРуководитель=Строка(Выборка.ТекущийРуководитель);
        ОписаниеОбъекта.ТекущаяДолжностьРуководителя=Строка(Выборка.ТекущаяДолжностьРуководителя);
        ОписаниеОбъекта.ТекущийГлавныйБухгалтер=Строка(Выборка.ТекущийГлавныйБухгалтер);
        ОписаниеОбъекта.ТекущийКассир=Строка(Выборка.ТекущийКассир);
        ОписаниеОбъекта.ТекущийПаспортист=Строка(Выборка.ТекущийПаспортист);
        ОписаниеОбъекта.ТипОрганизации=Строка(Выборка.ТипОрганизации);
        ОписаниеОбъекта.УчетнаяЗаписьЭлектроннойПочты=Строка(Выборка.УчетнаяЗаписьЭлектроннойПочты);
        ОписаниеОбъекта.НазваниеДляСвернутыхУслуг=Строка(Выборка.НазваниеДляСвернутыхУслуг);
        ОписаниеОбъекта.ИнформацияПредупреждениеНовойКвитанции=Строка(Выборка.ИнформацияПредупреждениеНовойКвитанции);
             // ОписаниеОбъекта.Контрагент = Строка(Заказ.Контрагент);
        Массив_записи.Добавить(ОписаниеОбъекта);
    КонецЦикла;
      
      
       СериализаторXDTO.ЗаписатьJSON(ЗаписьJSON,Массив_записи,НастройкиСериализации);     //НастройкиСериализации
       ЗаписьJSON.ЗаписатьКонецОбъекта();
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #166479 · Ответов: 2 · Просмотров: 152
 

>  не выгружается количество табличной части документа в ПКС
svetas_l
Отправлено: 08.08.20, 22:34


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 23.12.18
Пользователь №: 63555


не выгружается количество ПКС из табличной части Товары ПоступлениеТоваровУслуг из Бухгалтерия для Украины, редакция 1.2. в ERP
выгружаю 3 табличные части в одну (Товары, Услуги, оборудование). Цена, сумма переносятся , а количество нет.
но при этом в коде "перед обработкой" сообщение отрабатывает - количество выдаёт.
Т.е. количество из базы попадает, но количество в другую базу не переносится.
Прошу помощи


 ! 

Правила: 8
 
  Форум: Конфигурация "1С:Конвертация данных" · Просмотр сообщения: #165431 · Ответов: 1 · Просмотров: 177
 

>  Ошибка при вызове конструктора COMОбъект
svetas_l
Отправлено: 27.07.20, 16:24


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 23.12.18
Пользователь №: 63555


все сделали.
теперь ошибка ниже при открытии самого файла



теперь не открывает сам файл - ругается
исключитешльная ситуация 0*80004005 -
Произошла исключительная ситуация Microsoft Excel Программный доступ к M Visual Basic -не является доверенным
Excel 16, 64 Сервер
ПОМОГИТЕ, ПОЖАЛУЙСТА
В ИНТЕРФЕЙСЕ ПОЛЬЗОВАТЕЛЯ - пишет не удалось обнаружить файл, хотя его открівала через диалог пользователя выбора файла и на другой -на локальной машине все работает
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #165068 · Ответов: 3 · Просмотров: 376
 

>  Ошибка при вызове конструктора COMОбъект
svetas_l
Отправлено: 27.07.20, 13:20


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 23.12.18
Пользователь №: 63555



НЕ ЗАПУСКАЕТСЯ НА СЕРВЕРЕ
 = Новый COMОбъект("Excel.Application");

НЕ ВИДИТ
ПРАВ НА ЗАПУСК EXcel добавили
EXcel 2016
библиотеку админ сказал что зарегистрировал
сразу выпадает в исключение
Ошибка при вызове конструктора COMОбъект
 = Новый COMОбъект("Excel.Application");

-2147467262(0*80004002):интерфейс не поддерживается
что может быть?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #165059 · Ответов: 3 · Просмотров: 376
 

>  не отображается партнер, контрагент в справочнике
svetas_l
Отправлено: 15.07.20, 10:39


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 23.12.18
Пользователь №: 63555


Vofka @ Сегодня, 11:28 * ,
МОЖЕТ поможете?
  Форум: BAS Комплексное управление предприятием · Просмотр сообщения: #164767 · Ответов: 3 · Просмотров: 167
 

>  не отображается партнер, контрагент в справочнике
svetas_l
Отправлено: 15.07.20, 10:19


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 23.12.18
Пользователь №: 63555


При программном создании или импорте из БУХ для Украина в консоли запросов видны элементы, а в справочниках не отображаются. Вроде все поля заполнены ПОМОГИТЕ,пожалуйста.
Vofka помоги, пожалуйста
  Форум: BAS Комплексное управление предприятием · Просмотр сообщения: #164763 · Ответов: 3 · Просмотров: 167
 

>  Не срабатывает подсчет количества в запросе
svetas_l
Отправлено: 22.03.20, 11:45


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 23.12.18
Пользователь №: 63555


svetas_l @ Вчера, 21:12 * ,
все всем спасибо... дело было в типе значения характеристики icon_beer17.gif
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #161531 · Ответов: 7 · Просмотров: 405
 

>  Не срабатывает подсчет количества в запросе
svetas_l
Отправлено: 21.03.20, 21:12


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 23.12.18
Пользователь №: 63555


alex1c @ Вчера, 19:44 * ,
так же- без изменений...помогите,кто-нибудь...пожалуйста
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #161519 · Ответов: 7 · Просмотров: 405
 

>  Не срабатывает подсчет количества в запросе
svetas_l
Отправлено: 19.03.20, 23:05


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 23.12.18
Пользователь №: 63555




svetas_l @ Сегодня, 23:01 * ,
помогите, пожалуйста...

svetas_l @ Сегодня, 23:03 * ,
Vofka а ещё раз помочь можете, пожалуйста.....
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #161468 · Ответов: 7 · Просмотров: 405
 

>  Не срабатывает подсчет количества в запросе
svetas_l
Отправлено: 16.03.20, 11:09


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 23.12.18
Пользователь №: 63555


svetas_l @ Вчера, 20:13 * ,
Vofka а ещё раз помочь можете, пожалуйста.....
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #161365 · Ответов: 7 · Просмотров: 405
 

>  Не срабатывает подсчет количества в запросе
svetas_l
Отправлено: 15.03.20, 20:13


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 23.12.18
Пользователь №: 63555


ЕСТЬ ФУНКЦИЯ -которая должна возвращать существующую характеристику или создавать новую, если текущая не найдена,
причем сам запрос в консоли запросов отрабатывает, но в функции не хочет. В результате функция создаёт к одной номенклатуре 16 характеристик одинаковых, а должна только одну.
В чем ошибка?

Код
  
Функция СоздатьХарактеристику(Номенклатура,Цвет)
// ХарактеристикиНоменклатуры
перем  kol;
kol=0;
    Запрос = Новый Запрос;
    Запрос.Текст = "
    |ВЫБРАТЬ
    |    количество(ХарактеристикиНоменклатуры.Ссылка) КАК Количество_Характеристик
    |ИЗ
    |    Справочник.ХарактеристикиНоменклатуры.ДополнительныеРеквизиты КАК ХарактеристикиНоменклатуры
    |ЛЕВОЕ СОЕДИНЕНИЕ Справочник.Номенклатура КАК Номенклатура
    |    ПО ХарактеристикиНоменклатуры.Ссылка.Владелец = Номенклатура.Ссылка
    |ЛЕВОЕ СОЕДИНЕНИЕ ПланВидовХарактеристик.ДополнительныеРеквизитыИСведения КАК ДополнительныеРеквизитыИСведения
    |    ПО ХарактеристикиНоменклатуры.Свойство = ДополнительныеРеквизитыИСведения.Ссылка
    |ГДЕ
    |    Номенклатура.Наименование = &Номенклатура_    
    |    И ДополнительныеРеквизитыИСведения.Наименование = ""Цвет (Мотоциклы (Для характеристик))""
    |    И ХарактеристикиНоменклатуры.Значение = &Цвет_
    |";

Запрос.УстановитьПараметр("Номенклатура_", СокрЛП(Строка(Номенклатура)));
Запрос.УстановитьПараметр("Цвет_", СокрЛП(Строка(Цвет)));

    РезультатЗапроса = Запрос.Выполнить();

    ВыборкаДокументов = РезультатЗапроса.Выбрать();

    Пока ВыборкаДокументов.Следующий() Цикл
       kol=kol+ (ВыборкаДокументов.Количество_Характеристик);
    КонецЦикла;




Если kol=0 Тогда
     Цвет = Справочники.ЗначенияСвойствОбъектов.НайтиПоНаименованию(СокрЛП(Строка(Цвет)));
    СоздадимХарактеристику = Справочники.ХарактеристикиНоменклатуры.СоздатьЭлемент();
СоздадимХарактеристику.УстановитьНовыйКод();
СоздадимХарактеристику.Владелец =Справочники.Номенклатура.НайтиПоНаименованию(СокрЛП(Строка(Номенклатура)));
СоздадимХарактеристику.УстановитьСсылкуНового(Справочники.ХарактеристикиНоменклатуры.ПолучитьСсылку(Новый УникальныйИдентификатор));
  СоздадимХарактеристику.Наименование =  Цвет;
СоздадимХарактеристику.НаименованиеПолное=  Цвет;

    НовоеСвойство3=СоздадимХарактеристику.ДополнительныеРеквизиты.Добавить();
    НовоеСвойство3.Свойство=ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию(Строка("Цвет (Мотоциклы (Для характеристик))"));
    НовоеСвойство3.Значение= СокрЛП(Строка(Цвет));
НовоеСвойство3.ТекстоваяСтрока= СокрЛП(Строка(Цвет));

Попытка
      СоздадимХарактеристику.Записать();
Возврат СоздадимХарактеристику.Ссылка;
Исключение
      Сообщить("Не удалось записать элемент справочника. " + ОписаниеОшибки());
  Возврат неопределено;
    КонецПопытки;  

    
ИначеЕсли kol>0 тогда
Запрос.УстановитьПараметр("Номенклатура_", СокрЛП(Строка(Номенклатура)));
Запрос.УстановитьПараметр("Цвет_", СокрЛП(Строка(Цвет)));


    РезультатЗапроса = Запрос.Выполнить();

    ВыборкаДокументов = РезультатЗапроса.Выбрать();

    Пока ВыборкаДокументов.Следующий() Цикл
       Характеристика = ВыборкаДокументов.Характеристика;
    КонецЦикла;


kol=0;
Возврат  Характеристика;

КонецЕсли;

КонецФункции
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #161335 · Ответов: 7 · Просмотров: 405
 

>  программное заполнение ссылки на вновь созданную характеристику номенклатуры ERP управляемые формы 8.3
svetas_l
Отправлено: 12.03.20, 20:27


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 23.12.18
Пользователь №: 63555


Vofka @ Сегодня, 17:16 * ,
нашла запись ошибки уже.. просто в стандартных настройках блокируется добавление характеристик с одинаковыми названиями даже подчинённый разным единицам номенклатуры. вот и тихо съезжало с создания элемента, блин без вашего совета снять обработку исключения, я ковырялась уже неделю....спасибо.....сейчас еще отлаживаю...может ещё что-то цепляет....Спасибо....


svetas_l @ Сегодня, 20:24 * ,
картинка человека с бокалом очень красивая - её прям поцеловать хочется.....
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #161263 · Ответов: 40 · Просмотров: 1610
 

>  программное заполнение ссылки на вновь созданную характеристику номенклатуры ERP управляемые формы 8.3
svetas_l
Отправлено: 12.03.20, 15:21


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 23.12.18
Пользователь №: 63555


andr_andrey @ Сегодня, 14:56 * ,
да
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #161256 · Ответов: 40 · Просмотров: 1610
 

>  программное заполнение ссылки на вновь созданную характеристику номенклатуры ERP управляемые формы 8.3
svetas_l
Отправлено: 12.03.20, 8:56


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 23.12.18
Пользователь №: 63555


sava1 @ Сегодня, 8:16 * ,
да только эти строки мы уже вставляли- в одном из вариантов кода

svetas_l @ Сегодня, 8:50 * ,
 
Цвет = Справочники.ЗначенияСвойствОбъектов.НайтиПоНаименованию(Цвет);
    
    Характеристика = Справочники.ХарактеристикиНоменклатуры.СоздатьЭлемент();
    Характеристика.Владелец = СсылкаНаОбъект;
    Характеристика.Наименование = Размер + ", " + Рост + ", " + Цвет;
    Характеристика.Записать();

этот код из https://pro1c.org.ua/redirect.php?https://f...c.php?id=280257
у меня уже был
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #161243 · Ответов: 40 · Просмотров: 1610
 

>  программное заполнение ссылки на вновь созданную характеристику номенклатуры ERP управляемые формы 8.3
svetas_l
Отправлено: 12.03.20, 0:54


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 23.12.18
Пользователь №: 63555


svetas_l @ Вчера, 23:49 * ,
Запрос.УстановитьПараметр("Номенклатура_",    СокрЛП(Строка(Номенклатура)));
Запрос.УстановитьПараметр("Цвет_",    СокрЛП(Строка(Цвет)));
РезультатЗапроса = Запрос.Выполнить().Выбрать();

Если РезультатЗапроса.Количество()=0   Тогда
     Цвет = Справочники.ЗначенияСвойствОбъектов.НайтиПоНаименованию(СокрЛП(Строка(Цвет)));
        СоздадимХарактеристику = Справочники.ХарактеристикиНоменклатуры.СоздатьЭлемент();
     СоздадимХарактеристику.УстановитьНовыйКод();
     СоздадимХарактеристику.Владелец =Справочники.Номенклатура.НайтиПоНаименованию(СокрЛП(Строка(Номенклатура))).Ссылка;
    
     СоздадимХарактеристику.УстановитьСсылкуНового(Справочники.ХарактеристикиНоменклатуры.ПолучитьСсылку(Новый УникальныйИдентификатор));
     СоздадимХарактеристику.Наименование =  Цвет;
    
     НовоеСвойство3=СоздадимХарактеристику.ДополнительныеРеквизиты.Добавить();
     НовоеСвойство3.Свойство=ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоРеквизиту(Строка("Цвет (Мотоциклы (Для характеристик))"));
     НовоеСвойство3.Значение= СокрЛП(Строка(Цвет));
    
         
    Попытка
      СоздадимХарактеристику.Записать();
      Возврат СоздадимХарактеристику.Ссылка;
     Исключение
       Сообщить("Не удалось записать элемент справочника. " + ОписаниеОшибки());
       Возврат неопределено;
    КонецПопытки;  
    
    
Иначе
    
    Пока РезультатЗапроса.Следующий() Цикл
      Характеристика = РезультатЗапроса.Характеристика;
    КонецЦикла;
  Возврат  Характеристика;
КонецЕсли;

КонецФункции
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #161240 · Ответов: 40 · Просмотров: 1610
 

>  программное заполнение ссылки на вновь созданную характеристику номенклатуры ERP управляемые формы 8.3
svetas_l
Отправлено: 11.03.20, 23:49


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 23.12.18
Пользователь №: 63555


Vofka @ Сегодня, 23:44 * ,
нет описания ошибки

svetas_l @ Сегодня, 23:46 * ,
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #161219 · Ответов: 40 · Просмотров: 1610
 

>  программное заполнение ссылки на вновь созданную характеристику номенклатуры ERP управляемые формы 8.3
svetas_l
Отправлено: 11.03.20, 23:36


Говорящий
***

Группа: Пользователи
Сообщений: 68
Регистрация: 23.12.18
Пользователь №: 63555


Vofka @ Сегодня, 23:35 * ,
да при записи, как оказалось попадаю в исключение

svetas_l @ Сегодня, 23:35 * ,
наверное отсюда и пустая ссылка после записи
я думаю -где-то параметры не правильно заполнены...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #161217 · Ответов: 40 · Просмотров: 1610
 

3 страниц V   1 2 3 >

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 24.11.20, 0:01
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!