Версия для печати темы (https://pro1c.org.ua/index.php?s=4e96c6589aba92521ef58816227727f1&showtopic=15696)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Утилиты, программки, общее для 1С 7 и 8 _ Драйвер + обработка обслуживания для 1С 8 для кассового аппарата Мария М-304Т

Автор: Vofka 27.11.13, 11:03

Так же обработка обслуживания должна подойти и для стандартного драйвера для аппарата Мария-301 МТМ. Должна, но я не проверял. Обработка обслуживания появится после установки в папке samples, куда установился драйвер.

Скачать:  olemanager2013_setup.zip ( 1.65 мегабайт ) : 516

Автор: master-73 04.12.13, 11:04

Проверил этот OLE Server, регистрационные номера выданные "Резонансом" не прокатывают под этим драйвером

Автор: Vofka 04.12.13, 11:09

У меня прокатывало. Может быть этот OLE Server жестко прошит под какие-то серийники, но я насчет этого не в курсе, честно говоря.

Автор: master-73 04.12.13, 11:27

Цитата(Vofka @ 04.12.13, 11:09) *
У меня прокатывало. Может быть этот OLE Server жестко прошит под какие-то серийники, но я насчет этого не в курсе, честно говоря.


У драйвера же есть окно ввода рег.кода.
Может для Maрia 304T прокатило а вот под Maрia 301MTM нет. пришлось вернутся на старый который глючит временами.

P.S. Чтобы я еще раз связался с этими фискальниками 47046430.gif

Автор: Vofka 04.12.13, 11:39

То, что оно работает с 301-МТМ это мне представитель нашего СЦ говорил, но я не проверял. bk.gif

Автор: master-73 04.12.13, 11:40

Значит у этого драйвера другая структура рег.номеров.

Автор: FlashON 05.02.14, 13:52

С Марией 304 работает. Без регистрации позволяет проводить чеки до 1 грн. В обработке ТО желательно исправлять сравнение времени.

Автор: sands 13.04.14, 22:32


 ! 

Правила, п.13
 

а какой пароль на менеджера?

Автор: logist 13.04.14, 23:08

Цитата(sands @ 13.04.14, 22:32) *
а какой пароль на менеджера?

Потрать пару минут для чтения правил совсем никак, лучше сидеть и ждать ответа?

Автор: dimon77888 26.05.15, 12:00

какой пароль

Автор: Булька 15.06.15, 11:07

Доброго дня, підкажіть будь ласка, при виклику функції Объект.Драйвер.InitEx затримка 5 сек., чи можна якось її обійти? чи у всіх так?

Автор: Santino 24.05.17, 14:38

Может, кому еще понадобится...
Фирма "Резонанс" выложила официально безплатный драйвер + обработку для 1С обычные формы.
Документацию можно взять тут: http://pro1c.org.ua/redirect.php?http://www.ekka.com.ua/tehpodderzhka-kassovyiy-apparat-mariya/
Сам архив:  M301ManagerPlusSetupR.rar ( 1.84 мегабайт ) : 266


Автор: Pashaboston 16.07.18, 20:24

Как подключить Марию 304 через Ehternet, побую вот так

Процедура ОткрытьПорт()
    
    Попытка
        Драйвер = CreateObject("M301Manager.Application");
        
        Если ПустоеЗначение(Драйвер)=1 Тогда
            Сообщить("Не найден драйвер ЭККА");
            Возврат;
        КонецЕсли;
        
        Порт = "192.168.1.220";//"COM"+СокрЛП(Константа.ПортЭККА);
        Скорость = 115200;
    Исключение
        Сообщить("Ошибка ЭККА :"+ОписаниеОшибки());
    КонецПопытки;
    ПортОткрыт = 1;
    ПризнакОшибка(Драйвер.Init(Порт,"Касир","1111111111"));
    Если Ошибка = 1 Тогда
        ЗакрытьПорт();
        Возврат;
    КонецЕсли;

КонецПроцедуры

Но первый параметр функции Init должен быть число.
Как решить хз может другой драйвер?

Автор: Vofka 17.07.18, 8:16

Цитата(Pashaboston @ 16.07.18, 21:24) *
Как решить хз может другой драйвер?

А может таки передавать число, а не IP адрес?

Автор: ildarian 12.09.18, 11:38

Pashaboston @ 16.07.18, 20:24 * ,
Какой пароль на архив ?

Автор: Bernet 12.09.18, 11:54

ildarian @ Сегодня, 12:38 * ,
читайте правила

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua