Версия для печати темы (https://pro1c.org.ua/index.php?s=e1f585a3fc1ade4dc0ba47a94f2c3e24&showtopic=62119)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Программирование в 1С Предприятие 8.3 _ Выделение в форме строк цветом

Автор: odzolalvl 09.10.20, 11:10

Добрый день. подскажите.

Процедура ТоварыПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    
    Если ЗначениеЗаполнено(ДанныеСтроки.Номенклатура) Тогда
        ОформлениеСтроки.Ячейки.Номенклатура.ЦветФона = Новый Цвет(217, 234, 211);
    КонецЕсли;
КонецПроцедуры

У номенклатуры есть свои реквизиты, мне надо что-то вроде

Если Номенклатура.Реквизит ("лалала") Тогда
ОформлениеСтроки.Ячейки.Номенклатура.ЦветФона = Новый Цвет(1, 1, 1);

вопрос как правильно обратиться к реквизиту номенклатуры в текущей строке

Автор: sava1 09.10.20, 11:27

Если ДанныеСтроки.Номенклатура.лалала Тогда ....

Автор: odzolalvl 09.10.20, 11:37

sava1 @ Сегодня, 12:27 * ,
Я так понимаю ДанныеСтроки - то что там прописано
у меня есть форма в которой два столбика номер и номенклатура
мне надо что если у номенклатуры реквизит НоменклатурнаяГруппа имет значение НоменклатурнаяГруппа1
тогда в моей табличке ,где номер и номенклатура, закрасило номенклатуру,если не имеет ничего или другой тогда ничего не окрашивало

Автор: sava1 09.10.20, 11:50

Процедура ТоварыПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)

    НомГруппа = /Нужная ном. группа/
    
    Если ДанныеСтроки.Номенклатура.НоменклатурнаяГруппа = НомГруппа Тогда
        ОформлениеСтроки.ЦветФона = Новый Цвет(217, 234, 211);
    КонецЕсли;
КонецПроцедуры

Автор: odzolalvl 09.10.20, 12:12

sava1 @ Сегодня, 12:50 * ,

Если ЗначениеЗаполнено(ДанныеСтроки.Номенклатура) Тогда
        ЦенГруп = Справочники.Номенклатура.ЦеноваяГруппа("Скидки");
        Если ДанныеСтроки.Номенклатура.ЦеноваяГруппа = ЦенГруп Тогда
        ОформлениеСтроки.Ячейки.Номенклатура.ЦветФона = Новый Цвет(217, 234, 211);
        КонецЕсли;
    КонецЕсли;

Ошибка
{Документ.ЗаказПокупателя.Форма.ФормаДокумента.Форма(2101)}: Метод объекта не обнаружен (ЦеноваяГруппа)
        ЦенГруп = Справочники.Номенклатура.ЦеноваяГруппа("Скидки");

можете объяснить в чем проблема

Автор: sava1 09.10.20, 12:16

у справочника Номенклатура нет реквизита ЦеноваяГруппа

конфигурация какая ?

Автор: odzolalvl 09.10.20, 12:18

sava1 @ Сегодня, 13:16 * ,
"Управление торговлей для Украины", редакция 2.3.


 ! 

https://pro1c.org.ua/index.php?act=announce&id=2: 8
 

Автор: sava1 09.10.20, 12:19

ЦенГруп = Справочники.Номенклатура.ЦеноваяГруппа("Скидки");


ЦенГруп = Справочники.ЦеновыеГруппы.НайтиПоНаименованию("Скидки");

Автор: odzolalvl 09.10.20, 12:24

sava1 @ Сегодня, 13:19 * ,
Огромное спасибо.
И вопрос почему 1 способ не работает,я же так понимаю я передаю занчение реквизита тут("")

Автор: sava1 09.10.20, 12:28

Потому, что 1С не знает, что Вы решили так передать реквизит

Автор: Vofka 09.10.20, 12:29

Цитата(odzolalvl @ 09.10.20, 13:24) *
Огромное спасибо.

У нас ещё и специальная кнопка (в виде пальца вверх) есть для этого

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua