Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Как можно запретить отмену проведения докумена, если документ сделал проводку на 281 счет?          
kostya77 Подменю пользователя
сообщение 26.07.22, 7:43
Сообщение #1

Общительный
**
Группа: Пользователи
Сообщений: 17
Спасибо сказали: 1 раз
Рейтинг: 0

Добрый день. Как можно запретить отмену проведения докумена, если документ сделал проводку на 281 счет?

Сообщение отредактировал Vofka - 26.07.22, 8:46

sava1 Подменю пользователя
сообщение 26.07.22, 8:05
Сообщение #2

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2581
Из: Проскуров
Спасибо сказали: 637 раз
Рейтинг: 616.2

типа так

// глобальный модуль

Процедура ПриОтменеПроведенияДокумента(Док)

    Если Док.СуществуетОперация()=1 Тогда

        Опер = Док.Операция;
        Опер.ВыбратьПроводки();  // тут можно проверить наличие проводок
        Пока Опер.ПолучитьПроводку()=1 Цикл

                        Если Опер.СчетДт = !нужныйСчет!  Тогда
                               СтатусВозврата(0);
                               Предупреждение("Низзя распроводить документ");
                               Возврат;
                        КонецЕсли;  
    
        КонецЦикла;
    КонецЕсли;


КонецПроцедуры

kostya77 Подменю пользователя
сообщение 26.07.22, 8:09
Сообщение #3

Общительный
**
Группа: Пользователи
Сообщений: 17
Спасибо сказали: 1 раз
Рейтинг: 0

спасибо.

andreydv87 Подменю пользователя
сообщение 27.07.22, 11:49
Сообщение #4

Говорящий
***
Группа: Пользователи
Сообщений: 67
Спасибо сказали: 13 раз
Рейтинг: 11.3

kostya77 @ Вчера, 8:43 * ,
Можно в глобальном модуле подправить, как написал SAVA1, а можно попробовать через подписку на событие, если надо для конкретных документов.

sava1 Подменю пользователя
сообщение 27.07.22, 14:05
Сообщение #5

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2581
Из: Проскуров
Спасибо сказали: 637 раз
Рейтинг: 616.2

andreydv87 @ Сегодня, 12:49 * ,

это 77 - какая подписка?

andreydv87 Подменю пользователя
сообщение 28.07.22, 10:28
Сообщение #6

Говорящий
***
Группа: Пользователи
Сообщений: 67
Спасибо сказали: 13 раз
Рейтинг: 11.3

sava1 @ Вчера, 15:05 * ,
Раздел не увидел, а в теме не указано...

Тогда глобальный модуль.

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 27.09.22, 0:25
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!