Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 3, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )




>  Передача данных клиент/сервер
demon14
Отправлено: 29.11.19, 15:36


Общительный
**

Группа: Пользователи
Сообщений: 10
Регистрация: 24.02.14
Из: Київ
Пользователь №: 33819


Макс1С @ Сегодня, 14:57 * ,
Так тоже думал, но нет. Обратно можно и то только результат.

Разные сеансы.

"Примечание:
Временное хранилище, сформированное в одном сеансе, недоступно из другого сеанса.
Исключением является возможность передачи данных из фонового задания в сеанс, инициировавший фоновое задание, с помощью временного хранилища... "
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #158088 · Ответов: 7 · Просмотров: 543
 

>  Передача данных клиент/сервер
demon14
Отправлено: 29.11.19, 11:45


Общительный
**

Группа: Пользователи
Сообщений: 10
Регистрация: 24.02.14
Из: Київ
Пользователь №: 33819


Кручусь вокруг "ВыполнитьВФоне" и никак не пойму как это сделать(

Сейчас примерно так:

&НаКлиенте
Процедура ЗагрузкаМассиваФайлов()
....

Для Каждого Файл Из МассивФайлов Цикл
МассивДанных.Добавить(ПоместитьВоВременноеХранилище(Новый ДвоичныеДанные(Файл),УникальныйИдентификатор));
КонецЦикла;

ДлительнаяОперация     = НачатьВыполнениеНаСервере(МассивДанных);
ПараметрыОжидания     = ДлительныеОперацииКлиент.ПараметрыОжидания(ЭтотОбъект);
...

КонецПроцедуры

&НаСервере
Функция НачатьВыполнениеНаСервере(МассивДанных)
    
    Для Каждого Данные Из МассивДанных Цикл
        МассивВФЗ.Добавить(ПолучитьИзВременногоХранилища(Данные.АдресДанных));    
    КонецЦикла;
    
    ПараметрыПроцедуры = Новый Структура;
    ПараметрыПроцедуры.Вставить("МассивВФЗ",МассивВФЗ);
    
    ПараметрыВыполнения = ДлительныеОперации.ПараметрыВыполненияВФоне(УникальныйИдентификатор);
    
    Возврат ДлительныеОперации.ВыполнитьВФоне("Документы.МойДок.ПроцедураВФон",
     ПараметрыПроцедуры, ПараметрыВыполнения);
КонецФункции


Если я МассивДанных отправляю в ПараметрыПроцедуры, хранилища с данными там уже нет (перечитал СП и гугл, все так).

Как быть?

Может запуск ВыполнитьВФоне сделать асинхронно? взлетит?

А если взлетит, то можно тогда и к массивам вернутся.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #158083 · Ответов: 7 · Просмотров: 543
 

>  Передача данных клиент/сервер
demon14
Отправлено: 29.11.19, 9:59


Общительный
**

Группа: Пользователи
Сообщений: 10
Регистрация: 24.02.14
Из: Київ
Пользователь №: 33819


Цитата(pablo @ 29.11.19, 9:37) *
2. Число во внутреннем представлении занимает меньше байт, чем строка.

Про числа не подумал.
Цитата(pablo @ 29.11.19, 9:37) *
1. Какую длину имеют строки в Вашем массиве?

колонка символьная с самыми длинными строками 50-100
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #158082 · Ответов: 7 · Просмотров: 543
 

>  Передача данных клиент/сервер
demon14
Отправлено: 29.11.19, 9:24


Общительный
**

Группа: Пользователи
Сообщений: 10
Регистрация: 24.02.14
Из: Київ
Пользователь №: 33819


pablo @ Сегодня, 8:59 * ,

Изначально так и проектировал, отказался большей частью из-за рекомендаций переносить чтение на клиент.

Цитата(pablo @ 29.11.19, 9:16) *
За счет типизированности данных может уменьшится объем пересылаемых данных.

Строковый тип не самый легкий?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #158079 · Ответов: 7 · Просмотров: 543
 

>  Передача данных клиент/сервер
demon14
Отправлено: 29.11.19, 8:50


Общительный
**

Группа: Пользователи
Сообщений: 10
Регистрация: 24.02.14
Из: Київ
Пользователь №: 33819


Загрузка из эксель, (Бухгалтерия 2.1.3.1, 8.3.13.1690)

1) читаю в массив ( Sheet.UsedRange.Value.Выгрузить() ) несколько файлов (на тесте 10 файлов, ~10 000 строк в каждом * 30 колонок).
2) прочитанные данные каждого файла добавляю в общий массив.
3) общий массив отправляю на сервер, там все разбираю - создаю/обновляю объекты.

Все выполняется не быстро (минуты), переписал через ДлительныеОперации.ВыполнитьВФоне, но запуск выполняется дольше чем серверные процедуры.

По итогу замера производительности, передача данных с клиента на сервер больше 50% времени (и это один комп, между разными или веб еще ж хуже будет...).

Вопрос, как правильно в таком случае поступить? Как быстрее всего будет передать данные на сервер, уже прочитанные, по каждому файлу отдельно или все сразу как у меня?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #158077 · Ответов: 7 · Просмотров: 543
 

>  загрузка из excel ( управляемые формы)
demon14
Отправлено: 28.11.19, 17:48


Общительный
**

Группа: Пользователи
Сообщений: 10
Регистрация: 24.02.14
Из: Київ
Пользователь №: 33819


В контексте этой темы есть вопрос, дабы не плодить темы спрошу тут.

Загрузка из эксель,

1) читаю в массив ( Sheet.UsedRange.Value.Выгрузить() ) несколько файлов (на тесте 10 файлов, ~10 000 строк в каждом * 30 колонок).
2) прочитанные данные каждого файла добавляю в общий массив.
3) общий массив отправляю на сервер, там все разбираю - создаю/обновляю объекты.

Все выполняется не быстро (минуты), переписал через ДлительныеОперации.ВыполнитьВФоне, но запуск выполняется дольше чем серверные процедуры.

По итогу замера производительности, передача данных с клиента на сервер больше 50% времени (и это один комп, между разными или веб еще ж хуже будет...).

Вопрос, как правильно в таком случае поступить? Как быстрее всего будет передать данные на сервер, уже прочитанные, по каждому файлу отдельно или все сразу как у меня?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #158056 · Ответов: 20 · Просмотров: 5208
 

>  ограниченные права в 1С проведение/запись
demon14
Отправлено: 25.11.19, 10:02


Общительный
**

Группа: Пользователи
Сообщений: 10
Регистрация: 24.02.14
Из: Київ
Пользователь №: 33819


PavelMarty @ Сегодня, 9:56 * ,
Печать не должна делать запрос на проведение и запись (исключение, новый не записанный документ).

Искать причину в коде, настройками ничего не поправить.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #157903 · Ответов: 10 · Просмотров: 510
 

>  Объеденение полей запроса
demon14
Отправлено: 10.10.19, 7:57


Общительный
**

Группа: Пользователи
Сообщений: 10
Регистрация: 24.02.14
Из: Київ
Пользователь №: 33819


TailorMade @ Сегодня, 7:59 * ,
...
Документ.ЗаказПокупателя.Расшифровка КАК ЗаказПокупателяРасшифровка
ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЗаказПокупателя.Расшифровка КАК ЗаказПокупателяРасшифровка2
ПО ЗаказПокупателяРасшифровка.ID = ЗаказПокупателяРасшифровка2.IDРодителя
...

ID если это все же УИД, необходимо хранить как строку.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #156391 · Ответов: 8 · Просмотров: 1224
 

>  Обробка "Обмін з банком" для БУ 2.0
demon14
Отправлено: 19.02.19, 16:02


Общительный
**

Группа: Пользователи
Сообщений: 10
Регистрация: 24.02.14
Из: Київ
Пользователь №: 33819


Petre @ Сегодня, 15:23 * ,
Дякую за відповідь, саму виплату ЗП так само іншими списаннями пропонується?

p.s. Врахуйте будь ласка в оновленні що реквізіт НомерВходящегоДокумента має довжину 20 символів (Завантаження.НомерДокумента в останній версії 10 символів).
  Форум: Отчеты / Обработки · Просмотр сообщения: #149984 · Ответов: 275 · Просмотров: 45327
 

>  Обробка "Обмін з банком" для БУ 2.0
demon14
Отправлено: 19.02.19, 11:11


Общительный
**

Группа: Пользователи
Сообщений: 10
Регистрация: 24.02.14
Из: Київ
Пользователь №: 33819


Petre @ 11.12.18, 13:10 * ,
Цитата(Petre @ 11.12.18, 13:10) *
Боюсь, уже не в этом году. Ориентировочно вторая половина января...

Доброго дня, Petre.

Дуже вдячний за вашу обробку. Є пару питаннь..
Чи є новини по оновленню?
Яка послідовність дій наразі є актуальною для завантаження виплат по ЗП та налогам. (якщо я обираю відповідні операції, отримую повідомлення "Таку операцію не реалізовано в обробці").

  Форум: Отчеты / Обработки · Просмотр сообщения: #149981 · Ответов: 275 · Просмотров: 45327
 


Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 07.07.20, 0:25
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!