Версия для печати темы (https://pro1c.org.ua/index.php?s=06dff7bbccd695a579b71c3f2802f15b&showtopic=67121)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ 1С Торговля и Склад 7.7 для Украины _ Ошибка печатати товарного чека

Автор: Максон 10.11.22, 20:30

1cпредприятие 7.70.027. Конфигурация Торговля и склад 7.70.101 beta, Разработчик конфигурации Lexoftech 2006.
Когда перенес базу на другой компьютер, после открытия периода перестал печататься товарный чек, сразу выдает ошибку "Файл товарный чек не найден". После в окне сообщений пишет "Таб.ИсходнаяТаблица(ПечФорма);{Документ.РасходнаяНакладная.Форма.Модуль(693)}: Неверное имя Товарный чеку
Подскажите пожалуйста в чем причина и как с этим побороться.

Автор: denis84 10.11.22, 20:56

Максон @ Сегодня, 20:30 * ,
Отсутствкет файл печатной формы. Посмотрите в конфигураторе. На строку 693. Надо смотреть модуль документа. Больше всего что печатная форма чека подключалась как внешняя

Автор: Максон 11.11.22, 8:14

denis84 @ Вчера, 20:56 * ,
Форма печати открывалась до открытия нового периода. Как только открыл сразу перестала. Интересно что теперь подключаю эту базу с не открытым периодом а ошибка остается.

Автор: denis84 11.11.22, 8:23

Максон @ Сегодня, 8:14 * ,
Надо смотреть в колнфигуратор что там напсано, в модуле документа

Автор: Максон 11.11.22, 8:24

denis84 @ Вчера, 20:56 * ,
Подскажи пожалуйста это в константах глобальный модуль? Как узнать номер строки?

Автор: denis84 11.11.22, 8:33

Максон @ Сегодня, 8:24 * ,
Сначала смотрите в модуле формы документа РасходнаяНакладная.

Автор: Pepe 11.11.22, 8:44

Если чайник в 1С, лучше туда не лезть. Если есть возможность - выложите файл конфигурации (.MD) на обменник, Вам помогут.

Автор: Максон 11.11.22, 9:32

denis84 @ Сегодня, 8:23 * ,

//ПечФорма = "Накладная";
  ПечФорма = ИмяТабл;
  Язык = глЯзык(ПечФорма);  
  Таб.ИсходнаяТаблица(ПечФорма); ‐---‐--------------    строка 693
  глУстПропись(Валюта,Язык);
                  
  ПечОснование=глСтрокаОснование(Контекст,Договор,ДокументОснование);  
  
  Фирма.ИспользоватьДату(ДатаДок,1);
  Таб.ВывестиСекцию("Шапка");
  Ном = 1;
  ВСоставе = 0;
  ВыбратьСтроки();
  Пока ПолучитьСтроку()=1 Цикл                
    Если Набор.Выбран()=1 Тогда
      Если ПустоеЗначение(ВСоставе)=1 Тогда
        Таб.ВывестиСекцию("ВСоставе");
        ВСоставе=Набор;
      ИначеЕсли ВСоставе<>Набор Тогда
        Таб.ВывестиСекцию("ВСоставе");
        ВСоставе=Набор;
      КонецЕсли;
    Иначе
      Если ПустоеЗначение(ВСоставе)=0 Тогда
        ВСоставе=0;
      КонецЕсли;
    КонецЕсли;
//beg******ALEX 23.06.2006
    //ПечЦена = глФРМ(глПересчет(ЦенаБезНДС,Валюта,Курс,ВП,ДатаДок),ВП,0);
    //ПечСумма = глФРМ(глПересчет(СуммаБезСкидки,Валюта,Курс,ВП,ДатаДок),ВП,0);
    //Таб.ВывестиСекцию("Строка");
    //Ном = Ном+1;
    мояСкидка = глПересчет(СуммаСкидки,Валюта,Курс,ВП,ДатаДок);
    ПечЦена = глФРМ(глПересчет(ЦенаБезНДС,Валюта,Курс,ВП,ДатаДок) - (мояСкидка / Количество),ВП,0);
    ПечСумма = глФРМ(глПересчет(СуммаБезСкидки,Валюта,Курс,ВП,ДатаДок) - мояСкидка,ВП,0);
    Таб.ВывестиСекцию("Строка");
    Ном = Ном+1;
//end******ALEX 23.06.2006
  КонецЦикла;
//beg******ALEX 23.06.2006
  //Если Итог("СуммаСкидки")<>0 Тогда
  //  ПечСкидка = глФРМ(глПересчет(Итог("СуммаСкидки"),Валюта,Курс,ВП,ДатаДок),ВП,0);
  //  Таб.ВывестиСекцию("Скидка");    
  //КонецЕсли;    
//end******ALEX 23.06.2006
  ПечБезНДС = глФРМ(глПересчет(Итог("СуммаБезНДС"),Валюта,Курс,ВП,ДатаДок),ВП,0);  
  ПечНДС = глФРМ(глПересчет(Итог("СуммаСНДС") - Итог("СуммаБезНДС"),Валюта,Курс,ВП,ДатаДок),ВП,0);
  ПечСНДС = глФРМ(глПересчет(Итог("СуммаСНДС"),Валюта,Курс,ВП,ДатаДок),ВП,0);  
  ПечНДСПропись = " "+Формат(глПересчет(Итог("СуммаСНДС") - Итог("СуммаБезНДС"),Валюта,Курс,ВП,ДатаДок),"Ч12.2")+" "+ВП.Кратко;
  ПечСНДСПропись = глСуммаПрописью(глПересчет(Итог("СуммаСНДС"),Валюта,Курс,ВП,ДатаДок),ВП);  
  ПечБезНДСПропись = глСуммаПрописью(глПересчет(Итог("СуммаБезНДС"),Валюта,Курс,ВП,ДатаДок),ВП);  
  Таб.ВывестиСекцию("Дно");  
  Если БыстраяПечать = 1 Тогда
    Таб.ПараметрыСтраницы(,,,,,,,,,1,,);
    Таб.КоличествоЭкземпляров(Константа.ПечКолЭкзНакладнойПриБыстройПродаже);
    Таб.Напечатать(глОтладка);
  Иначе  
    Таб.Защита(Константа.ФлагЗащитыТаблиц);
    Таб.ТолькоПросмотр(1);
    Таб.Опции(0,0,,);    
//beg******ALEX 23.06.2006    
    //Таб.Показать("ПЕЧАТЬ: Расходная накладная","");
    Если ИмяТабл = "Накладная" Тогда
        Таб.Показать("ПЕЧАТЬ: Расходная накладная","");
    ИначеЕсли ИмяТабл = "Акт" Тогда
        Таб.Показать("ПЕЧАТЬ: Акт выполненных работ","");
    Иначе
        Таб.Показать("ПЕЧАТЬ: Гарантийный талон","");
    КонецЕсли;    
//end******ALEX 23.06.2006  
  КонецЕсли;
КонецПроцедуры
                
// ===============================
Процедура Печать(БыстраяПечать=0)
  Варианы= СоздатьОбъект("СписокЗначений");
  Варианы.ДобавитьЗначение("накладной");
  Варианы.ДобавитьЗначение("акта выполненных работ");
  Варианы.ДобавитьЗначение("гарантийного талона");
  Варианы.ДобавитьЗначение("товарного чека");
  Результат = 0;
  Если Варианы.ВыбратьЗначение(,,Результат,,1)=1 Тогда
      Если Результат = 1 Тогда
      ПечатьНАГ(БыстраяПечать,"Накладная")
    ИначеЕсли Результат = 2 Тогда
      ПечатьНАГ(БыстраяПечать,"Акт")
    ИначеЕсли Результат = 3 Тогда
      ПечатьНАГ(БыстраяПечать,"Гарантия")
    ИначеЕсли Результат = 4 Тогда
      ПечатьНАГ(БыстраяПечать,"Товарный чек")
      КонецЕсли;
  КонецЕсли;

КонецПроцедуры

Автор: denis84 11.11.22, 10:02

Максон @ Сегодня, 9:32 * ,
скиньте файл 1с7.md (это чисто конфигурации, без данных) с каталога вашей конфигурации на почту vdv1984@i.ua

Автор: Pepe 11.11.22, 10:56

Если чайник в 1С, лучше туда не лезть. Если есть возможность - выложите файл конфигурации (.MD) на обменник, Вам помогут.

Цитата(Максон @ 11.11.22, 10:32) *
ПечФорма = ИмяТабл;

В переменной "ИмяТабл" возможно содержится инфа о файле печатной формы. Это может быть и константа, и глобальная переменная, реквизит. надо смотреть она где инициализируется.
Из приведенного фрагмента кода ничего не видно, без МД никак.

Автор: denis84 11.11.22, 10:57

Pepe @ Сегодня, 10:56 * ,
та что-то Максон конфигурацию не хочет дать, а то по тексту тяжело понять

Автор: Pepe 11.11.22, 11:07

Цитата(denis84 @ 11.11.22, 11:57) *
та что-то Максон конфигурацию не хочет дать, а то по тексту тяжело понять

Мы предложили, это в его интересах, а так баба з воза...

Автор: denis84 11.11.22, 11:51

Pepe @ Сегодня, 11:07 * ,
так, то й так

Автор: Максон 11.11.22, 14:38

denis84 @ Сегодня, 8:33 * ,
Ошибка ушла, похоже я делал изменения в базе с не открытым периодом. Сейчас сразу открыл период и начал редактировать, вроде ошибок пока нет.




Еще вопросик возник, если не трудно, подскажите как редактировать шапку печатной формы. Сами формы похоже встроены в базу, отдельно я их не нашел. Спасибо за ответы!

Автор: denis84 11.11.22, 15:15

Максон @ Сегодня, 14:38 * ,
В конфигураторе. Находите свой документ. Открываете его форму и там есть макеты печатных форм. И там уже их правите, как хотите. Но если не сильно ориентируетеся в 1с, лучше обращаться к программистам 1с

Автор: Максон 11.11.22, 15:26

denis84 @ Сегодня, 15:15 * ,
Спасибо большое. Нашел.
Хочется самому разобраться в простом. В программирование пока не лезу.

Автор: denis84 11.11.22, 15:53

Максон @ Сегодня, 15:26 * ,
для спасибо есть специальная кнопка

Автор: Максон 29.11.22, 22:25

denis84 @ 11.11.22, 15:15
Теперь не могу найти форму печати фискального чека прро, нужно обновить данные фирмы. Подскажите пожалуйста если сталкивались с настройкой таких вещей.

Автор: Vofka 30.11.22, 9:24

Максон, https://pro1c.org.ua/index.php?act=announce&f=36&id=2, пункт 6. Эту тему закрываю.

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua