Версия для печати темы (https://pro1c.org.ua/index.php?s=080cf05645d75eb9b9c929310f982722&showtopic=67122)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Программирование в 1С Предприятие 7.7 _ Проведения документа по ссылке

Автор: kostya77 14.11.22, 15:15

Добрый день. В шапке документа есть ссылка на другой документ.как его провести при проведении родительского документа?

Автор: denis84 14.11.22, 15:53

kostya77 @ Сегодня, 15:15 * ,
Иногда необходимо при проведении документа, перепровести связанные с текущим, другие документы. В 1С:7.7 существует ограничение на проведение документов из модуля проведения, обойти ограничение можно следующим образом:
Иногда необходимо при проведении документа, перепровести связанные с текущим, другие документы. В 1С:7.7 существует ограничение на проведение документов из модуля проведения, обойти ограничение можно следующим образом:

    
//документ с которого хотим провести другой
Процедура ОбработкаПроведения()

Док = СоздатьОбъект("Документ");
Если Док.НайтиДокумент(ДокументОснование) = 1 Тогда
       ОткрытьФормуМодально(Док.ТекущийДокумент(),"ПровестиИЗакрыть",0);
КонецЕсли;

КонецПроцедуры

//Документ2, Модуль формы документа основание

Процедура ПриОткрытии()
       Если Форма.Параметр="ПровестиИЗакрыть" Тогда
         Провести();
         СтатусВозврата(0)
       КонецЕсли;
КонецПроцедуры

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua