Версия для печати темы (https://pro1c.org.ua/index.php?s=436baafc8c0594451ce41ff9a6c640f7&showtopic=67114)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ 1С Управление небольшой фирмой для Украины _ При создании новой базы из CF файла - ошибка: Запись с такими ключевыми полями существует!

Автор: f12 28.10.22, 22:02

Прошу допомоги.
Конфігурація УНФ 1.6.1 Створив cf-файл з робочої бази. При створенні нової чистої бази при загрузці цього cf-файлу видає таку помилку. Як виправити?

Запись с такими ключевыми полями существует! МРОТ: 01.12.2015 (Регистр сведений. Мінімальна оплата праці; Номер строки 17

Ось що пише в цій в конфігураторі

#Если Сервер Или ТолстыйКлиентОбычноеПриложение Или ВнешнееСоединение Тогда

#Область ПрограммныйИнтерфейс

// Возвращает значение МРОт на переданную дату
//
Функция МРОТНаДату(Дата = Неопределено) Экспорт
    
     //МРОТ
    Запрос = Новый Запрос(
    "ВЫБРАТЬ
      |    МРОТСрезПоследних.Значение
      |ИЗ
      |    РегистрСведений.МРОТ.СрезПоследних(&ДатаСреза, ) КАК МРОТСрезПоследних");
      Запрос.УстановитьПараметр("ДатаСреза", НачалоГода(Дата));
    
      Выборка = Запрос.Выполнить().Выбрать();
    
      Если Выборка.Следующий() Тогда
        Возврат Выборка.Значение;
      Иначе
        ВызватьИсключение НСтр("ru='Регистр сведений МРОТ не заполнен';uk='Регістр відомостей МРОП не заповнений'");
    КонецЕсли;
    
КонецФункции

#КонецОбласти

#КонецЕсли

Автор: Moloko 29.10.22, 23:09

f12 @ Вчера, 22:02 * ,
Перевірив - при створенні бази зі стандартного цфника таких проблем не виникає. Якщо в вас вже вскрита конфігурація,
подивіться на макет НачальноеЗаполнение в цьому регістрі, можливо, там і є ця фігня з 01.12.2015

Автор: f12 31.10.22, 11:13

Питання закрите, проблема вирішилась іншим шляхом.

Автор: Vofka 31.10.22, 15:03

f12, то може розкажете яким?

Автор: f12 01.11.22, 8:34

Vofka @ Вчера, 16:03 * ,

Знайшов в архіві за 2021 рік файл вигрузки чистої бази (з якою працював наш попередній програміст) без документів і залишків номенклатури, загрузив її, а потім поновив її більш новим cf-файлом з актуальної на даний момент бази. Ось так і вийшов з ситуації..

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua