Версия для печати темы (https://pro1c.org.ua/index.php?s=ff84726cb86ace2d810f2df82e9e4261&showtopic=31809)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ С чем мне приходилось сталкиваться... _ Зіштовхнувся з 1C Trade Managment

Автор: XBrut 14.09.16, 11:35

Наскільки я здогадуюсь, для закордону (типу франція наприклад) існує єдина конфігурація трейд менеджмент, яку локалізують під різні країни.

Під час впровадження виявилось....

1) в програмі ділення на чорно/білий облік не передбачено.
2) подія "товар куплений" = створенню вхідної податкової накладної. (навіть якщо товар ще не надійшов на склад)
3) а подія "товар проданий" = створенню вихідної податкової накладної (навіть якщо товар ще не надійшов на склад)
4) І в зв'язку з цим виникають якісь дивовижні речі. типу... оцінити вартість товару на складі - неможливо.

П.С.
і взагалі. звіт з продажу робиться по податковим накладним smile.gif
Правда є варіант, що менеджер зі сторони замовника не дуже кваліфікована людина і щось мені не те каже....

доречі. обговорення цієї конфігурації в інтернетах щось не дуже видно.

поки що думаю примастирить регістр "партії на складах", який буде працювать , як в звичайній УТ для України....

Автор: XBrut 22.09.16, 12:38

    
If ReturnResult = Undefined Then
        
      WriteInFile = False;
        
      If WriteInFile Then


crazy.gif

Автор: TipsyKID 23.09.16, 14:53

Ну, для того, что - бы мы были уверенны в реальном идиотизме кода необходимо удостоверится, что дальше в условии нет "Метки".
Ведь дальше может быть следующее (пофантазируем)

If ReturnResult = Undefined Then
        
      WriteInFile = False;
        
      If WriteInFile Then
          ~SendMessage:

          Text = "Беда не в том, что человек глуп, беда в том, что он глуп внезапно."
          StrReplace(Text,"глуп","смертен");

          Message(Text);

          WriteInFile = True; //условие выхода
      EndIf;

EndIf;

If (ReturnResult = Undefined) AND (Not WriteInFile) Then
   Goto ~SendMessage;
EndIf;


Сори, за оффтопик, да простят меня модераторы.

Автор: XBrut 12.10.16, 12:00

шановний колего, навряд чи це хтось один написав в стислий проміжок часу через свій нерозум.
можливо таким чином заблокували ділянку коду навмисне
мені здається, що такі ділянки коду скоріше свідчать , що конфігурація знаходиться в стані постійної розробки, і що ресурсів у розробника не вистачає.
там же в середені нечуваний розмах бля. просто монголо-татарська навала на ринок всесвітнього корпоративного обліку smile.gif

Автор: Vofka 12.10.16, 12:26

Цитата(XBrut @ 12.10.16, 13:00) *
можливо таким чином заблокували ділянку коду навмисне

Я помню как-то увидел где-то подобный код:

Функция ЧтоТо(Документ)

Если Ложь Тогда
   Документ = Документы.МойДокумент.СоздатьОбъект();
КонецЕсли;

// ... дальше что-то происходит

КонецФункции


Есть варианты что это?

Автор: logist 12.10.16, 12:51

Цитата(Vofka @ 12.10.16, 13:26) *
Есть варианты что это?

Для того, что бы код удобней писать было, так по точке доступны свойства и методы объекта, но он не создается smile.gif

Автор: TipsyKID 12.10.16, 13:35

logist @ Сегодня, 13:51 * ,

Плюсую, правда, сам пишу несколько по другому:

    #Если _ Тогда
        СтруктураПараметрыУслуги = Новый Структура;    
        ТаблицаАналогиХарактеристикНоменклатуры = Новый ТаблицаЗначений;
    #КонецЕсли


Так, мне кажется, удобнее (читабельнее) выходит структура с предопределеним параметров для разработки.

Автор: logist 12.10.16, 13:40

TipsyKID, интересная конструкция smile.gif

Автор: Vofka 12.10.16, 13:42

logist, вот и определился наш победитель 07000000.gif . Все верно.

TipsyKID, тут

#Если _ Тогда

ошибок не возникает? Если между Если и Тогда можно писать что угодно, я бы тогда лучше писал
#Если РежимРазработки Тогда

Автор: TipsyKID 12.10.16, 14:08

Цитата(Vofka @ 12.10.16, 14:42) *
ошибок не возникает

Нет.

Можно писать что угодно, другое дело, вероятность, что разработчики платформы добавят предопределенную команду препроцессора "РежимРазработки" выше, чем "_".

Автор: logist 12.10.16, 14:12

Цитата(TipsyKID @ 12.10.16, 15:08) *
"_"

По сути это фича платформы, о которой разработчики не знают?

Автор: TipsyKID 12.10.16, 14:26

logist @ Сегодня, 15:12 * ,
Сложно сказать, думаю знают, но для них это не существенно.

Автор: XBrut 12.10.16, 14:26

Круто.
А я, як лох, писав

 Документ=Документи.МійДокумент.СоздатьОбъект();


а потім видаляв цю строку
тепер буду знати, що треба робить.

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua