Версия для печати темы (https://pro1c.org.ua/index.php?s=2dbd8bdca06337c90ddfedbb85a7a5d3&showtopic=54057)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Бухгалтерия 8, редакция 1 для Украины _ Работает ли у вас Клиент-банк Приват + Бухгалтерия 1.2? Ждать ли обновления Бух 1.2?

Автор: andreykyiv@bigmir.net 10.09.19, 15:32

Работает ли у вас Клиент-банк Приват + Бухгалтерия 1.2?
С новыми IBan счетами проблема. После из введения перестал работать Клиент-Банк для Привата.
У меня одного такая проблема?

Автор: RedCat77 10.09.19, 15:42

Цитата(andreykyiv@bigmir.net @ 10.09.19, 16:32) *
Работает ли у вас Клиент-банк Приват + Бухгалтерия 1.2?
С новыми IBan счетами проблема. После из введения перестал работать Клиент-Банк для Привата.

1 "Допилить" конфигурацию
2 "Допилить" обработку импорта
И все будет работать 47067070.gif

Автор: romarker 10.09.19, 16:42

andreykyiv@bigmir.net @ Сегодня, 16:32 * ,
У меня при импорте стандартная обработка Приват24 зависала, я очистил временные файлы обработки (3 папки на закладке пути к файлам) и всё заработало.

Автор: kihor 10.09.19, 16:58

andreykyiv@bigmir.net @ Сегодня, 16:32 * ,
Обновления Бух 1.2 уже не будет. Так нам сказал наш поставщик 1С. Мы все предприятия перевели на Бух 2.0.

Автор: Макс1С 10.09.19, 19:07

andreykyiv@bigmir.net @ Сегодня, 16:32 * ,
Дело в том что поменялось несколько моментов в файлах импорта из привата:
1. Имя файла больше 8 символов, 1С до сих пор не умеет их открывать. Обход - переименовываем.
2. Р/счет организации теперь всегда в одной колонке (COUNT_A)
3. Р/счет может быть как в формате IBAN так и в старом
4. Поменялся формат даты платежа
5. Поменялось обозначение вида операции (приход/расход)

В большинстве обработок на основе распространяемой АБИ (Конто) где под каждый формат банка используется мини-обработка достаточно поменять несколько строк.

Функция ИмпортDBF(Параметры)
    ФайлDBF = Новый XBase;
    ФайлDBF.Кодировка = КодировкаXBase[Параметры.КодировкаФайла];    //DOS
    
    ИмяФайла = Параметры.ИмяФайла;
    
    Попытка
        ФайлDBF.ОткрытьФайл(ИмяФайла,,Истина); //Только для чтения
    Исключение
        Предупреждение("Ошибка открытия файла " + ИмяФайла);
        Возврат Неопределено;
    КонецПопытки;        
    
    Если НЕ ФайлDBF.Открыта() Тогда
        Предупреждение("Ошибка открытия файла " + ИмяФайла);
        Возврат Неопределено;
    КонецЕсли;
    
    тзВыписка =  Новый ТаблицаЗначений;
    тзВыписка.Колонки.Добавить("НомерПП");
    тзВыписка.Колонки.Добавить("Приход");
    тзВыписка.Колонки.Добавить("Расход");
    тзВыписка.Колонки.Добавить("ОКПО");
    тзВыписка.Колонки.Добавить("Контрагент");
    тзВыписка.Колонки.Добавить("МФО");
    тзВыписка.Колонки.Добавить("РСчет");
    тзВыписка.Колонки.Добавить("Содержание");
    
    ФайлDBF.Первая();
    Пока НЕ ФайлDBF.ВКонце() Цикл
        // проверка на дату платежа
        Если ФайлDBF.DATE <> Параметры.ДатаДок И СокрЛП(ФайлDBF.DATE) <> Формат(Параметры.ДатаДок,"ДФ=dd.MM.yyyy") Тогда
            ФайлDBF.Следующая();
            Продолжить;
        КонецЕсли;    
        
        НомерСчетаА = СокрЛП(ФайлDBF.COUNT_A);
        НомерСчетаБ = СокрЛП(ФайлDBF.COUNT_B);
        
        Если СтрДлина(НомерСчетаА) = 14 Тогда
            ПоискСчета = НомерСчетаА;
        Иначе
            ПоискСчета = Прав(НомерСчетаА,14);
        КонецЕсли;
                
        Если Найти(Параметры.Рсчет,ПоискСчета) = 0 Тогда
            ФайлDBF.Следующая();
            Продолжить;
        КонецЕсли;
        
        Если СокрЛП(ФайлDBF.TIP) = "D;R;" Тогда
            НовСтрока = тзВыписка.Добавить();
            НовСтрока.РСчет            = СокрЛП(Формат(НомерСчетаБ,"ЧГ=0"));
            НовСтрока.МФО             = СокрЛП(Формат(ФайлDBF.MFO_B,"ЧГ=0"));
            НовСтрока.ОКПО            = СокрЛП(Формат(ФайлDBF.OKPO_B,"ЧГ=0"));
            НовСтрока.Контрагент    = СокрЛП(ФайлDBF.NAME_B);
            НовСтрока.Приход        = 0;
            НовСтрока.Расход        = -ФайлDBF.SUMMA;
        ИначеЕсли СокрЛП(ФайлDBF.TIP) = "C;R;" Тогда
            НовСтрока = тзВыписка.Добавить();
            НовСтрока.РСчет            = СокрЛП(Формат(НомерСчетаБ,"ЧГ=0"));
            НовСтрока.МФО             = СокрЛП(Формат(ФайлDBF.MFO_B,"ЧГ=0"));
            НовСтрока.ОКПО            = СокрЛП(Формат(ФайлDBF.OKPO_B,"ЧГ=0"));
            НовСтрока.Контрагент    = СокрЛП(ФайлDBF.NAME_B);
            НовСтрока.Приход        = ФайлDBF.SUMMA;
            НовСтрока.Расход        = 0;
        Иначе    
            ФайлDBF.Следующая();
            Продолжить;
        КонецЕсли;
        
        НовСтрока.НомерПП             = СокрЛП(ФайлDBF.N_D);
        НовСтрока.Содержание         = СокрЛП(СтрЗаменить(ФайлDBF.N_P,Символы.ПС," "));
        
        ФайлDBF.Следующая();
    КонецЦикла;    
    
    Если НЕ тзВыписка.Количество() И ФайлDBF.КоличествоЗаписей() Тогда
        Предупреждение("В текущем файле нет платежей с данной датой выписки и расчетным счетом!");
    КонецЕсли;
    
    ФайлDBF.ЗакрытьФайл();
    
    Возврат тзВыписка;
    
КонецФункции


kihor @ Сегодня, 17:58 * ,
Кстати да. Уже можно переводить на 2.1 BAS Бухгалтерию))

В Бухгалтерии 1.2 нужно не забыть увеличить длину поля НомерСчета в справочнике Банковские счета до 29 символов

Автор: RedCat77 11.09.19, 8:37

Цитата(Макс1С @ 10.09.19, 20:07) *
НовСтрока.РСчет            = СокрЛП(Формат(НомерСчетаБ,"ЧГ=0"))

Вы обрезаете счет контрагента с IBAN
Нужно:
НовСтрока.РСчет            = СокрЛП(НомерСчетаБ)

Автор: andreykyiv@bigmir.net 11.09.19, 14:07

romarker @ Вчера, 17:42 * ,
Кстати, да , у меня тоже зависает.
Чистил 1с-ные папки кеш-файлов, не помогло.
А какие именно папки надо почистить?
Так, пути вижу. И что, их просто надо очистить, те папки?

andreykyiv@bigmir.net @ Сегодня, 14:50 * ,

romarker? Дякую. На самом деле в папке с Базой 1с хранятся файлы логи Клиент-банка.
Они уже разрослись до размеров 500мб. Понятно, что работать с тестовыми файлами такого размера - то еще занятие. Потому и зависал процесс.
А общий вывод - Приватбанк все еще поддерживает Бухгалтерию 1.2 .
Хотя я руководство уже озадачил, что переход на 2.1 неминучий
Всем спасибо за обсуждение

Автор: Макс1С 12.09.19, 8:05

RedCat77 @ Вчера, 9:37 * ,
Действительно не поправил старый кусок кода. В своё оправдание скажу, что редко кому нужен р/счет клиентов ))

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua