Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

5 страниц V   1 2 3 > » 

>  В печатной форме вместо фирмы НеизвестныйОбъект 1с 7.7 конф 7.7.003
ZUBR
Отправлено: 07.10.19, 20:08


Завсегдатай
****

Группа: Пользователи
Сообщений: 105
Регистрация: 05.07.19
Из: Київ
Пользователь №: 65920


andrew76 @ Сегодня, 16:31 * , о каком старом варианте файла Вы говорите? Который нужно сохранить на всякий случай? Я так понимаю, только новый файл добавить. И все.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156290 · Ответов: 18 · Просмотров: 278
 

>  Префикс номеров документов в 1С 7.70.003 торговля склад для Украины?
ZUBR
Отправлено: 07.10.19, 19:59


Завсегдатай
****

Группа: Пользователи
Сообщений: 105
Регистрация: 05.07.19
Из: Київ
Пользователь №: 65920


Уважаемые господа! Прошу прощения за так мого текста. Жаль, что я не могу его удалить. В общем, результаты следующие. В моей конфигурации, независимо от того, прописан в параметрах учета префикс и какой, система автоматически присваивает префиксы к документам, состоящий из трех начальных букв основной фирмы. Основную фирму можно удалить, создав перед этим в справочнике свою фирму и записав ее в константу "ОсновнаяФирма". Почему нельзя менять префикс, я не знаю, но, в принципе, это меня тоже устраивает. Спасибо! Модераторы, прошу прощения за обилие воды. Если бы мог, почистил бы icon_beer17.gif
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156289 · Ответов: 18 · Просмотров: 362
 

>  Префикс номеров документов в 1С 7.70.003 торговля склад для Украины?
ZUBR
Отправлено: 07.10.19, 18:30


Завсегдатай
****

Группа: Пользователи
Сообщений: 105
Регистрация: 05.07.19
Из: Київ
Пользователь №: 65920


Карочь, ребята, долго я ковырялся и пришел к выводу, что эта система в любом случае генерирует префиксы - первые три буквы от названия основной фирмы. Причем основная фирма одна и ее нельзя создать. Можно только переименовать.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156288 · Ответов: 18 · Просмотров: 362
 

>  Префикс номеров документов в 1С 7.70.003 торговля склад для Украины?
ZUBR
Отправлено: 07.10.19, 16:57


Завсегдатай
****

Группа: Пользователи
Сообщений: 105
Регистрация: 05.07.19
Из: Київ
Пользователь №: 65920


Здравствуйте! Я немного доработал конфигурацию, в тестовом режиме с префиксами было все нормально. Затем я удалил все со справочников, включая тестовую фирму и ее реквизиты, удалил все документы и т.д. чтобы сохранить конфигурацию в чистом виде. Затем для пробы снова записал фирму под тестовым названием Lala. Внес по паре данных в справочники. В параметрах учета поставил префикс АСЦ. Но документы выдаются не с этим префиксом. Номера штатной расходной накладной, равно как и приходной, куда я вообще не лазил, выдаются с префиксом "Осн - " - я так понимаю от слова Основной.
А номера вновь созданного документа, в модуль которого я по совету добавил
глЗаполнитьШапку(Контекст);
начинаются с префикса "Lal-" -первые три буквы названия тестовой фирмы Lala, которую я поставил в константах, как основную.
Префикса АСЦ нет, хотя в настройках параметров учета он есть. Не могу понять, в чем проблема. Может, это как-то зависит от типа учета, или еще чего-то? Подскажите, пожалуйста!

Только что запустил совершенно чистую конфигурацию. Там вообще нет префиксов. Одни цифры в номере, даже если поставить префикс в настройках. Этот префикс ставится в номерах документов по УПР учету. Где поставить этот вид учета - УПР? Спасибо!

Я посмотрел журнал тестового проведенного документа РасходнойНакладной. Там в поле ТитУчета автоматом появился "Упр". Но префикс все равно "Осн-".
Мне вообще не ясно, может, при первом запуске конфигурации устанавливается префикс документов, а потом он не меняется уже? А у меня получается не первый запуск.

Так, У меня в расходной стояла основная фирма. Поэтому префикс там Осн-
Значит, на префикс номеров документа программа берет первых три знака из названия фирмы. А почему же не работает другой префикс, который я указал в настройках? И раньше он тоже не работал. Просто я указал в настройках раньше три первых буквы названия фирмы. А программа и сама их берет. И мне тогда показалось, что это я указал префикс. А это просто совпало.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156286 · Ответов: 18 · Просмотров: 362
 

>  В печатной форме вместо фирмы НеизвестныйОбъект 1с 7.7 конф 7.7.003
ZUBR
Отправлено: 07.10.19, 14:59


Завсегдатай
****

Группа: Пользователи
Сообщений: 105
Регистрация: 05.07.19
Из: Київ
Пользователь №: 65920


Макс1С @ Сегодня, 11:29 * ,
Это я знаю. Находил в гугле. И про файл находил. Вот только не получается. У меня два компа. Один винд.7, другой винд.10. Пробовал выставить одинаковые рег стандарты. Все равно если к одному компу адаптируешь кодовую страницу, на другом требует перекодировки. И наоборот.Не пойму, в чем дело. А насчет пустого файла - будет ли программа коректно работать без проверки?
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156277 · Ответов: 18 · Просмотров: 278
 

>  Как создать отчет для текущего пользователя 1с 7.7 конф 7.7.003
ZUBR
Отправлено: 06.10.19, 20:40


Завсегдатай
****

Группа: Пользователи
Сообщений: 105
Регистрация: 05.07.19
Из: Київ
Пользователь №: 65920


Здравствуйте. Еще один интересный вопрос. У меня есть доработанная сетевая версия 1С7.7 Торговля + Склад. Есть сотрудники. Я их прописываю, как пользователей с правами созданного интерфейса Инженер. Есть отчет по сдельной части зарплаты. Мне нужно, чтобы программа автоматически подставляла в этот отчет сотрудника, который в данный момент под своим именем пользователя зашел в программу. К примеру, что нужно написать ТЗ.Сотрудник = ????. Или по-другому сделать? Чтобы в дальнейшем сотрудник мог посмотреть показатели. Только свои. В справочниках Сотрудники и Пользователи ФИО идентичны.
Спасибо!
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156249 · Ответов: 2 · Просмотров: 149
 

>  В печатной форме вместо фирмы НеизвестныйОбъект 1с 7.7 конф 7.7.003
ZUBR
Отправлено: 06.10.19, 17:57


Завсегдатай
****

Группа: Пользователи
Сообщений: 105
Регистрация: 05.07.19
Из: Київ
Пользователь №: 65920


Karabasoff @ Сегодня, 14:23 * ,
Дело в том, что нет кодовой страницы Русский. Есть Русский, болгарский и сербский языки. И есть отдельно украинский. Я пробовал настраивать системные установки винды под них, но кодовая страница все равно не совпадала. Киньте ссылку, если можно, где это все подробно описано. То, что нарыл в интернете, не помогает.... Или плохо рыл?
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156248 · Ответов: 18 · Просмотров: 278
 

>  В печатной форме вместо фирмы НеизвестныйОбъект 1с 7.7 конф 7.7.003
ZUBR
Отправлено: 05.10.19, 22:50


Завсегдатай
****

Группа: Пользователи
Сообщений: 105
Регистрация: 05.07.19
Из: Київ
Пользователь №: 65920


1Cv77 @ Сегодня, 23:20 * ,
Что реквизит Фирма общий - это ясно. А адрес точно периодический. Я об этом сказал. Кстати, насчет

ТаблицаРеквизитов.Значение = Конт.ПолучитьАтрибут(Идентификатор);
{Обработка.ЗаписьПериодическихРеквизитов.Форма.Модуль(53)}: Неверное имя атрибута

Эта ошибка каким-то образом связана с Виндовс 7. На десятке ее нет.


Цитата(1Cv77 @ 05.10.19, 23:20) *
Тогда, нужно так:
Адрес.Получить(ДатаДок)

И откуда Вы это знаете??? Вот как можно самому додуматься? 64000000.gif
СПОСИБО! 32000000.gif
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156230 · Ответов: 18 · Просмотров: 278
 

>  В печатной форме вместо фирмы НеизвестныйОбъект 1с 7.7 конф 7.7.003
ZUBR
Отправлено: 05.10.19, 20:22


Завсегдатай
****

Группа: Пользователи
Сообщений: 105
Регистрация: 05.07.19
Из: Київ
Пользователь №: 65920


andrew76 @ Сегодня, 21:11 * ,
Да, в Расходной есть реквизит Фирма и в АктеПриема точно такой же реквизит. Но тут есть нюанс. Телефоны появляются. А адреса нет. Пишет НеизвестныйОбъект. Причем сообщение появляется не как ошибка, а появляется прямо в отпечатываемом документе. Вместо адреса.
Пришла мысль, что это связано с тем, что адреса есть периодическими атрибутами. Или реквизитами.
Реквизит Фирма в расходнойНакладной на форме присутствует. Но в списке реквизитов шапки ее нет. Видно, этот реквизит в глобальном модуле. Это проблема для меня...
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156228 · Ответов: 18 · Просмотров: 278
 

>  В печатной форме вместо фирмы НеизвестныйОбъект 1с 7.7 конф 7.7.003
ZUBR
Отправлено: 05.10.19, 20:03


Завсегдатай
****

Группа: Пользователи
Сообщений: 105
Регистрация: 05.07.19
Из: Київ
Пользователь №: 65920


И снова ДобрыйВечер!)))
Опять проблема у меня.
В РасходнойНакладной есть ячейки со следующим шаблоном: [Фирма.ПолнНаименование], [Фирма.ЮридическийАдрес], [Фирма.Телефоны].
В Расходной накладной при создании нового документа и последующем его распечатывании на соответствующих местах появляются название фирмы, адрес, телефоны со справочника. Фирма в справочнике одна. Она же основная. Я создал дополнительный документ АктПриема и в его печатной форме прописал те же шаблоны. Однако, при печати телефоны появляются, а вместо названия фирмы и адреса при печати появляется сообщение НеизвестныйОбъект. Если я вместо шаблона Фирма.ПолнНаименование поставлю просто Фирма, тогда название появляется, но оно появляется из реквизита АктаПриема.
Вопрос. Почему телефоны из справочника прописываются, а вместо юридического, почтового адресов и вместо ПолнНаименования выходит сообщение "НеизвестныйОбъект"?
Причем проблемы в созданном документе АктПриема. В штатном документе РасходнаяНакладная все ок.
Еще один момент, который может быть как-то связан с данной проблемой. При изменении содержимого поля Официальное наименование в справочнике Фирмы и нажатии кнопки Записать появляется сообщение:

ТаблицаРеквизитов.Значение = Конт.ПолучитьАтрибут(Идентификатор);
{Обработка.ЗаписьПериодическихРеквизитов.Форма.Модуль(53)}: Неверное имя атрибута

Но реквизит записывается.
При изменении же поля Полное наименование все нормально. Появляется стандартное окно записи периодических реквизитов с сообщением, на какую дату будет записан реквизит. Но это не главное. Главное, как в печатной форме прописать выражение, чтобы там появлялся адрес фирмы. Которая в справочнике одна. Предвосхищаю уточняющие вопросы. Это происходит не только при печати доков из журнала, но и при печати вновь созданных документов. Кто сталкивался?
Спасибо!
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156226 · Ответов: 18 · Просмотров: 278
 

>  Как настроить печатную форму в 1С 7.70.003 торговля склад для Украины?
ZUBR
Отправлено: 05.10.19, 14:06


Завсегдатай
****

Группа: Пользователи
Сообщений: 105
Регистрация: 05.07.19
Из: Київ
Пользователь №: 65920


andrew76 @ Сегодня, 7:30 * , Благодарю Вас. Я это уже нашел в синтаксе. Уже сделал. Все получилось)
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156223 · Ответов: 7 · Просмотров: 324
 

>  Помогите понять принцип создания запросов в 1с 7.7 конф 7.7.00
ZUBR
Отправлено: 04.10.19, 23:27


Завсегдатай
****

Группа: Пользователи
Сообщений: 105
Регистрация: 05.07.19
Из: Київ
Пользователь №: 65920


Цитата(andrew76 @ 03.10.19, 4:59) *
Это смотря по ситуации.Замеряйте производительность в каждом варианте ( запрос или перебор документов ).
Ну а код должен быть лёгким для восприятия.Мой вариант считает правильно ?


Ваш вариант считает только количество систем. Но если его немного поправить, тогда он считает отлично! 32000000.gif


Процедура Сформировать() 
    
        ТЗ = СоздатьОбъект ("ТаблицаЗначений");
    Расх = СоздатьОбъект("Документ.РасходнаяНакладная");    
    
//Создание колонок
     ТЗ.НоваяКолонка("НачДата");    
     ТЗ.НоваяКолонка("КонДата");    
     ТЗ.НоваяКолонка("КолСис");   //Количество систем
     ТЗ.НоваяКолонка("Вал");     //Общая стоимость работ
     ТЗ.НоваяКолонка("СумУс");  //Стоимость услуг
      
//и т.д.
    
    
         СумУс=0;
             КолСис=0;
             СумАкс=0;
             Вал=0;

Расх.ВыбратьДокументы(НачДата,КонДата);
          
Пока Расх.ПолучитьДокумент()=1 Цикл
        
     Если  (Расх.СтатусЗаказа = Перечисление.Статусы.Выдан) или (Расх.СтатусЗаказа = Перечисление.Статусы.Выезд) или (Расх.СтатусЗаказа =
                Перечисление.Статусы.ВыдОтказ) тогда
              КолСис=КолСис+1;
              Вал=Вал+Расх.Итог("СуммаСНДС");
    
             Расх.ВыбратьСтроки();
             Пока Расх.ПолучитьСтроку() = 1 Цикл
                 Если Расх.Товар.ВидТовара = Перечисление.ВидыТоваров.Услуга тогда
               СумУс=СумУс+Расх.СуммаСНДС;
                КонецЕсли;
     КонецЦикла;

    КонецЕсли;

    Если Расх.СтатусЗаказа = Перечисление.Статусы.Акс тогда
           СумАкс =СумАкс+Расх.Итог("СуммаСНДС");
    КонецЕсли;

КонецЦикла;

Сообщить("Количество систем:"+КолСис);    
Сообщить("Сумма:"+Вал);
Сообщить("Сумма услуг:"+СумУс);
Сообщить("Сумма акс:"+СумАкс);
    
КонецПроцедуры


Думаю, этот вариант более быстрый, чем вариант с тремя запросами. И мне, например, он пока легче в понимании. Вам спасибо.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156205 · Ответов: 43 · Просмотров: 983
 

>  Помогите понять принцип создания запросов в 1с 7.7 конф 7.7.00
ZUBR
Отправлено: 04.10.19, 19:47


Завсегдатай
****

Группа: Пользователи
Сообщений: 105
Регистрация: 05.07.19
Из: Київ
Пользователь №: 65920


Макс1С @ Сегодня, 15:36 * ,
Я сейчас проверю и сообщу результат

Макс1С @ Сегодня, 15:36 * ,
У меня все считает правильно. Товары со статусом заказа АКС (Это аксессуары) разные и в разных количествах. Услуги тоже разные. Видов 4 или 5. В разных документах могут быть разные товары и услуги. Привожу реально работающую часть кода еще раз.

Процедура Сформировать() 

    Запрос = СоздатьОбъект("Запрос");
    
        ТЗ = СоздатьОбъект ("ТаблицаЗначений");
    
//Создание колонок
     ТЗ.НоваяКолонка("НачДата");    
     ТЗ.НоваяКолонка("КонДата");    
     ТЗ.НоваяКолонка("КолСис");   //Количество систем
     ТЗ.НоваяКолонка("Вал");     //Общая стоимость работ
     ТЗ.НоваяКолонка("СумУс");  //Стоимость услуг
     ТЗ.НоваяКолонка("ЗЧ");     //Стоимость запчастей
     ТЗ.НоваяКолонка("СумАкс");   //Стоимость аксессуаров
    
ТекстЗапросаС =
    "
    |Период с НачДата по КонДата;
    |ОбрабатыватьДокументы Проведенные;
    |СтатусЗаказа = Документ.РасходнаяНакладная.СтатусЗаказа;    
    |Товар = Документ.РасходнаяНакладная.Товар;
    |ВидТовара = Документ.РасходнаяНакладная.Товар.ВидТовара;
    |СуммаСНДС = Документ.РасходнаяНакладная.СуммаСНДС;
    |Функция Сум = Сумма(СуммаСНДС);
    |Функция СумУс = Сумма(СуммаСНДС) когда (ВидТовара = Перечисление.ВидыТоваров.Услуга);
    |Группировка Товар Без Групп;
    |Условие ((СтатусЗаказа = Перечисление.Статусы.Выдан)или(СтатусЗаказа = Перечисление.Статусы.Выезд)или(СтатусЗаказа = Перечисление.Статусы.ВыдОтказ));";
    
ТекстЗапросаК =
     "    
    |Период с НачДата по КонДата;
    |ОбрабатыватьДокументы Проведенные;
    |ТекДок = Документ.РасходнаяНакладная.ТекущийДокумент;
    |СтатусЗаказа = Документ.РасходнаяНакладная.СтатусЗаказа;
    |Функция КолСис = Счётчик(ТекДок);
    |Группировка  ТекДок;
    |Условие ((СтатусЗаказа = Перечисление.Статусы.Выдан)или(СтатусЗаказа = Перечисление.Статусы.Выезд)или(СтатусЗаказа = Перечисление.Статусы.ВыдОтказ));";
    
    ТекстЗапросаАкс =
    "
    |Период с НачДата по КонДата;
    |ОбрабатыватьДокументы Проведенные;
    |СтатусЗаказа = Документ.РасходнаяНакладная.СтатусЗаказа;    
    |Товар = Документ.РасходнаяНакладная.Товар;
    |СуммаСНДС = Документ.РасходнаяНакладная.СуммаСНДС;
    |Функция СумАкс = Сумма(СуммаСНДС);
    |Группировка Товар Без Групп;
    |Условие (СтатусЗаказа = Перечисление.Статусы.Акс);";
    
Запрос.Выполнить(ТекстЗапросаС);
    Пока Запрос.Группировка() = 1 Цикл
        Вал = Запрос.Сум;
        СумУс = Запрос.СумУс;
    КонецЦикла;
    
Запрос.Выполнить(ТекстЗапросаК);
   КолСис = Запрос.КолСис;
  
Запрос.Выполнить(ТекстЗапросаАкс);
    Пока Запрос.Группировка() = 1 Цикл
        СумАкс = Запрос.СумАкс;
    КонецЦикла;
    
Сообщить("Количество систем:"+КолСис);    
Сообщить("Сумма:"+Вал);
Сообщить("Сумма услуг:"+СумУс);
Сообщить("Сумма акс:"+СумАкс);  
  
   ТЗ.НоваяСтрока();
   ТЗ.НачДата = НачДата;
   ТЗ.КонДата = КонДата;
   ТЗ.КолСис = КолСис;
   ТЗ.Вал = Вал;
   ТЗ.СумУс = СумУс;
   ТЗ.ЗЧ = Вал - СумУс;

// и т.д. Дальше идут колонки, данные в которые заносятся на основании предыдущих колонок

КонецПроцедуры


Сумму услуг считает правильно. Общую сумму и сумму аксесуаров за указанный период тоже считает правильно.

Вот такая вот магия. Оценивать я не могу, потому что до сих пор мелко плаваю в запросах.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156203 · Ответов: 43 · Просмотров: 983
 

>  В печатной форме расходной накладной сумму прописью не пишет на украинском языке1С 7.70.003 торговля склад для Украины
ZUBR
Отправлено: 04.10.19, 17:19


Завсегдатай
****

Группа: Пользователи
Сообщений: 105
Регистрация: 05.07.19
Из: Київ
Пользователь №: 65920


volodya1122 @ Сегодня, 9:14 * ,
все вийшло! Дякую! Такий файл є!
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156202 · Ответов: 3 · Просмотров: 169
 

>  Благодарю Вас за неоценимую помощь, уважаемые специалисты.
ZUBR
Отправлено: 04.10.19, 16:39


Завсегдатай
****

Группа: Пользователи
Сообщений: 105
Регистрация: 05.07.19
Из: Київ
Пользователь №: 65920


Привет, ребята. У меня есть старая 1С 7.7 торговля плюс склад для Украины. Я имею маленький сервисный центр по ремонту бытовой техники. Я использовал 1С чисто для учета запчастей и взаиморасчетов с поставщиками. А для клиентов у меня была небольшая программка для выписки акта приема и акта выдачи оборудования, а также для базы данных. Я задолбался вести эти две базы. Все назойливее мою голову сверлила мысль о том, что нужно доработать 1С под мои потребности. Я искал программиста, который бы сделал эту доработку, но все, кого я находил, как-то не очень хотели за это браться. Ссылались на занятость и т.д. В конце-концов я позвонил в официальное представительство 1С и там мне сказали, что такая разработка под меня будет стоить примерно 38 тыс грн. Я никоим образом не хочу сказать, что это дорого. Я очень уважаю труд программистов. Я сам когда-то собирался им стать и даже немного начинал программирование на Бейсике, на Паскале, пробовал на Делфи. Так что я знаю, что высококвалифицированный труд должен цениться. Просто для меня это многовато. И тут я подумал - а почему бы не освоить самому это? Ведь лучше всего для себя могу сделать только я. Математику знаю хорошо, с логикой все в порядке, общее понятие о принципах программирования имею. В конце-концов, это для меня очень интересно и для здоровья полезно - бегство от Альцгеймера. И я занялся. Начал рыть информацию в интернете и в числе прочего наткнулся на этот форум. Должен сказать, ребята, что вы мне очень помогаете. Я уже кое-что знаю и умею. Совсем мало, конечно, но не полный ноль, как в начале. Вначале я ставил себе минимальную задачу - добавить пару полей в РасходнуюНакладную, пару справочников и все. Но по мере реализации плана у меня возникают новые и новые запросы. И я тоже их постепенно реализую. Времени только не хватает. Работаю в основном по ночам, когда никто не отвлекает. Единственное, о чем сожалею - это о том, что сутки имеют только 24 часа. Если бы в них было 36 часов, я бы уже, наверное, все бы закончил.
Здесь на форуме очень доброжелательная атмосфера и доходчивое изложение мыслей. Мне никто ни разу не сказал, чего ты сюда пришел, обратись к программисту. Никто не в претензии за простые вопросы. Никто не разговаривал со мной свысока. За это вам всем большое спасибо! Особо хочу поблагодарить... нет, не буду никого называть, а то вдруг кого-то пропущу. Короче, ребята, все, кто мне помог и помогает, еще раз большое вам всем спасибо, здоровья и удачи. Я это очень-очень ценю!
У вас очень высокоинтеллектуальное сообщество.
icon_beer17.gif 64000000.gif
  Форум: Тематическое общение · Просмотр сообщения: #156201 · Ответов: 0 · Просмотров: 73
 

>  Как настроить печатную форму в 1С 7.70.003 торговля склад для Украины?
ZUBR
Отправлено: 04.10.19, 0:57


Завсегдатай
****

Группа: Пользователи
Сообщений: 105
Регистрация: 05.07.19
Из: Київ
Пользователь №: 65920


Все получается. Только по бокам при просмотре печати остаются большие поля. И снизу и сверху тоже. Где их можно уменьшить, чтобы было больше места для печати? Это настройки принтера, или 1с?
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156190 · Ответов: 7 · Просмотров: 324
 

>  В печатной форме расходной накладной сумму прописью не пишет на украинском языке1С 7.70.003 торговля склад для Украины
ZUBR
Отправлено: 03.10.19, 21:48


Завсегдатай
****

Группа: Пользователи
Сообщений: 105
Регистрация: 05.07.19
Из: Київ
Пользователь №: 65920


Здравствуйте. Опять вопрос от меня. В печатной форме РасходнойНакладной все надписи на украинском языке, кроме суммы прописью.
Например: "Три тысячи семьсот сорок пять гривень 00 копеек" Как сделать, чтобы программа писала на украинском?

Этот момент в поиске не нашел, в гугле тоже. Кто сталкивался, подскажите, пожалуйста, пути решения проблемы. Читал, что нужно заменить какие-то файлы. Где их можно скачать и куда вставить?

Да, и еще названия месяцев тоже на русском. Нужно на украинском. Спасибо.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156171 · Ответов: 3 · Просмотров: 169
 

>  Как изменить дату на месяц? 1с 7.7 конф 7.7.00
ZUBR
Отправлено: 03.10.19, 21:20


Завсегдатай
****

Группа: Пользователи
Сообщений: 105
Регистрация: 05.07.19
Из: Київ
Пользователь №: 65920


Спасибо за поддержку. Вопрос по теме - а можно ли сделать так, чтобы в таблице в строке вместо начальной и конечной дат месяца стояло название самого месяца? Чтобы не городить кусок программы для этого. Есть такая возможность?
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156170 · Ответов: 5 · Просмотров: 178
 

>  Как изменить дату на месяц? 1с 7.7 конф 7.7.00
ZUBR
Отправлено: 03.10.19, 16:53


Завсегдатай
****

Группа: Пользователи
Сообщений: 105
Регистрация: 05.07.19
Из: Київ
Пользователь №: 65920


Здравствуйте. Я хочу создать отчет по результатам работы помесячно. Для этого в цикле прикаждом проходе мне нужно менять конечную дату месяца на месяц вперед. Есть такой оператор ДобавитьМесяц(). Но он тупо добавляет 30 дней. То есть, после февраля он выставит не 31 марта, а 28 марта, 28 апреля и т.д. Мне же нужно, чтобы при добавлении месяца получалась конечная дата каждого месяца. Как это можно сделать? Спасибо!
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156166 · Ответов: 5 · Просмотров: 178
 

>  Помогите понять принцип создания запросов в 1с 7.7 конф 7.7.00
ZUBR
Отправлено: 03.10.19, 16:43


Завсегдатай
****

Группа: Пользователи
Сообщений: 105
Регистрация: 05.07.19
Из: Київ
Пользователь №: 65920


Макс1С @ Сегодня, 9:22 * , я не понял, в чем проблема. Отчет формируется нормально. Можете объяснить?
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156165 · Ответов: 43 · Просмотров: 983
 

>  Помогите понять принцип создания запросов в 1с 7.7 конф 7.7.00
ZUBR
Отправлено: 02.10.19, 21:47


Завсегдатай
****

Группа: Пользователи
Сообщений: 105
Регистрация: 05.07.19
Из: Київ
Пользователь №: 65920


andrew76 @ Сегодня, 16:03 * , у меня вопрос тогда. Как к профессору. Какой вариант забирает меньше ресурсов и более быстродейственен? Вариант запросов? Или предложенный Вами? Вопрос чисто академический для лучшего понимания оптимальных методов программирования. Осмелюсь предположить, что Ваш вариант проще и лучше.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156138 · Ответов: 43 · Просмотров: 983
 

>  Помогите понять принцип создания запросов в 1с 7.7 конф 7.7.00
ZUBR
Отправлено: 01.10.19, 23:55


Завсегдатай
****

Группа: Пользователи
Сообщений: 105
Регистрация: 05.07.19
Из: Київ
Пользователь №: 65920


Доброй ночи! Сегодня создал нужній мне отчет. Небольшой. Состоит из 3 текстов запросов. Работает))) Очень Прошу профессуру посмотреть и дать свои замечания. Можно ли его сократить? Оптимизировать? Спасибо!

Процедура Сформировать()   

    Запрос = СоздатьОбъект("Запрос");
    
ТекстЗапросаС =
    "
    |Период с НачДата по КонДата;
    |ОбрабатыватьДокументы Проведенные;
    |СтатусЗаказа = Документ.РасходнаяНакладная.СтатусЗаказа;    
    |Товар = Документ.РасходнаяНакладная.Товар;
    |ВидТовара = Документ.РасходнаяНакладная.Товар.ВидТовара;
    |СуммаСНДС = Документ.РасходнаяНакладная.СуммаСНДС;
    |Функция Сум = Сумма(СуммаСНДС);

    |Функция СумУс = Сумма(СуммаСНДС) когда (ВидТовара = Перечисление.ВидыТоваров.Услуга);
    |Группировка Товар Без Групп;
    |Условие ((СтатусЗаказа = Перечисление.Статусы.Выдан)или(СтатусЗаказа = Перечисление.Статусы.Выезд)или(СтатусЗаказа = Перечисление.Статусы.ВыдОтказ));";
    
ТекстЗапросаК =
     "    
    |Период с НачДата по КонДата;
    |ОбрабатыватьДокументы Проведенные;
    |ТекДок = Документ.РасходнаяНакладная.ТекущийДокумент;
    |СтатусЗаказа = Документ.РасходнаяНакладная.СтатусЗаказа;
    |Функция КолСис = Счётчик(ТекДок);
    |Группировка  ТекДок;
    |Условие ((СтатусЗаказа = Перечисление.Статусы.Выдан)или(СтатусЗаказа = Перечисление.Статусы.Выезд)или(СтатусЗаказа = Перечисление.Статусы.ВыдОтказ));";
    
    ТекстЗапросаАкс =
    "
    |Период с НачДата по КонДата;
    |ОбрабатыватьДокументы Проведенные;
    |СтатусЗаказа = Документ.РасходнаяНакладная.СтатусЗаказа;    
    |Товар = Документ.РасходнаяНакладная.Товар;
    |СуммаСНДС = Документ.РасходнаяНакладная.СуммаСНДС;
    |Функция СумАкс = Сумма(СуммаСНДС);
    |Группировка Товар Без Групп;
    |Условие (СтатусЗаказа = Перечисление.Статусы.Акс);";
    
Запрос.Выполнить(ТекстЗапросаС);
    Пока Запрос.Группировка() = 1 Цикл
        Вал = Запрос.Сум;
        СумУс = Запрос.СумУс;
    КонецЦикла;
    
Запрос.Выполнить(ТекстЗапросаК);
   КолСис = Запрос.КолСис;
  
Запрос.Выполнить(ТекстЗапросаАкс);
    Пока Запрос.Группировка() = 1 Цикл
        СумАкс = Запрос.СумАкс;
    КонецЦикла;
    
Сообщить("Количество систем:"+КолСис);    
Сообщить("Сумма:"+Вал);
Сообщить("Сумма услуг:"+СумУс);
Сообщить("Сумма акс:"+СумАкс);


КонецПроцедуры
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156131 · Ответов: 43 · Просмотров: 983
 

>  Как изменить реквизит ВыбратьПериод в 1с 7.7 конф 7.7.003
ZUBR
Отправлено: 29.09.19, 21:54


Завсегдатай
****

Группа: Пользователи
Сообщений: 105
Регистрация: 05.07.19
Из: Київ
Пользователь №: 65920


andrew76 @ Сегодня, 19:15 * ,
я вот хочу отменить проведение документа в процедуре формы:

Процедура Выдать()
СтатусЗаказа = Перечисление.Статусы.Выдан;
    
  ТекущийДокумент().СделатьНеПроведенным();
    ДатаВыд = ТекущаяДата();
    ДатаДок = ТекущаяДата();    
    Форма.кнВыдать.Доступность(0);
    Форма.кнПодбор.Доступность(0);
    Форма.ДатаВыд.Доступность(0);
    Форма.СтатусЗаказа.Доступность(0);
    Форма.ДатаДок.Доступность(0);
    Записать();

КонецПроцедуры

Но мне пишет сообщение, что документ не выбран... Можно ли это сделать ?

Sharzem @ 23.09.19, 8:18 * , я не хочу створювати новий документ, тому що мені треба, щоб дані табличної частини оброблялись так, як вони обробляються зараз в ВидатковійНакладній. Реквізити її я практично не змінюю, а додаю свої. Ті, які мені потрібні. Тому, як Ви виразились, і "теліпаю" цей документ.


Ага, накопал. Этот метод используется только для объектов, созданных функцией "СоздатьОбъект" и его, наверное, нельзя использовать в модуле документа((
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156060 · Ответов: 18 · Просмотров: 599
 

>  Как изменить реквизит ВыбратьПериод в 1с 7.7 конф 7.7.003
ZUBR
Отправлено: 29.09.19, 14:20


Завсегдатай
****

Группа: Пользователи
Сообщений: 105
Регистрация: 05.07.19
Из: Київ
Пользователь №: 65920


Снова здравствуйте. Я вот решил обойти проблему с датами путем изменения даты проведенного документа на момент выдачи. Прописал все в модуле формы в процедуре Видати. Но система не желает сохранять документ с измененной датой. При перепроведении пишет предупреждение "Изменена дата проведенного документа!" И не закрывает документ и не перепроводит, пока не отменишь изменение даты. Где- то есть предохранитель. Я не могу найти. Если кто знает, подскажите, где он зашит и можно ли это ограничение отменить или обойти. Спасибо!
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156057 · Ответов: 18 · Просмотров: 599
 

>  Доступность кнопок и полей ввода в расходной накладной в 1С 7.70.003 торговля склад для Украины?
ZUBR
Отправлено: 29.09.19, 12:51


Завсегдатай
****

Группа: Пользователи
Сообщений: 105
Регистрация: 05.07.19
Из: Київ
Пользователь №: 65920


Здравствуйте! В своей доработке я добавил несколько кнопок и полей ввода в РасходнуюНакладную. При некоторых условиях я хочу их сделать недоступными. Я это прописал в коде модуля формы и это работает. Но при повторном открытии документа из журнала поля и кнопки снова становятся доступными. Как сделать, чтобы недоступность указанных полей и кнопок сохранялась? Спасибо!

Процедура Выдать()
СтатусЗаказа = Перечисление.Статусы.Выдан;
        ДатаВыд = ТекущаяДата();
    Форма.кнВыдать.Доступность(0);
    Форма.кнПодбор.Доступность(0);
    Форма.ДатаВыд.Доступность(0);
    Форма.СтатусЗаказа.Доступность(0);
    Записать();

КонецПроцедуры


ZUBR @ Сегодня, 13:33 * , так, озарение, как правило, приходит после того, как тема уже опубликована, и удалить ее я не могу. Отвечаю. В модуле формы есть процедура УстДоступностьКнопок. Вот в ней нужно указать условие и установить доступность. И тогда все сохраняется.

Процедура УстДоступностьКнопок()
    
    ......................................................................
         ......................................................................
    
    Если Симптомы = Константа.СимптомыУм Тогда Форма.Симптомы.Доступность(0);               //Моя вставка
       КонецЕсли;          
    Если СтатусЗаказа = Перечисление.Статусы.АКС Тогда Форма.СтатусЗаказа.Доступность(0);
    КонецЕсли;
    
    Если СтатусЗаказа = Перечисление.Статусы.Выдан Тогда
         Форма.кнВыдать.Доступность(0);
         Форма.кнПодбор.Доступность(0);
         Форма.ДатаВыд.Доступность(0);
         Форма.СтатусЗаказа.Доступность(0);
    КонецЕсли;
                                                                             //Конец моей вставки              
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156056 · Ответов: 0 · Просмотров: 156
 

5 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 14.10.19, 23:19
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!