Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )




>  Как загрузить номенклатуру из внешнего файла (Excel и др.) в 1С 8.3 штатными средствами?
glavkomnn
Отправлено: 30.11.19, 23:23


Молчаливый
*

Группа: Пользователи
Сообщений: 8
Регистрация: 28.06.14
Пользователь №: 36814


Коллеги приветствую!

Подавляющее большинство не знает, что разработчики оставили лазейку - возможность загрузить справочники в базу самостоятельно. Но оставить-то оставили, да не совсем. Ряд справочников доступен для загрузки, а некоторые стратегически важные, такие, как, например, Номенклатура - недоступны. Но путем нехитрых действий с расширениями можно добиться того, чтобы типовая загрузка могла загрузить в базу также и справочник Номенклатура. В данном видео описан порядок действий, чтобы этого достичь.

Неожиданно для себя наткнулся на то, что оказывается МОЖНО загрузить номенклатуру штатными средствами, встроенной загрузкой из файла в конфигурации УТ 11. Если немного подпилить её расширением.

Может кому пригодится, делюсь лайфхаком, записал на видео, как это можно сделать

В модуле менеджера обработки "ЗагрузкаИзВнешнегоФайла" надо в функции "СправочникСодержитРеквизитИсключение" закомментировать код:

Для каждого Реквизит Из Справочник.ТабличныеЧасти Цикл
        Если Реквизит.Имя <> "КонтактнаяИнформация"
            И Реквизит.Имя <> "ДополнительныеРеквизиты"
            И Реквизит.Имя <> "СертификатыШифрования" Тогда
                Возврат Истина;
        КонецЕсли;
    КонецЦикла;
    
    Для каждого Реквизит Из Справочник.Реквизиты Цикл
        Для каждого ТипРеквизита Из Реквизит.Тип.Типы() Цикл
            Если ТипРеквизита = Тип("ХранилищеЗначения") Тогда
                Возврат Истина;
            КонецЕсли;
        КонецЦикла;
    КонецЦикла;


Тогда справочник "Номенклатура" будет доступен в списке загрузки
И собственно вопрос
Вы не разбирались, по какой причине разработчики зашили такое ограничение - не загружать "Доп. реквизиты" и "Хранилище значения". Это намеренный ход или случайное совпадение, что самый стратегически загружаемый справочник, содержащий такие реквизиты, оказался за пределами возможностей загрузки?
  Форум: Обучающее видео · Просмотр сообщения: #158112 · Ответов: 0 · Просмотров: 387
 

>  Как изменить пробитый чек 1С 8.3
glavkomnn
Отправлено: 10.11.19, 18:32


Молчаливый
*

Группа: Пользователи
Сообщений: 8
Регистрация: 28.06.14
Пользователь №: 36814


Как исправить пробитый чек ККМ - отменить, редактировать, удалить и т.п.

Справедливо для конфигураций 1С 8.3., в которых есть функционал розничной торговли: Розница 2.1/2.2/2.3, УТ 11, БП 3.0, КА 2, ERP 2 и др.

На примере конфигурации Розница 2.3.1.130, платформа 8.3.13.1690

видео с примером
  Форум: Обучающее видео · Просмотр сообщения: #157382 · Ответов: 0 · Просмотров: 384
 

>  Групповое изменение реквизитов - Произвольный алгоритм
glavkomnn
Отправлено: 04.11.19, 17:17


Молчаливый
*

Группа: Пользователи
Сообщений: 8
Регистрация: 28.06.14
Пользователь №: 36814


Основные возможности способа обработки данных "Произвольный алгоритм" в инструменте "Групповое изменение реквизитов", который имеется в основных типовых конфигурациях 1С 8.3 на управляемых формах ("УТ 11, БП 3.0, ЗУП 3.1, КА 2, ERP 2 и др.)

На примере конфигурации "Управление торговлей 11.4", платформа 8.3.13.1690

Инструментом можно обрабатывать по собственному правилу любые справочники, документы и их табличные части с любыми отборами, и даже создавать новые. Ограничений в способах обработки практически нет. Фактически без привлечения программиста можно изменить данные своей базы как угодно. Надо только знать правила написания команд и выполнения кода...

  Форум: Обучающее видео · Просмотр сообщения: #157203 · Ответов: 0 · Просмотров: 1489
 

>  Как в отчет 1С добавить колонки, которые в нём не предусмотрены
glavkomnn
Отправлено: 04.11.19, 17:15


Молчаливый
*

Группа: Пользователи
Сообщений: 8
Регистрация: 28.06.14
Пользователь №: 36814


Возможности и правила использования пользовательских полей в схеме компоновки данных отчета.

На примере типового отчета "Валовая прибыль предприятия" конфигурации "Управление торговлей 11.4", платформа 8.3.13.1690

  Форум: Обучающее видео · Просмотр сообщения: #157202 · Ответов: 0 · Просмотров: 874
 

>  Универсальный отчет 1С - как им пользоваться?
glavkomnn
Отправлено: 09.10.19, 0:51


Молчаливый
*

Группа: Пользователи
Сообщений: 8
Регистрация: 28.06.14
Пользователь №: 36814


Коллеги приветствую!

Как мог, попытался описать по своим наблюдениям и практике, разобрать основные возможности инструмента "Универсальный отчёт", присутствующего в большинстве основных типовых конфигураций 1С 8.3 на управляемых формах ("УТ 11, БП 3.0, ЗУП 3.1, КА 2, ERP 2 и др.)

Конкретно использовал универсальный отчёт конфигурации "Управление торговлей 11.4", платформа 8.3.13.1690

Кто хорошо разбирается в этой теме, с какой основной целью его добавили в типовые конфигурации и как им правильно пользоваться?

Можно ли с его помощью делать соединения, запросы, строить произвольные алгоритмы, то что позволяла консоль отчетов 8.2? Где в типовых конфигурациях 8.3 на управляемых формах, то что на конфах 8.2 называлось консоль отчетов?
  Форум: Управление торговлей для Украины редакция 3 (Уп... · Просмотр сообщения: #156347 · Ответов: 0 · Просмотров: 489
 

>  Резервное копирование 1с: быстрый и удобный способ восстановления данных без выхода пользователей
glavkomnn
Отправлено: 06.10.19, 15:58


Молчаливый
*

Группа: Пользователи
Сообщений: 8
Регистрация: 28.06.14
Пользователь №: 36814


Как сделать резервную копию отдельно взятых справочников или документов программы 1С Бухгалтерия для Украины, не останавливая работу, не выгоняя пользователей и не теряя время на выгрузку и загрузку копии базы.

Автор предлагает оригинальный способ.

Очень быстрая выгрузка копии нужного участка данных и их восстановление в базе 1С после неудачных экспериментов с базой.

  Форум: Обучающее видео · Просмотр сообщения: #156247 · Ответов: 1 · Просмотров: 471
 

>  Как в отчет 1С добавить колонки, которые в нём не предусмотрены
glavkomnn
Отправлено: 06.10.19, 15:56


Молчаливый
*

Группа: Пользователи
Сообщений: 8
Регистрация: 28.06.14
Пользователь №: 36814


Возможности и правила использования пользовательских полей в схеме компоновки данных отчета.

На примере типового отчета "Валовая прибыль предприятия" конфигурации "Управление торговлей 11.4", платформа 8.3.13.1690

  Форум: Обучающее видео · Просмотр сообщения: #156246 · Ответов: 0 · Просмотров: 540
 

>  Как самостоятельно настроить любой документ 1С 8.3 (управляемые формы)
glavkomnn
Отправлено: 06.10.19, 15:54


Молчаливый
*

Группа: Пользователи
Сообщений: 8
Регистрация: 28.06.14
Пользователь №: 36814


Основные возможности пользовательской настройки форм документов и справочников любых конфигураций 1С 8.3 на управляемых формах.

На примере типового документа "Заказ клиента" конфигурации "Управление торговлей 11.4", платформа 8.3.13.1690

  Форум: Обучающее видео · Просмотр сообщения: #156245 · Ответов: 0 · Просмотров: 547
 


Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 04.08.20, 1:19
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!