Версия для печати темы (https://pro1c.org.ua/index.php?s=691300b74110e36807a8deb424639ede&showtopic=67037)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Программирование в 1С Предприятие 7.7 _ Как можно запретить отмену проведения докумена, если документ сделал проводку на 281 счет?

Автор: kostya77 26.07.22, 7:43

Добрый день. Как можно запретить отмену проведения докумена, если документ сделал проводку на 281 счет?

Автор: sava1 26.07.22, 8:05

типа так

// глобальный модуль

Процедура ПриОтменеПроведенияДокумента(Док)

    Если Док.СуществуетОперация()=1 Тогда

        Опер = Док.Операция;
        Опер.ВыбратьПроводки();  // тут можно проверить наличие проводок
        Пока Опер.ПолучитьПроводку()=1 Цикл

                        Если Опер.СчетДт = !нужныйСчет!  Тогда
                               СтатусВозврата(0);
                               Предупреждение("Низзя распроводить документ");
                               Возврат;
                        КонецЕсли;  
    
        КонецЦикла;
    КонецЕсли;


КонецПроцедуры

Автор: kostya77 26.07.22, 8:09

спасибо.

Автор: andreydv87 27.07.22, 11:49

kostya77 @ Вчера, 8:43 * ,
Можно в глобальном модуле подправить, как написал SAVA1, а можно попробовать через подписку на событие, если надо для конкретных документов.

Автор: sava1 27.07.22, 14:05

andreydv87 @ Сегодня, 12:49 * ,

это 77 - какая подписка?

Автор: andreydv87 28.07.22, 10:28

sava1 @ Вчера, 15:05 * ,
Раздел не увидел, а в теме не указано...

Тогда глобальный модуль.

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua