Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



История благодарностей участнику astonvilla ::: Спасибо сказали: 66 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
31.03.21, 17:19 Групповая выгрузка налоговых документов XML
вот обработка под BAS 2.1.11, проверяйте ))
и да, не забудьте заменить в документе ВыгрузкаРегламентированныхОтчетов код процедуры СформироватьИЗаписать на

    // реквизиты шапки берем из первого документа, если такой есть
    Если ДокументыОснования.Количество() = 0 Тогда
        Возврат Ложь;
    КонецЕсли;
    
    ПервыйДок                              = ДокументыОснования.Получить(0).Значение;
    Дата                                  = ТекущаяДата();
    
    Объект.Основание                      = ПервыйДок;
    ЗаполнитьИнформациюОбОтчете();    
    
    РеквизитыДокумента = Новый Структура();
    РеквизитыДокумента.Вставить("Организация");
    ПолучитьРеквизитыДокумента(Объект.Основание, РеквизитыДокумента);        
    
    Объект.Организация                      = РеквизитыДокумента.Организация;
    
    СформироватьТаблицуВыгрузки();
    
    ПолучитьДанныеДляВыгрузки();
    
    // формируем текст выгрузки. Если во время формирования произошла ошибка - вернем признак ошибки
    Попытка
        СформироватьТекстыВыгрузкиКлиент(ПервыйДок);
    Исключение
                
        Сообщение = Новый СообщениеПользователю;

        Сообщение.Текст = РегламентированнаяОтчетностьКлиентСервер.СформироватьТекстСообщения(ОписаниеОшибки());

        Сообщение.Сообщить();
        
        ОшибкаВыгрузки = Истина;
        
    КонецПопытки;
    
    Если ОшибкаВыгрузки = Истина Тогда
        Возврат Ложь;
    КонецЕсли;
    
    Попытка
        СохранитьТексты(КаталогСохранения, , , , ВВебКлиентеСохранятьФайлВыгрузкиИнтерактивно);
    Исключение
        
        Сообщение = Новый СообщениеПользователю;

        Сообщение.Текст = РегламентированнаяОтчетностьКлиентСервер.СформироватьТекстСообщения(ОписаниеОшибки());

        Сообщение.Сообщить();
        
        ОшибкаВыгрузки = Истина;
        
    КонецПопытки;
    
    Если ОшибкаВыгрузки Тогда
        Возврат Ложь;
    КонецЕсли;
    
    Возврат Истина;    
    
    
    Результат = ПродолжитьВызов(ДокументыОснования, КаталогСохранения, ВВебКлиентеСохранятьФайлВыгрузкиИнтерактивно);
    Возврат Результат;


код также можно взять из файла cfu во вложении
Al_na, anna282, buhadmin, cloud, Coast, CSotec, fedchishen, romangrom, shaman_003, VSB, webturist, Румата, Сергій, _kr0t_,
11.03.21, 13:29 Групповая выгрузка налоговых документов XML
Вариант обработки для бухгалтерии 2.0.16
anna282, buhadmin, Coast, kit7772010, oleg2020, Vofka,
04.12.20, 12:14 Отправить данные из 1с на SQL
astonvilla @ 01.12.20, 17:37 * ,
Разобрался... Параметры в данном случае надо было передавать по другому.
Ну и, как выяснилось, ошибку еще возвращало, т.к. номер карты был несуществующий ))
Окончательно это теперь выглядит так, может кому поможет в будущем..
    
        Command = Новый COMОбъект("ADODB.Command");
    Command.CommandTimeout = 100;
    Command.ActiveConnection = Соединение;
    Command.CommandText = "p_AddPin2";
    Command.CommandType = 4;                        
    Command.Parameters("@cardNo").Value = "77088800000000125";
    Command.Parameters("@pin").Value = 1254;
        Command.Execute();
Vofka,
15.05.20, 11:48 Обработка - Декомпилятор объектов
redigorovich @ 11.05.20, 10:54 * ,
10$ на карту админам, для поддержки сайта и они в ответ высылают пароль
(шепотом: "почитайте правила")
Bernet,
12.03.20, 20:09 Внешний отчет "Продажи и прибыль" для "Бухгалтерия для Украины"
[attachment=1189:ProdPrib.rar]Вариант для Бухгалтерии 2.0. Сделан с полгода назад на основе версии для 1.2.

Учитывая, что коммерческой ценности он особой не имеет, выкладываю для свободного доступа.

Он же сегодня выложен на инфостарте, куда я при необходимости буду скидывать обновленные версии (хотя и вряд ли ))))

Доработки, исправления найденных ошибок разрешаются и привествуются )))

О коммерческом использовании прошу сообщать в передачах Лондонского радио в 17-00 по Киеву, каждую вторую субботу, используя кодовую фразу "Бабушка приехала" )))
brutalv4, nataxs, Vofka,
24.10.17, 17:37 Вывести все месяцы по оборотному регистру, даже не имеющие оборотов
Все - вопрос снят....
Все было до обидного элементарно.
В результатах запроса этих месяцев действительно нет (что собственно меня и сбивало с толку).
НО! Чтобы они появились достаточно было в обходе группировок указать "Все"...

ВыборкаПериод = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, "Период", "ВСЕ"); 
Пока ВыборкаПериод.Следующий() Цикл
    ОбластьПериод.Параметры.Заполнить(ВыборкаПериод);
    ТабДок.Вывести(ОбластьПериод, ВыборкаПериод.Уровень());
КонецЦикла;


https://its.1c.ru/db/metod8dev/content/2660/hdoc
andreykyiv@bigmir.net,
30.12.14, 11:05 Всем, пропустившим заполнение кодов при обновлении на релиз 307 платформы 7.7
Всем, пропустившим заполнение кодов при обновлении на релиз 307 платформы 7.7

При обновлении на релиз 307 есть возможность автозаполнения кодов ЕдИзм для печати в НН и НН2
Если вы это пропустили и номенклатуры в справочнике много то это становится реальной проблемой (для не программиста).

Для того чтобы ее решить может пригодится данная обработка.
malexmen, sicheva, sv111, tony.se, Vofka,
20.04.12, 11:40 Аптечний облік
Конфигурация на 7.7 для учета в аптеке
http://sinhro.net/76ye1ujh6unr/Аптека.zip.html
gunnerhans, klopit, leha5822, VitDOK, XBrut,
20.04.12, 11:36 Дополнение "Комиссионная торговля"
Дополнение "Комиссионная торговля" к типовой конфигурации "Бухгалтерский учет для Украины"
http://sinhro.net/5sv456v4aj2a/Комиссионна...рговля.zip.html
Во вложении мд-файл и документация.
klopit, Савадика,
19.04.12, 10:56 Внешний отчет "Продажи и прибыль" для "Бухгалтерия для Украины"
Внешний отчет "Продажи и прибыль" для "Бухгалтерия для Украины", редакция 1.2.
В архиве файл отчета и документация по установке и применению.
Скачать с sinhro.net
Скачать с сайта [attachment=611:Prodazi_...bil_BU82.zip]
abrafaks, Alen55, alex1c, ALEX_TARAN, Anderson, AT-2000, bogdan3112, Chiffi, craneua, crimson37, darimradost, denis84, gavrisholga, kolobok888, Ksena, light07, liksoft, MATEVI, mvk2000, natasha_za, pupkinv, sasha007, spmig, tvk-avto, vadim007, vikkov, viktorija_2005, Vofka,

RSS Текстовая версия Сейчас: 28.09.21, 8:43
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!