Версия для печати темы (https://pro1c.org.ua/index.php?s=e7f1e2fb4a28a9b955e3c995ac64fc0d&showtopic=67584)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Программирование в 1С Предприятие 8.3 _ НачалоВыбора или НачалоВыбораизСписка ? (1c 8.3 УФ)

Автор: andrew76 10.07.24, 11:24

Добрый день !

Имеется справочник Насосные с табличной частью Резервуары.
На форме форме (управляемой) ввода данных имеются поля ввода данных:
насосная,номер резервуара.
Пользователь сначала выбирает насосную.
Далее мне необходимо при выборе номера резервуара,сделать так ,чтобы в этом поле ввода появился список номеров резервуаров,
привязанных именно к насосной выбранной выше.На простых формах я это делал через событие НачалоВыбораИзСписка.
Как это сделать на упраляемых формах - затрудняюсь.

Автор: AnryMc 10.07.24, 11:48

andrew76 @ Сегодня, 12:24 * ,

Возможно как то так:

&НаКлиенте
//Замена стандартного выбора элементов
Процедура ХХХХХХХХХХХХХХХНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;

ВариантыВыбора = СписокМоихЗачений();

    Оповещение = Новый ОписаниеОповещения("ВыполнитьПослеВыбораНужного", ЭтотОбъект,  Элемент);

        ПоказатьВыборИзСписка(Оповещение, ВариантыВыбора, Элемент);

//*************

&НаКлиенте
Процедура ВыполнитьПослеВыбораНужного(РезультатВыбора, ДополнительныеПараметры) Экспорт
    
    Если РезультатВыбора = Неопределено Тогда
        Возврат;
    КонецЕсли;
    
    Объект.МойРеквизит= РезультатВыбора.Значение;
    
КонецПроцедуры

&НаСервер
Функция СписокМоихЗачений()
    
    ВариантыВыбора = Новый СписокЗначений();

//заполнить как надо - например запросом
    
    ВариантыВыбора.Добавить(НужноеМнеЗначение_1, "Представление нужного мне значения № 1 для отображения при выборе");

    Возврат ВариантыВыбора;
    
КонецФункции

Автор: andrew76 10.07.24, 12:49

AnryMc @ Сегодня, 14:48 * ,

А саму форму элемента справочника Насосных нельзя открыть программно ? Я пытаюсь,но открывается форма ввода нового элемента.

&НаКлиенте
Процедура РезервуарНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
        
СтандартнаяОбработка = Ложь;
Структура = Новый Структура("Насосная", Объект.Насосная);
ОткрытьФорму("Справочник.Насосная.Форма.ФормаЭлемента", Структура);


AnryMc @ Сегодня, 14:48 * ,

Большое Вам Спасибо ! Все работает !

Автор: DariaDaria 12.07.24, 10:35

А почему бы просто не воспользоваться такой штукой как СвязиПараметровВыбора? Прямо в свойствах реквизита или в свойствах элемента формы

Автор: AnryMc 14.07.24, 10:04

Цитата(DariaDaria @ 12.07.24, 11:35) *
А почему бы просто не воспользоваться такой штукой как СвязиПараметровВыбора? Прямо в свойствах реквизита или в свойствах элемента формы

Связь даст весь список
А если нужны дополнительные отборы???

//заполнить как надо - например запросом

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua