Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

История благодарностей участнику Kaliban ::: Спасибо сказали: 28 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
05.08.14, 9:29 Объединение баз данных на ур файлов
Цитата(Домовик @ 05.08.14, 7:10) *
кто-то подобное пробовал? чем чревато?

В теории возможно.
Объединяем мдшники, читаем новый словарь данных.
Закидываем дбфки попутно исправляя названия полей в соответствии с новым словарем.

Но даже если данные не пересекаются в вашей постановке - то они все-таки пересекаются как минимум в общем журнале.
Нужно или править таблицу журнала - либо грохнуть его и попробовать ТИ.
Так что в теории можно но гемморойно. Лучше и правда объединить мд и закинуть нужные данные каким нибудь переносом.
Домовик,
03.02.14, 12:37 Ошибка при проведении: Не заполнено значение реквизита ''Ставка НДС''
Цитата(ayzhan @ 03.02.14, 12:29) *
" В строке номер "1" табличной части "Товары": Не заполнено значение реквизита "Ставка НДС"!

СРОЧНО!!!!!
Заполните реквизит "Ставка НДС"!
Телеграфируйте млния!
Ardi, Vofka,
14.01.14, 17:29 Зарплата в УТП (курс) кому нужен?
Это все постмодерн.
В каноничном виде это выглядит так:
"Я ни%у@ не понял"
Ardi, XBrut,
17.06.13, 14:43 не выгружает реестр НН
Цитата(senia @ 17.06.13, 13:28) *
ничего-ничего, я могу и програмистом, только скажите куда копать
между 2-3 числом ничего не происходило, работала, как всегда


Читаем схему:
<xs:element name="T1RXXXXG41S" type="DGKodTypeDoc6_1Column"
....
<xs:element name="T1RXXXXG43S" type="DGKodRectification6Column"

G41S - Это вид доку-мента в реестре ПНП итд

Ищите нет ли какого косяка в этой колонке
senia,
06.02.13, 17:02 Получение даты без ''точек''
Цитата(apsorry @ 06.02.13, 15:45) *
Таб.Область(11, 3,11,3).Текст = ТаблТМЦ.ТМЦ.КвоЗаМесяц.Получить(ТаблТМЦ.Выпуск);//установка количества выпущенного чая

вот там нужно это сделать!


ДатаДляПечати=Строка(ТаблТМЦ.Выпуск);
ДатаДляПечати=стрЗаменить(ДатаДляПечати,".","");
Таб.Область(11, 3,11,3).Текст =ДатаДляПечати;



 i 

Выделяем код
 
apsorry,
21.08.12, 14:20 1С Выдал ошибку runtime library. Помогите решить!
mlg ни при чем.
А вот че там у вас на флешке похерилось - хз.
highwhite2,
24.05.12, 14:17 Сообщение о входе?
ПриНачалеРаботыСистемы()

Это если самому охота лог писать.
А так - 1С в режиме "Монитор" и просмотр журнала регистраций
Petrofan,
22.05.12, 14:09 Отчет Кросс-таблица в 7.7
С секциями.
Запустите конструктор запроса к БИ типа Шахматка.
Общий смысл поймете.
Flexy,
24.04.12, 13:57 Бухгалтерские итоги за определенное время
ВыполнитьЗапрос(<?>,,,,,,,)
Синтаксис:
ВыполнитьЗапрос(<НачалоПериода>,<КонецПериода>,<Счет>,<КоррСчет>,<Валюта>,<ТипИтогов>,<Периодичность>,<ТипСуммы>)
Назначение:
Выполнить отбор и расчет итогов по параметрам.
Возвращает число 1 - запрос выполнен; 0 - запрос не выполнен.
Параметры:
<НачалоПериода> - дата, документ или позиция начала периода запроса.
<КонецПериода> - дата, документ или позиция конца периода запроса.


Не оно?
Kutuzov,
24.02.12, 15:28 Расчет цены и/или кол-ва
Плевое дело:
сумма=1775,46
Множитель1=2    множитель2=887.73
Множитель1=3    множитель2=591.82
Множитель1=6    множитель2=295.91
Множитель1=127 множитель2=13.98
Множитель1=233 множитель2=7.62
Множитель1=254 множитель2=6.99
Множитель1=381 множитель2=4.66


алгоритм - самый тупой, "Перебор делителей"
хотите не тупой - обратитесь в университеты, они под ваше финансирование пару диссеров защитят.

код на диалекте 7.7
    сумма=;//задайте самостоятельно
    множительРазрядности=100;
    с1=сумма*множительРазрядности;
    предел=КвaдpaтныйКopeнь(с1);
     х=2;
     пока х<=предел Цикл
         
        частное=с1/х;
        остаток=Цел(частное)-(частное);
        Если остаток=0 Тогда
            Сообщить("Множитель1="+х+" множитель2="+частное/множительРазрядности);
        КонецЕсли;
        х=х+1;
    КонецЦикла;


результат работы я привел выше, можете проверить на калькуляторе.
bereznoy,
17.02.12, 10:04 Обработка Приват24 клиент-банк
Читатель дело говорит
    ДатаСтр=ДБФ.DATE; 
    год=Сред(ДатаСтр,3,2);
    мес=Сред(ДатаСтр,5,2);
    дн=Сред(ДатаСтр,7,2);
    дтВыписки=Дата(год,мес,дн);


Только подправьте циферки, мы ж не знаем в каком формате у вас дата
vethera,
31.01.12, 13:24 Обновление "древней" конфигурации
Давно это было.
266 критичный.
там изменен план счетов.
нужно почитать апдейтс.ткст от него.

а с 266 можно на последний.
вроде так.
vaStar,
23.01.12, 15:49 Экспорт НН из 1с в формате xml для последующего импорта в M.E.DOC
Цитата(olivv @ 23.01.12, 14:45) *
Хоть и отчеты уже обновляла и существует папка E:\.....\.....\ExtForms\Rp11q4.1.grp\


говорили уже
E:\.....\.....\ExtForms\Rp11q4.1.grp\
переименовать в
E:\.....\.....\ExtForms\Rp11q4.grp\
panyakin,
18.01.12, 16:38 Варианты реализации возможности пользователям выбрать строки из Таблицы
в 7-ке нет булево.
Сделать можно разными способами.
1-обработка подбора - смотреть как в типовой сделан подбор в документы, толька делать из формы журнала.
2-посмотреть как сделаны множественные фильтры в отчетах
3- как в предидущем совете, новая обработка с ТаблицейЗначений, с отдельной колонкой - в которой выводить пиктограмы(выбран-не выбран)
4- еще в Учойсе можно посмотреть как сделано.
короче много способов
Valdi77,
05.01.12, 17:27 Экспорт НН из 1с в формате xml для последующего импорта в M.E.DOC
Цитата(noom @ 05.01.12, 17:22) *
спасибо, но у меня посл Rp11q2.grp, нужно обновить?

Да. у вас отчетность за 2кв. а нужна за 4-й.
noom,
26.12.11, 13:00 Кор-ка остатков на 01.04
Константы->Сумму амортизации в БУ определять по данным НУ->Да
Лесик,
09.12.11, 9:47 Как сделать автоматичискую очистку в инвентаризации
Влепите в обработчик кнопки код:
ВыбратьСтроки();
пока получитьСтроку()=1 цикл
инвКоличество=0;
конеццикла;

вот и все
onis,
29.11.11, 10:05 Запрос с двумя периодами
Я бы сделал так.
Навскидку:

тз1-выкинуть
тз - видоизменить
    ТЗ = СоздатьОбъект("ТаблицаЗначений");
    ТЗ.НоваяКолонка("Сотрудник");
    ТЗ.НоваяКолонка("ИНН");
    ТЗ.НоваяКолонка("СельРада");
    ТЗ.НоваяКолонка("Нараховано0"); // !!!
    ТЗ.НоваяКолонка("Нараховано1"); // !!!


в цикле первого запроса заполняем
ТЗ.Нараховано0=Запрос.СуммаДО; // !!!

в цикле второго запроса:

    Пока Запрос1.Группировка("Сотрудник")=1 Цикл  
        Если Запрос1.Сотрудник.ПометкаУдаления()=1 Тогда
             Продолжить;
        КонецЕсли;
        Если Запрос1.Сотрудник.ЭтоГруппа()=1 Тогда
            Продолжить;
        КонецЕсли;
      
// моё
нс="";
если тз.найтиЗначение(Запрос1.Сотрудник,нс>0,"сотрудник") тогда
тз.ПолучитьСтрокуПоНомеру(нс);
тз.Нараховано1=Запрос1.СуммаДО; // !!!
иначе
       ТЗ.НоваяСтрока();
        ТЗ.Сотрудник=Запрос1.Сотрудник;
        ТЗ.ИНН=Запрос1.ИНН;
        ТЗ.СельРада=Запрос1.СельРада;
        ТЗ.Нараховано1=Запрос1.СуммаДО; // !!!
конецесли;


    КонецЦикла;


ну и перед выводом делаем

тз.Группировать("Сотрудник, и прочая","Нараховано0,Нараховано1")


смысл, думаю понятен.



Хе, даблшот.
Кстати внутри тега <код> не работает тег <b>
mavrik,
02.11.11, 10:33 Как программно добавить/изменить цены?
Ну если имена категорий жестко заданы и не будут изменяться никогда - будьте как все, хардкодьте.
Пример быдлокода:
...
Пока КатегорииЦен.ПолучитьЭлемент()=1 Цикл
если (категорияЦен.Наименование="Закупочная")или(категорияЦен.Наименование="Розничная") тогда
...
иначе
продолжить;
конецЕсли
...

если нужно произвольное количество произвольных категорий,
влепите на форму обработки список или тз, и вместо цикла по всем категориям выбирайте из списка или тз.
Делов то.
Flexy,
31.10.11, 10:07 Как программно добавить/изменить цены?
как-то так:
             ЦеныТовара = СоздатьОбъект("Справочник.Цены"); 
    Если ПустоеЗначение(НаДату)=1 Тогда
        НаДату = РабочаяДата();
    КонецЕсли;
    ЦеныТовара.ИспользоватьДату(НаДату);
    ЦеныТовара.ИспользоватьВладельца(Тов.ТекущийЭлемент());
    КатегорииЦен = СоздатьОбъект("Справочник.КатегорииЦен");
    КатегорииЦен.ВыбратьЭлементы();
    Пока КатегорииЦен.ПолучитьЭлемент()=1 Цикл
        Если КатегорииЦен.ПометкаУдаления()=1 Тогда
            Продолжить;
        КонецЕсли;
        Если ЦеныТовара.НайтиПоРеквизиту("КатегорияЦены",КатегорииЦен.ТекущийЭлемент(),0)=0 Тогда
            ЦеныТовара.Новый();
        Иначе
            Если ЦеныТовара.ПометкаУдаления()=1 Тогда
                Если Вопрос("Цена "+ЦеныТовара.КатегорияЦены+ " помечена на удаление и не будет заполнена.
                            |Снять пометку удаления?","Да+Нет")="Да" Тогда
                    Попытка
                        ЦеныТовара.СнятьПометкуУдаления();
                    Исключение
                    Предупреждение(ОписаниеОшибки());
                        Возврат;
                    КонецПопытки;            
                КонецЕсли;
                Продолжить;
            КонецЕсли;
        КонецЕсли;  
        //опр валюту  
        ВалютаЦ=Тов.ВалютаУчета;
        ЦеныТовара.Наименование = КатегорииЦен.Наименование;
        ЦеныТовара.Единица = Тов.ЕдиницаПоУмолчанию;
        ЦеныТовара.КатегорияЦены = КатегорииЦен.ТекущийЭлемент();    
                           //ВычисленнаяЦена= тащите их экселя;
         ЦеныТовара.Цена = ВычисленнаяЦена;
        // Попытка
        ЦеныТовара.Записать();
                     // Исключение                                                                                                                  х
         //    глТрассировка(ОписаниеОшибки(),0);
         //    Возврат;
                  // КонецПопытки;
        
    КонецЦикла;
Flexy,
26.09.11, 16:46 Функции работы со временем
Время - строка вида ЧЧ:ММ:СС

//------------------------------------------------------------ 
Функция разницаВрем(Время1,Время2) Экспорт
    рез=0;                                                                        
    //         секунды                    минуты                часы
    Время1Сек=Число(Прав(Время1,2))+Число(Сред(Время1,4,2))*60+Число(Лев(Время1,2))*60*60;
    Время2Сек=Число(Прав(Время2,2))+Число(Сред(Время2,4,2))*60+Число(Лев(Время2,2))*60*60;
    
    разнСек= Время1Сек- Время2Сек;
    
    часов=Цел(разнСек/(60*60) );
    минут=Цел( (разнСек-часов*60*60 )/60 );
    сек=разнСек-часов*60*60-минут*60;
    рез=Строка(Формат(часов,"Ч(0)2"))+":"+Строка(Формат(минут,"Ч(0)2"))+":"+Строка(Формат(сек,"Ч(0)2"));
    Возврат рез;
    
КонецФункции
//------------------------------------------------------------
Функция ВремяВСекунды(время1) Экспорт
    Время1Сек=0;                                                                        
    //         секунды                    минуты                часы
    Время1Сек=Число(Прав(Время1,2))+Число(Сред(Время1,4,2))*60+Число(Лев(Время1,2))*60*60;
    Возврат Время1Сек;    
КонецФункции                                                  

//------------------------------------------------------------
Функция СекундыВоВремя(Секунды) Экспорт  
    рез=0;
    часов=Цел(Секунды/(60*60) );
    минут=Цел( (Секунды-часов*60*60 )/60 );
    сек=Секунды-часов*60*60-минут*60;
    рез=Строка(Формат(часов,"Ч(0)2"))+":"+Строка(Формат(минут,"Ч(0)2"))+":"+Строка(Формат(сек,"Ч(0)2"));
    Возврат рез;
КонецФункции
//------------------------------------------------------------
Функция СуммаВрем(Время1,Время2) Экспорт
    рез=0;                                                                        
    //         секунды                    минуты                часы
    Время1Сек=Число(Прав(Время1,2))+Число(Сред(Время1,4,2))*60+Число(Лев(Время1,2))*60*60;
    Время2Сек=Число(Прав(Время2,2))+Число(Сред(Время2,4,2))*60+Число(Лев(Время2,2))*60*60;
    
    суммаСек= Время1Сек + Время2Сек;
    
    часов=Цел(суммаСек/(60*60) );
    минут=Цел( (суммаСек-часов*60*60 )/60 );
    сек=суммаСек-часов*60*60-минут*60;
    рез=Строка(Формат(часов,"Ч(0)2"))+":"+Строка(Формат(минут,"Ч(0)2"))+":"+Строка(Формат(сек,"Ч(0)2"));
    Возврат рез;
    
КонецФункции
//------------------------------------------------------------
mister-x, vadim007,
26.09.11, 16:32 27 релиз, баг объекта ФС
Платформа 27, сетевая и SQL, на других - не проверял

Объект ФС
метод ВыбратьФайл()

вызываем:
    ФС.ВыбратьФайл(0,Файл,Путь,,"все(*.*)|*.*",,);  
    Сообщить(Файл);


Баг:
Если имя файла длинее чем 63 символа в переменную файл, вернется только первые 63 символа имени.

В документации про это ничего не сказано.
mister-x, Vofka,
25.08.11, 14:43 Баг с типом учета (Общ,Упр,Фин)
Поймал забавный баг в последнем релизе ТиСа(7.70.020) с новым реестром НН.
Если вы на старый релиз накатывали реестр из 20 - у вас он тоже проявится.
Суть такова:
Пользователь заводит новый документ, к примеру, РН.
По умолчанию - тип учета "Общ". Второй документ - тоже "Общ", третий - "Общ".
Потом решает сформировать реестр. Формирует.
Снова заводит новый документ. Упс, а тип учета уже "Упр".

В чем же дело?
В глобальнике есть такие экспортируемые переменные:
// ===============================
// идентификаторы типов учета документов
Перем Общ Экспорт;
Перем Упр Экспорт;
Перем Фин Экспорт;
....
// ===============================
// Типы учета
Упр=0;
Общ=1;
Фин=2;


А в новом реестре такой фрагмент:
ОБЩ   = ?(СпецРежим = 0, "Х", "");


Динамическая типизация и необязательное объявлении переменных сыграли злую шутку.

Как говорил Козьма Прутков:
Бди!
Ardi, MATEVI,

RSS Текстовая версия Сейчас: 08.12.19, 2:17
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!