Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



6 страниц V   1 2 3 > » 

>  Нужен алгоритм обмена между базами
DrLivsi
Отправлено: 04.02.19, 11:41


Завсегдатай
****

Группа: Пользователи
Сообщений: 140
Регистрация: 13.08.11
Из: Киев
Пользователь №: 11051


andr_andrey @ Сегодня, 11:28 * ,

Только в одном документе насчитал около 20 ссылок на справочники, и что для каждого делать проверку?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #149493 · Ответов: 5 · Просмотров: 467
 

>  Нужен алгоритм обмена между базами
DrLivsi
Отправлено: 04.02.19, 11:19


Завсегдатай
****

Группа: Пользователи
Сообщений: 140
Регистрация: 13.08.11
Из: Киев
Пользователь №: 11051


Всем привет!

Прошу помощи в составлении схемы/алгоритма обмена между двумя базами.
Задача такая: раз в месяц, нужно перенести определенные документы, за выбранный период, из центральной базы в подчиненную.
Переносить нужно только новые документы (если в центральной базе они изменились, то нас это не интересует).
Конфигурации самописанные, но отличаются версии между ними.

Если делать перенос вручную, то сложно определять все связанные ссылки на новые объекты с этим документом, которые нужно перенести (Например создали нового контрагента и новую РТУ, то при переносе нужно понять что есть новый элемент справочника и перенести сначала его и.тд.).

Если делать через ПланОбмена, то в регистрацию для обмена не попадут документы с прошлых периодов. А в настройках переноса должна быть возможность выбрать произвольный период. Но зато попадут все новые созданные элементы справочников.

Как можно "скрестить" эти два способа что-бы получить оптимальный вариант?

  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #149491 · Ответов: 5 · Просмотров: 467
 

>  Выборка запросом по ТаблицеЗначений
DrLivsi
Отправлено: 04.12.18, 9:06


Завсегдатай
****

Группа: Пользователи
Сообщений: 140
Регистрация: 13.08.11
Из: Киев
Пользователь №: 11051


Тут собралась целая битва экстрасенсов, а автор тупо забил.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #147770 · Ответов: 10 · Просмотров: 709
 

>  Выборка запросом по ТаблицеЗначений
DrLivsi
Отправлено: 03.12.18, 16:05


Завсегдатай
****

Группа: Пользователи
Сообщений: 140
Регистрация: 13.08.11
Из: Киев
Пользователь №: 11051


Наверное забыли
Запрос.МенеджерВременныхТаблиц = Новый МенеджерВременныхТаблиц;
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #147746 · Ответов: 10 · Просмотров: 709
 

>  Мак адресс клиента
DrLivsi
Отправлено: 09.10.18, 15:39


Завсегдатай
****

Группа: Пользователи
Сообщений: 140
Регистрация: 13.08.11
Из: Киев
Пользователь №: 11051


l2d808 @ Сегодня, 15:27 * ,
https://www.forum.mista.ru/topic.php?id=327244
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #146118 · Ответов: 3 · Просмотров: 793
 

>  Вывод двух табличных документов в один с сохранением группировок
DrLivsi
Отправлено: 05.03.18, 9:34


Завсегдатай
****

Группа: Пользователи
Сообщений: 140
Регистрация: 13.08.11
Из: Киев
Пользователь №: 11051


sava1 @ 02.03.18, 17:04 * ,
Я так и делаю. Область1 и Область2 это табличные документы с определенными размерами. Объединяю в третьем ТабДок.

А можно ли как-то задать максимальное количество колонок в табличном документе?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #139327 · Ответов: 6 · Просмотров: 2225
 

>  Вывод двух табличных документов в один с сохранением группировок
DrLivsi
Отправлено: 02.03.18, 16:39


Завсегдатай
****

Группа: Пользователи
Сообщений: 140
Регистрация: 13.08.11
Из: Киев
Пользователь №: 11051


Vidocq05 @ Сегодня, 11:06 * ,
Вроде все описал. При получении области:
Область1 = ТабДокТаблица.ПолучитьОбласть("R1"+"C1:R"+Строка(ТабДокТаблица.ВысотаТаблицы)+ "C"+Строка(ТабДокТаблица.ШиринаТаблицы));

теряются группировки строк таблицы, которая находится в табличном документе "ТабДокТаблица". Но без этого кода невозможно присоединить справа другую область с диаграммой .
Она будет выведена внизу.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #139242 · Ответов: 6 · Просмотров: 2225
 

>  Вывод двух табличных документов в один с сохранением группировок
DrLivsi
Отправлено: 28.02.18, 13:55


Завсегдатай
****

Группа: Пользователи
Сообщений: 140
Регистрация: 13.08.11
Из: Киев
Пользователь №: 11051


Всем привет!
Нужно получить отчет, в котором слева будет таблица, а справа напротив нее диаграмма. И главное сохранить группировки в таблице.
Вывожу в один табличный документ таблицу, а во второй диаграмму. Дальше соединяю в один:
Область1 = ТабДокТаблица.ПолучитьОбласть("R1"+"C1:R"+Строка(ТабДокТаблица.ВысотаТаблицы)+ "C"+Строка(ТабДокТаблица.ШиринаТаблицы));
Область.ОтображатьГруппировки = Истина;

Область2 = ТабДокДиаграмма.ПолучитьОбласть("R1"+"C1:R"+Строка(ТабДокДиаграмма.ВысотаТаблицы)+ "C"+Строка(ТабДокДиаграмма.ШиринаТаблицы));
    
ТабДок.Вывести(Область1);
ТабДок.Присоединить(Область2);

Но в результате теряются группировки в таблице. Подскажите как решить задачу.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #139136 · Ответов: 6 · Просмотров: 2225
 

>  Обмен данными между базами без РИБ
DrLivsi
Отправлено: 20.12.17, 9:34


Завсегдатай
****

Группа: Пользователи
Сообщений: 140
Регистрация: 13.08.11
Из: Киев
Пользователь №: 11051


Moloko @ 16.12.17, 13:39 * ,
Можно подробнее, как реализована логика обмена через конвертацию данных?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #136410 · Ответов: 2 · Просмотров: 824
 

>  Передать таблицу значений в построитель отчета
DrLivsi
Отправлено: 06.11.17, 16:46


Завсегдатай
****

Группа: Пользователи
Сообщений: 140
Регистрация: 13.08.11
Из: Киев
Пользователь №: 11051


Vidocq05 @ Сегодня, 17:33 * ,
ПостроительОтчета.Параметры.Вставить(Ключ, Значение);

<Ключ> (обязательный)

Тип: Строка.
Ключ устанавливаемого элемента. Ключ должен соответствовать правилам, установленным для идентификаторов:
Первым символом ключа должна быть буква или символ подчеркивания (_).
Каждый из последующих символов может быть буквой, цифрой или символом подчеркивания (_).
<Значение> (необязательный)

Тип: Произвольный.
Значение устанавливаемого элемента.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #134492 · Ответов: 7 · Просмотров: 4286
 

>  Запросом не выводит или не находит ПКО
DrLivsi
Отправлено: 26.10.17, 8:04


Завсегдатай
****

Группа: Пользователи
Сообщений: 140
Регистрация: 13.08.11
Из: Киев
Пользователь №: 11051


Constantus @ Сегодня, 8:48 * ,
Уберите все условия, если выводит, то добавляйте по-одному. Так будет ясно на каком условии его исключает.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #133976 · Ответов: 8 · Просмотров: 877
 

>  Запрос к табличной части документа
DrLivsi
Отправлено: 24.10.17, 15:31


Завсегдатай
****

Группа: Пользователи
Сообщений: 140
Регистрация: 13.08.11
Из: Киев
Пользователь №: 11051


ВЫБРАТЬ
    ОтчетОРозничныхПродажахТовары.Сумма
ИЗ
    Документ.ОтчетОРозничныхПродажах.Товары КАК ОтчетОРозничныхПродажахТовары


и т.д.
  Форум: Программирование в 1С Предприятие 8.1 (8.0) · Просмотр сообщения: #133885 · Ответов: 8 · Просмотров: 2929
 

>  Работа с "Интайм" по API
DrLivsi
Отправлено: 24.10.17, 8:56


Завсегдатай
****

Группа: Пользователи
Сообщений: 140
Регистрация: 13.08.11
Из: Киев
Пользователь №: 11051


Решил. Вот может кому-то пригодится

Попытка
        Форма.WSDLОпределение = Новый WSОпределения("http://esb.intime.ua:8080/services/intime_api_3.0?wsdl");
        WSСервис = Форма.WSDLОпределение.Сервисы[0];
        Форма.прокси = Новый WSПрокси(Форма.WSDLОпределение, WSСервис.URIПространстваИмен, WSСервис.Имя, WSСервис.ТочкиПодключения[0].Имя);
    Исключение
        Форма.WSDLОпределение = Неопределено;
        Сообщить(ОписаниеОшибки());
    КонецПопытки;
    
    Если Форма.WSDLОпределение = Неопределено Тогда
        Сообщить("Не удалось подключится");
         Возврат;
    КонецЕсли;
    
    // Получаем все операци
    WSОперации = WSСервис.ТочкиПодключения[0].Интерфейс.Операции;
    
    //Получаем тип параметра, который передается в метод G
    Форма.WSDLОпределение.ФабрикаXDTO.Пакеты.Получить("http://ws.wso2.org/dataservice").Получить("get_country_by_id");
    
    //Создаем параметр на основе типа и заполняем значение параметра api_key
    WSПараметр       = Форма.Прокси.ФабрикаXDTO.Создать(ТипWSПараметра);
    WSПараметр.api_key    = АПИКлюч;
    WSПараметр.id    = "";
    
    //Вызываем метод веб-сервиса, записываем результат в переменную list_of_countries
    list_of_countries = Форма.Прокси.get_country_by_id(WSПараметр);
    
    Для Каждого Country Из list_of_countries.Entry_get_country_by_id Цикл
        Сообщить(Country.code+" "+Country.name_en+" "+Country.name_ru);
    КонецЦикла;


DrLivsi @ Сегодня, 9:48 * ,

Небольшая ошибка в строке
//Получаем тип параметра, который передается в метод G
    Форма.WSDLОпределение.ФабрикаXDTO.Пакеты.Получить("http://ws.wso2.org/dataservice").Получить("get_country_by_id");

нужно вот так:
//Получаем тип параметра, который передается в метод G
    ТипWSПараметра = Форма.WSDLОпределение.ФабрикаXDTO.Пакеты.Получить("http://ws.wso2.org/dataservice").Получить("get_country_by_id");
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #133848 · Ответов: 7 · Просмотров: 1732
 

>  Работа с "Интайм" по API
DrLivsi
Отправлено: 23.10.17, 14:25


Завсегдатай
****

Группа: Пользователи
Сообщений: 140
Регистрация: 13.08.11
Из: Киев
Пользователь №: 11051


Вот что сейчас получилось:

Попытка
        Форма.WSDLОпределение = Новый WSОпределения("http://esb.intime.ua:8080/services/intime_api_3.0?wsdl");
        WSСервис = Форма.WSDLОпределение.Сервисы[0];
        Форма.прокси = Новый WSПрокси(Форма.WSDLОпределение, WSСервис.URIПространстваИмен, WSСервис.Имя, WSСервис.ТочкиПодключения[0].Имя);
    Исключение
        Форма.WSDLОпределение = Неопределено;
        Сообщить(ОписаниеОшибки());
    КонецПопытки;
    
    Если Форма.WSDLОпределение = Неопределено Тогда
        Сообщить("Не удалось подключится");
         Возврат;
    КонецЕсли;
    
    
    WSОперации = WSСервис.ТочкиПодключения[0].Интерфейс.Операции;
        
    ОперацияПолучитьСтраны = WSОперации.Получить("get_country_by_id");
    
    ДанныеXDTO = Форма.WSDLОпределение.ФабрикаXDTO.Создать(ОперацияПолучитьСтраны.Параметры[0].Тип.Свойства.Получить("api_key").Тип, АПИКлюч);
    
    ОтветОтСервера = Форма.прокси.get_country_by_id(ДанныеXDTO); // Вызываем операцию


При выполнении последней строки вылетает ошибка:

При вызове веб-сервиса произошла ошибка. Ошибка SOAP сервера: DS Code: INCOMPATIBLE_PARAMETERS_ERROR
Nested Exception:-
javax.xml.stream.XMLStreamException: DS Fault Message: Error in 'CallQuery.extractParams', cannot find parameter with type:query-param name:api_key
DS Code: INCOMPATIBLE_PARAMETERS_ERROR
Source Data Service:-
Name: intime_api_3.0
Location: /intime_api_3.0.dbs
Description: N/A
Default Namespace: http://ws.wso2.org/dataservice
Current Request Name: get_country_by_id
Current Params: {}

Код ошибки: INCOMPATIBLE_PARAMETERS_ERROR
Техническая информация:
<detail xmlns:axis2ns3335="http://ws.wso2.org/dataservice" xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
<axis2ns3334:DataServiceFault xmlns:axis2ns3334="http://ws.wso2.org/dataservice">
<axis2ns3334:current_params>{}</axis2ns3334:current_params>
<axis2ns3334:source_data_service>
<axis2ns3334:data_service_name>intime_api_3.0</axis2ns3334:data_service_name>
<axis2ns3334:description>N/A</axis2ns3334:description>
<axis2ns3334:location>/intime_api_3.0.dbs</axis2ns3334:location>
<axis2ns3334:default_namespace>http://ws.wso2.org/dataservice</axis2ns3334:default_namespace>
</axis2ns3334:source_data_service>
<axis2ns3334:ds_code>INCOMPATIBLE_PARAMETERS_ERROR</axis2ns3334:ds_code>
<axis2ns3334:current_request_name>get_country_by_id</axis2ns3334:current_request_name>
</axis2ns3334:DataServiceFault>
</detail>
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #133804 · Ответов: 7 · Просмотров: 1732
 

>  Работа с "Интайм" по API
DrLivsi
Отправлено: 23.10.17, 12:05


Завсегдатай
****

Группа: Пользователи
Сообщений: 140
Регистрация: 13.08.11
Из: Киев
Пользователь №: 11051


Bernet @ Сегодня, 12:27 * ,
Ключ получил, WSОпределение создает нормально, дальше ругается на первой строке, может я тип не тот указываю

AuthData = Прокси.ФабрикаXDTO.Тип("http://inr.intime.ua/in-time/integration30","AuthData");
ЭлементЗапросаAuthData = WSDLОпределение.ФабрикаXDTO.Создать(AuthData);
            
ЭлементЗапросаAuthData.KEY = АПИКлюч;
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #133801 · Ответов: 7 · Просмотров: 1732
 

>  Работа с "Интайм" по API
DrLivsi
Отправлено: 23.10.17, 11:02


Завсегдатай
****

Группа: Пользователи
Сообщений: 140
Регистрация: 13.08.11
Из: Киев
Пользователь №: 11051


Bernet @ Сегодня, 11:42 * ,

Я ее видел, но она для версии API 2.0 а интайм уже работает с API 3.0

На сайте есть описание функций:
Скачать документацию API 3.0

но как к ним "достучатся"?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #133790 · Ответов: 7 · Просмотров: 1732
 

>  Работа с "Интайм" по API
DrLivsi
Отправлено: 23.10.17, 10:16


Завсегдатай
****

Группа: Пользователи
Сообщений: 140
Регистрация: 13.08.11
Из: Киев
Пользователь №: 11051


Всем привет!
Нужна помощь в подключении к апи Интайм. Раньше с таким не сталкивался, не могу понять как выполнить подключение. Или может у кого-то уже есть обработка.
Пока меня хватило на вот такой код:
Процедура Подключение(Форма) Экспорт
Попытка
        WSDLОпределение = Новый WSОпределения("http://esb.intime.ua:8080/services/intime_api_3.0?wsdl");
        WSСервис = WSDLОпределение.Сервисы[0];
        прокси = Новый WSПрокси(WSDLОпределение, WSСервис.URIПространстваИмен, WSСервис.Имя, WSСервис.ТочкиПодключения[0].Имя);
    Исключение
        WSDLОпределение = Неопределено;
        Сообщить(ОписаниеОшибки());
    КонецПопытки;
КонецПроцедуры

но что дальше с этим делать не пойму.
Конфа самописная 8.3.8.2088 обычные формы. Буду благодарен за любую помощь.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #133786 · Ответов: 7 · Просмотров: 1732
 

>  Ошибка в тонком клиенте через web
DrLivsi
Отправлено: 04.10.17, 8:14


Завсегдатай
****

Группа: Пользователи
Сообщений: 140
Регистрация: 13.08.11
Из: Киев
Пользователь №: 11051


Всем привет!
Есть такая проблема, начала возникать ошибка в тонком клиенте через веб браузер. При просмотре табличного документа (отчетов) не работает прокрутка вверх/вниз. В хроме просто не листает, а мозила выдает вот это:

Web сервер, платформа не обновлялась. Конфигурация самописная 8.3.8.2088
Подскажите кто знает.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #132991 · Ответов: 3 · Просмотров: 1154
 

>  Отчет по товарам на складах: заблокировать возможность изменения отбора по складам
DrLivsi
Отправлено: 15.06.17, 16:35


Завсегдатай
****

Группа: Пользователи
Сообщений: 140
Регистрация: 13.08.11
Из: Киев
Пользователь №: 11051


Flexy @ Сегодня, 16:59 * ,
Я же написал выше код, там не только галка устанавливается, а и вид сравнения и значение.
Только перед этим кодом нужно делать проверку, что-бы не задваивать.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #128407 · Ответов: 15 · Просмотров: 2403
 

>  Отчет по товарам на складах: заблокировать возможность изменения отбора по складам
DrLivsi
Отправлено: 15.06.17, 16:14


Завсегдатай
****

Группа: Пользователи
Сообщений: 140
Регистрация: 13.08.11
Из: Киев
Пользователь №: 11051


Constantus @ Сегодня, 15:54 * ,

Процедура СформироватьОтчет вызывается каждый раз при нажатии на кнопку "Сформировать" и что-бы пользователь с этой галочкой не делал в отборе, она все равно станет в истину перед формированием отчета:
УниверсальныйОтчет.ПостроительОтчета.Отбор.Склад.Использование = Истина;
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #128399 · Ответов: 15 · Просмотров: 2403
 

>  Отчет по товарам на складах: заблокировать возможность изменения отбора по складам
DrLivsi
Отправлено: 15.06.17, 14:47


Завсегдатай
****

Группа: Пользователи
Сообщений: 140
Регистрация: 13.08.11
Из: Киев
Пользователь №: 11051


Constantus @ Сегодня, 15:30 * ,

Я делаю в процедуре СформироватьОтчет()

Процедура СформироватьОтчет(ТабличныйДокумент) Экспорт
    
    УниверсальныйОтчет.ПостроительОтчета.Отбор.Добавить("Склад", "Склад", "Склад");
    УниверсальныйОтчет.ПостроительОтчета.Отбор.Склад.Использование = Истина;
    УниверсальныйОтчет.ПостроительОтчета.Отбор.Склад.Видсравнения = ВидСравнения.Равно;
    УниверсальныйОтчет.ПостроительОтчета.Отбор.Склад.Значение      = Склад;

КонецПроцедуры


Перед установкой нужно еще проверить не установлен ли уже отбор.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #128380 · Ответов: 15 · Просмотров: 2403
 

>  Места хранения склада: учет времени хранения
DrLivsi
Отправлено: 22.03.17, 10:55


Завсегдатай
****

Группа: Пользователи
Сообщений: 140
Регистрация: 13.08.11
Из: Киев
Пользователь №: 11051


Constantus @ Сегодня, 10:44 * ,
У нас в регистре накопления есть реквизиты "Секция" и "Ячейка", в документе перемещение, есть колонки "Секция Откуда", "Ячейка откуда" и "Секция куда" "Ячейка куда". У каждого склада есть свои секции и ячейки.
Потом отчетом смотрим в разрезе секций и ячеек.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #124502 · Ответов: 2 · Просмотров: 798
 

>  Выгрузка базы на ftp
DrLivsi
Отправлено: 16.03.17, 12:43


Завсегдатай
****

Группа: Пользователи
Сообщений: 140
Регистрация: 13.08.11
Из: Киев
Пользователь №: 11051


Короче для быстрого решения вопроса, написал регламентное задание, которое будет каждый день брать последний файл бекапа и ложить его на ftp. А бекап буду делать как и раньше bat -файлом.
Всем спасибо за помощь!
  Форум: Администрирование и настройка 1С · Просмотр сообщения: #124191 · Ответов: 16 · Просмотров: 2377
 

>  Выгрузка базы на ftp
DrLivsi
Отправлено: 16.03.17, 11:12


Завсегдатай
****

Группа: Пользователи
Сообщений: 140
Регистрация: 13.08.11
Из: Киев
Пользователь №: 11051


Vofka @ Сегодня, 9:42 * ,
В диалоге, в строке адреса вставляю: "ftp://Login:password@ServerFTP"
  Форум: Администрирование и настройка 1С · Просмотр сообщения: #124186 · Ответов: 16 · Просмотров: 2377
 

>  Выгрузка базы на ftp
DrLivsi
Отправлено: 16.03.17, 9:21


Завсегдатай
****

Группа: Пользователи
Сообщений: 140
Регистрация: 13.08.11
Из: Киев
Пользователь №: 11051


logist @ Вчера, 20:47 * ,
В обработке у меня FTPСоединение с авторизацией, писал ее для теста, и она нормально выгружает.
ФТП = Новый FTPСоединение(ФТПХост, , ФТППользователь, ФТППароль);
ФТП.Записать("C:\"+ФАйл,СокрЛП(Файл));

Не выгружает через bat файл и вручную.

Vofka @ Сегодня, 9:14 * ,
Да у меня тоже пока только этот вариант есть.
Может у кого-то будет возможность проверить выгрузку на другой платформе, отпишитесь.
  Форум: Администрирование и настройка 1С · Просмотр сообщения: #124172 · Ответов: 16 · Просмотров: 2377
 

6 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 24.01.20, 16:02
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!