Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

7 страниц V   1 2 3 > » 

>  В печатной форме вместо фирмы НеизвестныйОбъект 1с 7.7 конф 7.7.003
1Cv77
Отправлено: 05.10.19, 22:20


Завсегдатай
****

Группа: Пользователи
Сообщений: 192
Регистрация: 03.02.09
Из: Украина, Мелитополь
Пользователь №: 3


ZUBR @ Сегодня, 19:22 * ,
Доброго времени суток.

Реквизит "Фирма" - скорее всего - общий!!! (см. Документы -> Общие реквизиты)

Насчет "Адреса", то, посмотрите, возможно, он - периодический.

Тогда, нужно так:
Адрес.Получить(ДатаДок)

  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #156229 · Ответов: 18 · Просмотров: 278
 

>  В чем ошибка условия? 1С 7.70.003 торговля склад для Украины?
1Cv77
Отправлено: 15.09.19, 20:26


Завсегдатай
****

Группа: Пользователи
Сообщений: 192
Регистрация: 03.02.09
Из: Украина, Мелитополь
Пользователь №: 3


ZUBR @ Сегодня, 18:11 * ,
Доброго времени суток.

Прошу прощения за глупый вопрос:
А в Отладчике, если остановить процедуру на:
Если ТЗ.Сотрудник = Расх.Инженер Тогда


Что выдает по "ТЗ.Сотрудник" и "Расх.Инженер Тогда" ???
Какие значения?
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #155636 · Ответов: 11 · Просмотров: 414
 

>  Как сохранить текущее значение переменной в 1С 7.70.003 торговля склад для Украины?
1Cv77
Отправлено: 30.07.19, 20:18


Завсегдатай
****

Группа: Пользователи
Сообщений: 192
Регистрация: 03.02.09
Из: Украина, Мелитополь
Пользователь №: 3


ZUBR @ Сегодня, 18:49 * ,
В принципе : решение - правильное!!!
Хотя, можно, без объявления константы, просто, в процедуре ВводНового() прописать такое:
    НомерЗаказа=0;
    врДок=СоздатьОбъект("Документ.АктПриема");
    врДок.ОбратныйПорядок(1);
    врДок.ВыбратьДокументы(ДатаДок-30,ДатаДок);
    Пока врДок.ПолучитьДокумент()=1 Цикл
                НомерАкта=врДок.НомерЗаказа;
        Прервать;   /// для экономии времени
    КонецЦикла;
    НомерЗаказа+1;



 ! 

Правила: 9
 
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #154247 · Ответов: 6 · Просмотров: 264
 

>  Как в документ Расходная накладная внести по умолчанию курс валюты 1с 7.7 конф 7.7.003
1Cv77
Отправлено: 25.07.19, 13:53


Завсегдатай
****

Группа: Пользователи
Сообщений: 192
Регистрация: 03.02.09
Из: Украина, Мелитополь
Пользователь №: 3


ZUBR @ Сегодня, 10:50 * ,
Согласен, я, когда писал ответ, не обратил на это внимание(((((
Просто, "вытащил" кусок кода из своей базы.....
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #154117 · Ответов: 3 · Просмотров: 289
 

>  Как в документ Расходная накладная внести по умолчанию курс валюты 1с 7.7 конф 7.7.003
1Cv77
Отправлено: 24.07.19, 23:06


Завсегдатай
****

Группа: Пользователи
Сообщений: 192
Регистрация: 03.02.09
Из: Украина, Мелитополь
Пользователь №: 3


ZUBR @ Сегодня, 21:51 * ,

Пробуйте так:

Расх.Курс = Константа.БазоваяВалюта.Курс.Получить(ТекущаяДата());
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #154089 · Ответов: 3 · Просмотров: 289
 

>  Работа с табличными формами. Перенос данных на другую страницу.
1Cv77
Отправлено: 07.05.19, 21:46


Завсегдатай
****

Группа: Пользователи
Сообщений: 192
Регистрация: 03.02.09
Из: Украина, Мелитополь
Пользователь №: 3


Talkman @ Сегодня, 15:51 * ,

Из синтаксического помощника )))))

НоваяСтраница(<?>);
Синтаксис:
НоваяСтраница(<Ном>)
Назначение:
Вставить в результирующую таблицу разделитель страниц.
Параметры:
<Ном> - необязательный параметр. Номер строки, после которой начинать новую страницу. Если параметр не указан, то новая страница вставляется по текущей высоте таблицы.


Т.е в самом документе, в Процедуре Печать() (или, как, она, у Вас обозначена)

Если КоличествоСтрок()>15 Тогда
Таб.НоваяСтраница()
КонецЕсли;

А, уже после этого, выводите рисунок!!!
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #152009 · Ответов: 5 · Просмотров: 325
 

>  не могу найти печатную форму 1C:Предприятие 7.7
1Cv77
Отправлено: 19.09.18, 22:33


Завсегдатай
****

Группа: Пользователи
Сообщений: 192
Регистрация: 03.02.09
Из: Украина, Мелитополь
Пользователь №: 3


4andriy @ Сегодня, 18:44 * ,
Кто ищет, то - всегда найдет )))))))))
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #145533 · Ответов: 4 · Просмотров: 527
 

>  не могу найти печатную форму 1C:Предприятие 7.7
1Cv77
Отправлено: 19.09.18, 16:21


Завсегдатай
****

Группа: Пользователи
Сообщений: 192
Регистрация: 03.02.09
Из: Украина, Мелитополь
Пользователь №: 3


4andriy @ Сегодня, 14:43 * ,

СмотриТЕ в глобальном модуле Процедуру глПараметрыТаблицы(.... (или функцию)

Там же, в глобалке и таблицы нужные


 ! 

Правила: 1
 
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #145531 · Ответов: 4 · Просмотров: 527
 

>  Как получить количество из проводок через Бухг. итоги ?
1Cv77
Отправлено: 28.07.18, 22:14


Завсегдатай
****

Группа: Пользователи
Сообщений: 192
Регистрация: 03.02.09
Из: Украина, Мелитополь
Пользователь №: 3


KriAn @ Сегодня, 20:52 * ,
ДО(<?>,,,)
Синтаксис:
ДО(<Счет>,<ТипСуммы>,<Валюта>,<Субконто1...>)
Назначение:
Возвращает дебетовый оборот по счету за период.
Параметры:
<Счет> - значение типа ''Счет'' - счет расчета итогов. Может использоваться строка - код счета.
<ТипСуммы> - необязательный параметр. Число или строка - тип возвращаемой суммы. Может принимать одно из следующих значений: 1 (''C'') - сумма; 2 (''В'') - валютная сумма; 3 (''К'') - количество. Если параметр не указан, метод возвращает сумму.
<Валюта> - необязательный параметр. Значение типа ''Справочник.Валюты''. Если параметр не указан, то итоги выдаются без учета валюты.
<Субконто1...> - необязательные параметры. Значения субконто. Их количество зависит от настройки субконто для данного счета. Если параметры не указаны, то итоги выдаются без учета аналитики.


ТИП СУММЫ - 2 или "В"
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #143835 · Ответов: 8 · Просмотров: 798
 

>  работа с перечислениями
1Cv77
Отправлено: 29.05.18, 19:36


Завсегдатай
****

Группа: Пользователи
Сообщений: 192
Регистрация: 03.02.09
Из: Украина, Мелитополь
Пользователь №: 3


4andriy @ Сегодня, 17:29 * ,
Вообще-то, нужно так:

Если СокрЛП(Контрагент.ВидТМЦ)="Продукция" Тогда
    Склад="Первый";
ИначеЕсли СокрЛП(Контрагент.ВидТМЦ)="Материал" Тогда
    Склад="Второй";
КонецЕсли;


И, то, при условии: что Контрагент.ВидТМЦ - ЭТО СТРОКА!!!!!

  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #142011 · Ответов: 2 · Просмотров: 740
 

>  Число прописью на УКРАИНСОКМ
1Cv77
Отправлено: 23.05.18, 18:28


Завсегдатай
****

Группа: Пользователи
Сообщений: 192
Регистрация: 03.02.09
Из: Украина, Мелитополь
Пользователь №: 3


yeomanwarder @ Сегодня, 10:36 * ,

Не знаю, на сколько это Вам поможет:
Попробуйте в процедуре печати, в начале, обратится сюда:

Процедура глУстПропись(Вал,Язык = "") Экспорт
    Язык = Нрег(Язык);
    Если Язык = "" Тогда
        // из константы
        Если Константа.ФормыНаУкраинском = Нет Тогда
            Пропись(СокрЛП(Вал.ФайлПрописиРус));
        Иначе
            Пропись(СокрЛП(Вал.ФайлПрописиУкр));
        КонецЕсли;
    ИначеЕсли (Язык = "р") или (Язык = "русский") Тогда
        Пропись(СокрЛП(Вал.ФайлПрописиРус));
    ИначеЕсли (Язык = "у") или (Язык = "украинский") Тогда
        Пропись(СокрЛП(Вал.ФайлПрописиУкр));
    КонецЕсли;
КонецПроцедуры

Такая процедура ДОЛЖНА быть в глобалке

 ! 

Правила: 9
 
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #141854 · Ответов: 2 · Просмотров: 671
 

>  Сумма в запросе с условием
1Cv77
Отправлено: 30.01.18, 0:40


Завсегдатай
****

Группа: Пользователи
Сообщений: 192
Регистрация: 03.02.09
Из: Украина, Мелитополь
Пользователь №: 3


korney777@gmail.com @ Вчера, 23:02 * ,
Перед циклом обозначьТЕ
ДатаДок_= 0;
СуммаМес=0;

В ЦИКЛЕ, в конце, вставьТЕ такое:
Пока НачисленноОклад.Группировка(1)=1 Цикл
   _ДатаДок=НачисленноОклад.ДатаДок;  
   Если (_ДатаДок<>ДатаДок_) И (СуммаМес<>0) Тогда
         Сообщить(СуммаМес);               /////////// ЭТО ТО ЧТО НУЖНО
     СуммаМес=0;
   КонецЕсли;
   НомСтрок = НомСтрок+1;

            Результат.НоваяСтрока(НомСтрок);
            ОкладСумма=ОкладСумма+НачисленноОклад.ОкладСумма;                    
            НДФЛ6=СокрЛП(Формат((ОкладСумма/100*ПроцентСтавки),"Ч10.0"));
            Результат.УстановитьЗначение(НомСтрок,"Код",ДатаМесяц(_ДатаДок));
            Результат.УстановитьЗначение(НомСтрок,"ДатаДохода",_ДатаДок);
            Результат.УстановитьЗначение(НомСтрок,"СуммаДохода",ОкладСумма);
            Результат.УстановитьЗначение(НомСтрок,"СуммаУдерж",НДФЛ6);
            
            СуммаМес=СуммаМес+ОкладСумма
            
            ОкладСумма = 0;
            НДФЛ6 = 0;    
            ДатаДок_=_ДатаДок;
        КонецЦикла;


 ! 

Правила: 1,9
 

P.S. Прошу прощения за "корявый" код, в плане отступов.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #137878 · Ответов: 8 · Просмотров: 1347
 

>  загрузка свойств номенклатуры из xls
1Cv77
Отправлено: 13.07.17, 7:52


Завсегдатай
****

Группа: Пользователи
Сообщений: 192
Регистрация: 03.02.09
Из: Украина, Мелитополь
Пользователь №: 3


Korotkiy @ Вчера, 21:29 * ,
09000000.gif
Блин, я не внимателен(((((
не обратил внимание на "Далее"
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #129542 · Ответов: 3 · Просмотров: 1114
 

>  загрузка свойств номенклатуры из xls
1Cv77
Отправлено: 12.07.17, 22:03


Завсегдатай
****

Группа: Пользователи
Сообщений: 192
Регистрация: 03.02.09
Из: Украина, Мелитополь
Пользователь №: 3


Korotkiy @ Сегодня, 20:44 * ,
Строки

Запрос = СоздатьОбъект("Запрос"); 
СпрСвойств = СоздатьОбъект("Справочник.ВидыСвойств");        
СпрЗначСвойств = СоздатьОбъект("Справочник.ЗначенияСвойств");
СпрСвойствНом = СоздатьОбъект("Справочник.СвойстваНоменклатуры");


Перенеси ЗА строчку
Процедура  ПоКнопкеЗагрузить() Далее



 ! 

Правила: 9
 
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #129525 · Ответов: 3 · Просмотров: 1114
 

>  Проблема с работой нескольких пользователей.
1Cv77
Отправлено: 26.01.17, 17:48


Завсегдатай
****

Группа: Пользователи
Сообщений: 192
Регистрация: 03.02.09
Из: Украина, Мелитополь
Пользователь №: 3


Доброго времени суток.
Подскажите такой вопрос:
Два компа в сели
На обоих стоит 1С 8,3,7,2027
Но в базе работать могут только по одному пользователю(((
Когда пытается зайти второй вылетает ошибка:
Невосстановимая ошибка
Ошибка при выполнении запроса POST к ресурсу /e1cib/login:
по причине:
Ошибка при выполнении операции......

Отдельно каждый пользователь заходит без проблем, а вместе НЕА(((((

ПОДСКАЖИТЕ В ЧЕМ ПРОБЛЕМА????
Заранее благодарен


 ! 

Правила: 5.7
 
  Форум: Платформа 8 · Просмотр сообщения: #122198 · Ответов: 1 · Просмотров: 809
 

>  Клиенты под XP не видят ключ
1Cv77
Отправлено: 20.07.15, 9:34


Завсегдатай
****

Группа: Пользователи
Сообщений: 192
Регистрация: 03.02.09
Из: Украина, Мелитополь
Пользователь №: 3



 ! 

Правила: 1, 18!
 
  Форум: Администрирование и настройка 1С · Просмотр сообщения: #101000 · Ответов: 8 · Просмотров: 1816
 

>  Отфильтровать шт и кг в запросе
1Cv77
Отправлено: 05.07.15, 16:10


Завсегдатай
****

Группа: Пользователи
Сообщений: 192
Регистрация: 03.02.09
Из: Украина, Мелитополь
Пользователь №: 3


Извиняюсь за развитие можно сказать "закрытой" темы

Советую заменить Пернестат = СокрЛП(Запрос.ЕдВес);
на Пернестат = СокрЛП(НРег(Запрос.ЕдВес));

а то бывают шутки типа "Шт." или "ШТ." .....
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #100519 · Ответов: 5 · Просмотров: 1534
 

>  Отфильтровать шт и кг в запросе
1Cv77
Отправлено: 03.07.15, 18:05


Завсегдатай
****

Группа: Пользователи
Сообщений: 192
Регистрация: 03.02.09
Из: Украина, Мелитополь
Пользователь №: 3


Доброго времени суток

|ЕдВес = Документ.НедостачаТовара.Единица; - это разве строчная величина?

Там скорее всего ссылка на Спр или перечисление.....

вот тут и "собака" закопана

Соответственно и условие Если Запрос.ЕдВес<>"шт." нужно проверить
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #100500 · Ответов: 5 · Просмотров: 1534
 

>  Выбивает 1С-ку
1Cv77
Отправлено: 25.01.15, 19:15


Завсегдатай
****

Группа: Пользователи
Сообщений: 192
Регистрация: 03.02.09
Из: Украина, Мелитополь
Пользователь №: 3


Простите, ошибся веткой ((((
  Форум: Корзина · Просмотр сообщения: #95532 · Ответов: 1 · Просмотров: 1246
 

>  Тормозит база при работе отдельных пользователей
1Cv77
Отправлено: 14.10.14, 19:58


Завсегдатай
****

Группа: Пользователи
Сообщений: 192
Регистрация: 03.02.09
Из: Украина, Мелитополь
Пользователь №: 3


Была похожая проблема!
Посмотри компы пользователей!
Именно на скорость работы по сети...
  Форум: 1С Торговля и Склад 7.7 для Украины · Просмотр сообщения: #92149 · Ответов: 8 · Просмотров: 3972
 

>  пропали остатки товара
1Cv77
Отправлено: 27.09.14, 9:59


Завсегдатай
****

Группа: Пользователи
Сообщений: 192
Регистрация: 03.02.09
Из: Украина, Мелитополь
Пользователь №: 3


Цитата(jorik55555 @ 27.09.14, 8:37) *
Добрый день!Нужна ваша помощь! В 1с 7.7 пропали остатки товара. Произошло это, когда переустановил виндовс, а базы забыл скопировать и резервную копию создать тоже. Пришлось восстанавливать базу программой восстановления файлов. несколько дней все было в порядке, но после обновления периода остатки стали отличаться от реальных, а некоторые вообще со знаком минус.
Все мои попытки восстановить ни к чему не привели. Подскажите пожалуйста что можно сделать или где искать решение этой проблемы


Первое что приходит в голову:
1. Проверьте точкуАктуальности!
2. Сделайте полное тестирование и исправление БД
  Форум: 1С Торговля и Склад 7.7 для Украины · Просмотр сообщения: #91632 · Ответов: 4 · Просмотров: 5460
 

>  НДС 17%
1Cv77
Отправлено: 20.07.14, 14:54


Завсегдатай
****

Группа: Пользователи
Сообщений: 192
Регистрация: 03.02.09
Из: Украина, Мелитополь
Пользователь №: 3


Всем доброго времени суток.

Тут вчера ходил в аптеку, посмотрел на чек и обомлел:

ПДВ 7%

Кто-то что-то знает о новых формах налоговых и отчетности, ну вернее больше интересует бланк налоговой...!!!
  Форум: Бухгалтерский учет, налоги, последние изменения... · Просмотр сообщения: #89042 · Ответов: 17 · Просмотров: 5939
 

>  Заполнение табличной части документа
1Cv77
Отправлено: 15.07.14, 10:08


Завсегдатай
****

Группа: Пользователи
Сообщений: 192
Регистрация: 03.02.09
Из: Украина, Мелитополь
Пользователь №: 3


Ну элементарно:

    Для Сч = НачМесяца(ДатаДок) По КонМесяца(ДатаДок) Цикл
        НоваяСтрока();
        Дата=НачМесяца(ДатаДок)+Сч-1;
    КонецЦикла;


там насчет Сч-1 проверьте


 i 

Выделяем код!
 
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #88811 · Ответов: 3 · Просмотров: 2073
 

>  Амортизация в 1-С 7.7
1Cv77
Отправлено: 12.02.14, 14:45


Завсегдатай
****

Группа: Пользователи
Сообщений: 192
Регистрация: 03.02.09
Из: Украина, Мелитополь
Пользователь №: 3


Цитата(oks @ 12.02.14, 14:31) *
При проведении документа Начисление износа в 1-С 7.7 типовая версия по одному из объектов ОС начисление проводится Дт791 Кт131 (вместо Дт 831 Кт131), по налоговому учету вообще не делает проводок. В карточке НА все заполнено так же, как и для остальных объектов: Счет и вид затрат выбраны - 831 Амортиз. произв. ОС, для налогового учета стоит "галочка" начислять износ. Первоначальна стоимость указана, метод (прямолинейный), колич-во месяцев использования тоже есть.Что я сделала не так?


А за какой месяц делаете начисление?
и какая группа ОС у Вас?
  Форум: 1С Бухгалтерия 7.7 для Украины · Просмотр сообщения: #81718 · Ответов: 2 · Просмотров: 2406
 

>  Объединение конфигураций
1Cv77
Отправлено: 02.01.14, 19:24


Завсегдатай
****

Группа: Пользователи
Сообщений: 192
Регистрация: 03.02.09
Из: Украина, Мелитополь
Пользователь №: 3


Цитата(onsamuy @ 30.12.13, 10:44) *
Есть Бухгалтерия 7.7 для Украины, базовая версия. При обновлении, объединении конфигураций выдает ошибку "Нет возможности создать файл"


Проверьте права пользователя!

вариант 2 - перенесите конфу из папки програм..... в другое место
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #79967 · Ответов: 6 · Просмотров: 2972
 

7 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 14.10.19, 10:39
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!