Версия для печати темы (https://pro1c.org.ua/index.php?s=6770568d359b417d46e3b37c73da86ed&showtopic=67082)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Программирование в 1С Предприятие 7.7 _ ошибка при открытии обработки

Автор: 4andriy 22.09.22, 18:31

ИдентификаторКонфигурации = глРедакцияКонфигурации();

Спр = СоздатьОбъект("Справочник.Пользователи");
Если ИдентификаторКонфигурации = "UBUTK" Тогда //Бухгалтерский учет для Украины    
    Если Спр.НайтиПоНаименованию(ИмяПользователя(), 1) = 1 Тогда
        ТекущийПользователь = Спр.ТекущийЭлемент();    
    КонецЕсли;
ИначеЕсли ИдентификаторКонфигурации = "UBUOUSL" Тогда //"Бухгалтерия+Торговля+Склад+Зарплата+Кадры" для Украины
    спВидиДокументів.ВставитьЗначение(5,"Т_РасходнаяНакладная","Видаткова накладна (товари)");
    Если Спр.НайтиПоКоду(ИмяПользователя(), 0) = 1 Тогда
        ТекущийПользователь = Спр.ТекущийЭлемент();    
    КонецЕсли;
ИначеЕсли ИдентификаторКонфигурации = "UManf" Тогда //Производство+Услуги+Бухгалтерия для Украины
    Если Спр.НайтиПоКоду(ИмяПользователя(), 0) = 1 Тогда
        ТекущийПользователь = Спр.ТекущийЭлемент();    
    КонецЕсли;
ИначеЕсли ИдентификаторКонфигурации = "UOUTK" Тогда //Торговля+Склад для Украины
    ОказаниеУслугНом = спВидиДокументів.НайтиЗначение("ОказаниеУслуг");
    Если ОказаниеУслугНом > 0 Тогда
        спВидиДокументів.УдалитьЗначение(ОказаниеУслугНом);
    КонецЕсли;
    Если Спр.НайтиПоКоду(ИмяПользователя(), 0) = 1 Тогда
        ТекущийПользователь = Спр.ТекущийЭлемент();    
    КонецЕсли;
Иначе
    ТекущийПользователь = "";
КонецЕсли;


в глобальном модуле есть:
Перем глРедакцияКонфигурации Экспорт;//это для сравнения редакции конфигурации и константы "РедакцияКонфигурации"


ошибка:
ИдентификаторКонфигурации = глРедакцияКонфигурации<<?>>();
...: Функция не обнаружена (глРедакцияКонфигурации)

Автор: denis84 22.09.22, 19:11

4andriy @ Сегодня, 19:31 * ,
Там объявлено как переменная. А обращаетесь как к функции

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua