Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



История благодарностей участнику DrLivsi ::: Спасибо сказали: 19 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
15.04.21, 15:58 MacOs не корректно отображается приложение тонкого клиента
Оказалось что 1С еще не адаптирована под М1 и Big Sure.
https://forum.mista.ru/topic.php?id=865042
Vofka,
08.02.21, 4:32 Средства мультимедиа в мобильном клиенте
Может кому то будет полезно, проблему не победил, но убрал инструкцию препроцессору
 #Если МобильноеПриложениеКлиент Тогда

и сохранил с ошибкой.
Все работает. Наверное глюк платформы...
Vofka,
04.12.18, 9:06 Выборка запросом по ТаблицеЗначений
Тут собралась целая битва экстрасенсов, а автор тупо забил.
awp,
03.12.18, 16:05 Выборка запросом по ТаблицеЗначений
Наверное забыли
Запрос.МенеджерВременныхТаблиц = Новый МенеджерВременныхТаблиц;
bizisoft,
24.10.17, 8:56 Работа с "Интайм" по API
Решил. Вот может кому-то пригодится

Попытка
        Форма.WSDLОпределение = Новый WSОпределения("http://esb.intime.ua:8080/services/intime_api_3.0?wsdl");
        WSСервис = Форма.WSDLОпределение.Сервисы[0];
        Форма.прокси = Новый WSПрокси(Форма.WSDLОпределение, WSСервис.URIПространстваИмен, WSСервис.Имя, WSСервис.ТочкиПодключения[0].Имя);
    Исключение
        Форма.WSDLОпределение = Неопределено;
        Сообщить(ОписаниеОшибки());
    КонецПопытки;
    
    Если Форма.WSDLОпределение = Неопределено Тогда
        Сообщить("Не удалось подключится");
         Возврат;
    КонецЕсли;
    
    // Получаем все операци
    WSОперации = WSСервис.ТочкиПодключения[0].Интерфейс.Операции;
    
    //Получаем тип параметра, который передается в метод G
    Форма.WSDLОпределение.ФабрикаXDTO.Пакеты.Получить("http://ws.wso2.org/dataservice").Получить("get_country_by_id");
    
    //Создаем параметр на основе типа и заполняем значение параметра api_key
    WSПараметр       = Форма.Прокси.ФабрикаXDTO.Создать(ТипWSПараметра);
    WSПараметр.api_key    = АПИКлюч;
    WSПараметр.id    = "";
    
    //Вызываем метод веб-сервиса, записываем результат в переменную list_of_countries
    list_of_countries = Форма.Прокси.get_country_by_id(WSПараметр);
    
    Для Каждого Country Из list_of_countries.Entry_get_country_by_id Цикл
        Сообщить(Country.code+" "+Country.name_en+" "+Country.name_ru);
    КонецЦикла;


DrLivsi @ Сегодня, 9:48 * ,

Небольшая ошибка в строке
//Получаем тип параметра, который передается в метод G
    Форма.WSDLОпределение.ФабрикаXDTO.Пакеты.Получить("http://ws.wso2.org/dataservice").Получить("get_country_by_id");

нужно вот так:
//Получаем тип параметра, который передается в метод G
    ТипWSПараметра = Форма.WSDLОпределение.ФабрикаXDTO.Пакеты.Получить("http://ws.wso2.org/dataservice").Получить("get_country_by_id");
Alikk, Bernet, Flexy,
15.06.17, 16:14 Отчет по товарам на складах: заблокировать возможность изменения отбора по складам
Constantus @ Сегодня, 15:54 * ,

Процедура СформироватьОтчет вызывается каждый раз при нажатии на кнопку "Сформировать" и что-бы пользователь с этой галочкой не делал в отборе, она все равно станет в истину перед формированием отчета:
УниверсальныйОтчет.ПостроительОтчета.Отбор.Склад.Использование = Истина;
Constantus,
19.02.16, 13:07 Признак документа Проведен*
candrey @ Сегодня, 14:05 *,

Да, реквизит изменился уже после записи документа.
candrey,
19.02.16, 12:54 Признак документа Проведен*
Petre @ Сегодня, 13:51 *,

Модифицированность() дает на это ответ, если проверять весь код построчно, и если при выполнении очередной строки она возвращает "истина" то там уже будет понятно какой реквизит изменяется.
Лично я так много раз находил.
candrey,
19.02.16, 12:51 Признак документа Проведен*
candrey @ Сегодня, 13:50 *,

Ну можно и так если вас это устраивает.
candrey,
19.02.16, 12:36 Признак документа Проведен*
candrey @ Сегодня, 13:32 *,

Какой-то реквизит документа, нужно смотреть отладчиком с помощью функции Модифицированность(). Проверте в обработчиках событий ПриЗаписи() или ПослеЗаписи(). Ну или тот код который вы дописали.
candrey,
19.02.16, 12:30 Признак документа Проведен*
candrey @ Сегодня, 13:25 *,

* значит что после записи документа, вы изменяете его реквизит, и документ нужно снова провести.
candrey,
07.09.15, 13:31 Поле "Вес" из "Формы элемента"
Вставте вместо строки "СтрокаОформления.Ячейки.Вес.УстановитьТекст(ТекСсылка.ЕдиницыИзмерения[0].Вес);"

Выборка =Справочники.ЕдиницыИзмерения.Выбрать(,ТекСсылка);
        
Выборка.Следующий();

СтрокаОформления.Ячейки.Вес.УстановитьТекст(Выборка.Вес);
candrey,
07.09.15, 13:01 Поле "Вес" из "Формы элемента"
Цитата(candrey @ 07.09.15, 13:34) *
это надо реквизит создать(ЕдиницыИзмерения) и прикрутить к колонке?

Нет. Посмотрите как у вас называется табличная часть (та где указан вес) и замените имя.

Если ЕдиницыИзмерения у вас отдельный справочник, тогда выбираете из него запросом по владельцу
candrey,
07.09.15, 12:13 Поле "Вес" из "Формы элемента"
У табличного поля есть свойство ПриПолученииДанных, вставляем туда код

Процедура СправочникСписокПриПолученииДанных(Элемент, ОформленияСтрок)

Для Каждого СтрокаОформления Из ОформленияСтрок Цикл
    ТекДанные=СтрокаОформления.ДанныеСтроки;
    ТекСсылка=ТекДанные.Ссылка;
    Если НЕ ТекДанные.ЭтоГруппа Тогда

             СтрокаОформления.Ячейки.Вес.УстановитьТекст(ТекСсылка.ЕдиницыИзмерения[0].Вес);

    КонецЕсли;

КонецЦикла;
КонецПроцедуры;

candrey,
07.09.15, 11:38 Поле "Вес" из "Формы элемента"
В событии"ПриПолученииДанных" табличного поля СправочникСписок, получаем вес номенклатуры и вставляем в нужную колонку.
candrey,
18.08.14, 11:04 Получение электронных писем из 1с
Всем спасибо вопрос решен. У меня постоянно был открыт аутлук, и он забирал письма с сервера. Вот я ничего и не получал...
Vofka,
24.05.12, 11:46 таблица значений
Цитата(gorik77 @ 24.05.12, 12:09) *
проблема в том что не представляю себе как ето можно сделать, может подскажете если не сложно?



// Сначала помещаем ТЗ во временную таблицу
Запрос = Новый Запрос;
Запрос.МенеджерВременныхТаблиц = Новый МенеджерВременныхТаблиц;
Запрос.Текст = "ВЫБРАТЬ * ПОМЕСТИТЬ ТЗ ИЗ &ТЗ КАК ТЗ";
Запрос.УстановитьПараметр("ТЗ", тзДанные);
//где тзДанные = ваша таблица
Запрос.Выполнить();

// Теперь ТЗ можно использовать в запросе:
Запрос.Текст = "ВЫБРАТЬ
               |    ТЗ.Контрагент КАК Контрагент
               |    //.....
               |ИЗ
               |    ТЗ КАК ТЗ";


Как-то так.
gorik77,

RSS Текстовая версия Сейчас: 30.11.21, 8:59
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!