Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

16 страниц V   1 2 3 > » 

>  відключити видимість організації для користувача
Юля
Отправлено: 18.07.19, 12:25


Оратор
*****

Группа: Пользователи
Сообщений: 398
Регистрация: 26.10.11
Из: Хмельницький
Пользователь №: 12438


Привіт, бухгалтерія 2.0 , в одній базі ведуть дві організації, як можна для користувача відключити видимість даних по одній з організації? Дякую
  Форум: Бухгалтерия 8, редакция 2 для Украины · Просмотр сообщения: #153917 · Ответов: 1 · Просмотров: 163
 

>  Создание документ ОперацияБух
Юля
Отправлено: 14.06.19, 12:29


Оратор
*****

Группа: Пользователи
Сообщений: 398
Регистрация: 26.10.11
Из: Хмельницький
Пользователь №: 12438


Заработало))))))
Вместо:
БухгалтерскийУчет.УстановитьСубконто(РегЗапись.СчетДт,РегЗапись.СубконтоДт, "НоменклатурныеГруппы", Строка.НоменкГрупа);

прописала так:
РегЗапись.СубконтоДт[ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.НоменклатурныеГруппы]= Строка.НомГрупа;
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #153111 · Ответов: 6 · Просмотров: 357
 

>  Создание документ ОперацияБух
Юля
Отправлено: 13.06.19, 14:47


Оратор
*****

Группа: Пользователи
Сообщений: 398
Регистрация: 26.10.11
Из: Хмельницький
Пользователь №: 12438


sava1 @ Сегодня, 15:18 * ,
проводки создает, субконто не хочет прописовать(
может я не до конца понимаю - ИЗВИНИТЕ why.gif
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #153077 · Ответов: 6 · Просмотров: 357
 

>  Создание документ ОперацияБух
Юля
Отправлено: 13.06.19, 13:23


Оратор
*****

Группа: Пользователи
Сообщений: 398
Регистрация: 26.10.11
Из: Хмельницький
Пользователь №: 12438


sava1 @ 10.06.19, 15:48 * ,

Не хочи добавляти субконто Дт , допоможіть будь-ласка. Помилки не видає, поля добавляє, суму, рахунки, а субконто ні.

&НаСервере
Процедура СоздатьДокументНаСервере()
    
     ДокОперация = Документы.ОперацияБух.СоздатьДокумент();
        ДокОперация.Дата = КонПериода;
        ДокОперация.Организация = Организация;
        ДокОперация.Ответственный = ПараметрыСеанса.ТекущийПользователь;
        ДокОперация.Содержание =  "створено програмно, Розподіл: " + НомГрупаГотова;
        ДокОперация.Комментарий = "Комментарий";
        //ДокОперация.СуммаОперации = Объект.ХозрасчетныйНаборЗаписей.Итог("Сумма");  
        ДокОперация.Записать();

        ДокОперацияСсылка = ДокОперация.Ссылка;
        
                // Добавляем в хозрастчет.
        РегХозрасчетный = РегистрыБухгалтерии.Хозрасчетный.СоздатьНаборЗаписей();
        РегХозрасчетный.Отбор.Регистратор.Значение = ДокОперацияСсылка;
                  
        
        Для Каждого Строка из Объект.ТабличнаяЧасть1 Цикл
        
            РегЗапись = РегХозрасчетный.Добавить();
            РегЗапись.Период = КонПериода;
            РегЗапись.Регистратор = ДокОперацияСсылка;
            РегЗапись.Организация = Организация;
          
            
            РегЗапись.СчетДт = ПланыСчетов.Хозрасчетный.НайтиПоКоду("231");
            РегЗапись.Сумма = Строка.Сумма;
            РегЗапись.НалоговоеНазначениеДт = Строка.НалогНазнач;
            БухгалтерскийУчет.УстановитьСубконто(РегЗапись.СчетДт,РегЗапись.СубконтоДт, "НоменклатурныеГруппы", Строка.НоменкГрупа);
            
            

            РегЗапись.СчетКт = КТ;
            
            //РегЗапись = РегХозрасчетный.Добавить();
            //РегЗапись.Сумма = -1 * Строка.Сумма;
             
            
                  
        КонецЦикла;
                        
        РегХозрасчетный.Записать();
    
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #153070 · Ответов: 6 · Просмотров: 357
 

>  Создание документ ОперацияБух
Юля
Отправлено: 10.06.19, 14:41


Оратор
*****

Группа: Пользователи
Сообщений: 398
Регистрация: 26.10.11
Из: Хмельницький
Пользователь №: 12438


Привіт, бухгалтерія 2.0 потрібно обробкою створити документ Операції введені вручну. Тобто є форма на якій розміщена кнопка створити документ і заповнити. Документ створюється, але табличну частину не можу заповнити, таблицю бачу , бачу колонки, заповнити рне можу. Підкажіть, як звернутися до строк в таблиці. Потрібно прописати рах 231 - всі його субконто, відповідно суму...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #152981 · Ответов: 6 · Просмотров: 357
 

>  Обороти Дт по номенклатурним групам
Юля
Отправлено: 27.05.19, 11:50


Оратор
*****

Группа: Пользователи
Сообщений: 398
Регистрация: 26.10.11
Из: Хмельницький
Пользователь №: 12438


Petre @ Сегодня, 12:42 * ,
я вже виправила на СчетДт =ПланыСчетов.Хозрасчетный.ОсновноеПроизводство;
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #152530 · Ответов: 5 · Просмотров: 315
 

>  Обороти Дт по номенклатурним групам
Юля
Отправлено: 27.05.19, 11:25


Оратор
*****

Группа: Пользователи
Сообщений: 398
Регистрация: 26.10.11
Из: Хмельницький
Пользователь №: 12438


Vofka @ Сегодня, 12:07 *
СчетДт =ПланыСчетов.Хозрасчетный.ОсновноеПроизводство;
на форі його не має, на формі період, номенклатурна нрупа і стаття витрат, рх Дт постійно 231
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #152526 · Ответов: 5 · Просмотров: 315
 

>  Обороти Дт по номенклатурним групам
Юля
Отправлено: 27.05.19, 11:04


Оратор
*****

Группа: Пользователи
Сообщений: 398
Регистрация: 26.10.11
Из: Хмельницький
Пользователь №: 12438


Привіт, потрібно витянути дебетову суму по 231 рахунку по відповідній номенклатурній нрупі і статі затрат, ці параметри ми вибираємо на формі, коли формую запит видає помилку: "не можна порівнювати поля необмеженої довжини і поля несумісних типів.ХохрасчетныйОборотыДтКт.СчетДт <<?>>СчетДт"
код запиту:
Процедура ЗагСумВитратНачалоВыбораИзСписка()
    ЗагСума= 0;    
    СубконтоДт2 = Элементы.НомГрупаГотова;
    СубконтоДт3 = Элементы.ВиберитьСтатюВитрат;
    СчетДт = Элементы.РахунокКт;
    //ВиберитьСтатюВитрат = Элементы.ВиберитьСтатюВитрат.Значение.код;
    
    
    //
    Запрос = Новый Запрос();
    Запрос.Текст =
        "ВЫБРАТЬ
        
        |    ХозрасчетныйОборотыДтКт.СубконтоДт2,
        |    ХозрасчетныйОборотыДтКт.СубконтоДт3,
        |    ХозрасчетныйОборотыДтКт.СчетДт,
        |    СУММА(ХозрасчетныйОборотыДтКт.СуммаОборот) КАК СуммаОборот
        |ИЗ
        |    РегистрБухгалтерии.Хозрасчетный.ОборотыДтКт КАК ХозрасчетныйОборотыДтКт
        |ГДЕ
        |    ХозрасчетныйОборотыДтКт.СчетДт = &СчетДт
        |    И ХозрасчетныйОборотыДтКт.СубконтоДт2 = &СубконтоДт2
        |    И ХозрасчетныйОборотыДтКт.СубконтоДт3 = &СубконтоДт3
        |
        |СГРУППИРОВАТЬ ПО
        |    ХозрасчетныйОборотыДтКт.СчетДт,
        |    ХозрасчетныйОборотыДтКт.СубконтоДт2,
        |    ХозрасчетныйОборотыДтКт.СубконтоДт3";
    
    Запрос.УстановитьПараметр("СубконтоДт2", СубконтоДт2);
    Запрос.УстановитьПараметр("СубконтоДт3", СубконтоДт3);
    Запрос.УстановитьПараметр("СчетДт", СчетДт);
    Запрос.УстановитьПараметр("КонПериода", КонПериода);
    Запрос.УстановитьПараметр("НачПериода", НачПериода);
    РезультатЗапроса = Запрос.Выполнить();
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        
        Если ВыборкаДетальныеЗаписи.СубконтоДт3.Код =  ВиберитьСтатюВитрат и ВыборкаДетальныеЗаписи.СубконтоДт2 = Элементы.СубконтоДт2.Значение  Тогда  
        ЗагСума = ВыборкаДетальныеЗаписи.СуммаОборотДт1;
        
         Элементы.ЗагСумВитрат.Значение = ВыборкаДетальныеЗаписи.СуммаОборот;

     КонецЕсли;
    // возврат ЗагСума;

        // Вставити обробку вибірки ВыборкаДетальныеЗаписи
    КонецЦикла;
    
    //}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
ЗагСумВитрат = ЗагСума;
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #152524 · Ответов: 5 · Просмотров: 315
 

>  Очистка кеша користувача
Юля
Отправлено: 08.05.19, 13:59


Оратор
*****

Группа: Пользователи
Сообщений: 398
Регистрация: 26.10.11
Из: Хмельницький
Пользователь №: 12438


Дякую, допомогло)
  Форум: Бухгалтерия 8, редакция 1 для Украины · Просмотр сообщения: #152037 · Ответов: 2 · Просмотров: 286
 

>  Очистка кеша користувача
Юля
Отправлено: 08.05.19, 13:05


Оратор
*****

Группа: Пользователи
Сообщений: 398
Регистрация: 26.10.11
Из: Хмельницький
Пользователь №: 12438


Привіт, не знала в який розділ віднетсти це запитання, тому прохання адміна, перенести куди потрібно, якщо я помилилась.
Питання наступне: в клієнтів бухгалтерія для України 1.2, при друку рахунка на оплату підтягує прінтер, який був видалений давно і не використовується, активний принтер, стоїть по замвчуваню, проблем немає. Цікаво те, що в інших документах такої проблеми не має, друк іде через активний прінтер, в інших користувачів також все добре. Я так розумію, що проблема в користувачові. Як можна вирішити проблему, але щоб інші налаштування по програмі не злетіли. Дякую.
  Форум: Бухгалтерия 8, редакция 1 для Украины · Просмотр сообщения: #152035 · Ответов: 2 · Просмотров: 286
 

>  Друк відомості в касу на виплату зарплати
Юля
Отправлено: 03.10.18, 14:42


Оратор
*****

Группа: Пользователи
Сообщений: 398
Регистрация: 26.10.11
Из: Хмельницький
Пользователь №: 12438


Юля @ 07.09.18, 14:57 * ,
Знайшла в чому проблема, якщо по працівнику були кадрові зміни (кадрове переміщення), після цього, якщо я зайду в відомість в касу і на друк , то інформація по цьому працівнику не виводиться. Виходить, ящо були кадрові зміни по працівнику, то стару відомість роздрукувати не вийди. Так що друкуйте і підшивайте зразу)))


Або, коли створюємо кадрове переміщення і міняється тільки оклад, то не потрібно ставити галочку "Перевести в інший підрозділ або на іншу посаду", тоді документ не робить руху по регістру "кадрова історія співробітників". І є відомість друкується без проблем.
  Форум: Бухгалтерия 8, редакция 2 для Украины · Просмотр сообщения: #145943 · Ответов: 1 · Просмотров: 573
 

>  В видатковій накладній виводить на друк два рази адресу оргвнізації
Юля
Отправлено: 03.10.18, 14:00


Оратор
*****

Группа: Пользователи
Сообщений: 398
Регистрация: 26.10.11
Из: Хмельницький
Пользователь №: 12438


Юля @ Сегодня, 12:33 * ,
розібралась, в налаштуваннях облікової політики є закладка друк, бухгалтер прописав туди повну адресу організації з кодами ...., тому на друк виводилось два рази)))) хз картки організації та облікової політики, застрелитися можна))0
  Форум: Бухгалтерия 8, редакция 2 для Украины · Просмотр сообщения: #145941 · Ответов: 4 · Просмотров: 465
 

>  В видатковій накладній виводить на друк два рази адресу оргвнізації
Юля
Отправлено: 03.10.18, 11:33


Оратор
*****

Группа: Пользователи
Сообщений: 398
Регистрация: 26.10.11
Из: Хмельницький
Пользователь №: 12438


Kerberos @ 11.09.18, 22:27 * ,
Переходили з редакції 1.2 на 2.0, в рахунку, акті теж два рази, а документах по надходженю все нормально 09000000.gif
  Форум: Бухгалтерия 8, редакция 2 для Украины · Просмотр сообщения: #145935 · Ответов: 4 · Просмотров: 465
 

>  Списання товарів на підставі інвентаризації
Юля
Отправлено: 13.09.18, 12:45


Оратор
*****

Группа: Пользователи
Сообщений: 398
Регистрация: 26.10.11
Из: Хмельницький
Пользователь №: 12438


клієнти хотіли списати всі товари по інвентаризації. А коли облікова кількість = кількості, то в списання відповідно нічого не переноситься. але в документі списання є кнопка "змінити" - додати товари з документа - вибираємо документ інвентаризація - натискаємо "виконати" - відзначаємо галочками товари - натискаємо "перенести в докумен". І все переноситься)))
  Форум: Бухгалтерия 8, редакция 2 для Украины · Просмотр сообщения: #145361 · Ответов: 3 · Просмотров: 371
 

>  Списання товарів на підставі інвентаризації
Юля
Отправлено: 13.09.18, 9:42


Оратор
*****

Группа: Пользователи
Сообщений: 398
Регистрация: 26.10.11
Из: Хмельницький
Пользователь №: 12438


Привіт, бухгалтерія для України 2.0, робимо інвентаризацію, а на підставі списання, але перелік товарів не переноситься, створюється чистий документ. Підкажіть це глюк в програмі??
  Форум: Бухгалтерия 8, редакция 2 для Украины · Просмотр сообщения: #145358 · Ответов: 3 · Просмотров: 371
 

>  В видатковій накладній виводить на друк два рази адресу оргвнізації
Юля
Отправлено: 07.09.18, 14:02


Оратор
*****

Группа: Пользователи
Сообщений: 398
Регистрация: 26.10.11
Из: Хмельницький
Пользователь №: 12438


Привіт, бухгалтерія 2.0 (2.0.10.1), при друку видаткової накладної, виводить два рази адресу організації в шапку друкованої форми(
  Форум: Бухгалтерия 8, редакция 2 для Украины · Просмотр сообщения: #145160 · Ответов: 4 · Просмотров: 465
 

>  Друк відомості в касу на виплату зарплати
Юля
Отправлено: 07.09.18, 13:57


Оратор
*****

Группа: Пользователи
Сообщений: 398
Регистрация: 26.10.11
Из: Хмельницький
Пользователь №: 12438


Привіт, бухгалтерія 2.0 (2.0.10.1), коли кидаємо на друк документ "відомість на виплату зарплати через касу" , то За цією відомістю виплачено гривень - пише вірно, а в таблицю підтягує тілтьки частину працівників, що цікаво що така проблема не з всіма відомостями, є такі що виводить на друк все вірно(в чому мое бути проблема? дякую
  Форум: Бухгалтерия 8, редакция 2 для Украины · Просмотр сообщения: #145159 · Ответов: 1 · Просмотров: 573
 

>  Отчет по проданным товарам
Юля
Отправлено: 09.08.18, 11:33


Оратор
*****

Группа: Пользователи
Сообщений: 398
Регистрация: 26.10.11
Из: Хмельницький
Пользователь №: 12438


Цитата(sava1 @ 09.08.18, 12:24) *
100 пудов.

права или не права???? faceoff.gif
  Форум: Бухгалтерия 8, редакция 2 для Украины · Просмотр сообщения: #144211 · Ответов: 12 · Просмотров: 645
 

>  Отчет по проданным товарам
Юля
Отправлено: 09.08.18, 11:21


Оратор
*****

Группа: Пользователи
Сообщений: 398
Регистрация: 26.10.11
Из: Хмельницький
Пользователь №: 12438


Цитата(Bernet @ 09.08.18, 11:24) *
продажи по ном группам

я извиняюсь за глупой вопрос , но там вроде нету возможности показать по каждой номенклатуре, а только по группам или я не права?(((
  Форум: Бухгалтерия 8, редакция 2 для Украины · Просмотр сообщения: #144209 · Ответов: 12 · Просмотров: 645
 

>  Отчет по проданным товарам
Юля
Отправлено: 09.08.18, 10:15


Оратор
*****

Группа: Пользователи
Сообщений: 398
Регистрация: 26.10.11
Из: Хмельницький
Пользователь №: 12438


Привіт, бухгалтерія для України 2.0, потрібно бачити інформацію по проданим товарам (кількість, можна суму). Можливо є звіт, якого я не знайшла??(((
  Форум: Бухгалтерия 8, редакция 2 для Украины · Просмотр сообщения: #144197 · Ответов: 12 · Просмотров: 645
 

>  загрузка из excel ( управляемые формы)
Юля
Отправлено: 24.07.18, 13:46


Оратор
*****

Группа: Пользователи
Сообщений: 398
Регистрация: 26.10.11
Из: Хмельницький
Пользователь №: 12438


Petre @ Сегодня, 14:10 * ,
Да)))
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #143693 · Ответов: 20 · Просмотров: 3255
 

>  загрузка из excel ( управляемые формы)
Юля
Отправлено: 24.07.18, 12:54


Оратор
*****

Группа: Пользователи
Сообщений: 398
Регистрация: 26.10.11
Из: Хмельницький
Пользователь №: 12438


Решила как-то так:

&НаСервере
Процедура ПрочитатьНаСервере()
    
    ТЗ=Новый ТаблицаЗначений;    
    
    //очищаем таблицу и удаляем колонки
    //Таблица.Очистить();
    //Таблица.Колонки.Очистить();
    //Элементы.Таблица.Колонки.Очистить();
    
    
    //подключаемся к эксел
    Попытка
        Excel = Новый COMОбъект("Excel.Application");
        Excel.WorkBooks.Open(КаталогФайла);
        Сообщить("Обработка файла Microsoft Excel...");
    Исключение
        Сообщить("Ошибка при открытии файла с помощью Excel! Загрузка не будет произведена!");
        Сообщить(ОписаниеОшибки());
        Возврат;
    КонецПопытки;
        
    Попытка
        //Открываем необходимый лист
        Excel.Sheets(1).Select();  // лист 1, по умолчанию  
    Исключение
        //Закрываем Excel
        Excel.ActiveWorkbook.Close();     
        Excel = 0;
        Сообщить("Файл "+Строка(КаталогФайла)+" не соответствует необходимому формату! Первый лист не найден!");
        //ОтменитьТранзакцию();
        Возврат;
    КонецПопытки;    
    

    //Получим количество строк и колонок.
    //В разных версиях Excel получаются по-разному, поэтому сначала определим версию Excel
    Версия = Лев(Excel.Version,Найти(Excel.Version,".")-1);
    Если Версия = "8" тогда
        ФайлСтрок   = Excel.Cells.CurrentRegion.Rows.Count;
        ФайлКолонок = Макс(Excel.Cells.CurrentRegion.Columns.Count, 13);
    Иначе
        ФайлСтрок   = Excel.Cells(1,1).SpecialCells(11).Row;
        ФайлКолонок = Excel.Cells(1,1).SpecialCells(11).Column;  
    Конецесли;
    
    
    //считываем первую строку и генерируем колонки    
    Сч = 1;    
    Пока ЗначениеЗаполнено(Excel.Cells(1, Сч).Text) Цикл
        ИмяКолонки = Excel.Cells(1, Сч).Text;
        ИмяБезПробелов = СтрЗаменить(ИмяКолонки," ",""); // убираем из имени колонок пробелы
        //Сообщить(""+ИмяБезПробелов);
        //Таблица.Колонки.Добавить(ИмяБезПробелов,,ИмяКолонки);         
        ТЗ.Колонки.Добавить(ИмяБезПробелов);
        //НоваяКолонка = Элементы.Таблица.Колонки.Добавить(ИмяБезПробелов, ИмяКолонки);
        //НоваяКолонка.Данные = ИмяБезПробелов;
    
        Сч = Сч + 1;
    КонецЦикла;
    
    
    Для НС = 2 по ФайлСтрок Цикл  // НС указываем с какой строки начинать обработку        
        
        Сообщить("Файл "+Строка(КаталогФайла)+": Обрабатывается первый лист "+Строка(Формат(?(ФайлСтрок=0,0,((100*НС)/ФайлСтрок)),"ЧЦ=3; ЧДЦ=0"))+" %");
        
        //ОбработкаПрерыванияПользователя(); //указав данный оператор, цикл можно прервать в любой момент нажатие ctrl+break
        
        НоваяСтрока = ТЗ.Добавить();        
            
        Для НомерКолонки = 1 по ТЗ.Колонки.Количество() Цикл
            //заполняем строку значениями
            ТекущееЗначение = Excel.Cells(НС, НомерКолонки).Text;
            ИмяКолонки = ТЗ.Колонки[НомерКолонки-1].Имя;             
            НоваяСтрока[ИмяКолонки] = ТекущееЗначение;            
        КонецЦикла;
        
    КонецЦикла;  
    
    Объект.Таблица.Очистить();
    Объект.Таблица.Загрузить(ТЗ);
    
    Excel.ActiveWorkbook.Close();     
    Excel = 0;
    

КонецПроцедуры

&НаКлиенте
Процедура Прочитать()
    // Вставити вміст обробника.
     ПрочитатьНаСервере();
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #143685 · Ответов: 20 · Просмотров: 3255
 

>  загрузка из excel ( управляемые формы)
Юля
Отправлено: 20.07.18, 10:19


Оратор
*****

Группа: Пользователи
Сообщений: 398
Регистрация: 26.10.11
Из: Хмельницький
Пользователь №: 12438


faceoff.gif 09000000.gif
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #143582 · Ответов: 20 · Просмотров: 3255
 

>  загрузка из excel ( управляемые формы)
Юля
Отправлено: 20.07.18, 9:50


Оратор
*****

Группа: Пользователи
Сообщений: 398
Регистрация: 26.10.11
Из: Хмельницький
Пользователь №: 12438


если на клиенте,тогда пишет:
{ВнешняяОбработка.пкм_УниверсальнаяЗагрузкаИзExcel.Форма.Форма1.Форма(39,17)}: Тип не визначений (ТаблицаЗначений)
ТЗ=Новый <<?>>ТаблицаЗначений; (Перевірка: Тонкий клієнт)

а если на сервере:

ВнешняяОбработка.пкм_УниверсальнаяЗагрузкаИзExcel.Форма.Форма1.Форма(51,3)}: Процедура або функція з вказаним ім`ям не визначена (Состояние)
<<?>>Состояние("Обработка файла Microsoft Excel..."); (Перевірка: Сервер)
{ВнешняяОбработка.пкм_УниверсальнаяЗагрузкаИзExcel.Форма.Форма1.Форма(97,3)}: Процедура або функція з вказаним ім`ям не визначена (Состояние)
<<?>>Состояние("Файл "+Строка(КаталогФайла)+": Обрабатывается первый лист "+Строка(Формат(?(ФайлСтрок=0,0,((100*НС)/ФайлСтрок)),"ЧЦ=3; ЧДЦ=0"))+" %"); (Перевірка: Сервер)
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #143579 · Ответов: 20 · Просмотров: 3255
 

>  загрузка из excel ( управляемые формы)
Юля
Отправлено: 20.07.18, 9:20


Оратор
*****

Группа: Пользователи
Сообщений: 398
Регистрация: 26.10.11
Из: Хмельницький
Пользователь №: 12438


Цитата(Vofka @ 19.07.18, 16:29) *
ЭлементыФорм

это я уже исправила на "элементы", просто переписываю с 1.2 на 2.0 (2.0 только учу)

а если сделать через виртуальную таблицу, а потом передавать в таблицу данные?
как то так:
&НаСервере

Процедура Прочитать(Команда)
    
    //ПрочитатьНаСервере();
       ТЗ=Новый ТаблицаЗначений;    
    
    //очищаем таблицу и удаляем колонки
    Таблица.Очистить();
    Таблица.Колонки.Очистить();
    Элементы.Таблица.Колонки.Очистить();
    
    
    //подключаемся к эксел
    Попытка
        Excel = Новый COMОбъект("Excel.Application");
        Excel.WorkBooks.Open(КаталогФайла);
        Состояние("Обработка файла Microsoft Excel...");
    Исключение
        Сообщить("Ошибка при открытии файла с помощью Excel! Загрузка не будет произведена!");
        Сообщить(ОписаниеОшибки());
        Возврат;
    КонецПопытки;
        
    Попытка
        //Открываем необходимый лист
        Excel.Sheets(1).Select();  // лист 1, по умолчанию  
    Исключение
        //Закрываем Excel
        Excel.ActiveWorkbook.Close();     
        Excel = 0;
        Сообщить("Файл "+Строка(КаталогФайла)+" не соответствует необходимому формату! Первый лист не найден!");
        //ОтменитьТранзакцию();
        Возврат;
    КонецПопытки;    
    

    //Получим количество строк и колонок.
    //В разных версиях Excel получаются по-разному, поэтому сначала определим версию Excel
    Версия = Лев(Excel.Version,Найти(Excel.Version,".")-1);
    Если Версия = "8" тогда
        ФайлСтрок   = Excel.Cells.CurrentRegion.Rows.Count;
        ФайлКолонок = Макс(Excel.Cells.CurrentRegion.Columns.Count, 13);
    Иначе
        ФайлСтрок   = Excel.Cells(1,1).SpecialCells(11).Row;
        ФайлКолонок = Excel.Cells(1,1).SpecialCells(11).Column;  
    Конецесли;
    
    
    //считываем первую строку и генерируем колонки    
    Сч = 1;    
    Пока ЗначениеЗаполнено(Excel.Cells(1, Сч).Text) Цикл
        ИмяКолонки = Excel.Cells(1, Сч).Text;
        ИмяБезПробелов = СтрЗаменить(ИмяКолонки," ",""); // убираем из имени колонок пробелы
        //Таблица.Колонки.Добавить(ИмяБезПробелов,,ИмяКолонки);         
        НоваяКолонка = ТЗ.Колонки.Добавить(ИмяБезПробелов, ИмяКолонки);
        НоваяКолонка.Данные = ИмяБезПробелов;
        Сч = Сч + 1;
    КонецЦикла;
    
    
    Для НС = 2 по ФайлСтрок Цикл  // НС указываем с какой строки начинать обработку        
        
        Состояние("Файл "+Строка(КаталогФайла)+": Обрабатывается первый лист "+Строка(Формат(?(ФайлСтрок=0,0,((100*НС)/ФайлСтрок)),"ЧЦ=3; ЧДЦ=0"))+" %");
        
        //ОбработкаПрерыванияПользователя(); //указав данный оператор, цикл можно прервать в любой момент нажатие ctrl+break
        
        НоваяСтрока = ТЗ.Добавить();        
            
        Для НомерКолонки = 1 по Таблица.Колонки.Количество() Цикл
            //заполняем строку значениями
            ТекущееЗначение = Excel.Cells(НС, НомерКолонки).Text;
            ИмяКолонки = ТЗ.Колонки[НомерКолонки-1].Имя;             
            НоваяСтрока[ИмяКолонки] = ТекущееЗначение;            
        КонецЦикла;
        
    КонецЦикла;  
    
Объект.Таблица.Очистить();
    Объект.Таблица.Загрузить(ТЗ);
    
Excel.ActiveWorkbook.Close();     
        Excel = 0;
    

КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #143577 · Ответов: 20 · Просмотров: 3255
 

16 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 09.12.19, 1:31
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!